- fixing multilib conflict (#135305): o remove buildsys check/conditional
for gziping info pages (let rpm do it) o don't pre-byte-compile emacs code
This commit is contained in:
parent
99f56652a0
commit
2662c7287a
43
gpm-1.20.1-multilib.patch
Normal file
43
gpm-1.20.1-multilib.patch
Normal file
@ -0,0 +1,43 @@
|
||||
--- gpm-1.20.1/doc/Makefile.in.orig 2004-10-20 15:01:00.632467098 -0400
|
||||
+++ gpm-1.20.1/doc/Makefile.in 2004-10-20 15:02:08.596188418 -0400
|
||||
@@ -131,8 +131,8 @@
|
||||
#i keep all my infopages compressed and i'm tired to do it by
|
||||
#hand, so check if there are any compressed pages and do this
|
||||
#one too
|
||||
- -ls $(infodir)/*[-.]info.gz >/dev/null 2>&1 \
|
||||
- && gzip -f $(infodir)/gpm.info
|
||||
+ #-ls $(infodir)/*[-.]info.gz >/dev/null 2>&1 \
|
||||
+ # && gzip -f $(infodir)/gpm.info
|
||||
# Hmm.... shouldn't man pages be compressed too?
|
||||
# maybe they should, but at least at my system they are not.
|
||||
|
||||
--- gpm-1.20.1/contrib/Makefile.in.orig 2004-10-20 15:36:18.471336949 -0400
|
||||
+++ gpm-1.20.1/contrib/Makefile.in 2004-10-20 15:38:02.104189510 -0400
|
||||
@@ -9,10 +9,10 @@
|
||||
|
||||
include $(top_builddir)/Makefile.include
|
||||
|
||||
-all: $(srcdir)/$(ELISP)
|
||||
+all: $(filter-out %.elc,$(srcdir)/$(ELISP))
|
||||
|
||||
install: all
|
||||
- if [ -n "$(ELISP)" ]; then for i in `echo $(ELISP)`; do \
|
||||
+ if [ -n "$(filter-out %.elc,$(ELISP))" ]; then for i in `echo $(filter-out %.elc,$(ELISP))`; do \
|
||||
$(INSTALL_DATA) $(srcdir)/$$i $(lispdir)/`basename $$i` ;\
|
||||
done; fi
|
||||
|
||||
@@ -20,7 +20,7 @@
|
||||
$(EMACS) -batch -l $(srcdir)/emacs/exec.el -exec '(byte-compile-file "$<")'
|
||||
|
||||
uninstall:
|
||||
- if [ -n "$(ELISP)" ]; then for i in `echo $(ELISP)`; do \
|
||||
+ if [ -n "$(filter-out %.elc,$(ELISP))" ]; then for i in `echo $(filter-out %.elc,$(ELISP))`; do \
|
||||
rm -f $(lispdir)/$$i ;\
|
||||
done; fi
|
||||
|
||||
@@ -28,4 +28,4 @@
|
||||
$(CP) -r $(srcdir) $(top_builddir)/gpm-$(release)/
|
||||
|
||||
clean distclean:
|
||||
- $(RM) -f $(srcdir)/emacs/*.elc
|
||||
+ $(RM) $(srcdir)/emacs/*.elc
|
9
gpm.spec
9
gpm.spec
@ -1,7 +1,7 @@
|
||||
Summary: A mouse server for the Linux console.
|
||||
Name: gpm
|
||||
Version: 1.20.1
|
||||
Release: 62
|
||||
Release: 63
|
||||
License: GPL
|
||||
Group: System Environment/Daemons
|
||||
Source: http://ftp.linux.it/pub/People/rubini/gpm/%{name}-%{version}.tar.gz
|
||||
@ -16,6 +16,7 @@ Patch6: gpm-1.20.1-idie.patch
|
||||
Patch16: gpm-1.20.1-subscript.patch
|
||||
Patch17: gpm-1.20.1-input.patch
|
||||
Patch18: gpm-1.20.1-consolename.patch
|
||||
Patch19: gpm-1.20.1-multilib.patch
|
||||
|
||||
Prereq: /sbin/chkconfig /sbin/ldconfig /sbin/install-info
|
||||
Requires: bash >= 2.0
|
||||
@ -56,6 +57,7 @@ mouse button.
|
||||
%patch16 -p1 -b .subscript
|
||||
%patch17 -p1 -b .input
|
||||
%patch18 -p1 -b .consolename
|
||||
%patch19 -p1 -b .multilib
|
||||
|
||||
%build
|
||||
autoconf
|
||||
@ -172,6 +174,11 @@ fi
|
||||
%{_libdir}/libgpm.so
|
||||
|
||||
%changelog
|
||||
* Wed Oct 20 2004 Adrian Havill <havill@redhat.com> 1.20.1-63
|
||||
- fixing multilib conflict (#135305):
|
||||
o remove buildsys check/conditional for gziping info pages (let rpm
|
||||
do it)
|
||||
|
||||
* Thu Oct 14 2004 Bill Nottingham <notting@redhat.com> 1.20.1-62
|
||||
- fix remaining sourcing of /etc/sysconfig/gpm (#135776)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user