Update to 1.11.0
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
daf8109ba4
commit
fb72ad7a6c
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@
|
||||
/.#*
|
||||
/#*
|
||||
/gpgme-1.10.0.tar.bz2
|
||||
/gpgme-1.11.0.tar.bz2
|
||||
|
@ -1,47 +0,0 @@
|
||||
From b99502274ae5efdf6df0d967900ec3d1e64373d7 Mon Sep 17 00:00:00 2001
|
||||
From: Werner Koch <wk@gnupg.org>
|
||||
Date: Thu, 12 Apr 2018 20:36:30 +0200
|
||||
Subject: [PATCH] core: Tweak STATUS_FAILURE handling.
|
||||
|
||||
* src/op-support.c (_gpgme_parse_failure): Ignore failures with
|
||||
location "gpg-exit".
|
||||
* tests/gpg/t-verify.c (main): Adjust for the now working checking of
|
||||
the second key.
|
||||
|
||||
Signed-off-by: Werner Koch <wk@gnupg.org>
|
||||
---
|
||||
src/op-support.c | 10 +++++++++-
|
||||
tests/gpg/t-verify.c | 8 +++++---
|
||||
2 files changed, 14 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/op-support.c b/src/op-support.c
|
||||
index 43cb1c76..e55875f9 100644
|
||||
--- a/src/op-support.c
|
||||
+++ b/src/op-support.c
|
||||
@@ -400,7 +400,13 @@ _gpgme_parse_plaintext (char *args, char **filenamep)
|
||||
|
||||
|
||||
/* Parse a FAILURE status line and return the error code. ARGS is
|
||||
- modified to contain the location part. */
|
||||
+ * modified to contain the location part. Note that for now we ignore
|
||||
+ * failure codes with a location of gpg-exit; they are too trouble
|
||||
+ * some. Instead we should eventually record that error in the
|
||||
+ * context and provide a function to return a fuller error
|
||||
+ * description; this could then also show the location of the error
|
||||
+ * (e.g. "option- parser") to make it easier for the user to detect
|
||||
+ * the actual error. */
|
||||
gpgme_error_t
|
||||
_gpgme_parse_failure (char *args)
|
||||
{
|
||||
@@ -418,6 +424,8 @@ _gpgme_parse_failure (char *args)
|
||||
*where = '\0';
|
||||
|
||||
where = args;
|
||||
+ if (!strcmp (where, "gpg-exit"))
|
||||
+ return 0;
|
||||
|
||||
return atoi (which);
|
||||
}
|
||||
--
|
||||
2.14.3
|
||||
|
14
gpgme.spec
14
gpgme.spec
@ -5,13 +5,12 @@
|
||||
|
||||
# STATUS_KEY_CONSIDERED has been added in 2.1.13
|
||||
%global gnupg2_min_ver 2.1.13
|
||||
# GPG_ERR_SUBKEYS_EXP_OR_REV has been added in 1.23
|
||||
%global libgpg_error_min_ver 1.23
|
||||
%global libgpg_error_min_ver 1.24
|
||||
|
||||
Name: gpgme
|
||||
Summary: GnuPG Made Easy - high level crypto API
|
||||
Version: 1.10.0
|
||||
Release: 4%{?dist}
|
||||
Version: 1.11.0
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: LGPLv2+
|
||||
URL: https://gnupg.org/related_software/gpgme/
|
||||
@ -19,8 +18,6 @@ Source0: ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-%{version}.tar.bz2
|
||||
Source2: gpgme-multilib.h
|
||||
|
||||
## upstream patches
|
||||
# https://git.gnupg.org/cgi-bin/gitweb.cgi?p=gpgme.git;a=commit;h=b99502274ae5efdf6df0d967900ec3d1e64373d7
|
||||
Patch1000: 0001-core-Tweak-STATUS_FAILURE-handling.patch
|
||||
|
||||
## downstream patches
|
||||
# Don't add extra libs/cflags in gpgme-config/cmake equivalent
|
||||
@ -38,7 +35,7 @@ BuildRequires: gawk
|
||||
BuildRequires: gnupg2 >= %{gnupg2_min_ver}
|
||||
BuildRequires: gnupg2-smime
|
||||
BuildRequires: libgpg-error-devel >= %{libgpg_error_min_ver}
|
||||
BuildRequires: libassuan-devel >= 2.0.2
|
||||
BuildRequires: libassuan-devel >= 2.4.2
|
||||
|
||||
# For python bindings
|
||||
BuildRequires: swig
|
||||
@ -237,6 +234,9 @@ fi
|
||||
%{python3_sitearch}/gpg/
|
||||
|
||||
%changelog
|
||||
* Thu Apr 19 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.11.0-1
|
||||
- Update to 1.11.0
|
||||
|
||||
* Tue Apr 17 2018 Jonathan Lebon <jonathan@jlebon.com> - 1.10.0-4
|
||||
- Backport patch to tweak STATUS_FAILURE handling
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gpgme-1.10.0.tar.bz2) = 8ffa348ef4775ed3209486444d54411e28c9a0ff1d7a4315feb0b2856ccd5d110b219100ea41262ca0016af69a1936d79fee0eadf2599c7c5bbeed05d11f7ab5
|
||||
SHA512 (gpgme-1.11.0.tar.bz2) = 79d1e4bb7a0a15ae107dae8aab29aa0b62c47ea93b228429332bb7ed24fc742afcc7abf537319d5466dee5a3b83b3fba3cf90a8bad8c97c64d7215c6573eabb5
|
||||
|
Loading…
Reference in New Issue
Block a user