patch out LIBASSUAN_LIBRARIES in cmake too
This commit is contained in:
parent
ecb68a2ff1
commit
cd7b8b224d
12
gpgme-1.8.0-cmake_extras.patch
Normal file
12
gpgme-1.8.0-cmake_extras.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up gpgme-1.8.0/lang/cpp/src/GpgmeppConfig.cmake.in.in.extras gpgme-1.8.0/lang/cpp/src/GpgmeppConfig.cmake.in.in
|
||||
--- gpgme-1.8.0/lang/cpp/src/GpgmeppConfig.cmake.in.in.extras 2017-01-18 11:28:03.707578717 -0600
|
||||
+++ gpgme-1.8.0/lang/cpp/src/GpgmeppConfig.cmake.in.in 2017-01-18 11:33:05.274758962 -0600
|
||||
@@ -63,7 +63,7 @@ add_library(Gpgmepp SHARED IMPORTED)
|
||||
|
||||
set_target_properties(Gpgmepp PROPERTIES
|
||||
INTERFACE_INCLUDE_DIRECTORIES "@resolved_includedir@/gpgme++;@resolved_includedir@"
|
||||
- INTERFACE_LINK_LIBRARIES "pthread;@resolved_libdir@/libgpgme.so;@LIBASSUAN_LIBS@"
|
||||
+ INTERFACE_LINK_LIBRARIES "pthread;@resolved_libdir@/libgpgme.so"
|
||||
IMPORTED_LOCATION "@resolved_libdir@/libgpgmepp.so"
|
||||
)
|
||||
|
23
gpgme.spec
23
gpgme.spec
@ -11,20 +11,25 @@
|
||||
Name: gpgme
|
||||
Summary: GnuPG Made Easy - high level crypto API
|
||||
Version: 1.8.0
|
||||
Release: 9%{?dist}
|
||||
Release: 10%{?dist}
|
||||
|
||||
License: LGPLv2+
|
||||
URL: https://gnupg.org/related_software/gpgme/
|
||||
Source0: ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-%{version}.tar.bz2
|
||||
Source2: gpgme-multilib.h
|
||||
|
||||
# Don't add extra libs/cflags in gpgme-config
|
||||
Patch0: gpgme-1.7.0-confix_extras.patch
|
||||
# add -D_FILE_OFFSET_BITS... to gpgme-config, upstreamable
|
||||
Patch1: gpgme-1.3.2-largefile.patch
|
||||
## upstream patches
|
||||
# upstream fix for cmake file(s)
|
||||
Patch2: 0002-Remove-a-forgotten-instance-of-libsuffix.patch
|
||||
|
||||
## downstream patches
|
||||
# Don't add extra libs/cflags in gpgme-config
|
||||
Patch10: gpgme-1.7.0-confix_extras.patch
|
||||
# add -D_FILE_OFFSET_BITS... to gpgme-config, upstreamable
|
||||
Patch11: gpgme-1.3.2-largefile.patch
|
||||
# cmake equivalent of confix_extras.patch
|
||||
Patch13: gpgme-1.8.0-cmake_extras.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gawk
|
||||
@ -56,9 +61,6 @@ management.
|
||||
Summary: Development headers and libraries for %{name}
|
||||
Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||
Requires: libgpg-error-devel%{?_isa} >= %{libgpg_error_min_ver}
|
||||
# http://bugzilla.redhat.com/676954
|
||||
# TODO: see if -lassuan can be added to config_extras patch too -- Rex
|
||||
#Requires: libassuan2-devel
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(postun): /sbin/install-info
|
||||
|
||||
@ -82,8 +84,6 @@ Provides: gpgme-pp-devel = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||
Provides: gpgme-pp-devel%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||
Requires: %{name}pp%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||
Requires: %{name}-devel%{?_isa}
|
||||
#Gpgmepp/GpgmeppConfig.cmake: INTERFACE_LINK_LIBRARIES "pthread;/usr/lib64/libgpgme.so;-lassuan -lgpg-error"
|
||||
Requires: libassuan-devel%{?_isa}
|
||||
# For automatic provides
|
||||
BuildRequires: cmake
|
||||
|
||||
@ -235,6 +235,9 @@ fi
|
||||
%{python3_sitearch}/gpg/
|
||||
|
||||
%changelog
|
||||
* Wed Jan 18 2017 Rex Dieter <rdieter@fedoraproject.org> - 1.8.0-10
|
||||
- patch out LIBASSUAN_LIBRARIES in cmake too
|
||||
|
||||
* Wed Jan 18 2017 Rex Dieter <rdieter@fedoraproject.org> - 1.8.0-9
|
||||
- gpgmepp-devel: Requires: libassuan-devel
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user