- 1.1.0
This commit is contained in:
parent
da3e112696
commit
c0f6fa80a2
@ -1,11 +0,0 @@
|
|||||||
--- gpgme/ath-compat.c~ 2004-12-07 23:11:52.000000000 +0200
|
|
||||||
+++ gpgme/ath-compat.c 2005-03-18 12:54:44.000000000 +0200
|
|
||||||
@@ -108,7 +108,7 @@
|
|
||||||
ath_read (int fd, void *buf, size_t nbytes)
|
|
||||||
{
|
|
||||||
if (ath_ops && ath_ops->read)
|
|
||||||
- return ath_ops->read (fd, buf, nbytes);
|
|
||||||
+ return (ath_ops->read) (fd, buf, nbytes);
|
|
||||||
else
|
|
||||||
return read (fd, buf, nbytes);
|
|
||||||
}
|
|
74
gpgme-1.1.0-tests.patch
Normal file
74
gpgme-1.1.0-tests.patch
Normal file
@ -0,0 +1,74 @@
|
|||||||
|
--- gpgme-1.1.0/tests/gpgsm/t-keylist.c.tests 2005-09-08 09:42:32.000000000 -0500
|
||||||
|
+++ gpgme-1.1.0/tests/gpgsm/t-keylist.c 2005-10-11 09:24:40.000000000 -0500
|
||||||
|
@@ -44,6 +44,7 @@
|
||||||
|
char *issuer_name;
|
||||||
|
char *chain_id;
|
||||||
|
char *uid;
|
||||||
|
+ char *email;
|
||||||
|
gpgme_validity_t validity;
|
||||||
|
unsigned int key_length;
|
||||||
|
}
|
||||||
|
@@ -53,7 +54,7 @@
|
||||||
|
"CN=test cert 1,OU=Aegypten Project,O=g10 Code GmbH,L=D\xc3\xbcsseldorf,C=DE",
|
||||||
|
"3CF405464F66ED4A7DF45BBDD1E4282E33BDB76E",
|
||||||
|
"CN=test cert 1,OU=Aegypten Project,O=g10 Code GmbH,L=D\xc3\xbcsseldorf,C=DE",
|
||||||
|
- GPGME_VALIDITY_ULTIMATE, 1024
|
||||||
|
+ NULL, GPGME_VALIDITY_ULTIMATE, 1024
|
||||||
|
},
|
||||||
|
{ "DFA56FB5FC41E3A8921F77AD1622EEFD9152A5AD", 0, 909684190, 1009821790, "01",
|
||||||
|
"1.2.840.113549.1.9.1=#63657274696679407063612E64666E2E6465,"
|
||||||
|
@@ -63,7 +64,7 @@
|
||||||
|
"1.2.840.113549.1.9.1=#63657274696679407063612E64666E2E6465,"
|
||||||
|
"CN=DFN Top Level Certification Authority,OU=DFN-PCA,"
|
||||||
|
"O=Deutsches Forschungsnetz,C=DE",
|
||||||
|
- GPGME_VALIDITY_NEVER, 2048
|
||||||
|
+ "<certify@pca.dfn.de>", GPGME_VALIDITY_NEVER, 2048
|
||||||
|
},
|
||||||
|
{ "2C8F3C356AB761CB3674835B792CDA52937F9285", 0, 973183644, 1009735200, "15",
|
||||||
|
"1.2.840.113549.1.9.1=#63657274696679407063612E64666E2E6465,"
|
||||||
|
@@ -73,7 +74,7 @@
|
||||||
|
"1.2.840.113549.1.9.1=#63657274696679407063612E64666E2E6465,"
|
||||||
|
"CN=DFN Server Certification Authority,OU=DFN-PCA,"
|
||||||
|
"O=Deutsches Forschungsnetz,C=DE",
|
||||||
|
- GPGME_VALIDITY_UNKNOWN, 2048
|
||||||
|
+ "<certify@pca.dfn.de>", GPGME_VALIDITY_UNKNOWN, 2048
|
||||||
|
},
|
||||||
|
{ NULL }
|
||||||
|
};
|
||||||
|
@@ -286,7 +287,8 @@
|
||||||
|
exit (1);
|
||||||
|
}
|
||||||
|
|
||||||
|
- if (!key->uids || key->uids->next)
|
||||||
|
+ /* Be tolerant against a missing email (ie, older gpgsm versions). */
|
||||||
|
+ if (!key->uids || (key->uids->next && !keys[i].email))
|
||||||
|
{
|
||||||
|
fprintf (stderr, "Key has unexpected number of user IDs\n");
|
||||||
|
exit (1);
|
||||||
|
@@ -336,6 +338,13 @@
|
||||||
|
key->uids->uid);
|
||||||
|
exit (1);
|
||||||
|
}
|
||||||
|
+ if (key->uids->next && strcmp (key->uids->next->uid, keys[i].email))
|
||||||
|
+ {
|
||||||
|
+ fprintf (stderr, "Unexpected email in user ID: %s\n",
|
||||||
|
+ key->uids->next->uid);
|
||||||
|
+ exit (1);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
|
||||||
|
gpgme_key_unref (key);
|
||||||
|
i++;
|
||||||
|
--- gpgme-1.1.0/tests/gpg/t-sig-notation.c.tests 2005-09-30 21:06:08.000000000 -0500
|
||||||
|
+++ gpgme-1.1.0/tests/gpg/t-sig-notation.c 2005-10-11 09:24:40.000000000 -0500
|
||||||
|
@@ -42,8 +42,8 @@
|
||||||
|
{ "laughing@me",
|
||||||
|
"Just Squeeze Me",
|
||||||
|
GPGME_SIG_NOTATION_HUMAN_READABLE },
|
||||||
|
- { "leave@home",
|
||||||
|
- "Right Now",
|
||||||
|
+ { "preferred-email-encoding@pgp.com",
|
||||||
|
+ "pgpmime",
|
||||||
|
GPGME_SIG_NOTATION_HUMAN_READABLE | GPGME_SIG_NOTATION_CRITICAL },
|
||||||
|
{ NULL,
|
||||||
|
"http://www.gnu.org/policy/",
|
16
gpgme.spec
16
gpgme.spec
@ -1,7 +1,7 @@
|
|||||||
|
|
||||||
Name: gpgme
|
Name: gpgme
|
||||||
Summary: GnuPG Made Easy - high level crypto API
|
Summary: GnuPG Made Easy - high level crypto API
|
||||||
Version: 1.0.3
|
Version: 1.1.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: LGPL
|
License: LGPL
|
||||||
@ -11,12 +11,12 @@ Source0: ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-%{version}.tar.bz2
|
|||||||
Source1: ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-%{version}.tar.bz2.sig
|
Source1: ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-%{version}.tar.bz2.sig
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Patch0: gpgme-1.0.2-macro.patch
|
Patch1: gpgme-1.1.0-tests.patch
|
||||||
|
|
||||||
BuildRequires: gnupg >= 1.2.2
|
BuildRequires: gnupg >= 1.2.2
|
||||||
BuildRequires: gnupg2 >= 1.9.6
|
BuildRequires: gnupg2 >= 1.9.6
|
||||||
BuildRequires: pth-devel
|
|
||||||
BuildRequires: libgpg-error-devel >= 0.5
|
BuildRequires: libgpg-error-devel >= 0.5
|
||||||
|
BuildRequires: pth-devel
|
||||||
|
|
||||||
Requires: gnupg >= 1.2.2
|
Requires: gnupg >= 1.2.2
|
||||||
Requires: gnupg2 >= 1.9.6
|
Requires: gnupg2 >= 1.9.6
|
||||||
@ -30,20 +30,20 @@ encryption, decryption, signing, signature verification and key
|
|||||||
management.
|
management.
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Static libraries and header files from GPGME, GnuPG Made Easy
|
Summary: Libraries and header files from GPGME, GnuPG Made Easy
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: libgpg-error-devel
|
Requires: libgpg-error-devel
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
Requires(postun): /sbin/install-info
|
Requires(postun): /sbin/install-info
|
||||||
%description devel
|
%description devel
|
||||||
Static libraries and header files from GPGME, GnuPG Made Easy.
|
%{summary}
|
||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch0 -p0
|
%patch1 -p1 -b .tests
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -92,13 +92,15 @@ fi
|
|||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_bindir}/gpgme-config
|
%{_bindir}/gpgme-config
|
||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
#{_libdir}/lib*.a
|
|
||||||
%{_libdir}/lib*.so
|
%{_libdir}/lib*.so
|
||||||
%{_datadir}/aclocal/gpgme.m4
|
%{_datadir}/aclocal/gpgme.m4
|
||||||
%{_infodir}/gpgme.info*
|
%{_infodir}/gpgme.info*
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 06 2005 Rex Dieter <rexdieter[AT]users.sf.net> - 1.1.0-1
|
||||||
|
- 1.1.0
|
||||||
|
|
||||||
* Mon Aug 8 2005 Rex Dieter <rexdieter[AT]users.sf.net> - 1.0.3-1
|
* Mon Aug 8 2005 Rex Dieter <rexdieter[AT]users.sf.net> - 1.0.3-1
|
||||||
- 1.0.3
|
- 1.0.3
|
||||||
- --disable-static
|
- --disable-static
|
||||||
|
Loading…
Reference in New Issue
Block a user