Merge #19 update to 1.23.2
This commit is contained in:
commit
b17d8df23a
@ -1,40 +0,0 @@
|
|||||||
From aee18a2ab2498bc6092bef518c532796bbe5b502 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Christian Hesse <mail@eworm.de>
|
|
||||||
Date: Tue, 22 Aug 2023 00:12:05 +0200
|
|
||||||
Subject: [PATCH] qt,tests: Fix build in source directory, part 2
|
|
||||||
|
|
||||||
* lang/qt/tests/Makefile.am (AM_CPPFLAGS): Include Qt binding sources
|
|
||||||
before C++ binding sources and C sources.
|
|
||||||
--
|
|
||||||
|
|
||||||
This fixes the problem that the debug.h in the C sources was found
|
|
||||||
before the one in the Qt bindings.
|
|
||||||
|
|
||||||
Commit d23528cadf4284f508bc4ba05e1b5c14b46bd354 fixed it for Qt5, we
|
|
||||||
need Qt6 as well.
|
|
||||||
|
|
||||||
GnuPG-bug-id: 6673
|
|
||||||
---
|
|
||||||
lang/qt/tests/Makefile.am | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/lang/qt/tests/Makefile.am b/lang/qt/tests/Makefile.am
|
|
||||||
index aedd3264..615daf6d 100644
|
|
||||||
--- a/lang/qt/tests/Makefile.am
|
|
||||||
+++ b/lang/qt/tests/Makefile.am
|
|
||||||
@@ -62,10 +62,10 @@ LDADD = ../../cpp/src/libgpgmepp.la ../src/libqgpgmeqt6.la \
|
|
||||||
../../../src/libgpgme.la @GPGME_QT6_LIBS@ @GPG_ERROR_LIBS@ \
|
|
||||||
@GPGME_QT6TEST_LIBS@ @LDADD_FOR_TESTS_KLUDGE@ -lstdc++
|
|
||||||
|
|
||||||
-AM_CPPFLAGS = -I$(top_srcdir)/lang/cpp/src -I$(top_builddir)/src \
|
|
||||||
+AM_CPPFLAGS = -I$(top_srcdir)/lang/qt/src -I$(top_srcdir)/lang/cpp/src \
|
|
||||||
+ -I$(top_builddir)/src \
|
|
||||||
@GPG_ERROR_CFLAGS@ @GPGME_QT6_CFLAGS@ @GPG_ERROR_CFLAGS@ \
|
|
||||||
@LIBASSUAN_CFLAGS@ @GPGME_QT6TEST_CFLAGS@ -DBUILDING_QGPGME \
|
|
||||||
- -I$(top_srcdir)/lang/qt/src \
|
|
||||||
-DTOP_SRCDIR="$(top_srcdir)"
|
|
||||||
endif
|
|
||||||
|
|
||||||
--
|
|
||||||
2.30.2
|
|
||||||
|
|
@ -1,37 +0,0 @@
|
|||||||
From d23528cadf4284f508bc4ba05e1b5c14b46bd354 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?utf8?q?Ingo=20Kl=C3=B6cker?= <dev@ingo-kloecker.de>
|
|
||||||
Date: Mon, 21 Aug 2023 21:08:01 +0200
|
|
||||||
Subject: [PATCH] qt,tests: Fix build in source directory
|
|
||||||
|
|
||||||
* lang/qt/tests/Makefile.am (AM_CPPFLAGS): Include Qt binding sources
|
|
||||||
before C++ binding sources and C sources.
|
|
||||||
--
|
|
||||||
|
|
||||||
This fixes the problem that the debug.h in the C sources was found
|
|
||||||
before the one in the Qt bindings.
|
|
||||||
|
|
||||||
GnuPG-bug-id: 6673
|
|
||||||
---
|
|
||||||
lang/qt/tests/Makefile.am | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/lang/qt/tests/Makefile.am b/lang/qt/tests/Makefile.am
|
|
||||||
index 32ad6466..aedd3264 100644
|
|
||||||
--- a/lang/qt/tests/Makefile.am
|
|
||||||
+++ b/lang/qt/tests/Makefile.am
|
|
||||||
@@ -51,10 +51,10 @@ LDADD = ../../cpp/src/libgpgmepp.la ../src/libqgpgme.la \
|
|
||||||
../../../src/libgpgme.la @GPGME_QT5_LIBS@ @GPG_ERROR_LIBS@ \
|
|
||||||
@GPGME_QT5TEST_LIBS@ @LDADD_FOR_TESTS_KLUDGE@ -lstdc++
|
|
||||||
|
|
||||||
-AM_CPPFLAGS = -I$(top_srcdir)/lang/cpp/src -I$(top_builddir)/src \
|
|
||||||
+AM_CPPFLAGS = -I$(top_srcdir)/lang/qt/src -I$(top_srcdir)/lang/cpp/src \
|
|
||||||
+ -I$(top_builddir)/src \
|
|
||||||
@GPG_ERROR_CFLAGS@ @GPGME_QT5_CFLAGS@ @GPG_ERROR_CFLAGS@ \
|
|
||||||
@LIBASSUAN_CFLAGS@ @GPGME_QT5TEST_CFLAGS@ -DBUILDING_QGPGME \
|
|
||||||
- -I$(top_srcdir)/lang/qt/src \
|
|
||||||
-DTOP_SRCDIR="$(top_srcdir)"
|
|
||||||
endif
|
|
||||||
if WANT_QT6
|
|
||||||
--
|
|
||||||
2.30.2
|
|
||||||
|
|
@ -11,7 +11,7 @@
|
|||||||
|
|
||||||
Name: gpgme
|
Name: gpgme
|
||||||
Summary: GnuPG Made Easy - high level crypto API
|
Summary: GnuPG Made Easy - high level crypto API
|
||||||
Version: 1.22.0
|
Version: 1.23.2
|
||||||
Release: %autorelease
|
Release: %autorelease
|
||||||
|
|
||||||
# MIT: src/cJSON.{c,h} (used by gpgme-json)
|
# MIT: src/cJSON.{c,h} (used by gpgme-json)
|
||||||
@ -36,9 +36,6 @@ Patch1004: 0002-setup_py_extra_opts.patch
|
|||||||
# Skip lang/qt/tests/t-remarks on gnupg 2.4+
|
# Skip lang/qt/tests/t-remarks on gnupg 2.4+
|
||||||
Patch3001: 1001-qt-skip-test-remarks-for-gnupg2-2.4.patch
|
Patch3001: 1001-qt-skip-test-remarks-for-gnupg2-2.4.patch
|
||||||
|
|
||||||
# fix FTBFS caused by include path order, for <= 1.22.0
|
|
||||||
Patch3002: gpgme-1.22.0-ftbfs-aee18a2a.patch
|
|
||||||
Patch3003: gpgme-1.22.0-ftbfs-d23528ca.patch
|
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (gpgme-1.22.0.tar.bz2) = 17053053fa885f01416433e43072ac716b5d5db0c3edf45b2d6e90e6384d127626e6ae3ce421abba8f449f5ca7e8963f3d62f3565d295847170bc998d1ec1a70
|
SHA512 (gpgme-1.23.2.tar.bz2) = 6cfcd07e81a93de240582de5a46545420cee93d1f27fe20ea2c983780fdd3036b69fdba073cf549d68a20791e189bf4b3cdde14a43f912d2ab9ef3414c83ac75
|
||||||
SHA512 (gpgme-1.22.0.tar.bz2.sig) = 7c62962f02c614dcc8008079c8cb6104d92c968575a927b870c9e2ef84f287e2620a5e213dddb34496f78ecea1290ddd506321001004aff89c623547b3d4f4b0
|
SHA512 (gpgme-1.23.2.tar.bz2.sig) = 65b7cdd4ce06bb0b15b13033d226423380338efdcb47ffc3f33780a92973453053f8f59b12a3f37e392e773bdd207a7420c25aa3a210c15eec45b7bfef6e891e
|
||||||
|
Loading…
Reference in New Issue
Block a user