new upstream version
- re-enable gpg tests (original patch by John Morris <john@zultron.com>) - quiet configure warning 'could not find g13' - there is no libgpgme-pth anymore
This commit is contained in:
parent
4abacfdc89
commit
abe58665ff
16
.gitignore
vendored
16
.gitignore
vendored
@ -1,4 +1,12 @@
|
||||
gpgme-1.2.0.tar.bz2
|
||||
gpgme-1.2.0.tar.bz2.sig
|
||||
/gpgme-1.3.0.tar.bz2.sig
|
||||
/gpgme-1.3.0.tar.bz2
|
||||
# ignore sources
|
||||
/gpgme-[0-9].[0-9].[0-9].tar.bz2
|
||||
/gpgme-[0-9].[0-9].[0-9].tar.bz2.sig
|
||||
# ignore fedpkg local build artifacts
|
||||
/.build-*.log
|
||||
/gpgme-[0-9].[0-9].[0-9]/
|
||||
/gpgme-[0-9].[0-9].[0-9]-*.src.rpm
|
||||
/i686/
|
||||
/x86_64/
|
||||
# ignore emacs cruft
|
||||
/.#*
|
||||
/#*
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -up gpgme-1.2.0/src/gpgme-config.in.largefile gpgme-1.2.0/src/gpgme-config.in
|
||||
--- gpgme-1.2.0/src/gpgme-config.in.largefile 2010-08-11 20:11:49.000000000 +0200
|
||||
+++ gpgme-1.2.0/src/gpgme-config.in 2010-08-11 20:23:45.000000000 +0200
|
||||
@@ -42,6 +42,10 @@ cflags_pthread=""
|
||||
cflags_glib="@GLIB_CFLAGS@"
|
||||
with_glib=
|
||||
|
||||
+if test "0@NEED__FILE_OFFSET_BITS@" -gt "0" ; then
|
||||
+ cflags_lfs="-D_FILE_OFFSET_BITS=@NEED__FILE_OFFSET_BITS@"
|
||||
+fi
|
||||
+
|
||||
output=""
|
||||
|
||||
usage()
|
||||
@@ -101,6 +105,9 @@ while test $# -gt 0; do
|
||||
exit 0
|
||||
;;
|
||||
--cflags)
|
||||
+ if test "x$cflags_lfs" != "x"; then
|
||||
+ output="$output $cflags_lfs"
|
||||
+ fi
|
||||
if test "x$includedir" != "x/usr/include" -a "x$includedir" != "x/include"; then
|
||||
output="$output -I$includedir"
|
||||
fi
|
@ -1,72 +0,0 @@
|
||||
diff -up gpgme-1.3.0/src/Makefile.am.ImplicitDSOLinking gpgme-1.3.0/src/Makefile.am
|
||||
--- gpgme-1.3.0/src/Makefile.am.ImplicitDSOLinking 2010-01-06 04:02:19.000000000 +0100
|
||||
+++ gpgme-1.3.0/src/Makefile.am 2011-02-11 18:14:54.000000000 +0100
|
||||
@@ -232,7 +232,7 @@ libgpgme_qt_la_LIBADD = $(gpgme_res) @LI
|
||||
endif
|
||||
|
||||
noinst_PROGRAMS = gpgme-tool
|
||||
-gpgme_tool_LDADD = libgpgme.la
|
||||
+gpgme_tool_LDADD = libgpgme.la @LIBASSUAN_LIBS@ @GPG_ERROR_LIBS@
|
||||
|
||||
status-table.h : gpgme.h
|
||||
$(srcdir)/mkstatus < $(builddir)/gpgme.h > status-table.h
|
||||
diff -up gpgme-1.3.0/src/Makefile.in.ImplicitDSOLinking gpgme-1.3.0/src/Makefile.in
|
||||
--- gpgme-1.3.0/src/Makefile.in.ImplicitDSOLinking 2010-01-11 12:06:54.000000000 +0100
|
||||
+++ gpgme-1.3.0/src/Makefile.in 2011-02-11 18:17:10.000000000 +0100
|
||||
@@ -572,7 +572,7 @@ libgpgme_pth_la_LIBADD = $(gpgme_res) @L
|
||||
@BUILD_W32_QT_TRUE@libgpgme_qt_la_LIBADD = $(gpgme_res) @LIBASSUAN_LIBS@ @LTLIBOBJS@ \
|
||||
@BUILD_W32_QT_TRUE@ @GPG_ERROR_LIBS@ @QT4_CORE_LIBS@
|
||||
|
||||
-gpgme_tool_LDADD = libgpgme.la
|
||||
+gpgme_tool_LDADD = libgpgme.la @LIBASSUAN_LIBS@ @GPG_ERROR_LIBS@
|
||||
all: $(BUILT_SOURCES)
|
||||
$(MAKE) $(AM_MAKEFLAGS) all-am
|
||||
|
||||
diff -up gpgme-1.3.0/tests/gpgsm/Makefile.am.ImplicitDSOLinking gpgme-1.3.0/tests/gpgsm/Makefile.am
|
||||
--- gpgme-1.3.0/tests/gpgsm/Makefile.am.ImplicitDSOLinking 2008-12-03 14:39:48.000000000 +0100
|
||||
+++ gpgme-1.3.0/tests/gpgsm/Makefile.am 2011-02-11 17:36:32.000000000 +0100
|
||||
@@ -32,7 +32,7 @@ EXTRA_DIST = cert_dfn_pca01.der cert_dfn
|
||||
INCLUDES = -I$(top_builddir)/src
|
||||
|
||||
AM_CPPFLAGS = @GPG_ERROR_CFLAGS@
|
||||
-LDADD = ../../src/libgpgme.la
|
||||
+LDADD = ../../src/libgpgme.la @GPG_ERROR_LIBS@
|
||||
|
||||
# We don't run t-genkey in the test suite, because it takes too long
|
||||
# and needs a working pinentry.
|
||||
diff -up gpgme-1.3.0/tests/gpgsm/Makefile.in.ImplicitDSOLinking gpgme-1.3.0/tests/gpgsm/Makefile.in
|
||||
--- gpgme-1.3.0/tests/gpgsm/Makefile.in.ImplicitDSOLinking 2010-01-11 12:06:54.000000000 +0100
|
||||
+++ gpgme-1.3.0/tests/gpgsm/Makefile.in 2011-02-11 17:36:32.000000000 +0100
|
||||
@@ -307,7 +307,7 @@ EXTRA_DIST = cert_dfn_pca01.der cert_dfn
|
||||
|
||||
INCLUDES = -I$(top_builddir)/src
|
||||
AM_CPPFLAGS = @GPG_ERROR_CFLAGS@
|
||||
-LDADD = ../../src/libgpgme.la
|
||||
+LDADD = ../../src/libgpgme.la @GPG_ERROR_LIBS@
|
||||
key_id = 32100C27173EF6E9C4E9A25D3D69F86D37A4F939
|
||||
DISTCLEANFILES = pubring.kbx pubring.kbx~ gpgsm.conf trustlist.txt \
|
||||
private-keys-v1.d/$(key_id).key random_seed
|
||||
diff -up gpgme-1.3.0/tests/opassuan/Makefile.am.ImplicitDSOLinking gpgme-1.3.0/tests/opassuan/Makefile.am
|
||||
--- gpgme-1.3.0/tests/opassuan/Makefile.am.ImplicitDSOLinking 2009-01-26 15:15:26.000000000 +0100
|
||||
+++ gpgme-1.3.0/tests/opassuan/Makefile.am 2011-02-11 17:36:32.000000000 +0100
|
||||
@@ -27,7 +27,7 @@ EXTRA_DIST =
|
||||
INCLUDES = -I$(top_builddir)/src
|
||||
|
||||
AM_CPPFLAGS = @GPG_ERROR_CFLAGS@
|
||||
-LDADD = ../../src/libgpgme.la
|
||||
+LDADD = ../../src/libgpgme.la @GPG_ERROR_LIBS@
|
||||
|
||||
noinst_PROGRAMS = $(TESTS) t-command
|
||||
|
||||
diff -up gpgme-1.3.0/tests/opassuan/Makefile.in.ImplicitDSOLinking gpgme-1.3.0/tests/opassuan/Makefile.in
|
||||
--- gpgme-1.3.0/tests/opassuan/Makefile.in.ImplicitDSOLinking 2010-01-11 12:06:54.000000000 +0100
|
||||
+++ gpgme-1.3.0/tests/opassuan/Makefile.in 2011-02-11 17:36:32.000000000 +0100
|
||||
@@ -258,7 +258,7 @@ noinst_HEADERS =
|
||||
EXTRA_DIST =
|
||||
INCLUDES = -I$(top_builddir)/src
|
||||
AM_CPPFLAGS = @GPG_ERROR_CFLAGS@
|
||||
-LDADD = ../../src/libgpgme.la
|
||||
+LDADD = ../../src/libgpgme.la @GPG_ERROR_LIBS@
|
||||
DISTCLEANFILES =
|
||||
all: all-am
|
||||
|
100
gpgme-1.3.2-ImplicitDSOLinking.patch
Normal file
100
gpgme-1.3.2-ImplicitDSOLinking.patch
Normal file
@ -0,0 +1,100 @@
|
||||
diff -up gpgme-1.3.2/src/Makefile.am.ImplicitDSOLinking gpgme-1.3.2/src/Makefile.am
|
||||
--- gpgme-1.3.2/src/Makefile.am.ImplicitDSOLinking 2012-04-13 10:01:09.000000000 +0200
|
||||
+++ gpgme-1.3.2/src/Makefile.am 2012-09-26 10:06:42.822675632 +0200
|
||||
@@ -223,7 +223,7 @@ libgpgme_qt_la_LIBADD = $(gpgme_res) @LI
|
||||
endif
|
||||
|
||||
noinst_PROGRAMS = gpgme-tool
|
||||
-gpgme_tool_LDADD = libgpgme.la @LIBASSUAN_LIBS@
|
||||
+gpgme_tool_LDADD = libgpgme.la @LIBASSUAN_LIBS@ @GPG_ERROR_LIBS@
|
||||
|
||||
install-data-local: install-def-file
|
||||
|
||||
diff -up gpgme-1.3.2/src/Makefile.in.ImplicitDSOLinking gpgme-1.3.2/src/Makefile.in
|
||||
--- gpgme-1.3.2/src/Makefile.in.ImplicitDSOLinking 2012-05-02 11:19:10.000000000 +0200
|
||||
+++ gpgme-1.3.2/src/Makefile.in 2012-09-26 10:07:14.361355694 +0200
|
||||
@@ -542,7 +542,7 @@ libgpgme_pthread_la_LIBADD = $(gpgme_res
|
||||
@BUILD_W32_QT_TRUE@libgpgme_qt_la_LIBADD = $(gpgme_res) @LIBASSUAN_LIBS@ @LTLIBOBJS@ \
|
||||
@BUILD_W32_QT_TRUE@ @GPG_ERROR_LIBS@ @QT4_CORE_LIBS@
|
||||
|
||||
-gpgme_tool_LDADD = libgpgme.la @LIBASSUAN_LIBS@
|
||||
+gpgme_tool_LDADD = libgpgme.la @LIBASSUAN_LIBS@ @GPG_ERROR_LIBS@
|
||||
all: all-am
|
||||
|
||||
.SUFFIXES:
|
||||
diff -up gpgme-1.3.2/tests/gpg/Makefile.am.ImplicitDSOLinking gpgme-1.3.2/tests/gpg/Makefile.am
|
||||
--- gpgme-1.3.2/tests/gpg/Makefile.am.ImplicitDSOLinking 2012-04-13 10:01:10.000000000 +0200
|
||||
+++ gpgme-1.3.2/tests/gpg/Makefile.am 2012-09-26 10:08:30.059987972 +0200
|
||||
@@ -47,8 +47,8 @@ EXTRA_DIST = pubdemo.asc secdemo.asc cip
|
||||
INCLUDES = -I$(top_builddir)/src
|
||||
|
||||
AM_CPPFLAGS = @GPG_ERROR_CFLAGS@
|
||||
-LDADD = ../../src/libgpgme.la
|
||||
-t_thread1_LDADD = ../../src/libgpgme-pthread.la -lpthread
|
||||
+LDADD = ../../src/libgpgme.la @GPG_ERROR_LIBS@
|
||||
+t_thread1_LDADD = ../../src/libgpgme-pthread.la @GPG_ERROR_LIBS@ -pthread
|
||||
|
||||
# We don't run t-genkey in the test suite, because it takes too long
|
||||
noinst_PROGRAMS = $(TESTS) t-genkey
|
||||
diff -up gpgme-1.3.2/tests/gpg/Makefile.in.ImplicitDSOLinking gpgme-1.3.2/tests/gpg/Makefile.in
|
||||
--- gpgme-1.3.2/tests/gpg/Makefile.in.ImplicitDSOLinking 2012-05-02 11:19:11.000000000 +0200
|
||||
+++ gpgme-1.3.2/tests/gpg/Makefile.in 2012-09-26 10:09:09.254833125 +0200
|
||||
@@ -380,8 +380,8 @@ EXTRA_DIST = pubdemo.asc secdemo.asc cip
|
||||
|
||||
INCLUDES = -I$(top_builddir)/src
|
||||
AM_CPPFLAGS = @GPG_ERROR_CFLAGS@
|
||||
-LDADD = ../../src/libgpgme.la
|
||||
-t_thread1_LDADD = ../../src/libgpgme-pthread.la -lpthread
|
||||
+LDADD = ../../src/libgpgme.la @GPG_ERROR_LIBS@
|
||||
+t_thread1_LDADD = ../../src/libgpgme-pthread.la @GPG_ERROR_LIBS@ -pthread
|
||||
all: all-am
|
||||
|
||||
.SUFFIXES:
|
||||
diff -up gpgme-1.3.2/tests/gpgsm/Makefile.am.ImplicitDSOLinking gpgme-1.3.2/tests/gpgsm/Makefile.am
|
||||
--- gpgme-1.3.2/tests/gpgsm/Makefile.am.ImplicitDSOLinking 2011-12-02 10:49:38.000000000 +0100
|
||||
+++ gpgme-1.3.2/tests/gpgsm/Makefile.am 2012-09-26 10:04:36.600953929 +0200
|
||||
@@ -32,7 +32,7 @@ EXTRA_DIST = cert_dfn_pca01.der cert_dfn
|
||||
INCLUDES = -I$(top_builddir)/src
|
||||
|
||||
AM_CPPFLAGS = @GPG_ERROR_CFLAGS@
|
||||
-LDADD = ../../src/libgpgme.la
|
||||
+LDADD = ../../src/libgpgme.la @GPG_ERROR_LIBS@
|
||||
|
||||
# We don't run t-genkey in the test suite, because it takes too long
|
||||
# and needs a working pinentry.
|
||||
diff -up gpgme-1.3.2/tests/gpgsm/Makefile.in.ImplicitDSOLinking gpgme-1.3.2/tests/gpgsm/Makefile.in
|
||||
--- gpgme-1.3.2/tests/gpgsm/Makefile.in.ImplicitDSOLinking 2012-05-02 11:19:11.000000000 +0200
|
||||
+++ gpgme-1.3.2/tests/gpgsm/Makefile.in 2012-09-26 10:09:38.607466053 +0200
|
||||
@@ -308,7 +308,7 @@ EXTRA_DIST = cert_dfn_pca01.der cert_dfn
|
||||
|
||||
INCLUDES = -I$(top_builddir)/src
|
||||
AM_CPPFLAGS = @GPG_ERROR_CFLAGS@
|
||||
-LDADD = ../../src/libgpgme.la
|
||||
+LDADD = ../../src/libgpgme.la @GPG_ERROR_LIBS@
|
||||
key_id = 32100C27173EF6E9C4E9A25D3D69F86D37A4F939
|
||||
CLEANFILES = pubring.kbx pubring.kbx~ gpgsm.conf trustlist.txt \
|
||||
random_seed S.gpg-agent
|
||||
diff -up gpgme-1.3.2/tests/opassuan/Makefile.am.ImplicitDSOLinking gpgme-1.3.2/tests/opassuan/Makefile.am
|
||||
--- gpgme-1.3.2/tests/opassuan/Makefile.am.ImplicitDSOLinking 2010-12-30 16:19:33.000000000 +0100
|
||||
+++ gpgme-1.3.2/tests/opassuan/Makefile.am 2012-09-26 10:04:36.601953950 +0200
|
||||
@@ -27,7 +27,7 @@ EXTRA_DIST =
|
||||
INCLUDES = -I$(top_builddir)/src
|
||||
|
||||
AM_CPPFLAGS = @GPG_ERROR_CFLAGS@
|
||||
-LDADD = ../../src/libgpgme.la
|
||||
+LDADD = ../../src/libgpgme.la @GPG_ERROR_LIBS@
|
||||
|
||||
noinst_PROGRAMS = $(TESTS) t-command
|
||||
|
||||
diff -up gpgme-1.3.2/tests/opassuan/Makefile.in.ImplicitDSOLinking gpgme-1.3.2/tests/opassuan/Makefile.in
|
||||
--- gpgme-1.3.2/tests/opassuan/Makefile.in.ImplicitDSOLinking 2012-05-02 11:19:11.000000000 +0200
|
||||
+++ gpgme-1.3.2/tests/opassuan/Makefile.in 2012-09-26 10:04:36.601953950 +0200
|
||||
@@ -259,7 +259,7 @@ noinst_HEADERS =
|
||||
EXTRA_DIST =
|
||||
INCLUDES = -I$(top_builddir)/src
|
||||
AM_CPPFLAGS = @GPG_ERROR_CFLAGS@
|
||||
-LDADD = ../../src/libgpgme.la
|
||||
+LDADD = ../../src/libgpgme.la @GPG_ERROR_LIBS@
|
||||
DISTCLEANFILES =
|
||||
all: all-am
|
||||
|
@ -1,8 +1,8 @@
|
||||
diff -up gpgme-1.3.0/src/gpgme-config.in.config_extras gpgme-1.3.0/src/gpgme-config.in
|
||||
--- gpgme-1.3.0/src/gpgme-config.in.config_extras 2009-10-23 08:44:56.000000000 -0500
|
||||
+++ gpgme-1.3.0/src/gpgme-config.in 2011-03-17 13:15:12.511565537 -0500
|
||||
@@ -20,26 +20,26 @@ LC_ALL=C
|
||||
LANG=C
|
||||
diff -up gpgme-1.3.2/src/gpgme-config.in.config_extras gpgme-1.3.2/src/gpgme-config.in
|
||||
--- gpgme-1.3.2/src/gpgme-config.in.config_extras 2012-05-02 10:42:23.000000000 +0200
|
||||
+++ gpgme-1.3.2/src/gpgme-config.in 2012-09-26 10:03:41.904413540 +0200
|
||||
@@ -22,22 +22,22 @@ cflags="-I@includedir@"
|
||||
libs="-L@libdir@"
|
||||
|
||||
# Network libraries.
|
||||
-assuan_cflags="@LIBASSUAN_CFLAGS@"
|
||||
@ -18,11 +18,6 @@ diff -up gpgme-1.3.0/src/gpgme-config.in.config_extras gpgme-1.3.0/src/gpgme-con
|
||||
# Configure thread packages.
|
||||
thread_modules=""
|
||||
|
||||
@HAVE_PTH_TRUE@thread_modules="$thread_modules pth"
|
||||
-libs_pth="@PTH_LDFLAGS@ @PTH_LIBS@"
|
||||
+#libs_pth="@PTH_LDFLAGS@ @PTH_LIBS@"
|
||||
cflags_pth="@PTH_CFLAGS@"
|
||||
|
||||
@HAVE_PTHREAD_TRUE@thread_modules="$thread_modules pthread"
|
||||
-libs_pthread="-lpthread"
|
||||
+#libs_pthread="-lpthread"
|
24
gpgme-1.3.2-largefile.patch
Normal file
24
gpgme-1.3.2-largefile.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -up gpgme-1.3.2/src/gpgme-config.in.largefile gpgme-1.3.2/src/gpgme-config.in
|
||||
--- gpgme-1.3.2/src/gpgme-config.in.largefile 2012-09-26 10:10:37.882744198 +0200
|
||||
+++ gpgme-1.3.2/src/gpgme-config.in 2012-09-26 10:16:02.558762827 +0200
|
||||
@@ -41,6 +41,10 @@ cflags_pthread=""
|
||||
cflags_glib="@GLIB_CFLAGS@"
|
||||
with_glib=
|
||||
|
||||
+if test "0@NEED__FILE_OFFSET_BITS@" -gt "0" ; then
|
||||
+ cflags_lfs="-D_FILE_OFFSET_BITS=@NEED__FILE_OFFSET_BITS@"
|
||||
+fi
|
||||
+
|
||||
output=""
|
||||
|
||||
usage()
|
||||
@@ -105,6 +109,9 @@ while test $# -gt 0; do
|
||||
exit 0
|
||||
;;
|
||||
--cflags)
|
||||
+ if test "x$cflags_lfs" != "x"; then
|
||||
+ output="$output $cflags_lfs"
|
||||
+ fi
|
||||
result=
|
||||
tmp_c=
|
||||
tmp_g=
|
22
gpgme.spec
22
gpgme.spec
@ -1,8 +1,8 @@
|
||||
|
||||
Name: gpgme
|
||||
Summary: GnuPG Made Easy - high level crypto API
|
||||
Version: 1.3.0
|
||||
Release: 9%{?dist}
|
||||
Version: 1.3.2
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: LGPLv2+
|
||||
Group: Applications/System
|
||||
@ -12,13 +12,13 @@ Source1: ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-%{version}.tar.bz2.sig
|
||||
Source2: gpgme-multilib.h
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Patch1: gpgme-1.3.0-config_extras.patch
|
||||
Patch1: gpgme-1.3.2-config_extras.patch
|
||||
|
||||
# fix ImplicitDSOLinking in tests/, upstreamable
|
||||
Patch2: gpgme-1.3.0-ImplicitDSOLinking.patch
|
||||
Patch2: gpgme-1.3.2-ImplicitDSOLinking.patch
|
||||
|
||||
# add -D_FILE_OFFSET_BITS... to gpgme-config, upstreamable
|
||||
Patch3: gpgme-1.2.0-largefile.patch
|
||||
Patch3: gpgme-1.3.2-largefile.patch
|
||||
|
||||
BuildRequires: gawk
|
||||
BuildRequires: gnupg2
|
||||
@ -27,9 +27,7 @@ BuildRequires: libgpg-error-devel
|
||||
BuildRequires: pth-devel
|
||||
BuildRequires: libassuan2-devel
|
||||
|
||||
# --disable-gpg-test required since 'make check' currently includes some
|
||||
# gpg(1)-specific tests
|
||||
%define _with_gpg --with-gpg=%{_bindir}/gpg2 --disable-gpg-test
|
||||
%define _with_gpg --with-gpg=%{_bindir}/gpg2
|
||||
Requires: gnupg2
|
||||
|
||||
# On the following architectures workaround multiarch conflict of -devel packages:
|
||||
@ -72,6 +70,7 @@ sed -i -e 's|^libdir=@libdir@$|libdir=@exec_prefix@/lib|g' src/gpgme-config.in
|
||||
%build
|
||||
%configure \
|
||||
--disable-static \
|
||||
--without-g13 \
|
||||
%{?_with_gpg}
|
||||
|
||||
make %{?_smp_mflags}
|
||||
@ -116,7 +115,6 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS COPYING* ChangeLog NEWS README* THANKS TODO VERSION
|
||||
%{_libdir}/libgpgme.so.11*
|
||||
%{_libdir}/libgpgme-pth.so.11*
|
||||
%{_libdir}/libgpgme-pthread.so.11*
|
||||
|
||||
%post devel
|
||||
@ -141,6 +139,12 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Sep 26 2012 Tomas Mraz <tmraz@redhat.com> - 1.3.2-1
|
||||
- new upstream version
|
||||
- re-enable gpg tests (original patch by John Morris <john@zultron.com>)
|
||||
- quiet configure warning 'could not find g13'
|
||||
- there is no libgpgme-pth anymore
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user