diff --git a/.gitignore b/.gitignore
index 89cd4e6..3f761f7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -10,3 +10,4 @@
/noto-fonts-86b2e553c3e3e4d6614dadd1fa0a7a6dafd74552.zip
/noto-fonts-db5c897c3954ab8dd49bfc3de4f3ef00a7ef6d06.zip
/noto-fonts-85e78f831469323c85847e23f95026c894159135.zip
+/noto-fonts-a5e21f60336d8b9b76a0f230d07dd59e12d6da80.zip
diff --git a/google-noto-fonts.spec b/google-noto-fonts.spec
index fb4adfd..32c47d6 100644
--- a/google-noto-fonts.spec
+++ b/google-noto-fonts.spec
@@ -1,24 +1,27 @@
-%global fontname google-noto
-%global fontconf %{fontname}
+%global _fontname google-noto
+%global _fontnamevf google-noto-vf
+%global _fontvfdir %{_fontbasedir}/%{_fontnamevf}
+%global fontname %{_fontname}
+%global fontconf %{_fontname}
%global common_desc Noto fonts aims to remove tofu from web by providing fonts for all \
Unicode supported scripts. Its design goal is to achieve visual harmonization\
between multiple scripts. Noto family supports almost all scripts available\
in Unicode.\
%{nil}
-%global commit 85e78f831469323c85847e23f95026c894159135
+%global commit a5e21f60336d8b9b76a0f230d07dd59e12d6da80
%global hprio 65
%global mprio 66
%global lprio 67
Name: %{fontname}-fonts
-Version: 20181130
-Release: 2%{?dist}
+Version: 20181223
+Release: 1%{?dist}
Summary: Hinted and Non Hinted OpenType fonts for Unicode scripts
License: OFL
URL: https://github.com/googlei18n/noto-fonts/
-# downloaded from https://github.com/googlei18n/noto-fonts/commits/85e78f831469323c85847e23f95026c894159135 -> download [zip]
-# link https://github.com/googlei18n/noto-fonts/archive/85e78f831469323c85847e23f95026c894159135.zip
+# downloaded from https://github.com/googlei18n/noto-fonts/commits/a5e21f60336d8b9b76a0f230d07dd59e12d6da80 -> download [zip]
+# link https://github.com/googlei18n/noto-fonts/archive/a5e21f60336d8b9b76a0f230d07dd59e12d6da80.zip
Source0: noto-fonts-%{commit}.zip
Source3: %{mprio}-%{fontconf}-sans-armenian.conf
Source5: %{mprio}-%{fontconf}-sans-bengali.conf
@@ -123,27 +126,33 @@ Summary: Common files for Noto fonts
%description common
Common files for Google Noto fonts.
-# notopkg [-c] [-a AltFontName] [-o old-name] Font Name
-# -c is for *.*tc fonts instead of *.*tf
+# notopkg [-a AltFontName] [-o old-name] Font Name
# -a overrides the FontName
# -o adds an obsoletes for an older package name
# -p overrides fontconfig .conf priority (default 66)
-%define notopkg(ca:o:p:)\
-%define pname %(echo %{*} | tr "A-Z " "a-z-")\
+# -v packages a variable font
+%define notopkg(c:a:o:p:v)\
+%define _pname %(echo %{*} | tr "A-Z " "a-z-")\
+%define pname %{_pname}%{-v:-vf}\
%{!-a:%define fname %(echo %{*} | sed -e "s/ //g")}\
-%define subpkg %{fontname}-%{pname}\
+%define subpkg %{_fontname}-%{pname}\
%define fconf %{-p*}%{!-p:%{mprio}}-%{fontconf}-%{pname}.conf\
%package -n %{subpkg}-fonts\
-Summary: %{*} font\
+Summary: %{*}%{-v: variable} font\
Requires: fontpackages-filesystem\
Requires: %{name}-common = %{version}-%{release}\
-%{?-o:Obsoletes: %{fontname}-%{-o*}-fonts < %{version}-%{release}}\
+%{?-o:Obsoletes: %{_fontname}-%{-o*}-fonts < %{version}-%{release}}\
\
%description -n %{subpkg}-fonts\
%common_desc\
Noto %1 font%{?2: for %(echo %* | sed -e "s/%1 //")}.\
\
-%_font_pkg -n %{pname} -f %{fconf} Noto%{-a*}%{!-a:%{fname}}-*.*t%{-c:c}%{!-c:f}\
+%{!-v:%_font_pkg -n %{pname} -f %{fconf} Noto%{-a*}%{!-a:%{fname}}-*.*tf} \
+%{-v:%files -n %{_fontname}-%{pname}-fonts\
+%dir %{_fontvfdir} \
+%{_fontvfdir}/Noto%{-a*}%{!-a:%{fname}}-*VF.*tf \
+%{_fontconfig_templatedir}/%{fconf} \
+%config(noreplace) %{_fontconfig_confdir}/%{fconf}} \
%{_datadir}/appdata/%{subpkg}.metainfo.xml
%notopkg Kufi Arabic
@@ -223,6 +232,7 @@ Noto %1 font%{?2: for %(echo %* | sed -e "s/%1 //")}.\
%notopkg Sans Mandaic
%notopkg Sans Manichaean
%notopkg Sans Marchen
+%notopkg -p %{lprio} Sans Math
%notopkg -o sans-meeteimayek Sans Meetei Mayek
%notopkg Sans Mende Kikakui
%notopkg Sans Meroitic
@@ -319,6 +329,57 @@ Noto %1 font%{?2: for %(echo %* | sed -e "s/%1 //")}.\
%notopkg Serif Telugu
%notopkg Serif Tibetan
+%global fontname %{_fontnamevf}
+%notopkg -v Sans
+%notopkg -v Sans Arabic
+%notopkg -v -p %{lprio} Sans Arabic UI
+%notopkg -v Sans Armenian
+%notopkg -v Sans Bengali
+%notopkg -v -p %{lprio} Sans Bengali UI
+%notopkg -v Sans Canadian Aboriginal
+%notopkg -v Sans Cham
+%notopkg -v Sans Cherokee
+%notopkg -v Sans Devanagari
+%notopkg -v -p %{lprio} Sans Devanagari UI
+%notopkg -v -p %{lprio} Sans Display
+%notopkg -v Sans Ethiopic
+%notopkg -v Sans Georgian
+%notopkg -v Sans Hebrew
+%notopkg -v Sans Kannada
+%notopkg -v -p %{lprio} Sans Kannada UI
+%notopkg -v Sans Khmer
+%notopkg -v -p %{lprio} Sans Khmer UI
+%notopkg -v Sans Lao
+%notopkg -v -p %{lprio} Sans Lao UI
+%notopkg -v Sans Malayalam
+%notopkg -v -p %{lprio} Sans Malayalam UI
+%notopkg -v Sans Mono
+%notopkg -v Sans Myanmar
+%notopkg -v -p %{lprio} Sans Myanmar UI
+%notopkg -v -p %{hprio} Sans Sinhala
+%notopkg -v Sans Symbols
+%notopkg -v Sans Tamil
+%notopkg -v -p %{lprio} Sans Tamil UI
+%notopkg -v Sans Thaana
+%notopkg -v Sans Thai
+%notopkg -v -p %{lprio} Sans Thai UI
+%notopkg -v Serif
+%notopkg -v Serif Armenian
+%notopkg -v -p %{lprio} Serif Display
+%notopkg -v Serif Ethiopic
+%notopkg -v Serif Georgian
+%notopkg -v Serif Gujarati
+%notopkg -v Serif Gurmukhi
+%notopkg -v Serif Hebrew
+%notopkg -v Serif Kannada
+%notopkg -v Serif Khmer
+%notopkg -v Serif Lao
+%notopkg -v Serif Myanmar
+%notopkg -v Serif Sinhala
+%notopkg -v Serif Tamil
+%notopkg -v Serif Tamil Slanted
+%notopkg -v Serif Thai
+%notopkg -v Serif Tibetan
%prep
%setup -q -n noto-fonts-%{commit}
@@ -327,9 +388,13 @@ Noto %1 font%{?2: for %(echo %* | sed -e "s/%1 //")}.\
%build
%install
+%global fontname %{_fontname}
install -m 0755 -d %{buildroot}%{_fontdir}
install -m 0644 -p unhinted/Noto*.ttf %{buildroot}%{_fontdir}
install -m 0644 -p hinted/Noto*.ttf %{buildroot}%{_fontdir}
+%global fontname %{_fontnamevf}
+install -m 0755 -d %{buildroot}%{_fontdir}
+install -m 0644 -p phaseIII_only/unhinted/variable-ttf/Noto*.ttf %{buildroot}%{_fontdir}
@@ -338,10 +403,11 @@ install -m 0755 -d %{buildroot}%{_fontconfig_templatedir} \
# Add appstream metadata
install -Dm 0644 -p %{SOURCE200} \
- %{buildroot}%{_datadir}/appdata/%{fontname}.metainfo.xml
+ %{buildroot}%{_datadir}/appdata/%{_fontname}.metainfo.xml
-%define fcconfbuild(a:g:p:)\
-%define pname %(echo %{*} | tr "A-Z " "a-z-")\
+%define fcconfbuild(a:g:p:v)\
+%define _pname %(echo %{*} | tr "A-Z " "a-z-")\
+%define pname %{_pname}%{-v:-vf}\
%define fconf %{-p*}%{!-p:%{mprio}}-%{fontconf}-%{pname}.conf\
cat<<_EOL_>%{buildroot}%{_fontconfig_templatedir}/%{fconf}\
\
@@ -399,6 +465,7 @@ _EOL_
%fcconfbuild -g sans-serif Sans Mandaic
%fcconfbuild -g sans-serif Sans Manichaean
%fcconfbuild -g sans-serif Sans Marchen
+%fcconfbuild -g sans-serif -p %{lprio} Sans Math
%fcconfbuild -g sans-serif Sans Mende Kikakui
%fcconfbuild -g sans-serif Sans Meroitic
%fcconfbuild -g sans-serif Sans Miao
@@ -451,6 +518,57 @@ _EOL_
%fcconfbuild -g serif Serif Tibetan
%fcconfbuild -g serif Serif
+%fcconfbuild -v -g sans-serif Sans
+%fcconfbuild -v -g sans-serif Sans Arabic
+%fcconfbuild -v -g sans-serif -p %{lprio} Sans Arabic UI
+%fcconfbuild -v -g sans-serif Sans Armenian
+%fcconfbuild -v -g sans-serif Sans Bengali
+%fcconfbuild -v -g sans-serif -p %{lprio} Sans Bengali UI
+%fcconfbuild -v -g sans-serif Sans Canadian Aboriginal
+%fcconfbuild -v -g sans-serif Sans Cham
+%fcconfbuild -v -g sans-serif Sans Cherokee
+%fcconfbuild -v -g sans-serif Sans Devanagari
+%fcconfbuild -v -g sans-serif -p %{lprio} Sans Devanagari UI
+%fcconfbuild -v -g sans-serif -p %{lprio} Sans Display
+%fcconfbuild -v -g sans-serif Sans Ethiopic
+%fcconfbuild -v -g sans-serif Sans Georgian
+%fcconfbuild -v -g sans-serif Sans Hebrew
+%fcconfbuild -v -g sans-serif Sans Kannada
+%fcconfbuild -v -g sans-serif -p %{lprio} Sans Kannada UI
+%fcconfbuild -v -g sans-serif Sans Khmer
+%fcconfbuild -v -g sans-serif -p %{lprio} Sans Khmer UI
+%fcconfbuild -v -g sans-serif Sans Lao
+%fcconfbuild -v -g sans-serif -p %{lprio} Sans Lao UI
+%fcconfbuild -v -g sans-serif Sans Malayalam
+%fcconfbuild -v -g sans-serif -p %{lprio} Sans Malayalam UI
+%fcconfbuild -v -g monospace Sans Mono
+%fcconfbuild -v -g sans-serif Sans Myanmar
+%fcconfbuild -v -g sans-serif -p %{lprio} Sans Myanmar UI
+%fcconfbuild -v -g sans-serif -p %{hprio} Sans Sinhala
+%fcconfbuild -v -g fantasy Sans Symbols
+%fcconfbuild -v -g sans-serif Sans Tamil
+%fcconfbuild -v -g sans-serif -p %{lprio} Sans Tamil UI
+%fcconfbuild -v -g sans-serif Sans Thaana
+%fcconfbuild -v -g sans-serif Sans Thai
+%fcconfbuild -v -g sans-serif -p %{lprio} Sans Thai UI
+%fcconfbuild -v -g serif Serif
+%fcconfbuild -v -g serif Serif Armenian
+%fcconfbuild -v -g serif -p %{lprio} Serif Display
+%fcconfbuild -v -g serif Serif Ethiopic
+%fcconfbuild -v -g serif Serif Georgian
+%fcconfbuild -v -g serif Serif Gujarati
+%fcconfbuild -v -g serif Serif Gurmukhi
+%fcconfbuild -v -g serif Serif Hebrew
+%fcconfbuild -v -g serif Serif Kannada
+%fcconfbuild -v -g serif Serif Khmer
+%fcconfbuild -v -g serif Serif Lao
+%fcconfbuild -v -g serif Serif Myanmar
+%fcconfbuild -v -g serif Serif Sinhala
+%fcconfbuild -v -g serif Serif Tamil
+%fcconfbuild -v -g serif Serif Tamil Slanted
+%fcconfbuild -v -g serif Serif Thai
+%fcconfbuild -v -g serif Serif Tibetan
+
for f in \
kufi-arabic music naskh-arabic naskh-arabic-ui \
sans sans-adlam sans-adlam-unjoined sans-anatolian-hieroglyphs \
@@ -471,7 +589,8 @@ for f in \
sans-kharoshthi sans-khmer sans-khmer-ui sans-khojki sans-khudawadi sans-lao \
sans-lao-ui sans-lepcha sans-limbu sans-linear-a sans-linear-b sans-lisu \
sans-lycian sans-lydian sans-mahajani sans-malayalam sans-malayalam-ui \
- sans-mandaic sans-manichaean sans-marchen sans-meetei-mayek sans-mende-kikakui \
+ sans-mandaic sans-manichaean sans-marchen sans-meetei-mayek sans-math \
+ sans-mende-kikakui \
sans-meroitic sans-miao sans-modi sans-mongolian sans-mro sans-multani \
sans-myanmar \
sans-myanmar-ui sans-nabataean sans-new-tai-lue sans-newa sans-nko sans-ogham \
@@ -494,6 +613,18 @@ for f in \
sans-oriya sans-oriya-ui sans-tibetan nastaliq-urdu sans-mono \
serif-balinese serif-bengali serif-devanagari serif-gujarati serif-kannada \
serif-malayalam serif-tamil serif-tamil-slanted serif-telugu serif-tibetan \
+ sans-vf sans-arabic-vf sans-arabic-ui-vf sans-armenian-vf sans-bengali-vf \
+ sans-bengali-ui-vf sans-canadian-aboriginal-vf sans-cham-vf sans-cherokee-vf \
+ sans-devanagari-vf sans-devanagari-ui-vf sans-display-vf sans-ethiopic-vf \
+ sans-georgian-vf sans-hebrew-vf sans-kannada-vf sans-kannada-ui-vf \
+ sans-khmer-vf sans-khmer-ui-vf sans-lao-vf sans-lao-ui-vf sans-malayalam-vf \
+ sans-malayalam-ui-vf sans-mono-vf sans-myanmar-vf sans-myanmar-ui-vf \
+ sans-sinhala-vf sans-symbols-vf sans-tamil-vf sans-tamil-ui-vf \
+ sans-thaana-vf sans-thai-vf sans-thai-ui-vf \
+ serif-vf serif-armenian-vf serif-display-vf serif-ethiopic-vf serif-georgian-vf \
+ serif-gujarati-vf serif-gurmukhi-vf serif-hebrew-vf serif-kannada-vf \
+ serif-khmer-vf serif-lao-vf serif-myanmar-vf serif-sinhala-vf \
+ serif-tamil-vf serif-tamil-slanted-vf serif-thai-vf serif-tibetan-vf \
; do
fconf=$(basename -a %{_sourcedir}/*-%{fontconf}-$f.conf)
ifconf=$(basename -a %{buildroot}%{_fontconfig_templatedir}/*-%{fontconf}-$f.conf)
@@ -510,7 +641,7 @@ for f in \
ln -s %{_fontconfig_templatedir}/${fconf} \
%{buildroot}%{_fontconfig_confdir}/${fconf}
- meta=%{fontname}-$f.metainfo.xml
+ meta=%{_fontname}-$f.metainfo.xml
echo '' > $meta
echo '' >> $meta
echo '' >> $meta
@@ -519,18 +650,22 @@ for f in \
echo ' google-noto' >> $meta
echo '' >> $meta
- install -Dm 0644 -p %{fontname}-$f.metainfo.xml \
- %{buildroot}%{_datadir}/appdata/%{fontname}-$f.metainfo.xml
+ install -Dm 0644 -p %{_fontname}-$f.metainfo.xml \
+ %{buildroot}%{_datadir}/appdata/%{_fontname}-$f.metainfo.xml
done
%files common
%license LICENSE
%doc README.md FAQ.md
-%{_datadir}/appdata/%{fontname}.metainfo.xml
+%{_datadir}/appdata/%{_fontname}.metainfo.xml
%changelog
+* Thu Dec 27 2018 Akira TAGOH - 20181223-1
+- Updates to 20181223.
+- Add new sub-packages for variable fonts.
+
* Mon Dec 17 2018 Akira TAGOH - 20181130-2
- Make Display and UI fonts lower priority.
- Add more languages to google-noto-*-devanagari.conf, google-noto-sans-ethiopic.conf,
diff --git a/sources b/sources
index e5e06c1..89ac092 100644
--- a/sources
+++ b/sources
@@ -1,2 +1,3 @@
SHA512 (noto-fonts-db5c897c3954ab8dd49bfc3de4f3ef00a7ef6d06.zip) = 5493168b731199bfb7cbd45404c839ac92be6d20f95289b783c60a8422d4f12f64bf4a48290eab1f3667678bdc06e2f3c1df87199dc029c6ae6197fc1158caa4
SHA512 (noto-fonts-85e78f831469323c85847e23f95026c894159135.zip) = df3058fd775e76a584964a38cd5bc3586cfdbdf3a90033c111bbd5177b9b04a166e877aab7ed1bd228b4b1c77c5ce545314c40d53c7e2435b8c1bf39c003d6d7
+SHA512 (noto-fonts-a5e21f60336d8b9b76a0f230d07dd59e12d6da80.zip) = 82f8a78a7c5e848d6e857ebe6869ab89c9c414ce9c6668a3a2edccbf11d6cb293d6e5649ff3c373771802884af5b95b7f0ebdf8b904bfb021a9f4e2586b194b9