1de22c6742
Also fixes the "people holding hands" sequence
30 lines
1.5 KiB
Diff
30 lines
1.5 KiB
Diff
diff -ru noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf.orig/Makefile noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf/Makefile
|
|
--- noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf.orig/Makefile 2019-07-09 10:15:51.036088559 +0200
|
|
+++ noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf/Makefile 2019-07-09 10:14:17.684085829 +0200
|
|
@@ -21,7 +21,8 @@
|
|
PNGQUANT = pngquant
|
|
PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
|
|
BODY_DIMENSIONS = 136x128
|
|
-IMOPS := -size $(BODY_DIMENSIONS) canvas:none -compose copy -gravity center
|
|
+#IMOPS := -size $(BODY_DIMENSIONS) canvas:none -compose copy -gravity center
|
|
+IMOPS = -size 136x128 -background none -gravity center -extent 136x128 -compose copy
|
|
|
|
# zopflipng is better (about 5-10%) but much slower. it will be used if
|
|
# present. pass ZOPFLIPNG= as an arg to make to use optipng instead.
|
|
@@ -178,13 +179,13 @@
|
|
# imagemagick packaged with ubuntu trusty (6.7.7-10) by using -composite.
|
|
|
|
$(EMOJI_DIR)/%.png: $(EMOJI_SRC_DIR)/%.png | $(EMOJI_DIR)
|
|
- @convert $(IMOPS) "$<" -composite "PNG32:$@"
|
|
+ @gm convert $(IMOPS) "$<" "PNG32:$@"
|
|
|
|
$(FLAGS_DIR)/%.png: $(FLAGS_SRC_DIR)/%.png ./waveflag | $(FLAGS_DIR)
|
|
@./waveflag $(FLAGS_DIR)/ "$<"
|
|
|
|
$(RESIZED_FLAGS_DIR)/%.png: $(FLAGS_DIR)/%.png | $(RESIZED_FLAGS_DIR)
|
|
- @convert $(IMOPS) "$<" -composite "PNG32:$@"
|
|
+ @gm convert $(IMOPS) "$<" "PNG32:$@"
|
|
|
|
flag-symlinks: $(RESIZED_FLAG_FILES) | $(RENAMED_FLAGS_DIR)
|
|
@$(subst ^, , \
|