Update to upstream snapshot tarball (color emoji font version 2.004)
This commit is contained in:
parent
521adae6ea
commit
b31ae1ad03
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@
|
||||
/nototools-0c99dff.tar.gz
|
||||
/noto-emoji-411334c.tar.gz
|
||||
/results_google-noto-emoji-fonts/
|
||||
/noto-emoji-153e1d4.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
%global commit0 411334c8e630acf858569602cbf5c19deba00878
|
||||
%global commit0 153e1d4c026c124fbac6ee93e559b5df375f24f5
|
||||
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
|
||||
|
||||
%global commit1 0c99dfff2a824c6f7210ff700c56b2c3d51e64cd
|
||||
@ -8,8 +8,8 @@
|
||||
|
||||
|
||||
Name: %{fontname}-fonts
|
||||
Version: 20170928
|
||||
Release: 4%{?dist}
|
||||
Version: 20180307
|
||||
Release: 1%{?dist}
|
||||
Summary: Google “Noto Emoji” Black-and-White emoji font
|
||||
|
||||
# In noto-emoji-fonts source
|
||||
@ -94,6 +94,9 @@ install -m 0644 -p %{SOURCE3} %{buildroot}%{_datadir}/appdata
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Mar 07 2018 Mike FABIAN <mfabian@redhat.com> - 20180307-1
|
||||
- Update to upstream snapshot tarball (color emoji font version 2.004)
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 20170928-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -ru noto-emoji-ff566b2c16f9332dc54e1b538e2bce2d213c0e3d.orig/Makefile noto-emoji-ff566b2c16f9332dc54e1b538e2bce2d213c0e3d/Makefile
|
||||
--- noto-emoji-ff566b2c16f9332dc54e1b538e2bce2d213c0e3d.orig/Makefile 2017-04-25 22:02:45.000000000 +0200
|
||||
+++ noto-emoji-ff566b2c16f9332dc54e1b538e2bce2d213c0e3d/Makefile 2017-04-26 09:55:23.736788590 +0200
|
||||
diff -ru noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5.orig/Makefile noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5/Makefile
|
||||
--- noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5.orig/Makefile 2018-03-07 09:22:49.670696985 +0100
|
||||
+++ noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5/Makefile 2018-03-07 09:23:06.824506178 +0100
|
||||
@@ -15,10 +15,9 @@
|
||||
EMOJI = NotoColorEmoji
|
||||
font: $(EMOJI).ttf
|
||||
@ -12,9 +12,9 @@ diff -ru noto-emoji-ff566b2c16f9332dc54e1b538e2bce2d213c0e3d.orig/Makefile noto-
|
||||
-PNGQUANT := $(PNGQUANTDIR)/pngquant
|
||||
+PNGQUANT = pngquant
|
||||
PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
|
||||
IMOPS = -size 136x128 canvas:none -compose copy -gravity center
|
||||
|
||||
@@ -96,6 +95,12 @@
|
||||
BODY_DIMENSIONS = 136x128
|
||||
IMOPS := -size $(BODY_DIMENSIONS) canvas:none -compose copy -gravity center
|
||||
@@ -97,6 +96,12 @@
|
||||
ALL_COMPRESSED_FILES = $(addprefix $(COMPRESSED_DIR)/, $(ALL_NAMES))
|
||||
|
||||
# tool checks
|
||||
@ -27,7 +27,7 @@ diff -ru noto-emoji-ff566b2c16f9332dc54e1b538e2bce2d213c0e3d.orig/Makefile noto-
|
||||
ifeq (,$(shell which $(ZOPFLIPNG)))
|
||||
ifeq (,$(wildcard $(ZOPFLIPNG)))
|
||||
MISSING_ZOPFLI = fail
|
||||
@@ -125,6 +130,11 @@
|
||||
@@ -126,6 +131,11 @@
|
||||
|
||||
compressed: $(ALL_COMPRESSED_FILES)
|
||||
|
||||
@ -39,7 +39,7 @@ diff -ru noto-emoji-ff566b2c16f9332dc54e1b538e2bce2d213c0e3d.orig/Makefile noto-
|
||||
check_compress_tool:
|
||||
ifdef MISSING_ZOPFLI
|
||||
ifdef MISSING_OPTIPNG
|
||||
@@ -145,8 +155,7 @@
|
||||
@@ -146,8 +156,7 @@
|
||||
$(EMOJI_DIR) $(FLAGS_DIR) $(RESIZED_FLAGS_DIR) $(RENAMED_FLAGS_DIR) $(QUANTIZED_DIR) $(COMPRESSED_DIR):
|
||||
mkdir -p "$@"
|
||||
|
||||
@ -49,10 +49,11 @@ diff -ru noto-emoji-ff566b2c16f9332dc54e1b538e2bce2d213c0e3d.orig/Makefile noto-
|
||||
|
||||
waveflag: waveflag.c
|
||||
$(CC) $< -o $@ $(CFLAGS) $(LDFLAGS)
|
||||
@@ -226,5 +235,5 @@
|
||||
@@ -227,5 +236,5 @@
|
||||
.SECONDARY: $(EMOJI_FILES) $(FLAG_FILES) $(RESIZED_FLAG_FILES) $(RENAMED_FLAG_FILES) \
|
||||
$(ALL_QUANTIZED_FILES) $(ALL_COMPRESSED_FILES)
|
||||
|
||||
-.PHONY: clean flags emoji renamed_flags quantized compressed check_compress_tool
|
||||
+.PHONY: clean flags emoji renamed_flags quantized compressed check_compress_tool check_quantization_tool
|
||||
|
||||
noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5/ のみに存在: Makefile.orig
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (noto-emoji-411334c.tar.gz) = 2b21bf329766e0e4dd1a0817000af6de82e3485da74f1899c6b7d98bad69a8b573aef4437a4837fa25a98235df3d11ebae2a7fc2c7c03ce88b56f572ef310f4d
|
||||
SHA512 (noto-emoji-153e1d4.tar.gz) = b2da342ccee73e72aac41a59afe0a726acf66cd1314f9582eb890b80ab646a340db14acbf4bd3146de9f30b50f84f38f76ca56369b7ef4b70b3e901e31b72355
|
||||
|
Loading…
Reference in New Issue
Block a user