import google-noto-emoji-fonts-20200916-2.el8

This commit is contained in:
CentOS Sources 2021-11-09 04:56:20 -05:00 committed by Stepan Oksanichenko
parent fcdded4161
commit a94728cf30
5 changed files with 43 additions and 65 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/noto-emoji-352632e.tar.gz
SOURCES/noto-emoji-aac7cca.tar.gz

View File

@ -1 +1 @@
6204fc375b0f8b90d29a2a9420ad00eec063d31c SOURCES/noto-emoji-352632e.tar.gz
5e6a809412c3947debe432adea4bbaf7310d8af4 SOURCES/noto-emoji-aac7cca.tar.gz

View File

@ -1,25 +1,24 @@
Index: noto-emoji-352632eb1935fd2b732f6f3ca0a24e9754c3eccf/Makefile
===================================================================
--- noto-emoji-352632eb1935fd2b732f6f3ca0a24e9754c3eccf.orig/Makefile
+++ noto-emoji-352632eb1935fd2b732f6f3ca0a24e9754c3eccf/Makefile
@@ -20,7 +20,8 @@ LDFLAGS = -lm `pkg-config --libs cairo`
PNGQUANT = pngquant
diff -ru noto-emoji-f8131fc45736000552cd04a8388dc414d666a829.orig/Makefile noto-emoji-f8131fc45736000552cd04a8388dc414d666a829/Makefile
--- noto-emoji-f8131fc45736000552cd04a8388dc414d666a829.orig/Makefile 2020-06-25 16:02:56.000000000 +0200
+++ noto-emoji-f8131fc45736000552cd04a8388dc414d666a829/Makefile 2020-07-21 11:12:06.948389580 +0200
@@ -22,7 +22,8 @@
PYTHON = python3
PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
BODY_DIMENSIONS = 136x128
-IMOPS := -size $(BODY_DIMENSIONS) canvas:none -compose copy -gravity center
+#IMOPS := -size $(BODY_DIMENSIONS) canvas:none -compose copy -gravity center
+IMOPS = -size 136x128 -background none -gravity center -extent 136x128 -compose copy
# zopflipng is better (about 5-10%) but much slower. it will be used if
# present. pass ZOPFLIPNG= as an arg to make to use optipng instead.
@@ -172,13 +173,13 @@ waveflag: waveflag.c
ZOPFLIPNG = zopflipng
TTX = ttx
@@ -163,13 +164,13 @@
# imagemagick packaged with ubuntu trusty (6.7.7-10) by using -composite.
$(EMOJI_DIR)/%.png: $(EMOJI_SRC_DIR)/%.png | $(EMOJI_DIR)
- @convert $(IMOPS) "$<" -composite "PNG32:$@"
+ @gm convert $(IMOPS) "$<" "PNG32:$@"
$(FLAGS_DIR)/%.png: $(FLAGS_SRC_DIR)/%.png ./waveflag $(PNGQUANT) | $(FLAGS_DIR)
$(FLAGS_DIR)/%.png: $(FLAGS_SRC_DIR)/%.png ./waveflag | $(FLAGS_DIR)
@./waveflag $(FLAGS_DIR)/ "$<"
$(RESIZED_FLAGS_DIR)/%.png: $(FLAGS_DIR)/%.png | $(RESIZED_FLAGS_DIR)
@ -28,3 +27,4 @@ Index: noto-emoji-352632eb1935fd2b732f6f3ca0a24e9754c3eccf/Makefile
flag-symlinks: $(RESIZED_FLAG_FILES) | $(RENAMED_FLAGS_DIR)
@$(subst ^, , \

View File

@ -1,59 +1,29 @@
diff -ru noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5.orig/Makefile noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5/Makefile
--- noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5.orig/Makefile 2018-03-07 09:22:49.670696985 +0100
+++ noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5/Makefile 2018-03-07 09:23:06.824506178 +0100
@@ -15,10 +15,9 @@
diff -ru noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f.orig/Makefile noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f/Makefile
--- noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f.orig/Makefile 2020-07-23 18:53:36.935321925 +0200
+++ noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f/Makefile 2020-07-23 19:05:20.380141144 +0200
@@ -15,10 +15,10 @@
EMOJI = NotoColorEmoji
font: $(EMOJI).ttf
-CFLAGS = -std=c99 -Wall -Wextra `pkg-config --cflags --libs cairo`
+CFLAGS = $(OPT_CFLAGS) `pkg-config --cflags --libs cairo`
+CFLAGS = $(OPT_CFLAGS) -Wextra `pkg-config --cflags --libs cairo`
LDFLAGS = -lm `pkg-config --libs cairo`
-PNGQUANTDIR := third_party/pngquant
-PNGQUANT := $(PNGQUANTDIR)/pngquant
+PNGQUANT = pngquant
-PNGQUANT = pngquant
+PNGQUANT = /usr/bin/pngquant
PYTHON = python3
PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
BODY_DIMENSIONS = 136x128
IMOPS := -size $(BODY_DIMENSIONS) canvas:none -compose copy -gravity center
@@ -97,6 +96,12 @@
ALL_COMPRESSED_FILES = $(addprefix $(COMPRESSED_DIR)/, $(ALL_NAMES))
@@ -87,9 +87,9 @@
endif
endif
# tool checks
+ifeq (,$(shell which $(PNGQUANT)))
+ ifeq (,$(wildcard $(PNGQUANT)))
+ MISSING_PNGQUANT = fail
+ endif
+endif
+
ifeq (,$(shell which $(ZOPFLIPNG)))
ifeq (,$(wildcard $(ZOPFLIPNG)))
MISSING_ZOPFLI = fail
@@ -126,6 +131,11 @@
-ifndef VIRTUAL_ENV
- MISSING_VENV = fail
-endif
+#ifndef VIRTUAL_ENV
+# MISSING_VENV = fail
+#endif
compressed: $(ALL_COMPRESSED_FILES)
+check_quantization_tool:
+ifdef MISSING_PNGQUANT
+ $(error "$(PNGQUANT) is not available")
+endif
+
check_compress_tool:
ifdef MISSING_ZOPFLI
ifdef MISSING_OPTIPNG
@@ -146,8 +156,7 @@
$(EMOJI_DIR) $(FLAGS_DIR) $(RESIZED_FLAGS_DIR) $(RENAMED_FLAGS_DIR) $(QUANTIZED_DIR) $(COMPRESSED_DIR):
mkdir -p "$@"
-$(PNGQUANT):
- $(MAKE) -C $(PNGQUANTDIR)
+$(PNGQUANT): check_quantization_tool
waveflag: waveflag.c
$(CC) $< -o $@ $(CFLAGS) $(LDFLAGS)
@@ -227,5 +236,5 @@
.SECONDARY: $(EMOJI_FILES) $(FLAG_FILES) $(RESIZED_FLAG_FILES) $(RENAMED_FLAG_FILES) \
$(ALL_QUANTIZED_FILES) $(ALL_COMPRESSED_FILES)
-.PHONY: clean flags emoji renamed_flags quantized compressed check_compress_tool
+.PHONY: clean flags emoji renamed_flags quantized compressed check_compress_tool check_quantization_tool
noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5/ のみに存在: Makefile.orig
ifeq (, $(shell which $(VS_ADDER)))
MISSING_PY_TOOLS = fail

View File

@ -1,4 +1,4 @@
%global commit0 352632eb1935fd2b732f6f3ca0a24e9754c3eccf
%global commit0 aac7ccaa4d1dea4543453b96f7d6fc47066a57ff
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
%global fontname google-noto-emoji
@ -11,8 +11,8 @@
Name: %{fontname}-fonts
Version: 20180508
Release: 4%{?dist}
Version: 20200916
Release: 2%{?dist}
Summary: Google “Noto Emoji” Black-and-White emoji font
# In noto-emoji-fonts source
@ -107,6 +107,14 @@ install -m 0644 -p %{SOURCE3} %{buildroot}%{_datadir}/appdata
%changelog
* Tue May 25 2021 Peng Wu <pwu@redhat.com> - 20200916-2
- Rebuild the package
- Resolves: RHBZ#1897541
* Tue May 25 2021 Peng Wu <pwu@redhat.com> - 20200916-1
- Update to Unicode 13.1.0 support
- Resolves: RHBZ#1897541
* Thu Jun 28 2018 Peng Wu <pwu@redhat.com> - 20180508-4
- Resolves: RHBZ#1591712