import google-noto-emoji-fonts-20200916-4.el9
This commit is contained in:
commit
845809c162
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/noto-emoji-aac7cca.tar.gz
|
1
.google-noto-emoji-fonts.metadata
Normal file
1
.google-noto-emoji-fonts.metadata
Normal file
@ -0,0 +1 @@
|
||||
5e6a809412c3947debe432adea4bbaf7310d8af4 SOURCES/noto-emoji-aac7cca.tar.gz
|
11
SOURCES/google-noto-emoji-color.metainfo.xml
Normal file
11
SOURCES/google-noto-emoji-color.metainfo.xml
Normal file
@ -0,0 +1,11 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!-- Copyright 2016 Peng Wu <pwu AT redhat DOT com> -->
|
||||
<component type="font">
|
||||
<id>google-noto-emoji-color</id>
|
||||
<metadata_license>CC-BY-3.0</metadata_license>
|
||||
<name>Noto Color Emoji</name>
|
||||
<summary>Google Noto Color Emoji Font</summary>
|
||||
<url type="homepage">https://github.com/googlei18n/noto-emoji</url>
|
||||
<update_contact><!-- upstream-contact_at_email.com --></update_contact>
|
||||
<extends>google-noto</extends>
|
||||
</component>
|
11
SOURCES/google-noto-emoji.metainfo.xml
Normal file
11
SOURCES/google-noto-emoji.metainfo.xml
Normal file
@ -0,0 +1,11 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!-- Copyright 2016 Peng Wu <pwu AT redhat DOT com> -->
|
||||
<component type="font">
|
||||
<id>google-noto-emoji</id>
|
||||
<metadata_license>CC-BY-3.0</metadata_license>
|
||||
<name>Noto Emoji</name>
|
||||
<summary>Google Noto Emoji Font</summary>
|
||||
<url type="homepage">https://github.com/googlei18n/noto-emoji</url>
|
||||
<update_contact><!-- upstream-contact_at_email.com --></update_contact>
|
||||
<extends>google-noto</extends>
|
||||
</component>
|
11
SOURCES/noto-emoji-build-all-flags.patch
Normal file
11
SOURCES/noto-emoji-build-all-flags.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- old/Makefile 2018-05-03 20:32:14.000000000 +0200
|
||||
+++ new/Makefile 2018-05-08 11:48:20.811073447 +0200
|
||||
@@ -78,7 +78,7 @@
|
||||
|
||||
ALL_FLAGS = $(basename $(notdir $(wildcard $(FLAGS_SRC_DIR)/*.png)))
|
||||
|
||||
-FLAGS = $(SELECTED_FLAGS)
|
||||
+FLAGS = $(ALL_FLAGS)
|
||||
|
||||
FLAG_NAMES = $(FLAGS:%=%.png)
|
||||
FLAG_FILES = $(addprefix $(FLAGS_DIR)/, $(FLAG_NAMES))
|
30
SOURCES/noto-emoji-use-gm.patch
Normal file
30
SOURCES/noto-emoji-use-gm.patch
Normal file
@ -0,0 +1,30 @@
|
||||
diff -ru noto-emoji-f8131fc45736000552cd04a8388dc414d666a829.orig/Makefile noto-emoji-f8131fc45736000552cd04a8388dc414d666a829/Makefile
|
||||
--- noto-emoji-f8131fc45736000552cd04a8388dc414d666a829.orig/Makefile 2020-06-25 16:02:56.000000000 +0200
|
||||
+++ noto-emoji-f8131fc45736000552cd04a8388dc414d666a829/Makefile 2020-07-21 11:12:06.948389580 +0200
|
||||
@@ -22,7 +22,8 @@
|
||||
PYTHON = python3
|
||||
PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
|
||||
BODY_DIMENSIONS = 136x128
|
||||
-IMOPS := -size $(BODY_DIMENSIONS) canvas:none -compose copy -gravity center
|
||||
+#IMOPS := -size $(BODY_DIMENSIONS) canvas:none -compose copy -gravity center
|
||||
+IMOPS = -size 136x128 -background none -gravity center -extent 136x128 -compose copy
|
||||
|
||||
ZOPFLIPNG = zopflipng
|
||||
TTX = ttx
|
||||
@@ -163,13 +164,13 @@
|
||||
# imagemagick packaged with ubuntu trusty (6.7.7-10) by using -composite.
|
||||
|
||||
$(EMOJI_DIR)/%.png: $(EMOJI_SRC_DIR)/%.png | $(EMOJI_DIR)
|
||||
- @convert $(IMOPS) "$<" -composite "PNG32:$@"
|
||||
+ @gm convert $(IMOPS) "$<" "PNG32:$@"
|
||||
|
||||
$(FLAGS_DIR)/%.png: $(FLAGS_SRC_DIR)/%.png ./waveflag | $(FLAGS_DIR)
|
||||
@./waveflag $(FLAGS_DIR)/ "$<"
|
||||
|
||||
$(RESIZED_FLAGS_DIR)/%.png: $(FLAGS_DIR)/%.png | $(RESIZED_FLAGS_DIR)
|
||||
- @convert $(IMOPS) "$<" -composite "PNG32:$@"
|
||||
+ @gm convert $(IMOPS) "$<" "PNG32:$@"
|
||||
|
||||
flag-symlinks: $(RESIZED_FLAG_FILES) | $(RENAMED_FLAGS_DIR)
|
||||
@$(subst ^, , \
|
||||
|
29
SOURCES/noto-emoji-use-system-pngquant.patch
Normal file
29
SOURCES/noto-emoji-use-system-pngquant.patch
Normal file
@ -0,0 +1,29 @@
|
||||
diff -ru noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f.orig/Makefile noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f/Makefile
|
||||
--- noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f.orig/Makefile 2020-07-23 18:53:36.935321925 +0200
|
||||
+++ noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f/Makefile 2020-07-23 19:05:20.380141144 +0200
|
||||
@@ -15,10 +15,10 @@
|
||||
EMOJI = NotoColorEmoji
|
||||
font: $(EMOJI).ttf
|
||||
|
||||
-CFLAGS = -std=c99 -Wall -Wextra `pkg-config --cflags --libs cairo`
|
||||
+CFLAGS = $(OPT_CFLAGS) -Wextra `pkg-config --cflags --libs cairo`
|
||||
LDFLAGS = -lm `pkg-config --libs cairo`
|
||||
|
||||
-PNGQUANT = pngquant
|
||||
+PNGQUANT = /usr/bin/pngquant
|
||||
PYTHON = python3
|
||||
PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
|
||||
BODY_DIMENSIONS = 136x128
|
||||
@@ -87,9 +87,9 @@
|
||||
endif
|
||||
endif
|
||||
|
||||
-ifndef VIRTUAL_ENV
|
||||
- MISSING_VENV = fail
|
||||
-endif
|
||||
+#ifndef VIRTUAL_ENV
|
||||
+# MISSING_VENV = fail
|
||||
+#endif
|
||||
|
||||
ifeq (, $(shell which $(VS_ADDER)))
|
||||
MISSING_PY_TOOLS = fail
|
243
SPECS/google-noto-emoji-fonts.spec
Normal file
243
SPECS/google-noto-emoji-fonts.spec
Normal file
@ -0,0 +1,243 @@
|
||||
%global commit0 aac7ccaa4d1dea4543453b96f7d6fc47066a57ff
|
||||
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
|
||||
|
||||
%global fontname google-noto-emoji
|
||||
|
||||
%if (0%{?fedora} > 25)
|
||||
%global buildfont 1
|
||||
%else
|
||||
%global buildfont 0
|
||||
%endif
|
||||
|
||||
|
||||
Name: %{fontname}-fonts
|
||||
Version: 20200916
|
||||
Release: 4%{?dist}
|
||||
Summary: Google “Noto Emoji” Black-and-White emoji font
|
||||
|
||||
# In noto-emoji-fonts source
|
||||
## noto-emoji code is in ASL 2.0 license
|
||||
## Emoji fonts are under OFL license
|
||||
### third_party color-emoji code is in BSD license
|
||||
### third_party region-flags code is in Public Domain license
|
||||
# In nototools source
|
||||
## nototools code is in ASL 2.0 license
|
||||
### third_party ucd code is in Unicode license
|
||||
License: OFL and ASL 2.0
|
||||
URL: https://github.com/googlei18n/noto-emoji
|
||||
Source0: https://github.com/googlei18n/noto-emoji/archive/%{commit0}.tar.gz#/noto-emoji-%{shortcommit0}.tar.gz
|
||||
Source2: %{fontname}.metainfo.xml
|
||||
Source3: %{fontname}-color.metainfo.xml
|
||||
|
||||
Patch0: noto-emoji-build-all-flags.patch
|
||||
Patch1: noto-emoji-use-gm.patch
|
||||
Patch2: noto-emoji-use-system-pngquant.patch
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: gcc
|
||||
BuildRequires: fontpackages-devel
|
||||
%if %buildfont
|
||||
BuildRequires: fonttools
|
||||
BuildRequires: python3-fonttools
|
||||
BuildRequires: nototools
|
||||
BuildRequires: python3-nototools
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: GraphicsMagick
|
||||
BuildRequires: pngquant
|
||||
BuildRequires: zopfli
|
||||
BuildRequires: cairo-devel
|
||||
%endif
|
||||
BuildRequires: make
|
||||
|
||||
Requires: fontpackages-filesystem
|
||||
|
||||
Obsoletes: google-noto-color-emoji-fonts < 20150617
|
||||
Provides: google-noto-color-emoji-fonts = 20150617
|
||||
|
||||
%description
|
||||
This package provides the Google “Noto Emoji” Black-and-White emoji font.
|
||||
|
||||
%package -n %{fontname}-color-fonts
|
||||
Summary: Google “Noto Color Emoji” colored emoji font
|
||||
Requires: fontpackages-filesystem
|
||||
Obsoletes: google-noto-color-emoji-fonts < 20150617
|
||||
Provides: google-noto-color-emoji-fonts = 20150617
|
||||
|
||||
%description -n %{fontname}-color-fonts
|
||||
This package provides the Google “Noto Color Emoji” colored emoji font.
|
||||
|
||||
%prep
|
||||
%setup -n noto-emoji-%{commit0}
|
||||
%patch0 -p1 -b .noto-emoji-build-all-flags
|
||||
%patch1 -p1 -b .noto-emoji-use-gm.patch
|
||||
%patch2 -p1 -b .noto-emoji-use-system-pngquant
|
||||
|
||||
rm -rf third_party/pngquant
|
||||
|
||||
%build
|
||||
%if %buildfont
|
||||
# Work around UTF-8
|
||||
export LANG=C.UTF-8
|
||||
|
||||
%make_build OPT_CFLAGS="$RPM_OPT_FLAGS" BYPASS_SEQUENCE_CHECK='True'
|
||||
%endif
|
||||
|
||||
%install
|
||||
install -m 0755 -d %{buildroot}%{_fontdir}
|
||||
|
||||
%if %buildfont
|
||||
# Built by us from the supplied pngs:
|
||||
install -m 0644 -p NotoColorEmoji.ttf %{buildroot}%{_fontdir}
|
||||
%else
|
||||
# Pre-built, and included with the source:
|
||||
install -m 0644 -p fonts/NotoColorEmoji.ttf %{buildroot}%{_fontdir}
|
||||
%endif
|
||||
|
||||
# Pre-built, and included with the source:
|
||||
install -m 0644 -p fonts/NotoEmoji-Regular.ttf %{buildroot}%{_fontdir}
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/appdata
|
||||
install -m 0644 -p %{SOURCE2} %{buildroot}%{_datadir}/appdata
|
||||
install -m 0644 -p %{SOURCE3} %{buildroot}%{_datadir}/appdata
|
||||
|
||||
%_font_pkg NotoEmoji-Regular.ttf
|
||||
%license LICENSE
|
||||
%doc AUTHORS CONTRIBUTING.md CONTRIBUTORS README.md
|
||||
%{_datadir}/appdata/google-noto-emoji.metainfo.xml
|
||||
|
||||
%_font_pkg -n color NotoColorEmoji.ttf
|
||||
%license LICENSE
|
||||
%doc AUTHORS CONTRIBUTING.md CONTRIBUTORS README.md
|
||||
%{_datadir}/appdata/google-noto-emoji-color.metainfo.xml
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 20200916-4
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 20200916-3
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 20200916-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Thu Dec 24 2020 Peng Wu <pwu@redhat.com> - 20200916-1
|
||||
- Update to upstream snapshot tarball (Unicode 13.1.0 support)
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 20200723-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jul 21 2020 Mike FABIAN <mfabian@redhat.com> - 20200723-1
|
||||
- Update to upstream snapshot tarball (Unicode 13.0.0 support)
|
||||
|
||||
* Mon Jul 13 2020 Tom Stellard <tstellar@redhat.com> - 20200402-2
|
||||
- Use make macros
|
||||
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||
|
||||
* Thu Apr 02 2020 Mike FABIAN <mfabian@redhat.com> - 20200402-1
|
||||
- Update to upstream snapshot tarball (fixes U+1F9D1 U+200D U+1F3A8 "artist"
|
||||
and many other sequences)
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 20191019-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Sat Oct 19 2019 Mike FABIAN <mfabian@redhat.com> - 20191019-1
|
||||
- Update to upstream snapshot tarball (Fixes for people holding hands)
|
||||
|
||||
* Thu Aug 29 2019 Mike FABIAN <mfabian@redhat.com> - 20190829-1
|
||||
- Update to upstream snapshot tarball (Fixes FR and NL flags)
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 20190709-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Tue Jul 09 2019 Mike FABIAN <mfabian@redhat.com> - 20190709-1
|
||||
- Update to upstream snapshot tarball (Contains the new emoji added in Unicode 12.0.0,
|
||||
also fixes the "people holding hands" sequence.
|
||||
- Port to Python3 and build using Python3
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 20180814-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Aug 14 2018 Mike FABIAN <mfabian@redhat.com> - 20180814-1
|
||||
- Update to upstream snapshot tarball (Contains the new emoji added in Unicode 11.0.0)
|
||||
|
||||
* Mon Jul 23 2018 Mike FABIAN <mfabian@redhat.com> - 20180508-6
|
||||
- Fix build in rawhide
|
||||
- Resolves: rhbz#1604247
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 20180508-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Tue Jun 26 2018 Peng Wu <pwu@redhat.com> - 20180508-4
|
||||
- Fixes buildfont macro
|
||||
|
||||
* Tue Jun 19 2018 Peng Wu <pwu@redhat.com> - 20180508-3
|
||||
- Only build emoji color font since Fedora 26
|
||||
|
||||
* Wed May 23 2018 Peng Wu <pwu@redhat.com> - 20180508-2
|
||||
- Use GraphicsMagick instead of ImageMagick
|
||||
|
||||
* Tue May 08 2018 Mike FABIAN <mfabian@redhat.com> - 20180508-1
|
||||
- Update to upstream snapshot tarball (color emoji font version 2.011)
|
||||
- Add patch to build all country flags (Resolves: rhbz#1574195)
|
||||
|
||||
* Wed Mar 07 2018 Mike FABIAN <mfabian@redhat.com> - 20180307-1
|
||||
- Update to upstream snapshot tarball (color emoji font version 2.004)
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 20170928-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Mon Feb 5 2018 Peng Wu <pwu@redhat.com> - 20170928-3
|
||||
- Use nototools package to build google-noto-emoji-fonts
|
||||
|
||||
* Wed Nov 8 2017 Peter Oliver <rpm@mavit.org.uk> - 20170928-2
|
||||
- Prefer zopflipng to optipng, since it should yield smaller files.
|
||||
- Use the font we built, rather than the one included with the source.
|
||||
|
||||
* Thu Sep 28 2017 Mike FABIAN <mfabian@redhat.com> - 20170828-1
|
||||
- Update to upstream snapshot tarball
|
||||
- split black-and-white and color fonts into different sub-packages.
|
||||
|
||||
* Mon Aug 28 2017 Mike FABIAN <mfabian@redhat.com> - 20170827-1
|
||||
- Update to upstream snapshot tarball
|
||||
- Update color emoji font to version 2.001, new design.
|
||||
- Contains the new emoji added in Unicode 10.0.0.
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 20170608-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Thu Jun 08 2017 Mike FABIAN <mfabian@redhat.com> - 20170608-1
|
||||
- Update to upstream snapshot tarball
|
||||
|
||||
* Tue May 23 2017 Mike FABIAN <mfabian@redhat.com> - 20170523-1
|
||||
- Update to upstream snapshot tarball
|
||||
- This fixes the skin tones of the light/medium light male cook emoji,
|
||||
which had been swapped.
|
||||
|
||||
* Wed Apr 26 2017 Mike FABIAN <mfabian@redhat.com> - 20170426-1
|
||||
- Update to upstream snapshot tarball
|
||||
(fixes the family emoji sequences:
|
||||
kiss: woman, man U+1F469 U+200D U+2764 U+FE0F U+200D U+1F48B U+200D U+1F468
|
||||
couple with heart: woman, man U+1F469 U+200D U+2764 U+FE0F U+200D U+1F468)
|
||||
|
||||
* Thu Feb 23 2017 Peng Wu <pwu@redhat.com> - 20170223-1
|
||||
- Update to upstream snapshot tarball
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 20160406-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri May 6 2016 Peng Wu <pwu@redhat.com> - 20160406-5
|
||||
- Avoid to use python setup.py
|
||||
|
||||
* Fri Apr 29 2016 Peng Wu <pwu@redhat.com> - 20160406-4
|
||||
- Replace google-noto-color-emoji-fonts package
|
||||
|
||||
* Mon Apr 25 2016 Peng Wu <pwu@redhat.com> - 20160406-3
|
||||
- Add google-noto-emoji.metainfo.xml
|
||||
|
||||
* Wed Apr 20 2016 Peng Wu <pwu@redhat.com> - 20160406-2
|
||||
- Use system pngquant
|
||||
|
||||
* Wed Apr 20 2016 Peng Wu <pwu@redhat.com> - 20160406-1
|
||||
- Initial packaging
|
Loading…
Reference in New Issue
Block a user