Use GraphicsMagick instead of ImageMagick
This commit is contained in:
parent
39208b348d
commit
58a1f9a482
@ -6,7 +6,7 @@
|
||||
|
||||
Name: %{fontname}-fonts
|
||||
Version: 20180508
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Google “Noto Emoji” Black-and-White emoji font
|
||||
|
||||
# In noto-emoji-fonts source
|
||||
@ -25,6 +25,7 @@ Source3: %{fontname}-color.metainfo.xml
|
||||
|
||||
Patch0: noto-emoji-use-system-pngquant.patch
|
||||
Patch1: noto-emoji-build-all-flags.patch
|
||||
Patch2: noto-emoji-use-gm.patch
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: gcc
|
||||
@ -34,7 +35,7 @@ BuildRequires: nototools
|
||||
BuildRequires: python2-nototools
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: fontpackages-devel
|
||||
BuildRequires: ImageMagick
|
||||
BuildRequires: GraphicsMagick
|
||||
BuildRequires: pngquant
|
||||
BuildRequires: zopfli
|
||||
BuildRequires: cairo-devel
|
||||
@ -92,6 +93,9 @@ install -m 0644 -p %{SOURCE3} %{buildroot}%{_datadir}/appdata
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed May 23 2018 Peng Wu <pwu@redhat.com> - 20180508-2
|
||||
- Use GraphicsMagick instead of ImageMagick
|
||||
|
||||
* Tue May 08 2018 Mike FABIAN <mfabian@redhat.com> - 20180508-1
|
||||
- Update to upstream snapshot tarball (color emoji font version 2.011)
|
||||
- Add patch to build all country flags (Resolves: rhbz#1574195)
|
||||
|
30
noto-emoji-use-gm.patch
Normal file
30
noto-emoji-use-gm.patch
Normal file
@ -0,0 +1,30 @@
|
||||
Index: noto-emoji-352632eb1935fd2b732f6f3ca0a24e9754c3eccf/Makefile
|
||||
===================================================================
|
||||
--- noto-emoji-352632eb1935fd2b732f6f3ca0a24e9754c3eccf.orig/Makefile
|
||||
+++ noto-emoji-352632eb1935fd2b732f6f3ca0a24e9754c3eccf/Makefile
|
||||
@@ -20,7 +20,8 @@ LDFLAGS = -lm `pkg-config --libs cairo`
|
||||
PNGQUANT = pngquant
|
||||
PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
|
||||
BODY_DIMENSIONS = 136x128
|
||||
-IMOPS := -size $(BODY_DIMENSIONS) canvas:none -compose copy -gravity center
|
||||
+#IMOPS := -size $(BODY_DIMENSIONS) canvas:none -compose copy -gravity center
|
||||
+IMOPS = -size 136x128 -background none -gravity center -extent 136x128 -compose copy
|
||||
|
||||
# zopflipng is better (about 5-10%) but much slower. it will be used if
|
||||
# present. pass ZOPFLIPNG= as an arg to make to use optipng instead.
|
||||
@@ -172,13 +173,13 @@ waveflag: waveflag.c
|
||||
# imagemagick packaged with ubuntu trusty (6.7.7-10) by using -composite.
|
||||
|
||||
$(EMOJI_DIR)/%.png: $(EMOJI_SRC_DIR)/%.png | $(EMOJI_DIR)
|
||||
- @convert $(IMOPS) "$<" -composite "PNG32:$@"
|
||||
+ @gm convert $(IMOPS) "$<" "PNG32:$@"
|
||||
|
||||
$(FLAGS_DIR)/%.png: $(FLAGS_SRC_DIR)/%.png ./waveflag $(PNGQUANT) | $(FLAGS_DIR)
|
||||
@./waveflag $(FLAGS_DIR)/ "$<"
|
||||
|
||||
$(RESIZED_FLAGS_DIR)/%.png: $(FLAGS_DIR)/%.png | $(RESIZED_FLAGS_DIR)
|
||||
- @convert $(IMOPS) "$<" -composite "PNG32:$@"
|
||||
+ @gm convert $(IMOPS) "$<" "PNG32:$@"
|
||||
|
||||
flag-symlinks: $(RESIZED_FLAG_FILES) | $(RENAMED_FLAGS_DIR)
|
||||
@$(subst ^, , \
|
Loading…
Reference in New Issue
Block a user