Update to upstream snapshot tarball (Unicode 13.0.0 support)
This commit is contained in:
parent
f489bed785
commit
566108510f
2
.gitignore
vendored
2
.gitignore
vendored
@ -21,3 +21,5 @@
|
|||||||
/noto-emoji-833a43d.tar.gz
|
/noto-emoji-833a43d.tar.gz
|
||||||
/noto-emoji-16151a2.tar.gz
|
/noto-emoji-16151a2.tar.gz
|
||||||
/noto-emoji-ac1703e.tar.gz
|
/noto-emoji-ac1703e.tar.gz
|
||||||
|
/noto-emoji-f8131fc.tar.gz
|
||||||
|
/noto-emoji-d5e2614.tar.gz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
%global commit0 ac1703e9d7feebbf5443a986e08332b1e1c5afcf
|
%global commit0 d5e261484286d33a1fe8a02676f5907ecc02106f
|
||||||
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
|
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
|
||||||
|
|
||||||
%global fontname google-noto-emoji
|
%global fontname google-noto-emoji
|
||||||
@ -11,8 +11,8 @@
|
|||||||
|
|
||||||
|
|
||||||
Name: %{fontname}-fonts
|
Name: %{fontname}-fonts
|
||||||
Version: 20200402
|
Version: 20200723
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Google “Noto Emoji” Black-and-White emoji font
|
Summary: Google “Noto Emoji” Black-and-White emoji font
|
||||||
|
|
||||||
# In noto-emoji-fonts source
|
# In noto-emoji-fonts source
|
||||||
@ -29,9 +29,10 @@ Source0: https://github.com/googlei18n/noto-emoji/archive/%{commit0}.tar.
|
|||||||
Source2: %{fontname}.metainfo.xml
|
Source2: %{fontname}.metainfo.xml
|
||||||
Source3: %{fontname}-color.metainfo.xml
|
Source3: %{fontname}-color.metainfo.xml
|
||||||
|
|
||||||
Patch0: noto-emoji-use-system-pngquant.patch
|
Patch0: noto-emoji-build-all-flags.patch
|
||||||
Patch1: noto-emoji-build-all-flags.patch
|
Patch1: noto-emoji-use-gm.patch
|
||||||
Patch2: noto-emoji-use-gm.patch
|
Patch2: noto-emoji-use-system-pngquant.patch
|
||||||
|
Patch3: noto-emoji-check-sequence.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -67,9 +68,10 @@ This package provides the Google “Noto Color Emoji” colored emoji font.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -n noto-emoji-%{commit0}
|
%setup -n noto-emoji-%{commit0}
|
||||||
%patch0 -p1 -b .noto-emoji-use-system-pngquant
|
%patch0 -p1 -b .noto-emoji-build-all-flags
|
||||||
%patch1 -p1 -b .noto-emoji-build-all-flags
|
%patch1 -p1 -b .noto-emoji-use-gm.patch
|
||||||
%patch2 -p1 -b .noto-emoji-use-gm.patch
|
%patch2 -p1 -b .noto-emoji-use-system-pngquant
|
||||||
|
%patch3 -p1 -b .noto-emoji-check-sequence
|
||||||
|
|
||||||
rm -rf third_party/pngquant
|
rm -rf third_party/pngquant
|
||||||
|
|
||||||
@ -78,7 +80,7 @@ rm -rf third_party/pngquant
|
|||||||
# Work around UTF-8
|
# Work around UTF-8
|
||||||
export LANG=C.UTF-8
|
export LANG=C.UTF-8
|
||||||
|
|
||||||
%make_build OPT_CFLAGS="$RPM_OPT_FLAGS"
|
%make_build OPT_CFLAGS="$RPM_OPT_FLAGS" BYPASS_SEQUENCE_CHECK='True'
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -111,6 +113,9 @@ install -m 0644 -p %{SOURCE3} %{buildroot}%{_datadir}/appdata
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 21 2020 Mike FABIAN <mfabian@redhat.com> - 20200723-1
|
||||||
|
- Update to upstream snapshot tarball (Unicode 13.0.0 support)
|
||||||
|
|
||||||
* Mon Jul 13 2020 Tom Stellard <tstellar@redhat.com> - 20200402-2
|
* Mon Jul 13 2020 Tom Stellard <tstellar@redhat.com> - 20200402-2
|
||||||
- Use make macros
|
- Use make macros
|
||||||
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||||
|
20
noto-emoji-check-sequence.patch
Normal file
20
noto-emoji-check-sequence.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
diff -ru noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f.orig/Makefile noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f/Makefile
|
||||||
|
--- noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f.orig/Makefile 2020-07-22 04:16:40.000000000 +0200
|
||||||
|
+++ noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f/Makefile 2020-07-24 12:36:48.786209598 +0200
|
||||||
|
@@ -206,7 +206,7 @@
|
||||||
|
@rm -f "$@"
|
||||||
|
ttx "$<"
|
||||||
|
|
||||||
|
-$(EMOJI).ttf: check_sequence $(EMOJI).tmpl.ttf $(EMOJI_BUILDER) $(PUA_ADDER) \
|
||||||
|
+$(EMOJI).ttf: $(EMOJI).tmpl.ttf $(EMOJI_BUILDER) $(PUA_ADDER) \
|
||||||
|
$(ALL_COMPRESSED_FILES) | check_tools
|
||||||
|
|
||||||
|
@$(PYTHON) $(EMOJI_BUILDER) $(SMALL_METRICS) -V $< "$@" "$(COMPRESSED_DIR)/emoji_u"
|
||||||
|
@@ -230,5 +230,5 @@
|
||||||
|
.SECONDARY: $(EMOJI_FILES) $(FLAG_FILES) $(RESIZED_FLAG_FILES) $(RENAMED_FLAG_FILES) \
|
||||||
|
$(ALL_QUANTIZED_FILES) $(ALL_COMPRESSED_FILES)
|
||||||
|
|
||||||
|
-.PHONY: clean flags emoji renamed_flags quantized compressed check_tools
|
||||||
|
+.PHONY: clean flags emoji renamed_flags quantized compressed check_tools check_sequence
|
||||||
|
|
||||||
|
noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f のみに存在: Makefile.~1~
|
@ -1,6 +1,6 @@
|
|||||||
diff -ru noto-emoji-ac1703e9d7feebbf5443a986e08332b1e1c5afcf.orig/Makefile noto-emoji-ac1703e9d7feebbf5443a986e08332b1e1c5afcf/Makefile
|
diff -ru noto-emoji-f8131fc45736000552cd04a8388dc414d666a829.orig/Makefile noto-emoji-f8131fc45736000552cd04a8388dc414d666a829/Makefile
|
||||||
--- noto-emoji-ac1703e9d7feebbf5443a986e08332b1e1c5afcf.orig/Makefile 2020-03-17 07:29:14.000000000 +0100
|
--- noto-emoji-f8131fc45736000552cd04a8388dc414d666a829.orig/Makefile 2020-06-25 16:02:56.000000000 +0200
|
||||||
+++ noto-emoji-ac1703e9d7feebbf5443a986e08332b1e1c5afcf/Makefile 2020-04-03 09:19:34.852917586 +0200
|
+++ noto-emoji-f8131fc45736000552cd04a8388dc414d666a829/Makefile 2020-07-21 11:12:06.948389580 +0200
|
||||||
@@ -22,7 +22,8 @@
|
@@ -22,7 +22,8 @@
|
||||||
PYTHON = python3
|
PYTHON = python3
|
||||||
PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
|
PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
|
||||||
@ -9,9 +9,9 @@ diff -ru noto-emoji-ac1703e9d7feebbf5443a986e08332b1e1c5afcf.orig/Makefile noto-
|
|||||||
+#IMOPS := -size $(BODY_DIMENSIONS) canvas:none -compose copy -gravity center
|
+#IMOPS := -size $(BODY_DIMENSIONS) canvas:none -compose copy -gravity center
|
||||||
+IMOPS = -size 136x128 -background none -gravity center -extent 136x128 -compose copy
|
+IMOPS = -size 136x128 -background none -gravity center -extent 136x128 -compose copy
|
||||||
|
|
||||||
# zopflipng is better (about 5-10%) but much slower. it will be used if
|
ZOPFLIPNG = zopflipng
|
||||||
# present. pass ZOPFLIPNG= as an arg to make to use optipng instead.
|
TTX = ttx
|
||||||
@@ -166,13 +167,13 @@
|
@@ -163,13 +164,13 @@
|
||||||
# imagemagick packaged with ubuntu trusty (6.7.7-10) by using -composite.
|
# imagemagick packaged with ubuntu trusty (6.7.7-10) by using -composite.
|
||||||
|
|
||||||
$(EMOJI_DIR)/%.png: $(EMOJI_SRC_DIR)/%.png | $(EMOJI_DIR)
|
$(EMOJI_DIR)/%.png: $(EMOJI_SRC_DIR)/%.png | $(EMOJI_DIR)
|
||||||
@ -27,3 +27,4 @@ diff -ru noto-emoji-ac1703e9d7feebbf5443a986e08332b1e1c5afcf.orig/Makefile noto-
|
|||||||
|
|
||||||
flag-symlinks: $(RESIZED_FLAG_FILES) | $(RENAMED_FLAGS_DIR)
|
flag-symlinks: $(RESIZED_FLAG_FILES) | $(RENAMED_FLAGS_DIR)
|
||||||
@$(subst ^, , \
|
@$(subst ^, , \
|
||||||
|
|
||||||
|
@ -1,53 +1,29 @@
|
|||||||
diff -ru noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf.orig/Makefile noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf/Makefile
|
diff -ru noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f.orig/Makefile noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f/Makefile
|
||||||
--- noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf.orig/Makefile 2019-07-08 18:40:44.000000000 +0200
|
--- noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f.orig/Makefile 2020-07-23 18:53:36.935321925 +0200
|
||||||
+++ noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf/Makefile 2019-07-09 10:07:13.028622382 +0200
|
+++ noto-emoji-d5e261484286d33a1fe8a02676f5907ecc02106f/Makefile 2020-07-23 19:05:20.380141144 +0200
|
||||||
@@ -15,7 +15,7 @@
|
@@ -15,10 +15,10 @@
|
||||||
EMOJI = NotoColorEmoji
|
EMOJI = NotoColorEmoji
|
||||||
font: $(EMOJI).ttf
|
font: $(EMOJI).ttf
|
||||||
|
|
||||||
-CFLAGS = -std=c99 -Wall -Wextra `pkg-config --cflags --libs cairo`
|
-CFLAGS = -std=c99 -Wall -Wextra `pkg-config --cflags --libs cairo`
|
||||||
+CFLAGS = $(OPT_CFLAGS) `pkg-config --cflags --libs cairo`
|
+CFLAGS = $(OPT_CFLAGS) -Wextra `pkg-config --cflags --libs cairo`
|
||||||
LDFLAGS = -lm `pkg-config --libs cairo`
|
LDFLAGS = -lm `pkg-config --libs cairo`
|
||||||
|
|
||||||
PNGQUANT = pngquant
|
-PNGQUANT = pngquant
|
||||||
@@ -101,6 +101,12 @@
|
+PNGQUANT = /usr/bin/pngquant
|
||||||
ALL_COMPRESSED_FILES = $(addprefix $(COMPRESSED_DIR)/, $(ALL_NAMES))
|
PYTHON = python3
|
||||||
|
PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
|
||||||
|
BODY_DIMENSIONS = 136x128
|
||||||
|
@@ -87,9 +87,9 @@
|
||||||
|
endif
|
||||||
|
endif
|
||||||
|
|
||||||
# tool checks
|
-ifndef VIRTUAL_ENV
|
||||||
+ifeq (,$(shell which $(PNGQUANT)))
|
- MISSING_VENV = fail
|
||||||
+ ifeq (,$(wildcard $(PNGQUANT)))
|
-endif
|
||||||
+ MISSING_PNGQUANT = fail
|
+#ifndef VIRTUAL_ENV
|
||||||
+ endif
|
+# MISSING_VENV = fail
|
||||||
+endif
|
+#endif
|
||||||
+
|
|
||||||
ifeq (,$(shell which $(ZOPFLIPNG)))
|
|
||||||
ifeq (,$(wildcard $(ZOPFLIPNG)))
|
|
||||||
MISSING_ZOPFLI = fail
|
|
||||||
@@ -130,6 +136,11 @@
|
|
||||||
|
|
||||||
compressed: $(ALL_COMPRESSED_FILES)
|
|
||||||
|
|
||||||
+check_quantization_tool:
|
|
||||||
+ifdef MISSING_PNGQUANT
|
|
||||||
+ $(error "$(PNGQUANT) is not available")
|
|
||||||
+endif
|
|
||||||
+
|
|
||||||
check_compress_tool:
|
|
||||||
ifdef MISSING_ZOPFLI
|
|
||||||
ifdef MISSING_OPTIPNG
|
|
||||||
@@ -151,6 +162,8 @@
|
|
||||||
mkdir -p "$@"
|
|
||||||
|
|
||||||
|
|
||||||
+$(PNGQUANT): check_quantization_tool
|
|
||||||
+
|
|
||||||
waveflag: waveflag.c
|
|
||||||
$(CC) $< -o $@ $(CFLAGS) $(LDFLAGS)
|
|
||||||
|
|
||||||
@@ -229,5 +242,5 @@
|
|
||||||
.SECONDARY: $(EMOJI_FILES) $(FLAG_FILES) $(RESIZED_FLAG_FILES) $(RENAMED_FLAG_FILES) \
|
|
||||||
$(ALL_QUANTIZED_FILES) $(ALL_COMPRESSED_FILES)
|
|
||||||
|
|
||||||
-.PHONY: clean flags emoji renamed_flags quantized compressed check_compress_tool
|
|
||||||
+.PHONY: clean flags emoji renamed_flags quantized compressed check_compress_tool check_quantization_tool
|
|
||||||
|
|
||||||
|
ifeq (, $(shell which $(VS_ADDER)))
|
||||||
|
MISSING_PY_TOOLS = fail
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (noto-emoji-ac1703e.tar.gz) = 958a589ef7d7a0b9e4fa3eb1caa20284fa7463419a740d0ca05f850618324883c13498f92839476042cfd1daffa7eff925b2f22ec318c0726391f69c04911bfb
|
SHA512 (noto-emoji-d5e2614.tar.gz) = 9b3960151114e57b94d698d1dc9d794da97d7061bf60e24f6b2513c40ef73bcd8db4b239c60719adf102a825713dc3086a825d1e58e2000f1b00438b8795d75e
|
||||||
|
Loading…
Reference in New Issue
Block a user