Update to upstream snapshot tarball (fixes some family emoji sequences)

Fixes the family emoji sequences:
kiss: woman, man U+1F469 U+200D U+2764 U+FE0F U+200D U+1F48B U+200D U+1F468
couple with heart: woman, man U+1F469 U+200D U+2764 U+FE0F U+200D U+1F468
This commit is contained in:
Mike FABIAN 2017-04-26 09:42:16 +02:00
parent 934cc4ed6d
commit 33e770ba09
4 changed files with 22 additions and 15 deletions

2
.gitignore vendored
View File

@ -2,3 +2,5 @@
/nototools-c1f2cff.tar.gz
/noto-emoji-1c0ce22.tar.gz
/nototools-d59a186.tar.gz
/noto-emoji-ff566b2.tar.gz
/nototools-b5af4b9.tar.gz

View File

@ -1,14 +1,14 @@
%global commit0 1c0ce222a4827d11501297f3c303f84cc3a45cad
%global commit0 ff566b2c16f9332dc54e1b538e2bce2d213c0e3d
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
%global commit1 d59a1867d3adc3e7ae94f1b4facecb9bf2a30089
%global commit1 b5af4b94a5744ca94f662de6a8f95a5ec3c8afcf
%global shortcommit1 %(c=%{commit1}; echo ${c:0:7})
%global fontname google-noto-emoji
Name: google-noto-emoji-fonts
Version: 20170223
Version: 20170426
Release: 1%{?dist}
Summary: Google Noto Emoji Fonts
@ -81,6 +81,12 @@ install -m 0644 -p %{SOURCE2} %{buildroot}%{_datadir}/appdata
%changelog
* Wed Apr 26 2017 Mike FABIAN <mfabian@redhat.com> - 20170426-1
- Update to upstream snapshot tarball
(fixes the family emoji sequences:
kiss: woman, man U+1F469 U+200D U+2764 U+FE0F U+200D U+1F48B U+200D U+1F468
couple with heart: woman, man U+1F469 U+200D U+2764 U+FE0F U+200D U+1F468)
* Thu Feb 23 2017 Peng Wu <pwu@redhat.com> - 20170223-1
- Update to upstream snapshot tarball

View File

@ -1,7 +1,6 @@
Index: noto-emoji-e7a7241a929625feb16920a40bfa29e4a302b82b/Makefile
===================================================================
--- noto-emoji-e7a7241a929625feb16920a40bfa29e4a302b82b.orig/Makefile
+++ noto-emoji-e7a7241a929625feb16920a40bfa29e4a302b82b/Makefile
diff -ru noto-emoji-ff566b2c16f9332dc54e1b538e2bce2d213c0e3d.orig/Makefile noto-emoji-ff566b2c16f9332dc54e1b538e2bce2d213c0e3d/Makefile
--- noto-emoji-ff566b2c16f9332dc54e1b538e2bce2d213c0e3d.orig/Makefile 2017-04-25 22:02:45.000000000 +0200
+++ noto-emoji-ff566b2c16f9332dc54e1b538e2bce2d213c0e3d/Makefile 2017-04-26 09:55:23.736788590 +0200
@@ -15,10 +15,9 @@
EMOJI = NotoColorEmoji
font: $(EMOJI).ttf
@ -12,10 +11,10 @@ Index: noto-emoji-e7a7241a929625feb16920a40bfa29e4a302b82b/Makefile
-PNGQUANTDIR := third_party/pngquant
-PNGQUANT := $(PNGQUANTDIR)/pngquant
+PNGQUANT = pngquant
PNGQUANTFLAGS = --speed 1 --skip-if-larger --force
PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
IMOPS = -size 136x128 canvas:none -compose copy -gravity center
# zopflipng is better (about 5-10%) but much slower. it will be used if
@@ -92,6 +91,12 @@ ALL_QUANTIZED_FILES = $(addprefix $(QUAN
@@ -96,6 +95,12 @@
ALL_COMPRESSED_FILES = $(addprefix $(COMPRESSED_DIR)/, $(ALL_NAMES))
# tool checks
@ -28,7 +27,7 @@ Index: noto-emoji-e7a7241a929625feb16920a40bfa29e4a302b82b/Makefile
ifeq (,$(shell which $(ZOPFLIPNG)))
ifeq (,$(wildcard $(ZOPFLIPNG)))
MISSING_ZOPFLI = fail
@@ -121,6 +126,11 @@ quantized: $(ALL_QUANTIZED_FILES)
@@ -125,6 +130,11 @@
compressed: $(ALL_COMPRESSED_FILES)
@ -40,7 +39,7 @@ Index: noto-emoji-e7a7241a929625feb16920a40bfa29e4a302b82b/Makefile
check_compress_tool:
ifdef MISSING_ZOPFLI
ifdef MISSING_OPTIPNG
@@ -141,8 +151,7 @@ endif
@@ -145,8 +155,7 @@
$(EMOJI_DIR) $(FLAGS_DIR) $(RESIZED_FLAGS_DIR) $(RENAMED_FLAGS_DIR) $(QUANTIZED_DIR) $(COMPRESSED_DIR):
mkdir -p "$@"
@ -50,7 +49,7 @@ Index: noto-emoji-e7a7241a929625feb16920a40bfa29e4a302b82b/Makefile
waveflag: waveflag.c
$(CC) $< -o $@ $(CFLAGS) $(LDFLAGS)
@@ -213,5 +222,5 @@ clean:
@@ -226,5 +235,5 @@
.SECONDARY: $(EMOJI_FILES) $(FLAG_FILES) $(RESIZED_FLAG_FILES) $(RENAMED_FLAG_FILES) \
$(ALL_QUANTIZED_FILES) $(ALL_COMPRESSED_FILES)

View File

@ -1,2 +1,2 @@
SHA512 (noto-emoji-1c0ce22.tar.gz) = 06e5913d5f30e24d184d2bfb405d24fc7c85a02669e067abd381cc900d0968145815277f1bfd95ce3977a3f99524c64d4d74c70cfea42c275a7c7073217d99f0
SHA512 (nototools-d59a186.tar.gz) = 166db06d36b32e16396adde1be6a47f48d3340773cbb47a2e2a86f3bbedb51ed9023c213a75bbeab749e9e815c875337bf1542f358a43e5e6104a2dac16e8925
SHA512 (noto-emoji-ff566b2.tar.gz) = 7bd8eb2a624df1e6d815ef56fb7ad3f3ad886a56a5876c8c17c7f83a37e8f7999a585560f6a14e3c4e6522a6d9e19ff2f560f24e56307e29feff632ad711123a
SHA512 (nototools-b5af4b9.tar.gz) = 55c1db59d9f3e9f367b5ebcdde5d65f9092d72ae73e9eac60dfeb7198ba2164eb3f87ee569d8db867fec203cd9e88086326353b6fbe7de5b79b2d26bb16e4438