Update to upstream snapshot tarball (Contains the new emoji added in Unicode 12.0.0)
Also fixes the "people holding hands" sequence
This commit is contained in:
parent
77e7dc2c43
commit
1de22c6742
1
.gitignore
vendored
1
.gitignore
vendored
@ -17,3 +17,4 @@
|
|||||||
/noto-emoji-153e1d4.tar.gz
|
/noto-emoji-153e1d4.tar.gz
|
||||||
/noto-emoji-352632e.tar.gz
|
/noto-emoji-352632e.tar.gz
|
||||||
/noto-emoji-3ffd20e.tar.gz
|
/noto-emoji-3ffd20e.tar.gz
|
||||||
|
/noto-emoji-f09acc5.tar.gz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
%global commit0 3ffd20ec7504657aa17c84f9aa475ad09b20c362
|
%global commit0 f09acc559b08e5f00c297c986d0e6112ebc88dbf
|
||||||
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
|
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
|
||||||
|
|
||||||
%global fontname google-noto-emoji
|
%global fontname google-noto-emoji
|
||||||
@ -11,8 +11,8 @@
|
|||||||
|
|
||||||
|
|
||||||
Name: %{fontname}-fonts
|
Name: %{fontname}-fonts
|
||||||
Version: 20180814
|
Version: 20190709
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Google “Noto Emoji” Black-and-White emoji font
|
Summary: Google “Noto Emoji” Black-and-White emoji font
|
||||||
|
|
||||||
# In noto-emoji-fonts source
|
# In noto-emoji-fonts source
|
||||||
@ -109,6 +109,10 @@ install -m 0644 -p %{SOURCE3} %{buildroot}%{_datadir}/appdata
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 09 2019 Mike FABIAN <mfabian@redhat.com> - 20190709-1
|
||||||
|
- Update to upstream snapshot tarball (Contains the new emoji added in Unicode 12.0.0,
|
||||||
|
also fixes the "people holding hands" sequence.
|
||||||
|
|
||||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 20180814-2
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 20180814-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
@ -1,8 +1,7 @@
|
|||||||
Index: noto-emoji-352632eb1935fd2b732f6f3ca0a24e9754c3eccf/Makefile
|
diff -ru noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf.orig/Makefile noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf/Makefile
|
||||||
===================================================================
|
--- noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf.orig/Makefile 2019-07-09 10:15:51.036088559 +0200
|
||||||
--- noto-emoji-352632eb1935fd2b732f6f3ca0a24e9754c3eccf.orig/Makefile
|
+++ noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf/Makefile 2019-07-09 10:14:17.684085829 +0200
|
||||||
+++ noto-emoji-352632eb1935fd2b732f6f3ca0a24e9754c3eccf/Makefile
|
@@ -21,7 +21,8 @@
|
||||||
@@ -20,7 +20,8 @@ LDFLAGS = -lm `pkg-config --libs cairo`
|
|
||||||
PNGQUANT = pngquant
|
PNGQUANT = pngquant
|
||||||
PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
|
PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
|
||||||
BODY_DIMENSIONS = 136x128
|
BODY_DIMENSIONS = 136x128
|
||||||
@ -12,14 +11,14 @@ Index: noto-emoji-352632eb1935fd2b732f6f3ca0a24e9754c3eccf/Makefile
|
|||||||
|
|
||||||
# zopflipng is better (about 5-10%) but much slower. it will be used if
|
# zopflipng is better (about 5-10%) but much slower. it will be used if
|
||||||
# present. pass ZOPFLIPNG= as an arg to make to use optipng instead.
|
# present. pass ZOPFLIPNG= as an arg to make to use optipng instead.
|
||||||
@@ -172,13 +173,13 @@ waveflag: waveflag.c
|
@@ -178,13 +179,13 @@
|
||||||
# imagemagick packaged with ubuntu trusty (6.7.7-10) by using -composite.
|
# imagemagick packaged with ubuntu trusty (6.7.7-10) by using -composite.
|
||||||
|
|
||||||
$(EMOJI_DIR)/%.png: $(EMOJI_SRC_DIR)/%.png | $(EMOJI_DIR)
|
$(EMOJI_DIR)/%.png: $(EMOJI_SRC_DIR)/%.png | $(EMOJI_DIR)
|
||||||
- @convert $(IMOPS) "$<" -composite "PNG32:$@"
|
- @convert $(IMOPS) "$<" -composite "PNG32:$@"
|
||||||
+ @gm convert $(IMOPS) "$<" "PNG32:$@"
|
+ @gm convert $(IMOPS) "$<" "PNG32:$@"
|
||||||
|
|
||||||
$(FLAGS_DIR)/%.png: $(FLAGS_SRC_DIR)/%.png ./waveflag $(PNGQUANT) | $(FLAGS_DIR)
|
$(FLAGS_DIR)/%.png: $(FLAGS_SRC_DIR)/%.png ./waveflag | $(FLAGS_DIR)
|
||||||
@./waveflag $(FLAGS_DIR)/ "$<"
|
@./waveflag $(FLAGS_DIR)/ "$<"
|
||||||
|
|
||||||
$(RESIZED_FLAGS_DIR)/%.png: $(FLAGS_DIR)/%.png | $(RESIZED_FLAGS_DIR)
|
$(RESIZED_FLAGS_DIR)/%.png: $(FLAGS_DIR)/%.png | $(RESIZED_FLAGS_DIR)
|
||||||
|
@ -1,20 +1,16 @@
|
|||||||
diff -ru noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5.orig/Makefile noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5/Makefile
|
diff -ru noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf.orig/Makefile noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf/Makefile
|
||||||
--- noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5.orig/Makefile 2018-03-07 09:22:49.670696985 +0100
|
--- noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf.orig/Makefile 2019-07-08 18:40:44.000000000 +0200
|
||||||
+++ noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5/Makefile 2018-03-07 09:23:06.824506178 +0100
|
+++ noto-emoji-f09acc559b08e5f00c297c986d0e6112ebc88dbf/Makefile 2019-07-09 10:07:13.028622382 +0200
|
||||||
@@ -15,10 +15,9 @@
|
@@ -15,7 +15,7 @@
|
||||||
EMOJI = NotoColorEmoji
|
EMOJI = NotoColorEmoji
|
||||||
font: $(EMOJI).ttf
|
font: $(EMOJI).ttf
|
||||||
|
|
||||||
-CFLAGS = -std=c99 -Wall -Wextra `pkg-config --cflags --libs cairo`
|
-CFLAGS = -std=c99 -Wall -Wextra `pkg-config --cflags --libs cairo`
|
||||||
+CFLAGS = $(OPT_CFLAGS) `pkg-config --cflags --libs cairo`
|
+CFLAGS = $(OPT_CFLAGS) `pkg-config --cflags --libs cairo`
|
||||||
LDFLAGS = -lm `pkg-config --libs cairo`
|
LDFLAGS = -lm `pkg-config --libs cairo`
|
||||||
-PNGQUANTDIR := third_party/pngquant
|
|
||||||
-PNGQUANT := $(PNGQUANTDIR)/pngquant
|
PNGQUANT = pngquant
|
||||||
+PNGQUANT = pngquant
|
@@ -101,6 +101,12 @@
|
||||||
PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
|
|
||||||
BODY_DIMENSIONS = 136x128
|
|
||||||
IMOPS := -size $(BODY_DIMENSIONS) canvas:none -compose copy -gravity center
|
|
||||||
@@ -97,6 +96,12 @@
|
|
||||||
ALL_COMPRESSED_FILES = $(addprefix $(COMPRESSED_DIR)/, $(ALL_NAMES))
|
ALL_COMPRESSED_FILES = $(addprefix $(COMPRESSED_DIR)/, $(ALL_NAMES))
|
||||||
|
|
||||||
# tool checks
|
# tool checks
|
||||||
@ -27,7 +23,7 @@ diff -ru noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5.orig/Makefile noto-
|
|||||||
ifeq (,$(shell which $(ZOPFLIPNG)))
|
ifeq (,$(shell which $(ZOPFLIPNG)))
|
||||||
ifeq (,$(wildcard $(ZOPFLIPNG)))
|
ifeq (,$(wildcard $(ZOPFLIPNG)))
|
||||||
MISSING_ZOPFLI = fail
|
MISSING_ZOPFLI = fail
|
||||||
@@ -126,6 +131,11 @@
|
@@ -130,6 +136,11 @@
|
||||||
|
|
||||||
compressed: $(ALL_COMPRESSED_FILES)
|
compressed: $(ALL_COMPRESSED_FILES)
|
||||||
|
|
||||||
@ -39,21 +35,19 @@ diff -ru noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5.orig/Makefile noto-
|
|||||||
check_compress_tool:
|
check_compress_tool:
|
||||||
ifdef MISSING_ZOPFLI
|
ifdef MISSING_ZOPFLI
|
||||||
ifdef MISSING_OPTIPNG
|
ifdef MISSING_OPTIPNG
|
||||||
@@ -146,8 +156,7 @@
|
@@ -151,6 +162,8 @@
|
||||||
$(EMOJI_DIR) $(FLAGS_DIR) $(RESIZED_FLAGS_DIR) $(RENAMED_FLAGS_DIR) $(QUANTIZED_DIR) $(COMPRESSED_DIR):
|
|
||||||
mkdir -p "$@"
|
mkdir -p "$@"
|
||||||
|
|
||||||
-$(PNGQUANT):
|
|
||||||
- $(MAKE) -C $(PNGQUANTDIR)
|
|
||||||
+$(PNGQUANT): check_quantization_tool
|
|
||||||
|
|
||||||
|
+$(PNGQUANT): check_quantization_tool
|
||||||
|
+
|
||||||
waveflag: waveflag.c
|
waveflag: waveflag.c
|
||||||
$(CC) $< -o $@ $(CFLAGS) $(LDFLAGS)
|
$(CC) $< -o $@ $(CFLAGS) $(LDFLAGS)
|
||||||
@@ -227,5 +236,5 @@
|
|
||||||
|
@@ -229,5 +242,5 @@
|
||||||
.SECONDARY: $(EMOJI_FILES) $(FLAG_FILES) $(RESIZED_FLAG_FILES) $(RENAMED_FLAG_FILES) \
|
.SECONDARY: $(EMOJI_FILES) $(FLAG_FILES) $(RESIZED_FLAG_FILES) $(RENAMED_FLAG_FILES) \
|
||||||
$(ALL_QUANTIZED_FILES) $(ALL_COMPRESSED_FILES)
|
$(ALL_QUANTIZED_FILES) $(ALL_COMPRESSED_FILES)
|
||||||
|
|
||||||
-.PHONY: clean flags emoji renamed_flags quantized compressed check_compress_tool
|
-.PHONY: clean flags emoji renamed_flags quantized compressed check_compress_tool
|
||||||
+.PHONY: clean flags emoji renamed_flags quantized compressed check_compress_tool check_quantization_tool
|
+.PHONY: clean flags emoji renamed_flags quantized compressed check_compress_tool check_quantization_tool
|
||||||
|
|
||||||
noto-emoji-153e1d4c026c124fbac6ee93e559b5df375f24f5/ のみに存在: Makefile.orig
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (noto-emoji-3ffd20e.tar.gz) = bca0fb73d3897c4ec1ba94173fda17804cdf2dfa365aa4a19bf1d24e9a94806bcdd5e6eb6304eb3e2312b37f37fa917905be6fe11c84510214f0eba70f426ea8
|
SHA512 (noto-emoji-f09acc5.tar.gz) = 2f90b9303341913c752a0b6e39a0b79da006ef615bb56ac69d0701e01e2e719c8a8a8d4f56a7662eca956539de9c024f6b921d3bc607fe7b1a7cb63413c900c0
|
||||||
|
Loading…
Reference in New Issue
Block a user