diff --git a/.gitignore b/.gitignore
index e69de29..d6f37c4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -0,0 +1,14 @@
+DroidSans-Bold.ttf
+DroidSans.ttf
+DroidSansJapanese.ttf
+DroidSansMono.ttf
+DroidSerif-Bold.ttf
+DroidSerif-BoldItalic.ttf
+DroidSerif-Italic.ttf
+DroidSerif-Regular.ttf
+DroidSansArabic.ttf
+DroidSansFallback.ttf
+DroidSansHebrew.ttf
+DroidSansThai.ttf
+/google-droid-fonts-20120715.tar.xz
+/google-droid-fonts-20200215.tar.xz
diff --git a/60-google-droid-sans-mono-fonts.xml b/60-google-droid-sans-mono-fonts.xml
new file mode 100644
index 0000000..a812a3f
--- /dev/null
+++ b/60-google-droid-sans-mono-fonts.xml
@@ -0,0 +1,13 @@
+
+
+
+
+
+ Droid Sans Mono
+
+ Noto Sans Mono
+ monospace
+
+
+
+
diff --git a/65-google-droid-sans-fonts.xml b/65-google-droid-sans-fonts.xml
new file mode 100644
index 0000000..b1f5ec9
--- /dev/null
+++ b/65-google-droid-sans-fonts.xml
@@ -0,0 +1,83 @@
+
+
+
+
+
+ Droid Sans
+
+ Droid Sans Hebrew
+ he
+ yi
+
+
+ Droid Sans Armenian
+ hy
+
+
+ Droid Sans Georgian
+ ka
+
+
+ Droid Sans Ethiopic
+ am
+ byn
+ gez
+ sid
+ ti-er
+ ti-et
+ tig
+ wal
+
+
+ Droid Sans Devanagari
+ bh
+ bho
+ brx
+ doi
+ hi
+ hne
+ kok
+ mai
+ mr
+ ne
+ sa
+ sat
+
+
+ Droid Sans Tamil
+ ta
+
+
+ Droid Sans Thai
+ th
+
+
+ Droid Arabic Kufi
+ ar
+ az-ir
+ fa
+ ku-iq
+ ku-ir
+ lah
+ ota
+ pa-pk
+ ps-af
+ ps-pk
+ sd
+ ug
+ ur
+
+
+ Droid Sans Japanese
+ ja
+
+ Droid Sans Fallback
+
+ Droid Sans Arabic
+ Noto Sans
+ Open Sans
+ sans-serif
+
+
+
+
diff --git a/65-google-droid-serif-fonts.xml b/65-google-droid-serif-fonts.xml
new file mode 100644
index 0000000..a8e3998
--- /dev/null
+++ b/65-google-droid-serif-fonts.xml
@@ -0,0 +1,30 @@
+
+
+
+
+
+ Droid Serif
+
+ Droid Arabic Naskh
+ ar
+ az-ir
+ fa
+ ku-iq
+ ku-ir
+ lah
+ ota
+ pa-pk
+ ps-af
+ ps-pk
+ sd
+ ug
+ ur
+
+
+ Noto Serif
+ Droid Naskh Shift Alt
+ serif
+
+
+
+
diff --git a/getdroid.sh b/getdroid.sh
new file mode 100755
index 0000000..ceac534
--- /dev/null
+++ b/getdroid.sh
@@ -0,0 +1,38 @@
+#!/bin/bash
+#Try to get upstream latest files
+
+DATE=$(date -u +%Y%m%d)
+ARCHIVE="google-droid-fonts-$DATE"
+TMPDIR=$(mktemp -d --tmpdir=/var/tmp getdroid-XXXXXXXXXX)
+[ $? != 0 ] && exit 1
+umask 022
+pushd "$TMPDIR"
+git init
+git remote add -t HEAD origin https://android.googlesource.com/platform/frameworks/base.git
+git config core.sparseCheckout true
+git config diff.renameLimit 999999
+cat > .git/info/sparse-checkout << EOF
+data/fonts/*
+!data/fonts/*ttf
+!data/fonts/*xml
+!data/fonts/*mk
+!MODULE_LICENSE_APACHE2
+data/fonts/Droid*
+EOF
+git pull --no-tags origin HEAD
+for file in $(git log --diff-filter=D --summary | grep delete | cut -d ' ' -f 5 |\
+ grep 'data/fonts/Droid.*ttf' | sort -u | \
+ grep -v data/fonts/DroidSansFallback | \
+ grep -v data/fonts/DroidSansHebrew.ttf | \
+ grep -v data/fonts/DroidNaskh-Regular-Shift.ttf | \
+ grep -v data/fonts/DroidNaskhUI-Regular.ttf | \
+ grep -v data/fonts/DroidSansArabic.ttf) ; do
+ git checkout $(git log --all -- ${file} | \
+ grep '^commit' | head -2 | tail -1 | cut -d ' ' -f 2) -- "${file}"
+done
+install -m 0755 -d "$ARCHIVE"
+install -m 0644 -p data/fonts/* "$ARCHIVE"
+tar -cvJf "$ARCHIVE.tar.xz" "$ARCHIVE"
+popd
+mv "$TMPDIR/$ARCHIVE.tar.xz" .
+rm -fr "$TMPDIR"
diff --git a/google-droid-fonts.spec b/google-droid-fonts.spec
new file mode 100644
index 0000000..b207ac8
--- /dev/null
+++ b/google-droid-fonts.spec
@@ -0,0 +1,146 @@
+# SPDX-License-Identifier: MIT
+BuildArch: noarch
+
+# No sane versionning upstream, use git clone timestamp
+Version: 20200215
+Release: 8%{?dist}
+License: ASL 2.0
+URL: https://android.googlesource.com/
+
+%global source_name google-droid-fonts
+
+%global foundry Google
+%global fontlicenses NOTICE
+%global fontdocs *.txt
+
+%global common_description %{expand:
+The Droid font family was designed in the fall of 2006 by Ascenderโs Steve
+Matteson, as a commission from Google to create a set of system fonts for its
+Android platform. The goal was to provide optimal quality and comfort on a
+mobile handset when rendered in application menus, web browsers and for other
+screen text.
+
+The family was later extended in collaboration with other designers such as
+Pascal Zoghbi of 29ArabicLetters.}
+
+%global fontfamily1 Droid Sans
+%global fontsummary1 Droid Sans, a humanist sans-serif font family
+%global fontpkgheader1 %{expand:
+Obsoletes: google-droid-kufi-fonts < %{version}-%{release}
+Suggests: font(notosans)
+}
+%global fonts1 DroidSans*ttf DroidKufi*ttf
+%global fontsex1 DroidSansMono*ttf DroidSansFallback.ttf DroidSansHebrew.ttf
+%global fontconfngs1 %{SOURCE11}
+%global fontdescription1 %{expand:
+%{common_description}
+
+Droid Sans is a humanist sans serif font family designed for user interfaces and electronic communication.
+
+The Arabic block was initially designed by Steve Matteson of Ascender under the
+Droid Kufi name, with consulting by Pascal Zoghbi of 29ArabicLetters to
+finalize the font family.}
+
+%global fontfamily2 Droid Sans Mono
+%global fontsummary2 Droid Sans Mono, a humanist mono-space sans-serif font family
+%global fontpkgheader2 %{expand:
+Suggests: font(notosansmono)
+}
+%global fonts2 DroidSansMono*ttf
+%global fontconfngs2 %{SOURCE12}
+%global fontdescription2 %{expand:
+%{common_description}
+
+Droid Sans Mono is a humanist mono-space sans serif font family designed for
+user interfaces and electronic communication.}
+
+%global fontfamily3 Droid Serif
+%global fontsummary3 Droid Serif, a contemporary serif font family
+%global fontpkgheader3 %{expand:
+Suggests: font(notoserif)
+}
+%global fonts3 DroidSerif*ttf DroidNaskh*ttf
+%global fontsex3 DroidNaskhUI-Regular.ttf DroidNaskh-Regular-Shift.ttf
+%global fontconfngs3 %{SOURCE13}
+%global fontdescription3 %{expand:
+%{common_description}
+
+Droid Serif is a contemporary serif typeface family designed for comfortable
+reading on screen. Droid Serif is slightly condensed to maximize the amount of
+text displayed on small screens. Vertical stress and open forms contribute to
+its readability while its proportion and overall design complement its
+companion Droid Sans.
+
+The Arabic block was designed by Pascal Zoghbi of 29ArabicLetters under the
+Droid Naskh name.}
+
+%global archivename google-droid-fonts-%{version}
+
+
+Source0: %{archivename}.tar.xz
+# Brutal script used to pull sources from upstream git
+# Needs at least 2 Gib of space in /var/tmp
+Source1: getdroid.sh
+Source11: 65-%{fontpkgname1}.xml
+Source12: 60-%{fontpkgname2}.xml
+Source13: 65-%{fontpkgname3}.xml
+
+Name: google-droid-fonts
+Summary: A set of general-purpose font families released by Google as part of Android
+%description
+%wordwrap -v common_description
+
+%fontpkg -a
+
+%fontmetapkg
+
+%prep
+%setup -q -n %{archivename}
+
+%build
+%fontbuild -a
+
+%install
+%fontinstall -a
+
+%check
+%fontcheck -a
+
+%fontfiles -a
+
+%changelog
+* Fri Sep 11 2020 Parag Nemade
+- 20200215-8
+- Fix this spec file to build for F33+
+
+* Tue Jul 28 2020 Fedora Release Engineering
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
+
+* Mon Apr 27 2020 Nicolas Mailhot
+- 20200215-6
+๐ Workaround Fedora problems created by rpm commit 93604e2
+
+* Thu Apr 02 2020 Nicolas Mailhot
+- 20200215-5
+๐ฅ Actually rebuild with fonts-rpm-macros 2.0.4 to make sure fontconfig files are
+ valid
+
+* Thu Apr 02 2020 Nicolas Mailhot
+- 20200215-4
+๐ป Rebuild with fonts-rpm-macros 2.0.4 to make sure fontconfig files are valid
+
+* Mon Mar 02 2020 Nicolas Mailhot
+- 20200215-3
+โ
Lint, lint, lint and lint again
+
+* Sat Feb 22 2020 Nicolas Mailhot
+- 20200215-2
+โ
Rebuild with fonts-rpm-macros 2.0.2
+
+* Sat Feb 15 2020 Nicolas Mailhot
+- 20200215-1
+โ
Convert to fonts-rpm-macros use
+
+* Sun Nov 23 2008 Nicolas Mailhot
+- 1.0.107-1
+โ
Initial packaging
diff --git a/sources b/sources
new file mode 100644
index 0000000..97bb6ad
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+SHA512 (google-droid-fonts-20200215.tar.xz) = 4ab5462819fbef043e4cc7df565a11da21e0f6afaee002576d52decbf43449053919a0787a1a06ce7187d5308afcf3c044cedf87ed2a6bb28ce18d981928d346