Update to 1.47.92
This commit is contained in:
parent
32319e3066
commit
f737486557
1
.gitignore
vendored
1
.gitignore
vendored
@ -52,3 +52,4 @@
|
|||||||
/gobject-introspection-1.45.4.tar.xz
|
/gobject-introspection-1.45.4.tar.xz
|
||||||
/gobject-introspection-1.46.0.tar.xz
|
/gobject-introspection-1.46.0.tar.xz
|
||||||
/gobject-introspection-1.47.1.tar.xz
|
/gobject-introspection-1.47.1.tar.xz
|
||||||
|
/gobject-introspection-1.47.92.tar.xz
|
||||||
|
@ -1,67 +0,0 @@
|
|||||||
From 13f7ca3a3e3f823690add83dd8bfada52da559d2 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Colin Walters <walters@verbum.org>
|
|
||||||
Date: Wed, 9 Dec 2015 16:17:48 -0500
|
|
||||||
Subject: [PATCH] Revert "libgirepository: Refuse to run in setuid
|
|
||||||
applications"
|
|
||||||
|
|
||||||
This reverts commit 98bb6c91b710a95efe4cfeb303daeec3381b9c98.
|
|
||||||
|
|
||||||
It breaks programs simply executed *transitively* from a setuid
|
|
||||||
binary like the dbus daemon launch helper.
|
|
||||||
|
|
||||||
https://bugzilla.redhat.com/show_bug.cgi?id=1285991
|
|
||||||
|
|
||||||
Conflicts:
|
|
||||||
girepository/girepository.c
|
|
||||||
---
|
|
||||||
configure.ac | 2 +-
|
|
||||||
girepository/girepository.c | 13 -------------
|
|
||||||
2 files changed, 1 insertion(+), 14 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index b74d182..a6a272d 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -247,7 +247,7 @@ AC_C_CONST
|
|
||||||
|
|
||||||
# Checks for library functions.
|
|
||||||
AC_FUNC_STRTOD
|
|
||||||
-AC_CHECK_FUNCS([memchr strchr strspn strstr strtol strtoull getauxval])
|
|
||||||
+AC_CHECK_FUNCS([memchr strchr strspn strstr strtol strtoull])
|
|
||||||
AC_CHECK_FUNCS([backtrace backtrace_symbols])
|
|
||||||
|
|
||||||
# Python
|
|
||||||
diff --git a/girepository/girepository.c b/girepository/girepository.c
|
|
||||||
index 82ee8a4..4537c03 100644
|
|
||||||
--- a/girepository/girepository.c
|
|
||||||
+++ b/girepository/girepository.c
|
|
||||||
@@ -27,11 +27,6 @@
|
|
||||||
#include <string.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
|
|
||||||
-#ifdef HAVE_GETAUXVAL
|
|
||||||
-#include <unistd.h>
|
|
||||||
-#include <sys/auxv.h>
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
#include <glib.h>
|
|
||||||
#include <glib/gprintf.h>
|
|
||||||
#include <gmodule.h>
|
|
||||||
@@ -152,14 +147,6 @@ init_globals (void)
|
|
||||||
if (!g_once_init_enter (&initialized))
|
|
||||||
return;
|
|
||||||
|
|
||||||
-#ifdef HAVE_GETAUXVAL
|
|
||||||
- if (getauxval (AT_SECURE))
|
|
||||||
- {
|
|
||||||
- g_printerr ("error: libgirepository.so (gobject-introspection) is not audited for use in setuid applications\nSee https://bugzilla.gnome.org/show_bug.cgi?id=755472\n");
|
|
||||||
- _exit (1);
|
|
||||||
- }
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
if (default_repository == NULL)
|
|
||||||
default_repository = g_object_new (G_TYPE_IREPOSITORY, NULL);
|
|
||||||
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
@ -1,8 +1,8 @@
|
|||||||
%global glib2_version 2.45.3
|
%global glib2_version 2.45.3
|
||||||
|
|
||||||
Name: gobject-introspection
|
Name: gobject-introspection
|
||||||
Version: 1.47.1
|
Version: 1.47.92
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Introspection system for GObject-based libraries
|
Summary: Introspection system for GObject-based libraries
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -10,8 +10,6 @@ License: GPLv2+, LGPLv2+, MIT
|
|||||||
URL: http://live.gnome.org/GObjectIntrospection
|
URL: http://live.gnome.org/GObjectIntrospection
|
||||||
#VCS: git:git://git.gnome.org/gobject-introspection
|
#VCS: git:git://git.gnome.org/gobject-introspection
|
||||||
Source0: http://download.gnome.org/sources/gobject-introspection/1.47/%{name}-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/gobject-introspection/1.47/%{name}-%{version}.tar.xz
|
||||||
# Upstream as https://git.gnome.org/browse/gobject-introspection/commit/?id=13f7ca3a3e3f823690add83dd8bfada52da559d2
|
|
||||||
Patch0: 0001-Revert-libgirepository-Refuse-to-run-in-setuid-appli.patch
|
|
||||||
|
|
||||||
Obsoletes: gir-repository
|
Obsoletes: gir-repository
|
||||||
|
|
||||||
@ -64,7 +62,6 @@ Obsoletes: gir-repository-devel
|
|||||||
Libraries and headers for gobject-introspection
|
Libraries and headers for gobject-introspection
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -Sgit
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# I'm getting autotools breakage due to
|
# I'm getting autotools breakage due to
|
||||||
@ -119,6 +116,9 @@ find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
|
|||||||
%{_datadir}/gtk-doc/html/gi/*
|
%{_datadir}/gtk-doc/html/gi/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 14 2016 Richard Hughes <rhughes@redhat.com> - 1.47.92-1
|
||||||
|
- Update to 1.47.92
|
||||||
|
|
||||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.47.1-3
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.47.1-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user