Workaround patch for compatibility with Python 3.12
This commit is contained in:
parent
24222cfb3c
commit
2485dd8d09
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: gobject-introspection
|
Name: gobject-introspection
|
||||||
Version: 1.76.1
|
Version: 1.76.1
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Introspection system for GObject-based libraries
|
Summary: Introspection system for GObject-based libraries
|
||||||
|
|
||||||
License: GPL-2.0-or-later AND LGPL-2.0-or-later AND LGPL-2.1-or-later AND BSD-2-Clause
|
License: GPL-2.0-or-later AND LGPL-2.0-or-later AND LGPL-2.1-or-later AND BSD-2-Clause
|
||||||
@ -10,6 +10,9 @@ URL: https://wiki.gnome.org/Projects/GObjectIntrospection
|
|||||||
Source0: https://download.gnome.org/sources/%{name}/1.76/%{name}-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/%{name}/1.76/%{name}-%{version}.tar.xz
|
||||||
# https://gitlab.gnome.org/GNOME/gobject-introspection/-/issues/458
|
# https://gitlab.gnome.org/GNOME/gobject-introspection/-/issues/458
|
||||||
Patch0: gobject-introspection-1.76.1-revert-failing-test.patch
|
Patch0: gobject-introspection-1.76.1-revert-failing-test.patch
|
||||||
|
# Workaround for Python 3.12 compatibility
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=2208966
|
||||||
|
Patch1: workaround.patch
|
||||||
|
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
@ -52,6 +55,7 @@ Libraries and headers for gobject-introspection
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -p1
|
%autosetup -p1
|
||||||
|
mv giscanner/ast.py giscanner/gio_ast.py
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%meson -Ddoctool=enabled -Dgtk_doc=true -Dpython=%{__python3}
|
%meson -Ddoctool=enabled -Dgtk_doc=true -Dpython=%{__python3}
|
||||||
@ -91,6 +95,9 @@ Libraries and headers for gobject-introspection
|
|||||||
%{_mandir}/man1/g-ir-scanner.1*
|
%{_mandir}/man1/g-ir-scanner.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 09 2023 Tomáš Hrnčiar <thrnciar@redhat.com> - 1.76.1-3
|
||||||
|
- Add workaround patch for compatibility with Python 3.12
|
||||||
|
|
||||||
* Fri May 19 2023 David King <amigadave@amigadave.com> - 1.76.1-2
|
* Fri May 19 2023 David King <amigadave@amigadave.com> - 1.76.1-2
|
||||||
- Enable tests during check phase
|
- Enable tests during check phase
|
||||||
|
|
||||||
|
24
workaround.patch
Normal file
24
workaround.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -rU3 gobject-introspection-1.76.1-orig/giscanner/__init__.py gobject-introspection-1.76.1/giscanner/__init__.py
|
||||||
|
--- gobject-introspection-1.76.1-orig/giscanner/__init__.py 2023-03-22 23:43:34.000000000 +0100
|
||||||
|
+++ gobject-introspection-1.76.1/giscanner/__init__.py 2023-06-07 11:50:00.217226422 +0200
|
||||||
|
@@ -25,3 +25,8 @@
|
||||||
|
from ._version import __version__
|
||||||
|
except ImportError:
|
||||||
|
__version__ = '0.0.0'
|
||||||
|
+
|
||||||
|
+from . import gio_ast as ast
|
||||||
|
+
|
||||||
|
+import sys
|
||||||
|
+sys.modules['giscanner.ast'] = ast
|
||||||
|
diff -rU3 gobject-introspection-1.76.1-orig/giscanner/meson.build gobject-introspection-1.76.1/giscanner/meson.build
|
||||||
|
--- gobject-introspection-1.76.1-orig/giscanner/meson.build 2023-03-22 23:43:34.000000000 +0100
|
||||||
|
+++ gobject-introspection-1.76.1/giscanner/meson.build 2023-06-07 11:48:32.922732028 +0200
|
||||||
|
@@ -2,7 +2,7 @@
|
||||||
|
'__init__.py',
|
||||||
|
'annotationmain.py',
|
||||||
|
'annotationparser.py',
|
||||||
|
- 'ast.py',
|
||||||
|
+ 'gio_ast.py',
|
||||||
|
'cachestore.py',
|
||||||
|
'ccompiler.py',
|
||||||
|
'codegen.py',
|
Loading…
Reference in New Issue
Block a user