112336b5f6
Like GMP, this changes the package build process so the libnettle and libhogweed are built and linked statically to libgnutls. That makes it a little simpler to handle FIPS installation, so the users don't need to install a specific version of the nettle package by themselves, at the cost of duplicating cryptography implementation provided by Nettle. Related: RHEL-50011 Signed-off-by: Daiki Ueno <dueno@redhat.com>
14 lines
389 B
Diff
14 lines
389 B
Diff
diff --git a/lib/Makefile.am b/lib/Makefile.am
|
|
index 0e89fdf..5179858 100644
|
|
--- a/lib/Makefile.am
|
|
+++ b/lib/Makefile.am
|
|
@@ -269,7 +269,7 @@ thirdparty_libadd += $(LIBTASN1_LIBS)
|
|
endif
|
|
|
|
if ENABLE_NETTLE
|
|
-thirdparty_libadd += $(NETTLE_LIBS) $(HOGWEED_LIBS) $(GMP_LIBS)
|
|
+thirdparty_libadd += $(HOGWEED_LIBS) $(NETTLE_LIBS) $(GMP_LIBS)
|
|
libgnutls_la_LIBADD += nettle/libcrypto.la
|
|
endif
|
|
|