new upstream release

This commit is contained in:
Tomas Mraz 2013-03-15 15:15:53 +01:00
parent 48bea99a11
commit dbc4639dff
4 changed files with 98 additions and 94 deletions

1
.gitignore vendored
View File

@ -21,3 +21,4 @@ gnutls-2.10.1-nosrp.tar.bz2
/gnutls-2.12.22-nosrp.tar.xz /gnutls-2.12.22-nosrp.tar.xz
/gnutls-3.1.7-hobbled.tar.xz /gnutls-3.1.7-hobbled.tar.xz
/gnutls-3.1.8-hobbled.tar.xz /gnutls-3.1.8-hobbled.tar.xz
/gnutls-3.1.9-hobbled.tar.xz

View File

@ -1,6 +1,6 @@
diff -up gnutls-3.1.8/lib/algorithms/kx.c.noecc gnutls-3.1.8/lib/algorithms/kx.c diff -up gnutls-3.1.9/lib/algorithms/kx.c.noecc gnutls-3.1.9/lib/algorithms/kx.c
--- gnutls-3.1.8/lib/algorithms/kx.c.noecc 2013-02-10 11:29:54.000000000 +0100 --- gnutls-3.1.9/lib/algorithms/kx.c.noecc 2013-02-10 11:29:54.000000000 +0100
+++ gnutls-3.1.8/lib/algorithms/kx.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/lib/algorithms/kx.c 2013-03-15 14:46:31.124952891 +0100
@@ -29,9 +29,11 @@ @@ -29,9 +29,11 @@
extern mod_auth_st rsa_auth_struct; extern mod_auth_st rsa_auth_struct;
extern mod_auth_st rsa_export_auth_struct; extern mod_auth_st rsa_export_auth_struct;
@ -43,9 +43,9 @@ diff -up gnutls-3.1.8/lib/algorithms/kx.c.noecc gnutls-3.1.8/lib/algorithms/kx.c
{0, 0, 0, 0, 0} {0, 0, 0, 0, 0}
}; };
diff -up gnutls-3.1.8/lib/algorithms/publickey.c.noecc gnutls-3.1.8/lib/algorithms/publickey.c diff -up gnutls-3.1.9/lib/algorithms/publickey.c.noecc gnutls-3.1.9/lib/algorithms/publickey.c
--- gnutls-3.1.8/lib/algorithms/publickey.c.noecc 2013-02-10 11:29:54.000000000 +0100 --- gnutls-3.1.9/lib/algorithms/publickey.c.noecc 2013-02-10 11:29:54.000000000 +0100
+++ gnutls-3.1.8/lib/algorithms/publickey.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/lib/algorithms/publickey.c 2013-03-15 14:46:31.124952891 +0100
@@ -50,8 +50,10 @@ static const gnutls_pk_map pk_mappings[] @@ -50,8 +50,10 @@ static const gnutls_pk_map pk_mappings[]
{GNUTLS_KX_RSA_EXPORT, GNUTLS_PK_RSA, CIPHER_SIGN}, {GNUTLS_KX_RSA_EXPORT, GNUTLS_PK_RSA, CIPHER_SIGN},
{GNUTLS_KX_DHE_RSA, GNUTLS_PK_RSA, CIPHER_SIGN}, {GNUTLS_KX_DHE_RSA, GNUTLS_PK_RSA, CIPHER_SIGN},
@ -67,9 +67,9 @@ diff -up gnutls-3.1.8/lib/algorithms/publickey.c.noecc gnutls-3.1.8/lib/algorith
{0, 0, 0} {0, 0, 0}
}; };
diff -up gnutls-3.1.8/lib/algorithms/sign.c.noecc gnutls-3.1.8/lib/algorithms/sign.c diff -up gnutls-3.1.9/lib/algorithms/sign.c.noecc gnutls-3.1.9/lib/algorithms/sign.c
--- gnutls-3.1.8/lib/algorithms/sign.c.noecc 2013-02-10 11:29:54.000000000 +0100 --- gnutls-3.1.9/lib/algorithms/sign.c.noecc 2013-02-13 20:40:12.000000000 +0100
+++ gnutls-3.1.8/lib/algorithms/sign.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/lib/algorithms/sign.c 2013-03-15 14:46:31.124952891 +0100
@@ -43,6 +43,14 @@ typedef struct gnutls_sign_entry gnutls_ @@ -43,6 +43,14 @@ typedef struct gnutls_sign_entry gnutls_
#define TLS_SIGN_AID_UNKNOWN {255, 255} #define TLS_SIGN_AID_UNKNOWN {255, 255}
static const sign_algorithm_st unknown_tls_aid = TLS_SIGN_AID_UNKNOWN; static const sign_algorithm_st unknown_tls_aid = TLS_SIGN_AID_UNKNOWN;
@ -85,9 +85,9 @@ diff -up gnutls-3.1.8/lib/algorithms/sign.c.noecc gnutls-3.1.8/lib/algorithms/si
static const gnutls_sign_entry sign_algorithms[] = { static const gnutls_sign_entry sign_algorithms[] = {
{"RSA-SHA1", SIG_RSA_SHA1_OID, GNUTLS_SIGN_RSA_SHA1, GNUTLS_PK_RSA, {"RSA-SHA1", SIG_RSA_SHA1_OID, GNUTLS_SIGN_RSA_SHA1, GNUTLS_PK_RSA,
GNUTLS_DIG_SHA1, {2, 1}}, GNUTLS_DIG_SHA1, {2, 1}},
diff -up gnutls-3.1.8/lib/auth/anon_ecdh.c.noecc gnutls-3.1.8/lib/auth/anon_ecdh.c diff -up gnutls-3.1.9/lib/auth/anon_ecdh.c.noecc gnutls-3.1.9/lib/auth/anon_ecdh.c
--- gnutls-3.1.8/lib/auth/anon_ecdh.c.noecc 2013-02-10 11:29:54.000000000 +0100 --- gnutls-3.1.9/lib/auth/anon_ecdh.c.noecc 2013-02-10 11:29:54.000000000 +0100
+++ gnutls-3.1.8/lib/auth/anon_ecdh.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/lib/auth/anon_ecdh.c 2013-03-15 14:46:31.124952891 +0100
@@ -28,6 +28,7 @@ @@ -28,6 +28,7 @@
#include <gnutls_int.h> #include <gnutls_int.h>
@ -102,9 +102,9 @@ diff -up gnutls-3.1.8/lib/auth/anon_ecdh.c.noecc gnutls-3.1.8/lib/auth/anon_ecdh
+#endif +#endif
#endif /* ENABLE_ANON */ #endif /* ENABLE_ANON */
diff -up gnutls-3.1.8/lib/auth/cert.c.noecc gnutls-3.1.8/lib/auth/cert.c diff -up gnutls-3.1.9/lib/auth/cert.c.noecc gnutls-3.1.9/lib/auth/cert.c
--- gnutls-3.1.8/lib/auth/cert.c.noecc 2013-02-10 11:29:54.000000000 +0100 --- gnutls-3.1.9/lib/auth/cert.c.noecc 2013-02-10 11:29:54.000000000 +0100
+++ gnutls-3.1.8/lib/auth/cert.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/lib/auth/cert.c 2013-03-15 14:46:31.125952912 +0100
@@ -63,7 +63,11 @@ static gnutls_privkey_t alloc_and_load_p @@ -63,7 +63,11 @@ static gnutls_privkey_t alloc_and_load_p
key, int deinit); key, int deinit);
#endif #endif
@ -138,9 +138,9 @@ diff -up gnutls-3.1.8/lib/auth/cert.c.noecc gnutls-3.1.8/lib/auth/cert.c
ret = _gnutls_buffer_append_data (data, tmp_data, CERTTYPE_SIZE); ret = _gnutls_buffer_append_data (data, tmp_data, CERTTYPE_SIZE);
if (ret < 0) if (ret < 0)
diff -up gnutls-3.1.8/lib/auth/dhe.c.noecc gnutls-3.1.8/lib/auth/dhe.c diff -up gnutls-3.1.9/lib/auth/dhe.c.noecc gnutls-3.1.9/lib/auth/dhe.c
--- gnutls-3.1.8/lib/auth/dhe.c.noecc 2013-02-10 11:29:54.000000000 +0100 --- gnutls-3.1.9/lib/auth/dhe.c.noecc 2013-02-17 09:14:01.000000000 +0100
+++ gnutls-3.1.8/lib/auth/dhe.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/lib/auth/dhe.c 2013-03-15 14:46:31.125952912 +0100
@@ -43,6 +43,7 @@ static int gen_dhe_server_kx (gnutls_ses @@ -43,6 +43,7 @@ static int gen_dhe_server_kx (gnutls_ses
static int proc_dhe_server_kx (gnutls_session_t, uint8_t *, size_t); static int proc_dhe_server_kx (gnutls_session_t, uint8_t *, size_t);
static int proc_dhe_client_kx (gnutls_session_t, uint8_t *, size_t); static int proc_dhe_client_kx (gnutls_session_t, uint8_t *, size_t);
@ -157,9 +157,9 @@ diff -up gnutls-3.1.8/lib/auth/dhe.c.noecc gnutls-3.1.8/lib/auth/dhe.c
const mod_auth_st dhe_rsa_auth_struct = { const mod_auth_st dhe_rsa_auth_struct = {
"DHE_RSA", "DHE_RSA",
diff -up gnutls-3.1.8/lib/auth/dhe_psk.c.noecc gnutls-3.1.8/lib/auth/dhe_psk.c diff -up gnutls-3.1.9/lib/auth/dhe_psk.c.noecc gnutls-3.1.9/lib/auth/dhe_psk.c
--- gnutls-3.1.8/lib/auth/dhe_psk.c.noecc 2013-02-10 11:29:54.000000000 +0100 --- gnutls-3.1.9/lib/auth/dhe_psk.c.noecc 2013-02-17 09:14:01.000000000 +0100
+++ gnutls-3.1.8/lib/auth/dhe_psk.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/lib/auth/dhe_psk.c 2013-03-15 14:46:31.126952934 +0100
@@ -68,6 +68,7 @@ const mod_auth_st dhe_psk_auth_struct = @@ -68,6 +68,7 @@ const mod_auth_st dhe_psk_auth_struct =
NULL NULL
}; };
@ -209,9 +209,9 @@ diff -up gnutls-3.1.8/lib/auth/dhe_psk.c.noecc gnutls-3.1.8/lib/auth/dhe_psk.c
int int
proc_psk_server_kx (gnutls_session_t session, uint8_t * data, proc_psk_server_kx (gnutls_session_t session, uint8_t * data,
diff -up gnutls-3.1.8/lib/auth/ecdh_common.c.noecc gnutls-3.1.8/lib/auth/ecdh_common.c diff -up gnutls-3.1.9/lib/auth/ecdh_common.c.noecc gnutls-3.1.9/lib/auth/ecdh_common.c
--- gnutls-3.1.8/lib/auth/ecdh_common.c.noecc 2013-02-10 11:29:54.000000000 +0100 --- gnutls-3.1.9/lib/auth/ecdh_common.c.noecc 2013-02-17 09:14:01.000000000 +0100
+++ gnutls-3.1.8/lib/auth/ecdh_common.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/lib/auth/ecdh_common.c 2013-03-15 14:46:31.126952934 +0100
@@ -41,6 +41,8 @@ @@ -41,6 +41,8 @@
#include <auth/psk.h> #include <auth/psk.h>
#include <gnutls_pk.h> #include <gnutls_pk.h>
@ -226,9 +226,9 @@ diff -up gnutls-3.1.8/lib/auth/ecdh_common.c.noecc gnutls-3.1.8/lib/auth/ecdh_co
return data->length; return data->length;
} }
+#endif +#endif
diff -up gnutls-3.1.8/lib/auth/ecdh_common.h.noecc gnutls-3.1.8/lib/auth/ecdh_common.h diff -up gnutls-3.1.9/lib/auth/ecdh_common.h.noecc gnutls-3.1.9/lib/auth/ecdh_common.h
--- gnutls-3.1.8/lib/auth/ecdh_common.h.noecc 2013-02-10 11:29:54.000000000 +0100 --- gnutls-3.1.9/lib/auth/ecdh_common.h.noecc 2013-02-10 11:29:54.000000000 +0100
+++ gnutls-3.1.8/lib/auth/ecdh_common.h 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/lib/auth/ecdh_common.h 2013-03-15 14:46:31.126952934 +0100
@@ -25,6 +25,8 @@ @@ -25,6 +25,8 @@
#include <gnutls_auth.h> #include <gnutls_auth.h>
@ -253,9 +253,9 @@ diff -up gnutls-3.1.8/lib/auth/ecdh_common.h.noecc gnutls-3.1.8/lib/auth/ecdh_co
#endif #endif
diff -up gnutls-3.1.8/lib/ext/ecc.c.noecc gnutls-3.1.8/lib/ext/ecc.c diff -up gnutls-3.1.9/lib/ext/ecc.c.noecc gnutls-3.1.9/lib/ext/ecc.c
--- gnutls-3.1.8/lib/ext/ecc.c.noecc 2013-02-10 11:29:54.000000000 +0100 --- gnutls-3.1.9/lib/ext/ecc.c.noecc 2013-02-10 11:29:54.000000000 +0100
+++ gnutls-3.1.8/lib/ext/ecc.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/lib/ext/ecc.c 2013-03-15 14:46:31.126952934 +0100
@@ -35,6 +35,7 @@ @@ -35,6 +35,7 @@
/* Maps record size to numbers according to the /* Maps record size to numbers according to the
* extensions draft. * extensions draft.
@ -270,9 +270,9 @@ diff -up gnutls-3.1.8/lib/ext/ecc.c.noecc gnutls-3.1.8/lib/ext/ecc.c
} }
+ +
+#endif +#endif
diff -up gnutls-3.1.8/lib/gnutls_extensions.c.noecc gnutls-3.1.8/lib/gnutls_extensions.c diff -up gnutls-3.1.9/lib/gnutls_extensions.c.noecc gnutls-3.1.9/lib/gnutls_extensions.c
--- gnutls-3.1.8/lib/gnutls_extensions.c.noecc 2013-02-10 11:29:54.000000000 +0100 --- gnutls-3.1.9/lib/gnutls_extensions.c.noecc 2013-02-18 19:20:47.000000000 +0100
+++ gnutls-3.1.8/lib/gnutls_extensions.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/lib/gnutls_extensions.c 2013-03-15 14:46:31.126952934 +0100
@@ -350,6 +350,7 @@ _gnutls_ext_init (void) @@ -350,6 +350,7 @@ _gnutls_ext_init (void)
if (ret != GNUTLS_E_SUCCESS) if (ret != GNUTLS_E_SUCCESS)
return ret; return ret;
@ -289,9 +289,9 @@ diff -up gnutls-3.1.8/lib/gnutls_extensions.c.noecc gnutls-3.1.8/lib/gnutls_exte
ret = _gnutls_ext_register (&ext_mod_sig); ret = _gnutls_ext_register (&ext_mod_sig);
if (ret != GNUTLS_E_SUCCESS) if (ret != GNUTLS_E_SUCCESS)
diff -up gnutls-3.1.8/lib/gnutls_priority.c.noecc gnutls-3.1.8/lib/gnutls_priority.c diff -up gnutls-3.1.9/lib/gnutls_priority.c.noecc gnutls-3.1.9/lib/gnutls_priority.c
--- gnutls-3.1.8/lib/gnutls_priority.c.noecc 2013-02-10 11:46:05.000000000 +0100 --- gnutls-3.1.9/lib/gnutls_priority.c.noecc 2013-02-10 13:15:37.000000000 +0100
+++ gnutls-3.1.8/lib/gnutls_priority.c 2013-02-26 12:39:45.905638260 +0100 +++ gnutls-3.1.9/lib/gnutls_priority.c 2013-03-15 14:47:53.997816225 +0100
@@ -245,35 +245,45 @@ gnutls_certificate_type_set_priority (gn @@ -245,35 +245,45 @@ gnutls_certificate_type_set_priority (gn
} }
@ -375,10 +375,10 @@ diff -up gnutls-3.1.8/lib/gnutls_priority.c.noecc gnutls-3.1.8/lib/gnutls_priori
GNUTLS_KX_ECDHE_ECDSA, GNUTLS_KX_ECDHE_ECDSA,
GNUTLS_KX_ECDHE_RSA, GNUTLS_KX_ECDHE_RSA,
+#endif +#endif
GNUTLS_KX_DHE_RSA,
GNUTLS_KX_DHE_DSS,
GNUTLS_KX_RSA, GNUTLS_KX_RSA,
@@ -437,51 +455,75 @@ static const int comp_priority[] = { /* KX-RSA is now ahead of DHE-RSA and DHE-DSS due to the compatibility
* issues the DHE ciphersuites have. That is, one cannot enforce a specific
@@ -441,51 +459,75 @@ static const int comp_priority[] = {
static const int sign_priority_default[] = { static const int sign_priority_default[] = {
GNUTLS_SIGN_RSA_SHA256, GNUTLS_SIGN_RSA_SHA256,
GNUTLS_SIGN_DSA_SHA256, GNUTLS_SIGN_DSA_SHA256,
@ -454,9 +454,9 @@ diff -up gnutls-3.1.8/lib/gnutls_priority.c.noecc gnutls-3.1.8/lib/gnutls_priori
0 0
}; };
diff -up gnutls-3.1.8/lib/nettle/init.c.noecc gnutls-3.1.8/lib/nettle/init.c diff -up gnutls-3.1.9/lib/nettle/init.c.noecc gnutls-3.1.9/lib/nettle/init.c
--- gnutls-3.1.8/lib/nettle/init.c.noecc 2013-02-10 11:29:54.000000000 +0100 --- gnutls-3.1.9/lib/nettle/init.c.noecc 2013-02-10 11:29:54.000000000 +0100
+++ gnutls-3.1.8/lib/nettle/init.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/lib/nettle/init.c 2013-03-15 14:46:31.127952956 +0100
@@ -32,7 +32,11 @@ @@ -32,7 +32,11 @@
int int
gnutls_crypto_init (void) gnutls_crypto_init (void)
@ -477,9 +477,9 @@ diff -up gnutls-3.1.8/lib/nettle/init.c.noecc gnutls-3.1.8/lib/nettle/init.c
ecc_wmnaf_cache_free(); ecc_wmnaf_cache_free();
+#endif +#endif
} }
diff -up gnutls-3.1.8/lib/nettle/Makefile.am.noecc gnutls-3.1.8/lib/nettle/Makefile.am diff -up gnutls-3.1.9/lib/nettle/Makefile.am.noecc gnutls-3.1.9/lib/nettle/Makefile.am
--- gnutls-3.1.8/lib/nettle/Makefile.am.noecc 2012-12-03 20:36:50.000000000 +0100 --- gnutls-3.1.9/lib/nettle/Makefile.am.noecc 2012-12-03 20:36:50.000000000 +0100
+++ gnutls-3.1.8/lib/nettle/Makefile.am 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/lib/nettle/Makefile.am 2013-03-15 14:46:31.127952956 +0100
@@ -33,9 +33,13 @@ endif @@ -33,9 +33,13 @@ endif
noinst_LTLIBRARIES = libcrypto.la noinst_LTLIBRARIES = libcrypto.la
@ -499,9 +499,9 @@ diff -up gnutls-3.1.8/lib/nettle/Makefile.am.noecc gnutls-3.1.8/lib/nettle/Makef
- ecc_projective_check_point.c ecc_projective_negate_point.c \ - ecc_projective_check_point.c ecc_projective_negate_point.c \
- ecc_projective_add_point_ng.c ecc_sign_hash.c ecc_verify_hash.c gnettle.h - ecc_projective_add_point_ng.c ecc_sign_hash.c ecc_verify_hash.c gnettle.h
+ multi.c wmnaf.c $(ECC_SOURCES) gnettle.h + multi.c wmnaf.c $(ECC_SOURCES) gnettle.h
diff -up gnutls-3.1.8/lib/nettle/pk.c.noecc gnutls-3.1.8/lib/nettle/pk.c diff -up gnutls-3.1.9/lib/nettle/pk.c.noecc gnutls-3.1.9/lib/nettle/pk.c
--- gnutls-3.1.8/lib/nettle/pk.c.noecc 2013-02-10 12:01:25.000000000 +0100 --- gnutls-3.1.9/lib/nettle/pk.c.noecc 2013-02-17 09:14:01.000000000 +0100
+++ gnutls-3.1.8/lib/nettle/pk.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/lib/nettle/pk.c 2013-03-15 14:46:31.128952977 +0100
@@ -137,6 +137,7 @@ static int _wrap_nettle_pk_derive(gnutls @@ -137,6 +137,7 @@ static int _wrap_nettle_pk_derive(gnutls
switch (algo) switch (algo)
@ -582,9 +582,9 @@ diff -up gnutls-3.1.8/lib/nettle/pk.c.noecc gnutls-3.1.8/lib/nettle/pk.c
default: default:
ret = gnutls_assert_val(GNUTLS_E_INVALID_REQUEST); ret = gnutls_assert_val(GNUTLS_E_INVALID_REQUEST);
} }
diff -up gnutls-3.1.8/tests/cert-tests/dane.noecc gnutls-3.1.8/tests/cert-tests/dane diff -up gnutls-3.1.9/tests/cert-tests/dane.noecc gnutls-3.1.9/tests/cert-tests/dane
--- gnutls-3.1.8/tests/cert-tests/dane.noecc 2013-01-25 20:24:10.000000000 +0100 --- gnutls-3.1.9/tests/cert-tests/dane.noecc 2013-02-27 17:28:17.000000000 +0100
+++ gnutls-3.1.8/tests/cert-tests/dane 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/tests/cert-tests/dane 2013-03-15 14:46:31.128952977 +0100
@@ -22,6 +22,8 @@ @@ -22,6 +22,8 @@
set -e set -e
@ -594,9 +594,9 @@ diff -up gnutls-3.1.8/tests/cert-tests/dane.noecc gnutls-3.1.8/tests/cert-tests/
srcdir=${srcdir:-.} srcdir=${srcdir:-.}
DANETOOL=${DANETOOL:-../../src/danetool$EXEEXT} DANETOOL=${DANETOOL:-../../src/danetool$EXEEXT}
diff -up gnutls-3.1.8/tests/dtls/dtls-nb.noecc gnutls-3.1.8/tests/dtls/dtls-nb diff -up gnutls-3.1.9/tests/dtls/dtls-nb.noecc gnutls-3.1.9/tests/dtls/dtls-nb
--- gnutls-3.1.8/tests/dtls/dtls-nb.noecc 2012-12-03 20:36:51.000000000 +0100 --- gnutls-3.1.9/tests/dtls/dtls-nb.noecc 2012-12-03 20:36:51.000000000 +0100
+++ gnutls-3.1.8/tests/dtls/dtls-nb 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/tests/dtls/dtls-nb 2013-03-15 14:46:31.128952977 +0100
@@ -22,9 +22,7 @@ @@ -22,9 +22,7 @@
set -e set -e
@ -608,9 +608,9 @@ diff -up gnutls-3.1.8/tests/dtls/dtls-nb.noecc gnutls-3.1.8/tests/dtls/dtls-nb
./dtls-stress -nb -shello 021 -sfinished 01 -cfinished 012 SKeyExchange CKeyExchange CFinished ./dtls-stress -nb -shello 021 -sfinished 01 -cfinished 012 SKeyExchange CKeyExchange CFinished
./dtls-stress -nb -shello 012 -sfinished 10 -cfinished 210 SHello SKeyExchange SHelloDone ./dtls-stress -nb -shello 012 -sfinished 10 -cfinished 210 SHello SKeyExchange SHelloDone
diff -up gnutls-3.1.8/tests/dtls/dtls.noecc gnutls-3.1.8/tests/dtls/dtls diff -up gnutls-3.1.9/tests/dtls/dtls.noecc gnutls-3.1.9/tests/dtls/dtls
--- gnutls-3.1.8/tests/dtls/dtls.noecc 2012-12-03 20:36:51.000000000 +0100 --- gnutls-3.1.9/tests/dtls/dtls.noecc 2012-12-03 20:36:51.000000000 +0100
+++ gnutls-3.1.8/tests/dtls/dtls 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/tests/dtls/dtls 2013-03-15 14:46:31.128952977 +0100
@@ -22,9 +22,7 @@ @@ -22,9 +22,7 @@
set -e set -e
@ -622,9 +622,9 @@ diff -up gnutls-3.1.8/tests/dtls/dtls.noecc gnutls-3.1.8/tests/dtls/dtls
./dtls-stress -shello 021 -sfinished 01 -cfinished 012 SKeyExchange CKeyExchange CFinished ./dtls-stress -shello 021 -sfinished 01 -cfinished 012 SKeyExchange CKeyExchange CFinished
./dtls-stress -shello 012 -sfinished 10 -cfinished 210 SHello SKeyExchange SHelloDone ./dtls-stress -shello 012 -sfinished 10 -cfinished 210 SHello SKeyExchange SHelloDone
diff -up gnutls-3.1.8/tests/ecdsa/ecdsa.noecc gnutls-3.1.8/tests/ecdsa/ecdsa diff -up gnutls-3.1.9/tests/ecdsa/ecdsa.noecc gnutls-3.1.9/tests/ecdsa/ecdsa
--- gnutls-3.1.8/tests/ecdsa/ecdsa.noecc 2012-12-03 20:36:51.000000000 +0100 --- gnutls-3.1.9/tests/ecdsa/ecdsa.noecc 2012-12-03 20:36:51.000000000 +0100
+++ gnutls-3.1.8/tests/ecdsa/ecdsa 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/tests/ecdsa/ecdsa 2013-03-15 14:46:31.128952977 +0100
@@ -22,6 +22,8 @@ @@ -22,6 +22,8 @@
#set -e #set -e
@ -634,9 +634,9 @@ diff -up gnutls-3.1.8/tests/ecdsa/ecdsa.noecc gnutls-3.1.8/tests/ecdsa/ecdsa
srcdir=${srcdir:-.} srcdir=${srcdir:-.}
CERTTOOL=${CERTTOOL:-../../src/certtool$EXEEXT} CERTTOOL=${CERTTOOL:-../../src/certtool$EXEEXT}
diff -up gnutls-3.1.8/tests/mini-dtls-record.c.noecc gnutls-3.1.8/tests/mini-dtls-record.c diff -up gnutls-3.1.9/tests/mini-dtls-record.c.noecc gnutls-3.1.9/tests/mini-dtls-record.c
--- gnutls-3.1.8/tests/mini-dtls-record.c.noecc 2013-01-17 20:07:30.000000000 +0100 --- gnutls-3.1.9/tests/mini-dtls-record.c.noecc 2013-01-17 20:07:30.000000000 +0100
+++ gnutls-3.1.8/tests/mini-dtls-record.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/tests/mini-dtls-record.c 2013-03-15 14:46:31.128952977 +0100
@@ -27,7 +27,7 @@ @@ -27,7 +27,7 @@
#include <stdio.h> #include <stdio.h>
#include <stdlib.h> #include <stdlib.h>
@ -646,9 +646,9 @@ diff -up gnutls-3.1.8/tests/mini-dtls-record.c.noecc gnutls-3.1.8/tests/mini-dtl
int int
main () main ()
diff -up gnutls-3.1.8/tests/mini-dtls-rehandshake.c.noecc gnutls-3.1.8/tests/mini-dtls-rehandshake.c diff -up gnutls-3.1.9/tests/mini-dtls-rehandshake.c.noecc gnutls-3.1.9/tests/mini-dtls-rehandshake.c
--- gnutls-3.1.8/tests/mini-dtls-rehandshake.c.noecc 2012-12-03 20:36:51.000000000 +0100 --- gnutls-3.1.9/tests/mini-dtls-rehandshake.c.noecc 2012-12-03 20:36:51.000000000 +0100
+++ gnutls-3.1.8/tests/mini-dtls-rehandshake.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/tests/mini-dtls-rehandshake.c 2013-03-15 14:46:31.129952998 +0100
@@ -27,7 +27,7 @@ @@ -27,7 +27,7 @@
#include <stdio.h> #include <stdio.h>
#include <stdlib.h> #include <stdlib.h>
@ -658,9 +658,9 @@ diff -up gnutls-3.1.8/tests/mini-dtls-rehandshake.c.noecc gnutls-3.1.8/tests/min
int main() int main()
{ {
diff -up gnutls-3.1.8/tests/mini-dtls-srtp.c.noecc gnutls-3.1.8/tests/mini-dtls-srtp.c diff -up gnutls-3.1.9/tests/mini-dtls-srtp.c.noecc gnutls-3.1.9/tests/mini-dtls-srtp.c
--- gnutls-3.1.8/tests/mini-dtls-srtp.c.noecc 2012-12-03 20:36:51.000000000 +0100 --- gnutls-3.1.9/tests/mini-dtls-srtp.c.noecc 2012-12-03 20:36:51.000000000 +0100
+++ gnutls-3.1.8/tests/mini-dtls-srtp.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/tests/mini-dtls-srtp.c 2013-03-15 14:46:31.129952998 +0100
@@ -27,7 +27,7 @@ @@ -27,7 +27,7 @@
#include <stdio.h> #include <stdio.h>
#include <stdlib.h> #include <stdlib.h>
@ -670,9 +670,9 @@ diff -up gnutls-3.1.8/tests/mini-dtls-srtp.c.noecc gnutls-3.1.8/tests/mini-dtls-
int int
main (int argc, char** argv) main (int argc, char** argv)
diff -up gnutls-3.1.8/tests/mini-handshake-timeout.c.noecc gnutls-3.1.8/tests/mini-handshake-timeout.c diff -up gnutls-3.1.9/tests/mini-handshake-timeout.c.noecc gnutls-3.1.9/tests/mini-handshake-timeout.c
--- gnutls-3.1.8/tests/mini-handshake-timeout.c.noecc 2012-12-03 20:36:51.000000000 +0100 --- gnutls-3.1.9/tests/mini-handshake-timeout.c.noecc 2012-12-03 20:36:51.000000000 +0100
+++ gnutls-3.1.8/tests/mini-handshake-timeout.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/tests/mini-handshake-timeout.c 2013-03-15 14:46:31.129952998 +0100
@@ -28,7 +28,7 @@ @@ -28,7 +28,7 @@
#include <stdlib.h> #include <stdlib.h>
#include <string.h> #include <string.h>
@ -695,9 +695,9 @@ diff -up gnutls-3.1.8/tests/mini-handshake-timeout.c.noecc gnutls-3.1.8/tests/mi
} }
static void static void
diff -up gnutls-3.1.8/tests/mini-loss-time.c.noecc gnutls-3.1.8/tests/mini-loss-time.c diff -up gnutls-3.1.9/tests/mini-loss-time.c.noecc gnutls-3.1.9/tests/mini-loss-time.c
--- gnutls-3.1.8/tests/mini-loss-time.c.noecc 2012-12-03 20:36:51.000000000 +0100 --- gnutls-3.1.9/tests/mini-loss-time.c.noecc 2012-12-03 20:36:51.000000000 +0100
+++ gnutls-3.1.8/tests/mini-loss-time.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/tests/mini-loss-time.c 2013-03-15 14:46:31.129952998 +0100
@@ -28,7 +28,7 @@ @@ -28,7 +28,7 @@
#include <stdlib.h> #include <stdlib.h>
#include <string.h> #include <string.h>
@ -707,9 +707,9 @@ diff -up gnutls-3.1.8/tests/mini-loss-time.c.noecc gnutls-3.1.8/tests/mini-loss-
int main() int main()
{ {
diff -up gnutls-3.1.8/tests/mini-record.c.noecc gnutls-3.1.8/tests/mini-record.c diff -up gnutls-3.1.9/tests/mini-record.c.noecc gnutls-3.1.9/tests/mini-record.c
--- gnutls-3.1.8/tests/mini-record.c.noecc 2013-01-23 20:31:17.000000000 +0100 --- gnutls-3.1.9/tests/mini-record.c.noecc 2013-01-23 20:31:17.000000000 +0100
+++ gnutls-3.1.8/tests/mini-record.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/tests/mini-record.c 2013-03-15 14:46:31.130953019 +0100
@@ -27,7 +27,7 @@ @@ -27,7 +27,7 @@
#include <stdio.h> #include <stdio.h>
#include <stdlib.h> #include <stdlib.h>
@ -719,9 +719,9 @@ diff -up gnutls-3.1.8/tests/mini-record.c.noecc gnutls-3.1.8/tests/mini-record.c
int main() int main()
{ {
diff -up gnutls-3.1.8/tests/mini-xssl.c.noecc gnutls-3.1.8/tests/mini-xssl.c diff -up gnutls-3.1.9/tests/mini-xssl.c.noecc gnutls-3.1.9/tests/mini-xssl.c
--- gnutls-3.1.8/tests/mini-xssl.c.noecc 2013-01-27 18:16:02.000000000 +0100 --- gnutls-3.1.9/tests/mini-xssl.c.noecc 2013-01-27 18:16:02.000000000 +0100
+++ gnutls-3.1.8/tests/mini-xssl.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/tests/mini-xssl.c 2013-03-15 14:46:31.130953019 +0100
@@ -27,7 +27,7 @@ @@ -27,7 +27,7 @@
#include <stdio.h> #include <stdio.h>
#include <stdlib.h> #include <stdlib.h>
@ -731,9 +731,9 @@ diff -up gnutls-3.1.8/tests/mini-xssl.c.noecc gnutls-3.1.8/tests/mini-xssl.c
int main() int main()
{ {
diff -up gnutls-3.1.8/tests/pkcs12_simple.c.noecc gnutls-3.1.8/tests/pkcs12_simple.c diff -up gnutls-3.1.9/tests/pkcs12_simple.c.noecc gnutls-3.1.9/tests/pkcs12_simple.c
--- gnutls-3.1.8/tests/pkcs12_simple.c.noecc 2012-12-06 09:01:28.000000000 +0100 --- gnutls-3.1.9/tests/pkcs12_simple.c.noecc 2012-12-06 09:01:28.000000000 +0100
+++ gnutls-3.1.8/tests/pkcs12_simple.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/tests/pkcs12_simple.c 2013-03-15 14:46:31.130953019 +0100
@@ -50,6 +50,10 @@ doit (void) @@ -50,6 +50,10 @@ doit (void)
gnutls_x509_privkey_t pkey; gnutls_x509_privkey_t pkey;
int ret; int ret;
@ -745,9 +745,9 @@ diff -up gnutls-3.1.8/tests/pkcs12_simple.c.noecc gnutls-3.1.8/tests/pkcs12_simp
ret = gnutls_global_init (); ret = gnutls_global_init ();
if (ret < 0) if (ret < 0)
fail ("gnutls_global_init failed %d\n", ret); fail ("gnutls_global_init failed %d\n", ret);
diff -up gnutls-3.1.8/tests/slow/keygen.c.noecc gnutls-3.1.8/tests/slow/keygen.c diff -up gnutls-3.1.9/tests/slow/keygen.c.noecc gnutls-3.1.9/tests/slow/keygen.c
--- gnutls-3.1.8/tests/slow/keygen.c.noecc 2012-12-03 20:36:52.000000000 +0100 --- gnutls-3.1.9/tests/slow/keygen.c.noecc 2012-12-03 20:36:52.000000000 +0100
+++ gnutls-3.1.8/tests/slow/keygen.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/tests/slow/keygen.c 2013-03-15 14:46:31.130953019 +0100
@@ -65,6 +65,11 @@ doit (void) @@ -65,6 +65,11 @@ doit (void)
if (algorithm == GNUTLS_PK_DH) if (algorithm == GNUTLS_PK_DH)
continue; continue;
@ -760,9 +760,9 @@ diff -up gnutls-3.1.8/tests/slow/keygen.c.noecc gnutls-3.1.8/tests/slow/keygen.c
ret = gnutls_x509_privkey_init (&pkey); ret = gnutls_x509_privkey_init (&pkey);
if (ret < 0) if (ret < 0)
{ {
diff -up gnutls-3.1.8/tests/srp/mini-srp.c.noecc gnutls-3.1.8/tests/srp/mini-srp.c diff -up gnutls-3.1.9/tests/srp/mini-srp.c.noecc gnutls-3.1.9/tests/srp/mini-srp.c
--- gnutls-3.1.8/tests/srp/mini-srp.c.noecc 2012-12-03 20:36:52.000000000 +0100 --- gnutls-3.1.9/tests/srp/mini-srp.c.noecc 2012-12-03 20:36:52.000000000 +0100
+++ gnutls-3.1.8/tests/srp/mini-srp.c 2013-02-21 09:39:26.000000000 +0100 +++ gnutls-3.1.9/tests/srp/mini-srp.c 2013-03-15 14:46:31.130953019 +0100
@@ -27,7 +27,7 @@ @@ -27,7 +27,7 @@
#include <stdio.h> #include <stdio.h>
#include <stdlib.h> #include <stdlib.h>

View File

@ -2,8 +2,8 @@
%bcond_with guile %bcond_with guile
Summary: A TLS protocol implementation Summary: A TLS protocol implementation
Name: gnutls Name: gnutls
Version: 3.1.8 Version: 3.1.9
Release: 3%{?dist} Release: 1%{?dist}
# The libgnutls library is LGPLv3+, utilities and remaining libraries are GPLv3+ # The libgnutls library is LGPLv3+, utilities and remaining libraries are GPLv3+
License: GPLv3+ and LGPLv3+ License: GPLv3+ and LGPLv3+
Group: System Environment/Libraries Group: System Environment/Libraries
@ -28,7 +28,7 @@ Patch1: gnutls-3.1.7-rpath.patch
# Use only FIPS approved ciphers in the FIPS mode # Use only FIPS approved ciphers in the FIPS mode
Patch7: gnutls-2.12.21-fips-algorithms.patch Patch7: gnutls-2.12.21-fips-algorithms.patch
# Make ECC optional as it is now hobbled # Make ECC optional as it is now hobbled
Patch8: gnutls-3.1.8-noecc.patch Patch8: gnutls-3.1.9-noecc.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: libgcrypt >= 1.2.2 Requires: libgcrypt >= 1.2.2
@ -257,6 +257,9 @@ fi
%endif %endif
%changelog %changelog
* Fri Mar 15 2013 Tomas Mraz <tmraz@redhat.com> 3.1.9-1
- new upstream release
* Thu Mar 7 2013 Tomas Mraz <tmraz@redhat.com> 3.1.8-3 * Thu Mar 7 2013 Tomas Mraz <tmraz@redhat.com> 3.1.8-3
- drop the temporary old library - drop the temporary old library

View File

@ -1 +1 @@
083973445c4416b25163014c727a41f6 gnutls-3.1.8-hobbled.tar.xz 74370d5219c834a17791f22046286274 gnutls-3.1.9-hobbled.tar.xz