Update to 3.5.9-1
- Update to upstream 3.5.9 release
This commit is contained in:
parent
037ae5e088
commit
d28c417730
1
.gitignore
vendored
1
.gitignore
vendored
@ -71,3 +71,4 @@ gnutls-2.10.1-nosrp.tar.bz2
|
||||
/gnutls-3.5.6-hobbled.tar.xz
|
||||
/gnutls-3.5.7-hobbled.tar.xz
|
||||
/gnutls-3.5.8-hobbled.tar.xz
|
||||
/gnutls-3.5.9-hobbled.tar.xz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -ur gnutls-3.2.7.orig/configure gnutls-3.2.7/configure
|
||||
--- gnutls-3.2.7.orig/configure 2013-11-23 11:09:49.000000000 +0100
|
||||
+++ gnutls-3.2.7/configure 2013-11-25 16:53:05.559440656 +0100
|
||||
@@ -39652,7 +39652,7 @@
|
||||
shlibpath_overrides_runpath=unknown
|
||||
version_type=none
|
||||
dynamic_linker="$host_os ld.so"
|
||||
-sys_lib_dlsearch_path_spec="/lib /usr/lib"
|
||||
+sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64"
|
||||
need_lib_prefix=unknown
|
||||
hardcode_into_libs=no
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up gnutls-3.4.2/guile/src/Makefile.in.jx gnutls-3.4.2/guile/src/Makefile.in
|
||||
--- gnutls-3.4.2/guile/src/Makefile.in.jx 2015-06-16 12:23:31.000000000 -0400
|
||||
+++ gnutls-3.4.2/guile/src/Makefile.in 2015-07-02 14:01:19.415060204 -0400
|
||||
@@ -1316,7 +1316,7 @@ guileextension_LTLIBRARIES = guile-gnutl
|
||||
# Use '-module' to build a "dlopenable module", in Libtool terms.
|
||||
# Use '-undefined' to placate Libtool on Windows; see
|
||||
# <http://lists.gnutls.org/pipermail/gnutls-devel/2014-December/007294.html>.
|
||||
-guile_gnutls_v_2_la_LDFLAGS = -module -no-undefined
|
||||
+guile_gnutls_v_2_la_LDFLAGS = -module -no-undefined -Wl,-z,lazy
|
||||
|
||||
# Linking against GnuTLS.
|
||||
GNUTLS_CORE_LIBS = $(top_builddir)/lib/libgnutls.la
|
@ -1,12 +0,0 @@
|
||||
diff --git a/lib/pkcs11.c b/lib/pkcs11.c
|
||||
index 21f8bc3..2473a4c 100644
|
||||
--- a/lib/pkcs11.c
|
||||
+++ b/lib/pkcs11.c
|
||||
@@ -3138,6 +3138,7 @@ gnutls_pkcs11_obj_list_import_url4(gnutls_pkcs11_obj_t ** p_list,
|
||||
if (ret < 0) {
|
||||
gnutls_assert();
|
||||
if (ret == GNUTLS_E_REQUESTED_DATA_NOT_AVAILABLE) {
|
||||
+ *p_list = NULL;
|
||||
*n_list = 0;
|
||||
ret = 0;
|
||||
}
|
24
gnutls.spec
24
gnutls.spec
@ -1,9 +1,12 @@
|
||||
# This spec file has been automatically updated
|
||||
Version: 3.5.9
|
||||
Release: 1%{?dist}
|
||||
Patch1: gnutls-3.2.7-rpath.patch
|
||||
Patch2: gnutls-3.4.2-no-now-guile.patch
|
||||
%bcond_without dane
|
||||
%bcond_without guile
|
||||
Summary: A TLS protocol implementation
|
||||
Name: gnutls
|
||||
Version: 3.5.8
|
||||
Release: 3%{?dist}
|
||||
# The libraries are LGPLv2.1+, utilities are GPLv3+
|
||||
License: GPLv3+ and LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
@ -13,7 +16,7 @@ BuildRequires: libtool, automake, autoconf, texinfo
|
||||
BuildRequires: autogen-libopts-devel >= 5.18 autogen
|
||||
BuildRequires: nettle-devel >= 3.1.1
|
||||
BuildRequires: trousers-devel >= 0.3.11.2
|
||||
BuildRequires: libidn-devel
|
||||
BuildRequires: libidn2-devel
|
||||
BuildRequires: libunistring-devel
|
||||
BuildRequires: gperf, net-tools, datefudge, softhsm
|
||||
Requires: crypto-policies
|
||||
@ -32,10 +35,6 @@ URL: http://www.gnutls.org/
|
||||
#Source1: ftp://ftp.gnutls.org/gcrypt/gnutls/%{name}-%{version}.tar.xz.sig
|
||||
# XXX patent tainted code removed.
|
||||
Source0: %{name}-%{version}-hobbled.tar.xz
|
||||
Source2: hobble-gnutls
|
||||
Patch1: gnutls-3.2.7-rpath.patch
|
||||
Patch2: gnutls-3.4.2-no-now-guile.patch
|
||||
Patch3: gnutls-3.5.8-init.patch
|
||||
|
||||
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
||||
Provides: bundled(gnulib) = 20130424
|
||||
@ -134,10 +133,8 @@ This package contains Guile bindings for the library.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1 -b .rpath
|
||||
%patch2 -p1 -b .guile
|
||||
%patch3 -p1 -b .init
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
||||
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
||||
@ -145,7 +142,6 @@ sed -i -e 's|sys_lib_dlsearch_path_spec="/lib /usr/lib|sys_lib_dlsearch_path_spe
|
||||
rm -f lib/minitasn1/*.c lib/minitasn1/*.h
|
||||
rm -f src/libopts/*.c src/libopts/*.h src/libopts/compat/*.c src/libopts/compat/*.h
|
||||
|
||||
%{SOURCE2} -e
|
||||
echo "SYSTEM=NORMAL" >> tests/system.prio
|
||||
|
||||
%build
|
||||
@ -170,6 +166,7 @@ echo "SYSTEM=NORMAL" >> tests/system.prio
|
||||
%endif
|
||||
--disable-rpath \
|
||||
--with-default-priority-string="@SYSTEM"
|
||||
|
||||
make %{?_smp_mflags} V=1
|
||||
|
||||
%install
|
||||
@ -270,6 +267,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Feb 14 2017 Nikos Mavrogiannopoulos <nmav@redhat.com> - 3.5.9-1
|
||||
- Update to upstream 3.5.9 release
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.5.8-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gnutls-3.5.8-hobbled.tar.xz) = 99eeccc960d9e496b24512ef8524205ac165fceae6b265908842bf59435793c89c87d70f22a77bf471082f7ea5f1c169b29d4e79bbd2f51fc38976b614d906aa
|
||||
SHA512 (gnutls-3.5.9-hobbled.tar.xz) = a8e308cafe6103ca613e113e6409d9fe73ad84db8c199680b437dacdecb7af0593ae8659d789dcb033c8a51d00e3d567e2a90585dfcd7008f9f49bb6e125d826
|
||||
|
Loading…
Reference in New Issue
Block a user