new upstream released (3.3.1)
This commit is contained in:
parent
4adeac77fb
commit
bbe5fc5877
1
.gitignore
vendored
1
.gitignore
vendored
@ -36,3 +36,4 @@ gnutls-2.10.1-nosrp.tar.bz2
|
|||||||
/gnutls-3.2.12.1-hobbled.tar.xz
|
/gnutls-3.2.12.1-hobbled.tar.xz
|
||||||
/gnutls-3.2.13-hobbled.tar.xz
|
/gnutls-3.2.13-hobbled.tar.xz
|
||||||
/gnutls-3.3.0-hobbled.tar.xz
|
/gnutls-3.3.0-hobbled.tar.xz
|
||||||
|
/gnutls-3.3.1-hobbled.tar.xz
|
||||||
|
27
gnutls-othername.patch
Normal file
27
gnutls-othername.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From 9b8271f0015526f017aa70b8d1f3a8fa1f8d3a62 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Nikos Mavrogiannopoulos <nmav@gnutls.org>
|
||||||
|
Date: Sat, 19 Apr 2014 18:32:07 +0200
|
||||||
|
Subject: [PATCH 01/01] Treat othername as printable (i.e., null terminate it),
|
||||||
|
as the XMPP printing code assumes that.
|
||||||
|
|
||||||
|
---
|
||||||
|
lib/x509/x509.c | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/lib/x509/x509.c b/lib/x509/x509.c
|
||||||
|
index d13c231..e63f059 100644
|
||||||
|
--- a/lib/x509/x509.c
|
||||||
|
+++ b/lib/x509/x509.c
|
||||||
|
@@ -847,7 +847,8 @@ gnutls_x509_crt_get_subject_key_id(gnutls_x509_crt_t cert, void *ret,
|
||||||
|
inline static int is_type_printable(int type)
|
||||||
|
{
|
||||||
|
if (type == GNUTLS_SAN_DNSNAME || type == GNUTLS_SAN_RFC822NAME ||
|
||||||
|
- type == GNUTLS_SAN_URI || type == GNUTLS_SAN_OTHERNAME_XMPP)
|
||||||
|
+ type == GNUTLS_SAN_URI || type == GNUTLS_SAN_OTHERNAME_XMPP ||
|
||||||
|
+ type == GNUTLS_SAN_OTHERNAME)
|
||||||
|
return 1;
|
||||||
|
else
|
||||||
|
return 0;
|
||||||
|
--
|
||||||
|
1.9.0
|
||||||
|
|
@ -2,7 +2,7 @@
|
|||||||
%bcond_with guile
|
%bcond_with guile
|
||||||
Summary: A TLS protocol implementation
|
Summary: A TLS protocol implementation
|
||||||
Name: gnutls
|
Name: gnutls
|
||||||
Version: 3.3.0
|
Version: 3.3.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
# The libraries are LGPLv2.1+, utilities are GPLv3+
|
# The libraries are LGPLv2.1+, utilities are GPLv3+
|
||||||
License: GPLv3+ and LGPLv2+
|
License: GPLv3+ and LGPLv2+
|
||||||
@ -31,6 +31,7 @@ Patch1: gnutls-3.2.7-rpath.patch
|
|||||||
# Use only FIPS approved ciphers in the FIPS mode
|
# Use only FIPS approved ciphers in the FIPS mode
|
||||||
Patch7: gnutls-2.12.21-fips-algorithms.patch
|
Patch7: gnutls-2.12.21-fips-algorithms.patch
|
||||||
Patch8: gnutls-3.1.11-nosrp.patch
|
Patch8: gnutls-3.1.11-nosrp.patch
|
||||||
|
Patch9: gnutls-othername.patch
|
||||||
|
|
||||||
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
||||||
Provides: bundled(gnulib) = 20130424
|
Provides: bundled(gnulib) = 20130424
|
||||||
@ -135,6 +136,7 @@ This package contains Guile bindings for the library.
|
|||||||
# later reused.
|
# later reused.
|
||||||
#%patch7 -p1 -b .fips
|
#%patch7 -p1 -b .fips
|
||||||
%patch8 -p1 -b .nosrp
|
%patch8 -p1 -b .nosrp
|
||||||
|
%patch9 -p1 -b .othername
|
||||||
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
||||||
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
||||||
|
|
||||||
@ -267,6 +269,10 @@ fi
|
|||||||
%{_datadir}/guile/site/gnutls.scm
|
%{_datadir}/guile/site/gnutls.scm
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Apr 28 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> 3.3.1-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Apr 14 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> 3.3.0-1
|
* Mon Apr 14 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> 3.3.0-1
|
||||||
- new upstream release
|
- new upstream release
|
||||||
|
Loading…
Reference in New Issue
Block a user