KTLS: disable ktls_keyupdate & tls1.2 chachapoly tests
There seems to be a kernel specific issues with CHACHA20-POLY1305 for TLS 1.2 [1] The test fails without a needed kernel patch [1] https://gitlab.com/gnutls/gnutls/-/issues/1443 Signed-off-by: Frantisek Krenzelok <krenzelok.frantisek@gmail.com>
This commit is contained in:
parent
c1f8e66db2
commit
a9d1c50f1a
13
gnutls-3.7.8-ktls_disable_keyupdate_test.patch
Normal file
13
gnutls-3.7.8-ktls_disable_keyupdate_test.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
||||||
|
index 2872cb1aa..247dfd3d8 100644
|
||||||
|
--- a/tests/Makefile.am
|
||||||
|
+++ b/tests/Makefile.am
|
||||||
|
@@ -504,8 +504,6 @@ endif
|
||||||
|
if ENABLE_KTLS
|
||||||
|
indirect_tests += gnutls_ktls
|
||||||
|
dist_check_SCRIPTS += ktls.sh
|
||||||
|
-indirect_tests += ktls_keyupdate
|
||||||
|
-dist_check_SCRIPTS += ktls_keyupdate.sh
|
||||||
|
endif
|
||||||
|
|
||||||
|
if !WINDOWS
|
12
gnutls-3.7.8-ktls_skip_tls12_chachapoly_test.patch
Normal file
12
gnutls-3.7.8-ktls_skip_tls12_chachapoly_test.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff --git a/tests/gnutls_ktls.c b/tests/gnutls_ktls.c
|
||||||
|
index 919270778..778a2f94a 100644
|
||||||
|
--- a/tests/gnutls_ktls.c
|
||||||
|
+++ b/tests/gnutls_ktls.c
|
||||||
|
@@ -351,7 +351,6 @@ void doit(void)
|
||||||
|
run("NORMAL:-VERS-ALL:+VERS-TLS1.2:-CIPHER-ALL:+AES-128-GCM");
|
||||||
|
run("NORMAL:-VERS-ALL:+VERS-TLS1.2:-CIPHER-ALL:+AES-256-GCM");
|
||||||
|
run("NORMAL:-VERS-ALL:+VERS-TLS1.2:-CIPHER-ALL:+AES-128-CCM");
|
||||||
|
- run("NORMAL:-VERS-ALL:+VERS-TLS1.2:-CIPHER-ALL:+CHACHA20-POLY1305");
|
||||||
|
run("NORMAL:-VERS-ALL:+VERS-TLS1.3:-CIPHER-ALL:+AES-128-GCM");
|
||||||
|
run("NORMAL:-VERS-ALL:+VERS-TLS1.3:-CIPHER-ALL:+AES-256-GCM");
|
||||||
|
run("NORMAL:-VERS-ALL:+VERS-TLS1.3:-CIPHER-ALL:+AES-128-CCM");
|
@ -28,6 +28,12 @@ Patch: gnutls-3.7.8-ktls_add_ciphersuites.patch
|
|||||||
Patch: gnutls-3.7.8-ktls_minor_fixes.patch
|
Patch: gnutls-3.7.8-ktls_minor_fixes.patch
|
||||||
Patch: gnutls-3.7.8-ktls_invalidate_session.patch
|
Patch: gnutls-3.7.8-ktls_invalidate_session.patch
|
||||||
|
|
||||||
|
# Delete only after the kernel has been patched for thested systems
|
||||||
|
Patch: gnutls-3.7.8-ktls_disable_keyupdate_test.patch
|
||||||
|
|
||||||
|
# follow https://gitlab.com/gnutls/gnutls/-/issues/1443
|
||||||
|
Patch: gnutls-3.7.8-ktls_skip_tls12_chachapoly_test.patch
|
||||||
|
|
||||||
%bcond_without bootstrap
|
%bcond_without bootstrap
|
||||||
%bcond_without dane
|
%bcond_without dane
|
||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
|
Loading…
Reference in New Issue
Block a user