- new upstream version
This commit is contained in:
parent
a883f00dc9
commit
a7a87e5138
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
gnutls-2.8.6-nosrp.tar.bz2
|
gnutls-2.8.6-nosrp.tar.bz2
|
||||||
gnutls-2.10.1-nosrp.tar.bz2
|
gnutls-2.10.1-nosrp.tar.bz2
|
||||||
|
/gnutls-2.10.2-nosrp.tar.bz2
|
||||||
|
@ -1,28 +0,0 @@
|
|||||||
From e6cc32d6af7749826807badd258224ec1bfa31ae Mon Sep 17 00:00:00 2001
|
|
||||||
From: Vivek Dasmohapatra <vivek@collabora.co.uk>
|
|
||||||
Date: Thu, 23 Sep 2010 16:43:12 +0100
|
|
||||||
Subject: [PATCH] IMED_RET macro should not clear session hash data if we are returning EAGAIN
|
|
||||||
|
|
||||||
GNUTLS_E_AGAIN implies we haven't finished the operation in question,
|
|
||||||
and therefore should not be clearing the cached hash data.
|
|
||||||
---
|
|
||||||
lib/gnutls_handshake.c | 3 ++-
|
|
||||||
1 files changed, 2 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/lib/gnutls_handshake.c b/lib/gnutls_handshake.c
|
|
||||||
index 84e6773..6e397b2 100644
|
|
||||||
--- a/lib/gnutls_handshake.c
|
|
||||||
+++ b/lib/gnutls_handshake.c
|
|
||||||
@@ -2736,7 +2736,8 @@ gnutls_handshake (gnutls_session_t session)
|
|
||||||
if (check_fatal != 0 && gnutls_error_is_fatal(ret)==0) return ret; \
|
|
||||||
gnutls_assert(); \
|
|
||||||
ERR( str, ret); \
|
|
||||||
- _gnutls_handshake_hash_buffers_clear(session); \
|
|
||||||
+ if (ret != GNUTLS_E_AGAIN) \
|
|
||||||
+ _gnutls_handshake_hash_buffers_clear(session); \
|
|
||||||
return ret; \
|
|
||||||
} } while (0)
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.0
|
|
||||||
|
|
@ -1,8 +1,8 @@
|
|||||||
diff -up gnutls-2.8.5/build-aux/config.rpath gnutls-2.8.5/build-aux/config
|
diff -up gnutls-2.10.2/build-aux/config.rpath gnutls-2.10.2/build-aux/config
|
||||||
diff -up gnutls-2.8.5/configure.rpath gnutls-2.8.5/configure
|
diff -up gnutls-2.10.2/configure.rpath gnutls-2.10.2/configure
|
||||||
--- gnutls-2.8.5/configure.rpath 2009-11-02 11:35:57.000000000 +0100
|
--- gnutls-2.10.2/configure.rpath 2010-09-30 08:43:40.000000000 +0200
|
||||||
+++ gnutls-2.8.5/configure 2010-01-28 22:12:20.000000000 +0100
|
+++ gnutls-2.10.2/configure 2010-09-30 15:56:59.000000000 +0200
|
||||||
@@ -15141,7 +15141,7 @@ shlibpath_var=
|
@@ -15112,7 +15112,7 @@ shlibpath_var=
|
||||||
shlibpath_overrides_runpath=unknown
|
shlibpath_overrides_runpath=unknown
|
||||||
version_type=none
|
version_type=none
|
||||||
dynamic_linker="$host_os ld.so"
|
dynamic_linker="$host_os ld.so"
|
||||||
@ -11,16 +11,16 @@ diff -up gnutls-2.8.5/configure.rpath gnutls-2.8.5/configure
|
|||||||
need_lib_prefix=unknown
|
need_lib_prefix=unknown
|
||||||
hardcode_into_libs=no
|
hardcode_into_libs=no
|
||||||
|
|
||||||
@@ -15526,7 +15526,7 @@ rm -f core conftest.err conftest.$ac_obj
|
@@ -15510,7 +15510,7 @@ fi
|
||||||
# Append ld.so.conf contents to the search path
|
# Append ld.so.conf contents to the search path
|
||||||
if test -f /etc/ld.so.conf; then
|
if test -f /etc/ld.so.conf; then
|
||||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||||
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||||
@@ -18610,7 +18610,7 @@ shlibpath_var=
|
@@ -18777,7 +18777,7 @@ shlibpath_var=
|
||||||
shlibpath_overrides_runpath=unknown
|
shlibpath_overrides_runpath=unknown
|
||||||
version_type=none
|
version_type=none
|
||||||
dynamic_linker="$host_os ld.so"
|
dynamic_linker="$host_os ld.so"
|
||||||
@ -29,28 +29,20 @@ diff -up gnutls-2.8.5/configure.rpath gnutls-2.8.5/configure
|
|||||||
need_lib_prefix=unknown
|
need_lib_prefix=unknown
|
||||||
hardcode_into_libs=no
|
hardcode_into_libs=no
|
||||||
|
|
||||||
@@ -18994,7 +18994,7 @@ rm -f core conftest.err conftest.$ac_obj
|
@@ -19173,7 +19173,7 @@ fi
|
||||||
# Append ld.so.conf contents to the search path
|
# Append ld.so.conf contents to the search path
|
||||||
if test -f /etc/ld.so.conf; then
|
if test -f /etc/ld.so.conf; then
|
||||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||||
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||||
@@ -29278,6 +29278,7 @@ finish_cmds='`$ECHO "X$finish_cmds" | $X
|
diff -up gnutls-2.10.2/lib/build-aux/config.rpath gnutls-2.10.2/lib/build-aux/config
|
||||||
finish_eval='`$ECHO "X$finish_eval" | $Xsed -e "$delay_single_quote_subst"`'
|
diff -up gnutls-2.10.2/lib/configure.rpath gnutls-2.10.2/lib/configure
|
||||||
hardcode_into_libs='`$ECHO "X$hardcode_into_libs" | $Xsed -e "$delay_single_quote_subst"`'
|
--- gnutls-2.10.2/lib/configure.rpath 2010-09-30 08:42:57.000000000 +0200
|
||||||
sys_lib_search_path_spec='`$ECHO "X$sys_lib_search_path_spec" | $Xsed -e "$delay_single_quote_subst"`'
|
+++ gnutls-2.10.2/lib/configure 2010-09-30 15:58:06.000000000 +0200
|
||||||
+
|
@@ -10839,7 +10839,8 @@ shlibpath_var=
|
||||||
sys_lib_dlsearch_path_spec='`$ECHO "X$sys_lib_dlsearch_path_spec" | $Xsed -e "$delay_single_quote_subst"`'
|
|
||||||
hardcode_action='`$ECHO "X$hardcode_action" | $Xsed -e "$delay_single_quote_subst"`'
|
|
||||||
enable_dlopen='`$ECHO "X$enable_dlopen" | $Xsed -e "$delay_single_quote_subst"`'
|
|
||||||
diff -up gnutls-2.8.5/lib/build-aux/config.rpath gnutls-2.8.5/lib/build-aux/config
|
|
||||||
diff -up gnutls-2.8.5/lib/configure.rpath gnutls-2.8.5/lib/configure
|
|
||||||
--- gnutls-2.8.5/lib/configure.rpath 2009-11-02 11:35:18.000000000 +0100
|
|
||||||
+++ gnutls-2.8.5/lib/configure 2010-01-28 22:14:03.000000000 +0100
|
|
||||||
@@ -10465,7 +10465,8 @@ shlibpath_var=
|
|
||||||
shlibpath_overrides_runpath=unknown
|
shlibpath_overrides_runpath=unknown
|
||||||
version_type=none
|
version_type=none
|
||||||
dynamic_linker="$host_os ld.so"
|
dynamic_linker="$host_os ld.so"
|
||||||
@ -60,16 +52,16 @@ diff -up gnutls-2.8.5/lib/configure.rpath gnutls-2.8.5/lib/configure
|
|||||||
need_lib_prefix=unknown
|
need_lib_prefix=unknown
|
||||||
hardcode_into_libs=no
|
hardcode_into_libs=no
|
||||||
|
|
||||||
@@ -10850,7 +10851,7 @@ rm -f core conftest.err conftest.$ac_obj
|
@@ -11237,7 +11238,7 @@ fi
|
||||||
# Append ld.so.conf contents to the search path
|
# Append ld.so.conf contents to the search path
|
||||||
if test -f /etc/ld.so.conf; then
|
if test -f /etc/ld.so.conf; then
|
||||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||||
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||||
@@ -24444,7 +24445,8 @@ shlibpath_var=
|
@@ -25790,7 +25791,8 @@ shlibpath_var=
|
||||||
shlibpath_overrides_runpath=unknown
|
shlibpath_overrides_runpath=unknown
|
||||||
version_type=none
|
version_type=none
|
||||||
dynamic_linker="$host_os ld.so"
|
dynamic_linker="$host_os ld.so"
|
||||||
@ -79,20 +71,20 @@ diff -up gnutls-2.8.5/lib/configure.rpath gnutls-2.8.5/lib/configure
|
|||||||
need_lib_prefix=unknown
|
need_lib_prefix=unknown
|
||||||
hardcode_into_libs=no
|
hardcode_into_libs=no
|
||||||
|
|
||||||
@@ -24828,7 +24830,7 @@ rm -f core conftest.err conftest.$ac_obj
|
@@ -26186,7 +26188,7 @@ fi
|
||||||
# Append ld.so.conf contents to the search path
|
# Append ld.so.conf contents to the search path
|
||||||
if test -f /etc/ld.so.conf; then
|
if test -f /etc/ld.so.conf; then
|
||||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||||
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||||
diff -up gnutls-2.8.5/libextra/build-aux/config.rpath gnutls-2.8.5/libextra/build-aux/config
|
diff -up gnutls-2.10.2/libextra/build-aux/config.rpath gnutls-2.10.2/libextra/build-aux/config
|
||||||
diff -up gnutls-2.8.5/libextra/configure.rpath gnutls-2.8.5/libextra/configure
|
diff -up gnutls-2.10.2/libextra/configure.rpath gnutls-2.10.2/libextra/configure
|
||||||
--- gnutls-2.8.5/libextra/configure.rpath 2009-11-02 11:35:38.000000000 +0100
|
--- gnutls-2.10.2/libextra/configure.rpath 2010-09-30 08:43:20.000000000 +0200
|
||||||
+++ gnutls-2.8.5/libextra/configure 2010-01-28 21:45:25.000000000 +0100
|
+++ gnutls-2.10.2/libextra/configure 2010-09-30 15:58:49.000000000 +0200
|
||||||
@@ -9821,7 +9821,7 @@ shlibpath_var=
|
@@ -10013,7 +10013,7 @@ shlibpath_var=
|
||||||
shlibpath_overrides_runpath=unknown
|
shlibpath_overrides_runpath=unknown
|
||||||
version_type=none
|
version_type=none
|
||||||
dynamic_linker="$host_os ld.so"
|
dynamic_linker="$host_os ld.so"
|
||||||
@ -101,10 +93,10 @@ diff -up gnutls-2.8.5/libextra/configure.rpath gnutls-2.8.5/libextra/configure
|
|||||||
need_lib_prefix=unknown
|
need_lib_prefix=unknown
|
||||||
hardcode_into_libs=no
|
hardcode_into_libs=no
|
||||||
|
|
||||||
@@ -10206,7 +10206,7 @@ rm -f core conftest.err conftest.$ac_obj
|
@@ -10411,7 +10411,7 @@ fi
|
||||||
# Append ld.so.conf contents to the search path
|
# Append ld.so.conf contents to the search path
|
||||||
if test -f /etc/ld.so.conf; then
|
if test -f /etc/ld.so.conf; then
|
||||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||||
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
||||||
fi
|
fi
|
11
gnutls.spec
11
gnutls.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A TLS protocol implementation
|
Summary: A TLS protocol implementation
|
||||||
Name: gnutls
|
Name: gnutls
|
||||||
Version: 2.10.1
|
Version: 2.10.2
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
|
# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
|
||||||
License: GPLv3+ and LGPLv2+
|
License: GPLv3+ and LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -15,13 +15,12 @@ URL: http://www.gnutls.org/
|
|||||||
# XXX patent tainted SRP code removed.
|
# XXX patent tainted SRP code removed.
|
||||||
Source0: %{name}-%{version}-nosrp.tar.bz2
|
Source0: %{name}-%{version}-nosrp.tar.bz2
|
||||||
Source1: libgnutls-config
|
Source1: libgnutls-config
|
||||||
Patch1: gnutls-2.8.5-rpath.patch
|
Patch1: gnutls-2.10.2-rpath.patch
|
||||||
Patch2: gnutls-2.8.6-link-libgcrypt.patch
|
Patch2: gnutls-2.8.6-link-libgcrypt.patch
|
||||||
# Remove nonexisting references from texinfo file
|
# Remove nonexisting references from texinfo file
|
||||||
Patch3: gnutls-2.10.1-nosrp.patch
|
Patch3: gnutls-2.10.1-nosrp.patch
|
||||||
# Backport from upstream git
|
# Backport from upstream git
|
||||||
Patch4: gnutls-2.10.1-handshake-errors.patch
|
Patch4: gnutls-2.10.1-handshake-errors.patch
|
||||||
Patch5: gnutls-2.10.1-imed-ret.patch
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Requires: libgcrypt >= 1.2.2
|
Requires: libgcrypt >= 1.2.2
|
||||||
@ -78,7 +77,6 @@ This package contains Guile bindings for the library.
|
|||||||
%patch2 -p1 -b .link
|
%patch2 -p1 -b .link
|
||||||
%patch3 -p1 -b .nosrp
|
%patch3 -p1 -b .nosrp
|
||||||
%patch4 -p1 -b .errors
|
%patch4 -p1 -b .errors
|
||||||
%patch5 -p1 -b .imed-ret
|
|
||||||
|
|
||||||
for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
|
for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
|
||||||
touch lib/$i
|
touch lib/$i
|
||||||
@ -162,6 +160,9 @@ fi
|
|||||||
%{_datadir}/guile/site/gnutls.scm
|
%{_datadir}/guile/site/gnutls.scm
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 30 2010 Tomas Mraz <tmraz@redhat.com> 2.10.2-1
|
||||||
|
- new upstream version
|
||||||
|
|
||||||
* Wed Sep 29 2010 jkeating - 2.10.1-4
|
* Wed Sep 29 2010 jkeating - 2.10.1-4
|
||||||
- Rebuilt for gcc bug 634757
|
- Rebuilt for gcc bug 634757
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user