updated to 3.4.1
This commit is contained in:
parent
dc191727a1
commit
a651ee8bf3
1
.gitignore
vendored
1
.gitignore
vendored
@ -50,3 +50,4 @@ gnutls-2.10.1-nosrp.tar.bz2
|
|||||||
/gnutls-3.3.12-hobbled.tar.xz
|
/gnutls-3.3.12-hobbled.tar.xz
|
||||||
/gnutls-3.3.13-hobbled.tar.xz
|
/gnutls-3.3.13-hobbled.tar.xz
|
||||||
/gnutls-3.3.14-hobbled.tar.xz
|
/gnutls-3.3.14-hobbled.tar.xz
|
||||||
|
/gnutls-3.4.1-hobbled.tar.xz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff --git a/tests/mini-loss-time.c b/tests/mini-loss-time.c
|
|
||||||
index 6a10606..e76ff05 100644
|
|
||||||
--- a/tests/mini-loss-time.c
|
|
||||||
+++ b/tests/mini-loss-time.c
|
|
||||||
@@ -287,6 +287,7 @@ void doit(void)
|
|
||||||
time_t tstart, tstop;
|
|
||||||
|
|
||||||
signal(SIGCHLD, ch_handler);
|
|
||||||
+ signal(SIGPIPE, SIG_IGN);
|
|
||||||
|
|
||||||
tstart = time(0);
|
|
||||||
start(2, -1);
|
|
11
gnutls.spec
11
gnutls.spec
@ -2,8 +2,8 @@
|
|||||||
%bcond_without guile
|
%bcond_without guile
|
||||||
Summary: A TLS protocol implementation
|
Summary: A TLS protocol implementation
|
||||||
Name: gnutls
|
Name: gnutls
|
||||||
Version: 3.3.14
|
Version: 3.4.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
# The libraries are LGPLv2.1+, utilities are GPLv3+
|
# The libraries are LGPLv2.1+, utilities are GPLv3+
|
||||||
License: GPLv3+ and LGPLv2+
|
License: GPLv3+ and LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -11,7 +11,7 @@ BuildRequires: p11-kit-devel >= 0.21.3, gettext
|
|||||||
BuildRequires: zlib-devel, readline-devel, libtasn1-devel >= 4.3
|
BuildRequires: zlib-devel, readline-devel, libtasn1-devel >= 4.3
|
||||||
BuildRequires: libtool, automake, autoconf, texinfo
|
BuildRequires: libtool, automake, autoconf, texinfo
|
||||||
BuildRequires: autogen-libopts-devel >= 5.18 autogen
|
BuildRequires: autogen-libopts-devel >= 5.18 autogen
|
||||||
BuildRequires: nettle-devel >= 2.7.1
|
BuildRequires: nettle-devel >= 3.1.1
|
||||||
BuildRequires: trousers-devel >= 0.3.11.2
|
BuildRequires: trousers-devel >= 0.3.11.2
|
||||||
BuildRequires: libidn-devel
|
BuildRequires: libidn-devel
|
||||||
BuildRequires: gperf
|
BuildRequires: gperf
|
||||||
@ -35,7 +35,6 @@ Source2: hobble-gnutls
|
|||||||
Patch1: gnutls-3.2.7-rpath.patch
|
Patch1: gnutls-3.2.7-rpath.patch
|
||||||
Patch3: gnutls-3.1.11-nosrp.patch
|
Patch3: gnutls-3.1.11-nosrp.patch
|
||||||
Patch4: gnutls-3.3.6-default-policy.patch
|
Patch4: gnutls-3.3.6-default-policy.patch
|
||||||
Patch5: gnutls-3.3.14-sigpipe.patch
|
|
||||||
|
|
||||||
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
||||||
Provides: bundled(gnulib) = 20130424
|
Provides: bundled(gnulib) = 20130424
|
||||||
@ -138,7 +137,6 @@ This package contains Guile bindings for the library.
|
|||||||
%patch1 -p1 -b .rpath
|
%patch1 -p1 -b .rpath
|
||||||
%patch3 -p1 -b .nosrp
|
%patch3 -p1 -b .nosrp
|
||||||
%patch4 -p1 -b .default-policy
|
%patch4 -p1 -b .default-policy
|
||||||
%patch5 -p1 -b .sigpipe
|
|
||||||
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
||||||
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
||||||
rm -f lib/minitasn1/*.c lib/minitasn1/*.h
|
rm -f lib/minitasn1/*.c lib/minitasn1/*.h
|
||||||
@ -274,6 +272,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 4 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> 3.4.1-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 3.3.14-2
|
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 3.3.14-2
|
||||||
- Rebuilt for GCC 5 C++11 ABI change
|
- Rebuilt for GCC 5 C++11 ABI change
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user