new upstream version
This commit is contained in:
parent
78e3636e8d
commit
90d6dcb824
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@ gnutls-2.10.1-nosrp.tar.bz2
|
||||
/gnutls-2.12.3-nosrp.tar.bz2
|
||||
/gnutls-2.12.4-nosrp.tar.bz2
|
||||
/gnutls-2.12.7-nosrp.tar.bz2
|
||||
/gnutls-2.12.8-nosrp.tar.bz2
|
||||
|
@ -1,147 +0,0 @@
|
||||
diff -up gnutls-2.12.7/lib/gcrypt/pk.c.mpi gnutls-2.12.7/lib/gcrypt/pk.c
|
||||
--- gnutls-2.12.7/lib/gcrypt/pk.c.mpi 2011-04-08 02:30:44.000000000 +0200
|
||||
+++ gnutls-2.12.7/lib/gcrypt/pk.c 2011-07-25 14:21:43.000000000 +0200
|
||||
@@ -112,7 +112,7 @@ _wrap_gcry_pk_encrypt (gnutls_pk_algorit
|
||||
goto cleanup;
|
||||
}
|
||||
|
||||
- res = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ res = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
gcry_sexp_release (list);
|
||||
if (res == NULL)
|
||||
{
|
||||
@@ -202,7 +202,7 @@ _wrap_gcry_pk_decrypt (gnutls_pk_algorit
|
||||
goto cleanup;
|
||||
}
|
||||
|
||||
- res = gcry_sexp_nth_mpi (s_plain, 0, 0);
|
||||
+ res = gcry_sexp_nth_mpi (s_plain, 0, GCRYMPI_FMT_USG);
|
||||
if (res == NULL)
|
||||
{
|
||||
gnutls_assert ();
|
||||
@@ -327,7 +327,7 @@ _wrap_gcry_pk_sign (gnutls_pk_algorithm_
|
||||
goto cleanup;
|
||||
}
|
||||
|
||||
- res[0] = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ res[0] = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
gcry_sexp_release (list);
|
||||
|
||||
list = gcry_sexp_find_token (s_sig, "s", 0);
|
||||
@@ -338,7 +338,7 @@ _wrap_gcry_pk_sign (gnutls_pk_algorithm_
|
||||
goto cleanup;
|
||||
}
|
||||
|
||||
- res[1] = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ res[1] = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
gcry_sexp_release (list);
|
||||
|
||||
ret = _gnutls_encode_ber_rs (signature, res[0], res[1]);
|
||||
@@ -360,7 +360,7 @@ _wrap_gcry_pk_sign (gnutls_pk_algorithm_
|
||||
goto cleanup;
|
||||
}
|
||||
|
||||
- res[0] = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ res[0] = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
gcry_sexp_release (list);
|
||||
|
||||
ret = _gnutls_mpi_dprint (res[0], signature);
|
||||
@@ -559,7 +559,7 @@ _dsa_generate_params (bigint_t * resarr,
|
||||
return GNUTLS_E_INTERNAL_ERROR;
|
||||
}
|
||||
|
||||
- resarr[0] = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ resarr[0] = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
gcry_sexp_release (list);
|
||||
|
||||
list = gcry_sexp_find_token (key, "q", 0);
|
||||
@@ -570,7 +570,7 @@ _dsa_generate_params (bigint_t * resarr,
|
||||
return GNUTLS_E_INTERNAL_ERROR;
|
||||
}
|
||||
|
||||
- resarr[1] = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ resarr[1] = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
gcry_sexp_release (list);
|
||||
|
||||
list = gcry_sexp_find_token (key, "g", 0);
|
||||
@@ -581,7 +581,7 @@ _dsa_generate_params (bigint_t * resarr,
|
||||
return GNUTLS_E_INTERNAL_ERROR;
|
||||
}
|
||||
|
||||
- resarr[2] = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ resarr[2] = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
gcry_sexp_release (list);
|
||||
|
||||
list = gcry_sexp_find_token (key, "y", 0);
|
||||
@@ -592,7 +592,7 @@ _dsa_generate_params (bigint_t * resarr,
|
||||
return GNUTLS_E_INTERNAL_ERROR;
|
||||
}
|
||||
|
||||
- resarr[3] = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ resarr[3] = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
gcry_sexp_release (list);
|
||||
|
||||
|
||||
@@ -604,7 +604,7 @@ _dsa_generate_params (bigint_t * resarr,
|
||||
return GNUTLS_E_INTERNAL_ERROR;
|
||||
}
|
||||
|
||||
- resarr[4] = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ resarr[4] = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
|
||||
gcry_sexp_release (list);
|
||||
gcry_sexp_release (key);
|
||||
@@ -660,7 +660,7 @@ _rsa_generate_params (bigint_t * resarr,
|
||||
return GNUTLS_E_INTERNAL_ERROR;
|
||||
}
|
||||
|
||||
- resarr[0] = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ resarr[0] = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
gcry_sexp_release (list);
|
||||
|
||||
list = gcry_sexp_find_token (key, "e", 0);
|
||||
@@ -671,7 +671,7 @@ _rsa_generate_params (bigint_t * resarr,
|
||||
return GNUTLS_E_INTERNAL_ERROR;
|
||||
}
|
||||
|
||||
- resarr[1] = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ resarr[1] = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
gcry_sexp_release (list);
|
||||
|
||||
list = gcry_sexp_find_token (key, "d", 0);
|
||||
@@ -682,7 +682,7 @@ _rsa_generate_params (bigint_t * resarr,
|
||||
return GNUTLS_E_INTERNAL_ERROR;
|
||||
}
|
||||
|
||||
- resarr[2] = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ resarr[2] = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
gcry_sexp_release (list);
|
||||
|
||||
list = gcry_sexp_find_token (key, "p", 0);
|
||||
@@ -693,7 +693,7 @@ _rsa_generate_params (bigint_t * resarr,
|
||||
return GNUTLS_E_INTERNAL_ERROR;
|
||||
}
|
||||
|
||||
- resarr[3] = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ resarr[3] = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
gcry_sexp_release (list);
|
||||
|
||||
|
||||
@@ -705,7 +705,7 @@ _rsa_generate_params (bigint_t * resarr,
|
||||
return GNUTLS_E_INTERNAL_ERROR;
|
||||
}
|
||||
|
||||
- resarr[4] = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ resarr[4] = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
gcry_sexp_release (list);
|
||||
|
||||
|
||||
@@ -717,7 +717,7 @@ _rsa_generate_params (bigint_t * resarr,
|
||||
return GNUTLS_E_INTERNAL_ERROR;
|
||||
}
|
||||
|
||||
- resarr[5] = gcry_sexp_nth_mpi (list, 1, 0);
|
||||
+ resarr[5] = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
|
||||
|
||||
gcry_sexp_release (list);
|
||||
gcry_sexp_release (key);
|
12
gnutls.spec
12
gnutls.spec
@ -1,11 +1,11 @@
|
||||
Summary: A TLS protocol implementation
|
||||
Name: gnutls
|
||||
Version: 2.12.7
|
||||
Release: 2%{?dist}
|
||||
Version: 2.12.8
|
||||
Release: 1%{?dist}
|
||||
# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
|
||||
License: GPLv3+ and LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
BuildRequires: libgcrypt-devel >= 1.2.2, gettext
|
||||
BuildRequires: libgcrypt-devel >= 1.2.2, p11-kit-devel, gettext
|
||||
BuildRequires: zlib-devel, readline-devel, libtasn1-devel
|
||||
BuildRequires: lzo-devel, libtool, automake, autoconf
|
||||
BuildRequires: guile-devel
|
||||
@ -21,8 +21,6 @@ Patch2: gnutls-2.8.6-link-libgcrypt.patch
|
||||
Patch3: gnutls-2.12.2-nosrp.patch
|
||||
# Skip tests that are expected to fail on libgcrypt build
|
||||
Patch4: gnutls-2.12.7-dsa-skiptests.patch
|
||||
# Patch incorrect calls to libgcrypt (patch by Andreas Metzler)
|
||||
Patch5: gnutls-2.12.7-libgcrypt-mpi.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: libgcrypt >= 1.2.2
|
||||
@ -90,7 +88,6 @@ This package contains Guile bindings for the library.
|
||||
%patch2 -p1 -b .link
|
||||
%patch3 -p1 -b .nosrp
|
||||
%patch4 -p1 -b .skiptests
|
||||
%patch5 -p1 -b .mpi
|
||||
|
||||
for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
|
||||
touch lib/$i
|
||||
@ -187,6 +184,9 @@ fi
|
||||
%{_datadir}/guile/site/gnutls.scm
|
||||
|
||||
%changelog
|
||||
* Tue Aug 16 2011 Tomas Mraz <tmraz@redhat.com> 2.12.8-1
|
||||
- new upstream version
|
||||
|
||||
* Mon Jul 25 2011 Tomas Mraz <tmraz@redhat.com> 2.12.7-2
|
||||
- fix problem when using new libgcrypt
|
||||
- split libgnutlsxx to a subpackage (#455146)
|
||||
|
Loading…
Reference in New Issue
Block a user