added patch to prevent test failure due to SIGPIPE
This commit is contained in:
parent
7e98ff1589
commit
7cdc3ae64b
12
gnutls-3.3.14-sigpipe.patch
Normal file
12
gnutls-3.3.14-sigpipe.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff --git a/tests/mini-loss-time.c b/tests/mini-loss-time.c
|
||||||
|
index 6a10606..e76ff05 100644
|
||||||
|
--- a/tests/mini-loss-time.c
|
||||||
|
+++ b/tests/mini-loss-time.c
|
||||||
|
@@ -287,6 +287,7 @@ void doit(void)
|
||||||
|
time_t tstart, tstop;
|
||||||
|
|
||||||
|
signal(SIGCHLD, ch_handler);
|
||||||
|
+ signal(SIGPIPE, SIG_IGN);
|
||||||
|
|
||||||
|
tstart = time(0);
|
||||||
|
start(2, -1);
|
@ -35,6 +35,7 @@ Source2: hobble-gnutls
|
|||||||
Patch1: gnutls-3.2.7-rpath.patch
|
Patch1: gnutls-3.2.7-rpath.patch
|
||||||
Patch3: gnutls-3.1.11-nosrp.patch
|
Patch3: gnutls-3.1.11-nosrp.patch
|
||||||
Patch4: gnutls-3.3.6-default-policy.patch
|
Patch4: gnutls-3.3.6-default-policy.patch
|
||||||
|
Patch5: gnutls-3.3.14-sigpipe.patch
|
||||||
|
|
||||||
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
||||||
Provides: bundled(gnulib) = 20130424
|
Provides: bundled(gnulib) = 20130424
|
||||||
@ -137,6 +138,7 @@ This package contains Guile bindings for the library.
|
|||||||
%patch1 -p1 -b .rpath
|
%patch1 -p1 -b .rpath
|
||||||
%patch3 -p1 -b .nosrp
|
%patch3 -p1 -b .nosrp
|
||||||
%patch4 -p1 -b .default-policy
|
%patch4 -p1 -b .default-policy
|
||||||
|
%patch5 -p1 -b .sigpipe
|
||||||
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
||||||
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
||||||
rm -f lib/minitasn1/*.c lib/minitasn1/*.h
|
rm -f lib/minitasn1/*.c lib/minitasn1/*.h
|
||||||
|
Loading…
Reference in New Issue
Block a user