updated to 3.4.6
This commit is contained in:
parent
cd47026216
commit
7cbe63834e
1
.gitignore
vendored
1
.gitignore
vendored
@ -55,3 +55,4 @@ gnutls-2.10.1-nosrp.tar.bz2
|
|||||||
/gnutls-3.4.3-hobbled.tar.xz
|
/gnutls-3.4.3-hobbled.tar.xz
|
||||||
/gnutls-3.4.4-hobbled.tar.xz
|
/gnutls-3.4.4-hobbled.tar.xz
|
||||||
/gnutls-3.4.5-hobbled.tar.xz
|
/gnutls-3.4.5-hobbled.tar.xz
|
||||||
|
/gnutls-3.4.6-hobbled.tar.xz
|
||||||
|
@ -1,27 +0,0 @@
|
|||||||
From 1b93f45fbd144cdf7095102bf6927c97019cf2e7 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Nikos Mavrogiannopoulos <nmav@redhat.com>
|
|
||||||
Date: Tue, 20 Oct 2015 09:03:25 +0200
|
|
||||||
Subject: [PATCH] ext master secret: extension is marked as mandatory
|
|
||||||
|
|
||||||
This forces the extension to be sent even where resuming sessions.
|
|
||||||
Resolves #45
|
|
||||||
---
|
|
||||||
lib/ext/ext_master_secret.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/lib/ext/ext_master_secret.c b/lib/ext/ext_master_secret.c
|
|
||||||
index 9610f12..0d90347 100644
|
|
||||||
--- a/lib/ext/ext_master_secret.c
|
|
||||||
+++ b/lib/ext/ext_master_secret.c
|
|
||||||
@@ -38,7 +38,7 @@ static int _gnutls_ext_master_secret_send_params(gnutls_session_t session,
|
|
||||||
extension_entry_st ext_mod_ext_master_secret = {
|
|
||||||
.name = "EXT MASTER SECRET",
|
|
||||||
.type = GNUTLS_EXTENSION_EXT_MASTER_SECRET,
|
|
||||||
- .parse_type = GNUTLS_EXT_TLS,
|
|
||||||
+ .parse_type = GNUTLS_EXT_MANDATORY,
|
|
||||||
|
|
||||||
.recv_func = _gnutls_ext_master_secret_recv_params,
|
|
||||||
.send_func = _gnutls_ext_master_secret_send_params,
|
|
||||||
--
|
|
||||||
2.5.0
|
|
||||||
|
|
13
gnutls.spec
13
gnutls.spec
@ -2,8 +2,8 @@
|
|||||||
%bcond_without guile
|
%bcond_without guile
|
||||||
Summary: A TLS protocol implementation
|
Summary: A TLS protocol implementation
|
||||||
Name: gnutls
|
Name: gnutls
|
||||||
Version: 3.4.5
|
Version: 3.4.6
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
# The libraries are LGPLv2.1+, utilities are GPLv3+
|
# The libraries are LGPLv2.1+, utilities are GPLv3+
|
||||||
License: GPLv3+ and LGPLv2+
|
License: GPLv3+ and LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -37,10 +37,6 @@ Patch1: gnutls-3.2.7-rpath.patch
|
|||||||
Patch3: gnutls-3.1.11-nosrp.patch
|
Patch3: gnutls-3.1.11-nosrp.patch
|
||||||
Patch4: gnutls-3.4.1-default-policy.patch
|
Patch4: gnutls-3.4.1-default-policy.patch
|
||||||
Patch5: gnutls-3.4.2-no-now-guile.patch
|
Patch5: gnutls-3.4.2-no-now-guile.patch
|
||||||
# RHBZ #1273102
|
|
||||||
# https://gitlab.com/gnutls/gnutls/issues/45
|
|
||||||
# https://gitlab.com/gnutls/gnutls/commit/1b93f45fbd144cdf7095102bf6927c97019cf2e7
|
|
||||||
Patch6: 0001-ext-master-secret-extension-is-marked-as-mandatory.patch
|
|
||||||
|
|
||||||
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
||||||
Provides: bundled(gnulib) = 20130424
|
Provides: bundled(gnulib) = 20130424
|
||||||
@ -144,7 +140,6 @@ This package contains Guile bindings for the library.
|
|||||||
%patch3 -p1 -b .nosrp
|
%patch3 -p1 -b .nosrp
|
||||||
%patch4 -p1 -b .default-policy
|
%patch4 -p1 -b .default-policy
|
||||||
%patch5 -p1 -b .guile
|
%patch5 -p1 -b .guile
|
||||||
%patch6 -p1 -b .master-secret
|
|
||||||
|
|
||||||
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
||||||
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
||||||
@ -282,6 +277,10 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 21 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> 3.4.6-1
|
||||||
|
- New upstream release (#1273672)
|
||||||
|
- Enhances p11tool to write CKA_ISSUER and CKA_SERIAL_NUMBER (#1272178)
|
||||||
|
|
||||||
* Tue Oct 20 2015 Adam Williamson <awilliam@redhat.com> - 3.4.5-2
|
* Tue Oct 20 2015 Adam Williamson <awilliam@redhat.com> - 3.4.5-2
|
||||||
- fix interaction with Chrome 45+ (master secret extension) (#1273102)
|
- fix interaction with Chrome 45+ (master secret extension) (#1273102)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user