updated to 3.5.2
This commit is contained in:
parent
1ef29d44b1
commit
6d461273ee
1
.gitignore
vendored
1
.gitignore
vendored
@ -64,3 +64,4 @@ gnutls-2.10.1-nosrp.tar.bz2
|
|||||||
/gnutls-3.4.12-hobbled.tar.xz
|
/gnutls-3.4.12-hobbled.tar.xz
|
||||||
/gnutls-3.4.13-hobbled.tar.xz
|
/gnutls-3.4.13-hobbled.tar.xz
|
||||||
/gnutls-3.5.1-hobbled.tar.xz
|
/gnutls-3.5.1-hobbled.tar.xz
|
||||||
|
/gnutls-3.5.2-hobbled.tar.xz
|
||||||
|
@ -1,24 +0,0 @@
|
|||||||
diff --git a/tests/srpbase64.c b/tests/srpbase64.c
|
|
||||||
index 80c1752..cb26e8b 100644
|
|
||||||
--- a/tests/srpbase64.c
|
|
||||||
+++ b/tests/srpbase64.c
|
|
||||||
@@ -34,6 +34,8 @@
|
|
||||||
|
|
||||||
#include "utils.h"
|
|
||||||
|
|
||||||
+#ifdef ENABLE_SRP
|
|
||||||
+
|
|
||||||
static void encode(const char *test_name, const gnutls_datum_t *raw, const char *expected)
|
|
||||||
{
|
|
||||||
int ret;
|
|
||||||
@@ -175,3 +177,10 @@ void doit(void)
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
+#else
|
|
||||||
+
|
|
||||||
+void doit(void)
|
|
||||||
+{
|
|
||||||
+ exit(77);
|
|
||||||
+}
|
|
||||||
+#endif
|
|
@ -2,7 +2,7 @@
|
|||||||
%bcond_without guile
|
%bcond_without guile
|
||||||
Summary: A TLS protocol implementation
|
Summary: A TLS protocol implementation
|
||||||
Name: gnutls
|
Name: gnutls
|
||||||
Version: 3.5.1
|
Version: 3.5.2
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
# The libraries are LGPLv2.1+, utilities are GPLv3+
|
# The libraries are LGPLv2.1+, utilities are GPLv3+
|
||||||
License: GPLv3+ and LGPLv2+
|
License: GPLv3+ and LGPLv2+
|
||||||
@ -37,7 +37,6 @@ Patch1: gnutls-3.2.7-rpath.patch
|
|||||||
Patch3: gnutls-3.1.11-nosrp.patch
|
Patch3: gnutls-3.1.11-nosrp.patch
|
||||||
Patch4: gnutls-3.5.1-default-policy.patch
|
Patch4: gnutls-3.5.1-default-policy.patch
|
||||||
Patch5: gnutls-3.4.2-no-now-guile.patch
|
Patch5: gnutls-3.4.2-no-now-guile.patch
|
||||||
Patch6: gnutls-3.5.1-srp-tests.patch
|
|
||||||
|
|
||||||
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
||||||
Provides: bundled(gnulib) = 20130424
|
Provides: bundled(gnulib) = 20130424
|
||||||
@ -141,7 +140,6 @@ This package contains Guile bindings for the library.
|
|||||||
%patch3 -p1 -b .nosrp
|
%patch3 -p1 -b .nosrp
|
||||||
%patch4 -p1 -b .default-policy
|
%patch4 -p1 -b .default-policy
|
||||||
%patch5 -p1 -b .guile
|
%patch5 -p1 -b .guile
|
||||||
%patch6 -p1 -b .srp-tests
|
|
||||||
|
|
||||||
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
||||||
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
||||||
@ -274,6 +272,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 6 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> 3.5.2-1
|
||||||
|
- New upstream release
|
||||||
|
|
||||||
* Wed Jun 15 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> 3.5.1-1
|
* Wed Jun 15 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> 3.5.1-1
|
||||||
- New upstream release
|
- New upstream release
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user