applied fix for issue in get-issuer
Resolves: rhbz#1155901
This commit is contained in:
parent
aa6e9f93a4
commit
6306f551d4
12
gnutls-3.3.9-get-issuer.patch
Normal file
12
gnutls-3.3.9-get-issuer.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff --git a/lib/x509/verify-high.c b/lib/x509/verify-high.c
|
||||||
|
index d570f2e..784aa80 100644
|
||||||
|
--- a/lib/x509/verify-high.c
|
||||||
|
+++ b/lib/x509/verify-high.c
|
||||||
|
@@ -766,6 +766,7 @@ int gnutls_x509_trust_list_get_issuer(gnutls_x509_trust_list_t list,
|
||||||
|
gnutls_x509_crt_deinit(crt);
|
||||||
|
return gnutls_assert_val(ret);
|
||||||
|
}
|
||||||
|
+ *issuer = crt;
|
||||||
|
return ret;
|
||||||
|
}
|
||||||
|
}
|
@ -3,7 +3,7 @@
|
|||||||
Summary: A TLS protocol implementation
|
Summary: A TLS protocol implementation
|
||||||
Name: gnutls
|
Name: gnutls
|
||||||
Version: 3.3.9
|
Version: 3.3.9
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
# The libraries are LGPLv2.1+, utilities are GPLv3+
|
# The libraries are LGPLv2.1+, utilities are GPLv3+
|
||||||
License: GPLv3+ and LGPLv2+
|
License: GPLv3+ and LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -34,6 +34,7 @@ Source2: hobble-gnutls
|
|||||||
Patch1: gnutls-3.2.7-rpath.patch
|
Patch1: gnutls-3.2.7-rpath.patch
|
||||||
Patch3: gnutls-3.1.11-nosrp.patch
|
Patch3: gnutls-3.1.11-nosrp.patch
|
||||||
Patch4: gnutls-3.3.6-default-policy.patch
|
Patch4: gnutls-3.3.6-default-policy.patch
|
||||||
|
Patch5: gnutls-3.3.9-get-issuer.patch
|
||||||
|
|
||||||
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
||||||
Provides: bundled(gnulib) = 20130424
|
Provides: bundled(gnulib) = 20130424
|
||||||
@ -136,6 +137,7 @@ This package contains Guile bindings for the library.
|
|||||||
%patch1 -p1 -b .rpath
|
%patch1 -p1 -b .rpath
|
||||||
%patch3 -p1 -b .nosrp
|
%patch3 -p1 -b .nosrp
|
||||||
%patch4 -p1 -b .default-policy
|
%patch4 -p1 -b .default-policy
|
||||||
|
%patch5 -p1 -b .get-issuer
|
||||||
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
||||||
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
||||||
rm -f lib/minitasn1/*.c lib/minitasn1/*.h
|
rm -f lib/minitasn1/*.c lib/minitasn1/*.h
|
||||||
@ -272,6 +274,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 23 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> 3.3.9-2
|
||||||
|
- applied fix for issue in get-issuer (#1155901)
|
||||||
|
|
||||||
* Mon Oct 13 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> 3.3.9-1
|
* Mon Oct 13 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> 3.3.9-1
|
||||||
- new upstream release
|
- new upstream release
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user