Remove patches no longer needed in 3.8.2
Also use XFAIL_TESTS envvar to skip ktls_keyupdate.sh, instead of patching the source code. Signed-off-by: Daiki Ueno <dueno@redhat.com>
This commit is contained in:
parent
d7d09eb023
commit
5e97cebf83
@ -1,13 +0,0 @@
|
||||
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
||||
index 2872cb1aa..247dfd3d8 100644
|
||||
--- a/tests/Makefile.am
|
||||
+++ b/tests/Makefile.am
|
||||
@@ -504,8 +504,6 @@ endif
|
||||
if ENABLE_KTLS
|
||||
indirect_tests += gnutls_ktls
|
||||
dist_check_SCRIPTS += ktls.sh
|
||||
-indirect_tests += ktls_keyupdate
|
||||
-dist_check_SCRIPTS += ktls_keyupdate.sh
|
||||
endif
|
||||
|
||||
if !WINDOWS
|
@ -1,12 +0,0 @@
|
||||
diff --git a/tests/gnutls_ktls.c b/tests/gnutls_ktls.c
|
||||
index 919270778..778a2f94a 100644
|
||||
--- a/tests/gnutls_ktls.c
|
||||
+++ b/tests/gnutls_ktls.c
|
||||
@@ -351,7 +351,6 @@ void doit(void)
|
||||
run("NORMAL:-VERS-ALL:+VERS-TLS1.2:-CIPHER-ALL:+AES-128-GCM");
|
||||
run("NORMAL:-VERS-ALL:+VERS-TLS1.2:-CIPHER-ALL:+AES-256-GCM");
|
||||
run("NORMAL:-VERS-ALL:+VERS-TLS1.2:-CIPHER-ALL:+AES-128-CCM");
|
||||
- run("NORMAL:-VERS-ALL:+VERS-TLS1.2:-CIPHER-ALL:+CHACHA20-POLY1305");
|
||||
run("NORMAL:-VERS-ALL:+VERS-TLS1.3:-CIPHER-ALL:+AES-128-GCM");
|
||||
run("NORMAL:-VERS-ALL:+VERS-TLS1.3:-CIPHER-ALL:+AES-256-GCM");
|
||||
run("NORMAL:-VERS-ALL:+VERS-TLS1.3:-CIPHER-ALL:+AES-128-CCM");
|
@ -16,12 +16,6 @@ Version: 3.8.1
|
||||
Release: %{?autorelease}%{!?autorelease:1%{?dist}}
|
||||
Patch: gnutls-3.2.7-rpath.patch
|
||||
|
||||
# Delete only after the kernel has been patched for thested systems
|
||||
Patch: gnutls-3.7.8-ktls_disable_keyupdate_test.patch
|
||||
|
||||
# follow https://gitlab.com/gnutls/gnutls/-/issues/1443
|
||||
Patch: gnutls-3.7.8-ktls_skip_tls12_chachapoly_test.patch
|
||||
|
||||
%bcond_without bootstrap
|
||||
%bcond_without dane
|
||||
%bcond_without fips
|
||||
@ -374,7 +368,8 @@ rm -f $RPM_BUILD_ROOT%{mingw64_libdir}/ncrypt.dll*
|
||||
%if %{with tests}
|
||||
pushd native_build
|
||||
|
||||
xfail_tests=
|
||||
# KeyUpdate is not yet supported in the kernel.
|
||||
xfail_tests=ktls_keyupdate.sh
|
||||
|
||||
# The ktls.sh test currently only supports kernel 5.11+. This needs to
|
||||
# be checked at run time, as the koji builder might be using a different
|
||||
|
Loading…
Reference in New Issue
Block a user