- upgrade to a new upstream version
This commit is contained in:
parent
428c45146b
commit
5cdd3d4a10
@ -1 +1 @@
|
|||||||
gnutls-2.8.5-nosrp.tar.bz2
|
gnutls-2.8.6-nosrp.tar.bz2
|
||||||
|
@ -1,80 +0,0 @@
|
|||||||
diff -up gnutls-2.8.5/doc/examples/Makefile.am.ImplicitDSOLinking_libgcrypt gnutls-2.8.5/doc/examples/Makefile.am
|
|
||||||
--- gnutls-2.8.5/doc/examples/Makefile.am.ImplicitDSOLinking_libgcrypt 2009-06-02 13:59:32.000000000 -0500
|
|
||||||
+++ gnutls-2.8.5/doc/examples/Makefile.am 2010-02-15 19:18:55.722180984 -0600
|
|
||||||
@@ -30,7 +30,7 @@ LDADD = libexamples.la \
|
|
||||||
../../lib/libgnutls.la \
|
|
||||||
../../libextra/libgnutls-extra.la \
|
|
||||||
../../gl/libgnu.la \
|
|
||||||
- $(LIBSOCKET)
|
|
||||||
+ $(LTLIBGCRYPT) $(LIBSOCKET)
|
|
||||||
|
|
||||||
CXX_LDADD = $(LDADD) \
|
|
||||||
../../lib/libgnutlsxx.la
|
|
||||||
diff -up gnutls-2.8.5/doc/examples/Makefile.in.ImplicitDSOLinking_libgcrypt gnutls-2.8.5/doc/examples/Makefile.in
|
|
||||||
--- gnutls-2.8.5/doc/examples/Makefile.in.ImplicitDSOLinking_libgcrypt 2009-11-02 04:36:00.000000000 -0600
|
|
||||||
+++ gnutls-2.8.5/doc/examples/Makefile.in 2010-02-15 19:19:46.900440435 -0600
|
|
||||||
@@ -810,7 +810,7 @@ LDADD = libexamples.la \
|
|
||||||
../../lib/libgnutls.la \
|
|
||||||
../../libextra/libgnutls-extra.la \
|
|
||||||
../../gl/libgnu.la \
|
|
||||||
- $(LIBSOCKET)
|
|
||||||
+ $(LTLIBGCRYPT) $(LIBSOCKET)
|
|
||||||
|
|
||||||
CXX_LDADD = $(LDADD) \
|
|
||||||
../../lib/libgnutlsxx.la
|
|
||||||
diff -up gnutls-2.8.5/src/Makefile.am.ImplicitDSOLinking_libgcrypt gnutls-2.8.5/src/Makefile.am
|
|
||||||
--- gnutls-2.8.5/src/Makefile.am.ImplicitDSOLinking_libgcrypt 2009-06-02 13:59:32.000000000 -0500
|
|
||||||
+++ gnutls-2.8.5/src/Makefile.am 2010-02-15 19:22:31.674183953 -0600
|
|
||||||
@@ -40,7 +40,7 @@ noinst_LTLIBRARIES =
|
|
||||||
|
|
||||||
gnutls_serv_SOURCES = list.h serv.c common.h common.c certtool-common.h
|
|
||||||
gnutls_serv_LDADD = ../lib/libgnutls.la ../libextra/libgnutls-extra.la
|
|
||||||
-gnutls_serv_LDADD += libcmd-serv.la ../gl/libgnu.la $(LIBSOCKET) $(GETADDRINFO_LIB)
|
|
||||||
+gnutls_serv_LDADD += libcmd-serv.la ../gl/libgnu.la $(LTLIBGCRYPT) $(LIBSOCKET) $(GETADDRINFO_LIB)
|
|
||||||
noinst_LTLIBRARIES += libcmd-serv.la
|
|
||||||
libcmd_serv_la_CFLAGS =
|
|
||||||
libcmd_serv_la_SOURCES = serv.gaa serv-gaa.h serv-gaa.c
|
|
||||||
@@ -61,14 +61,14 @@ libcmd_psk_la_SOURCES = psk.gaa psk-gaa.
|
|
||||||
|
|
||||||
gnutls_cli_SOURCES = cli.c common.h common.c
|
|
||||||
gnutls_cli_LDADD = ../lib/libgnutls.la ../libextra/libgnutls-extra.la
|
|
||||||
-gnutls_cli_LDADD += libcmd-cli.la ../gl/libgnu.la $(LIBSOCKET) $(GETADDRINFO_LIB)
|
|
||||||
+gnutls_cli_LDADD += libcmd-cli.la ../gl/libgnu.la $(LTLIBGCRYPT) $(LIBSOCKET) $(GETADDRINFO_LIB)
|
|
||||||
noinst_LTLIBRARIES += libcmd-cli.la
|
|
||||||
libcmd_cli_la_CFLAGS =
|
|
||||||
libcmd_cli_la_SOURCES = cli.gaa cli-gaa.h cli-gaa.c
|
|
||||||
|
|
||||||
gnutls_cli_debug_SOURCES = tls_test.c tests.h tests.c common.h common.c
|
|
||||||
gnutls_cli_debug_LDADD = ../lib/libgnutls.la libcmd-cli-debug.la
|
|
||||||
-gnutls_cli_debug_LDADD += ../gl/libgnu.la $(LIBSOCKET) $(GETADDRINFO_LIB)
|
|
||||||
+gnutls_cli_debug_LDADD += ../gl/libgnu.la $(LTLIBGCRYPT) $(LIBSOCKET) $(GETADDRINFO_LIB)
|
|
||||||
noinst_LTLIBRARIES += libcmd-cli-debug.la
|
|
||||||
libcmd_cli_debug_la_CFLAGS =
|
|
||||||
libcmd_cli_debug_la_SOURCES = tls_test.gaa tls_test-gaa.h tls_test-gaa.c
|
|
||||||
diff -up gnutls-2.8.5/src/Makefile.in.ImplicitDSOLinking_libgcrypt gnutls-2.8.5/src/Makefile.in
|
|
||||||
--- gnutls-2.8.5/src/Makefile.in.ImplicitDSOLinking_libgcrypt 2010-02-15 19:19:46.894442396 -0600
|
|
||||||
+++ gnutls-2.8.5/src/Makefile.in 2010-02-15 19:22:34.146181051 -0600
|
|
||||||
@@ -827,7 +827,7 @@ noinst_LTLIBRARIES = libcmd-serv.la $(am
|
|
||||||
libcmd-certtool.la
|
|
||||||
gnutls_serv_SOURCES = list.h serv.c common.h common.c certtool-common.h
|
|
||||||
gnutls_serv_LDADD = ../lib/libgnutls.la ../libextra/libgnutls-extra.la \
|
|
||||||
- libcmd-serv.la ../gl/libgnu.la $(LIBSOCKET) $(GETADDRINFO_LIB)
|
|
||||||
+ libcmd-serv.la ../gl/libgnu.la $(LTLIBGCRYPT) $(LIBSOCKET) $(GETADDRINFO_LIB)
|
|
||||||
libcmd_serv_la_CFLAGS =
|
|
||||||
libcmd_serv_la_SOURCES = serv.gaa serv-gaa.h serv-gaa.c
|
|
||||||
@ENABLE_SRP_TRUE@srptool_SOURCES = crypt.c
|
|
||||||
@@ -840,12 +840,12 @@ libcmd_psk_la_CFLAGS =
|
|
||||||
libcmd_psk_la_SOURCES = psk.gaa psk-gaa.h psk-gaa.c
|
|
||||||
gnutls_cli_SOURCES = cli.c common.h common.c
|
|
||||||
gnutls_cli_LDADD = ../lib/libgnutls.la ../libextra/libgnutls-extra.la \
|
|
||||||
- libcmd-cli.la ../gl/libgnu.la $(LIBSOCKET) $(GETADDRINFO_LIB)
|
|
||||||
+ libcmd-cli.la ../gl/libgnu.la $(LTLIBGCRYPT) $(LIBSOCKET) $(GETADDRINFO_LIB)
|
|
||||||
libcmd_cli_la_CFLAGS =
|
|
||||||
libcmd_cli_la_SOURCES = cli.gaa cli-gaa.h cli-gaa.c
|
|
||||||
gnutls_cli_debug_SOURCES = tls_test.c tests.h tests.c common.h common.c
|
|
||||||
gnutls_cli_debug_LDADD = ../lib/libgnutls.la libcmd-cli-debug.la \
|
|
||||||
- ../gl/libgnu.la $(LIBSOCKET) $(GETADDRINFO_LIB)
|
|
||||||
+ ../gl/libgnu.la $(LTLIBGCRYPT) $(LIBSOCKET) $(GETADDRINFO_LIB)
|
|
||||||
libcmd_cli_debug_la_CFLAGS =
|
|
||||||
libcmd_cli_debug_la_SOURCES = tls_test.gaa tls_test-gaa.h tls_test-gaa.c
|
|
||||||
certtool_SOURCES = certtool.c prime.c
|
|
10
gnutls.spec
10
gnutls.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A TLS protocol implementation
|
Summary: A TLS protocol implementation
|
||||||
Name: gnutls
|
Name: gnutls
|
||||||
Version: 2.8.5
|
Version: 2.8.6
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
|
# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
|
||||||
License: GPLv3+ and LGPLv2+
|
License: GPLv3+ and LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -16,8 +16,6 @@ URL: http://www.gnutls.org/
|
|||||||
Source0: %{name}-%{version}-nosrp.tar.bz2
|
Source0: %{name}-%{version}-nosrp.tar.bz2
|
||||||
Source1: libgnutls-config
|
Source1: libgnutls-config
|
||||||
Patch1: gnutls-2.8.5-rpath.patch
|
Patch1: gnutls-2.8.5-rpath.patch
|
||||||
# upstreamable patch fixing implicit linking against libgcrypt
|
|
||||||
Patch2: gnutls-2.8.5-ImplicitDSOLinking_libgcrypt.patch
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Requires: libgcrypt >= 1.2.2
|
Requires: libgcrypt >= 1.2.2
|
||||||
@ -71,7 +69,6 @@ This package contains Guile bindings for the library.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .rpath
|
%patch1 -p1 -b .rpath
|
||||||
%patch2 -p1 -b .ImplicitDSOLinking_libgcrypt
|
|
||||||
|
|
||||||
for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
|
for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
|
||||||
touch lib/$i
|
touch lib/$i
|
||||||
@ -155,6 +152,9 @@ fi
|
|||||||
%{_datadir}/guile/site/gnutls.scm
|
%{_datadir}/guile/site/gnutls.scm
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 12 2010 Tomas Mraz <tmraz@redhat.com> 2.8.6-1
|
||||||
|
- upgrade to a new upstream version
|
||||||
|
|
||||||
* Mon Feb 15 2010 Rex Dieter <rdieter@fedoraproject.org> 2.8.5-4
|
* Mon Feb 15 2010 Rex Dieter <rdieter@fedoraproject.org> 2.8.5-4
|
||||||
- FTBFS gnutls-2.8.5-3.fc13: ImplicitDSOLinking (#564624)
|
- FTBFS gnutls-2.8.5-3.fc13: ImplicitDSOLinking (#564624)
|
||||||
|
|
||||||
|
@ -1,4 +1,5 @@
|
|||||||
#!/bin/sh
|
#!/bin/sh
|
||||||
|
set -x
|
||||||
|
|
||||||
rm -f lib/auth_srp_sb64.c lib/auth_srp_passwd.c lib/auth_srp_rsa.c
|
rm -f lib/auth_srp_sb64.c lib/auth_srp_passwd.c lib/auth_srp_rsa.c
|
||||||
rm -f lib/gnutls_srp.c lib/auth_srp.c lib/ext_srp.c
|
rm -f lib/gnutls_srp.c lib/auth_srp.c lib/ext_srp.c
|
||||||
|
Loading…
Reference in New Issue
Block a user