new upstream release

This commit is contained in:
Tomas Mraz 2013-05-13 15:19:29 +02:00
parent 31646fb2fa
commit 58e5b65b4d
4 changed files with 116 additions and 88 deletions

1
.gitignore vendored
View File

@ -23,3 +23,4 @@ gnutls-2.10.1-nosrp.tar.bz2
/gnutls-3.1.8-hobbled.tar.xz /gnutls-3.1.8-hobbled.tar.xz
/gnutls-3.1.9-hobbled.tar.xz /gnutls-3.1.9-hobbled.tar.xz
/gnutls-3.1.10-hobbled.tar.xz /gnutls-3.1.10-hobbled.tar.xz
/gnutls-3.1.11-hobbled.tar.xz

View File

@ -1,6 +1,6 @@
diff -up gnutls-3.1.10/lib/algorithms/kx.c.noecc gnutls-3.1.10/lib/algorithms/kx.c diff -up gnutls-3.1.11/lib/algorithms/kx.c.noecc gnutls-3.1.11/lib/algorithms/kx.c
--- gnutls-3.1.10/lib/algorithms/kx.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/lib/algorithms/kx.c.noecc 2013-04-27 10:04:48.000000000 +0200
+++ gnutls-3.1.10/lib/algorithms/kx.c 2013-03-25 13:42:15.555309960 +0100 +++ gnutls-3.1.11/lib/algorithms/kx.c 2013-05-13 11:08:41.411446861 +0200
@@ -29,9 +29,11 @@ @@ -29,9 +29,11 @@
extern mod_auth_st rsa_auth_struct; extern mod_auth_st rsa_auth_struct;
extern mod_auth_st rsa_export_auth_struct; extern mod_auth_st rsa_export_auth_struct;
@ -13,9 +13,9 @@ diff -up gnutls-3.1.10/lib/algorithms/kx.c.noecc gnutls-3.1.10/lib/algorithms/kx
extern mod_auth_st dhe_dss_auth_struct; extern mod_auth_st dhe_dss_auth_struct;
extern mod_auth_st anon_auth_struct; extern mod_auth_st anon_auth_struct;
extern mod_auth_st anon_ecdh_auth_struct; extern mod_auth_st anon_ecdh_auth_struct;
diff -up gnutls-3.1.10/lib/algorithms/publickey.c.noecc gnutls-3.1.10/lib/algorithms/publickey.c diff -up gnutls-3.1.11/lib/algorithms/publickey.c.noecc gnutls-3.1.11/lib/algorithms/publickey.c
--- gnutls-3.1.10/lib/algorithms/publickey.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/lib/algorithms/publickey.c.noecc 2013-04-27 10:04:48.000000000 +0200
+++ gnutls-3.1.10/lib/algorithms/publickey.c 2013-03-25 13:42:15.555309960 +0100 +++ gnutls-3.1.11/lib/algorithms/publickey.c 2013-05-13 11:08:41.411446861 +0200
@@ -50,8 +50,10 @@ static const gnutls_pk_map pk_mappings[] @@ -50,8 +50,10 @@ static const gnutls_pk_map pk_mappings[]
{GNUTLS_KX_RSA_EXPORT, GNUTLS_PK_RSA, CIPHER_SIGN}, {GNUTLS_KX_RSA_EXPORT, GNUTLS_PK_RSA, CIPHER_SIGN},
{GNUTLS_KX_DHE_RSA, GNUTLS_PK_RSA, CIPHER_SIGN}, {GNUTLS_KX_DHE_RSA, GNUTLS_PK_RSA, CIPHER_SIGN},
@ -37,9 +37,9 @@ diff -up gnutls-3.1.10/lib/algorithms/publickey.c.noecc gnutls-3.1.10/lib/algori
{0, 0, 0} {0, 0, 0}
}; };
diff -up gnutls-3.1.10/lib/algorithms/sign.c.noecc gnutls-3.1.10/lib/algorithms/sign.c diff -up gnutls-3.1.11/lib/algorithms/sign.c.noecc gnutls-3.1.11/lib/algorithms/sign.c
--- gnutls-3.1.10/lib/algorithms/sign.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/lib/algorithms/sign.c.noecc 2013-04-24 10:34:02.000000000 +0200
+++ gnutls-3.1.10/lib/algorithms/sign.c 2013-03-25 13:42:15.556309982 +0100 +++ gnutls-3.1.11/lib/algorithms/sign.c 2013-05-13 11:08:41.412446883 +0200
@@ -43,6 +43,14 @@ typedef struct gnutls_sign_entry gnutls_ @@ -43,6 +43,14 @@ typedef struct gnutls_sign_entry gnutls_
#define TLS_SIGN_AID_UNKNOWN {255, 255} #define TLS_SIGN_AID_UNKNOWN {255, 255}
static const sign_algorithm_st unknown_tls_aid = TLS_SIGN_AID_UNKNOWN; static const sign_algorithm_st unknown_tls_aid = TLS_SIGN_AID_UNKNOWN;
@ -55,9 +55,9 @@ diff -up gnutls-3.1.10/lib/algorithms/sign.c.noecc gnutls-3.1.10/lib/algorithms/
static const gnutls_sign_entry sign_algorithms[] = { static const gnutls_sign_entry sign_algorithms[] = {
{"RSA-SHA1", SIG_RSA_SHA1_OID, GNUTLS_SIGN_RSA_SHA1, GNUTLS_PK_RSA, {"RSA-SHA1", SIG_RSA_SHA1_OID, GNUTLS_SIGN_RSA_SHA1, GNUTLS_PK_RSA,
GNUTLS_DIG_SHA1, {2, 1}}, GNUTLS_DIG_SHA1, {2, 1}},
diff -up gnutls-3.1.10/lib/auth/cert.c.noecc gnutls-3.1.10/lib/auth/cert.c diff -up gnutls-3.1.11/lib/auth/cert.c.noecc gnutls-3.1.11/lib/auth/cert.c
--- gnutls-3.1.10/lib/auth/cert.c.noecc 2013-03-21 21:45:47.000000000 +0100 --- gnutls-3.1.11/lib/auth/cert.c.noecc 2013-04-24 10:34:02.000000000 +0200
+++ gnutls-3.1.10/lib/auth/cert.c 2013-03-25 13:42:15.557310003 +0100 +++ gnutls-3.1.11/lib/auth/cert.c 2013-05-13 11:08:41.412446883 +0200
@@ -63,7 +63,11 @@ static gnutls_privkey_t alloc_and_load_p @@ -63,7 +63,11 @@ static gnutls_privkey_t alloc_and_load_p
key, int deinit); key, int deinit);
#endif #endif
@ -91,9 +91,9 @@ diff -up gnutls-3.1.10/lib/auth/cert.c.noecc gnutls-3.1.10/lib/auth/cert.c
ret = _gnutls_buffer_append_data (data, tmp_data, CERTTYPE_SIZE); ret = _gnutls_buffer_append_data (data, tmp_data, CERTTYPE_SIZE);
if (ret < 0) if (ret < 0)
diff -up gnutls-3.1.10/lib/auth/dhe_psk.c.noecc gnutls-3.1.10/lib/auth/dhe_psk.c diff -up gnutls-3.1.11/lib/auth/dhe_psk.c.noecc gnutls-3.1.11/lib/auth/dhe_psk.c
--- gnutls-3.1.10/lib/auth/dhe_psk.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/lib/auth/dhe_psk.c.noecc 2013-04-24 10:34:02.000000000 +0200
+++ gnutls-3.1.10/lib/auth/dhe_psk.c 2013-03-25 14:01:30.470454582 +0100 +++ gnutls-3.1.11/lib/auth/dhe_psk.c 2013-05-13 11:08:41.413446905 +0200
@@ -92,6 +92,7 @@ const mod_auth_st ecdhe_psk_auth_struct @@ -92,6 +92,7 @@ const mod_auth_st ecdhe_psk_auth_struct
}; };
#endif #endif
@ -158,9 +158,9 @@ diff -up gnutls-3.1.10/lib/auth/dhe_psk.c.noecc gnutls-3.1.10/lib/auth/dhe_psk.c
+#endif +#endif
#endif /* ENABLE_PSK */ #endif /* ENABLE_PSK */
diff -up gnutls-3.1.10/lib/ext/ecc.c.noecc gnutls-3.1.10/lib/ext/ecc.c diff -up gnutls-3.1.11/lib/ext/ecc.c.noecc gnutls-3.1.11/lib/ext/ecc.c
--- gnutls-3.1.10/lib/ext/ecc.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/lib/ext/ecc.c.noecc 2013-04-24 10:34:02.000000000 +0200
+++ gnutls-3.1.10/lib/ext/ecc.c 2013-03-25 13:42:20.746422026 +0100 +++ gnutls-3.1.11/lib/ext/ecc.c 2013-05-13 11:08:41.413446905 +0200
@@ -35,6 +35,7 @@ @@ -35,6 +35,7 @@
/* Maps record size to numbers according to the /* Maps record size to numbers according to the
* extensions draft. * extensions draft.
@ -175,9 +175,9 @@ diff -up gnutls-3.1.10/lib/ext/ecc.c.noecc gnutls-3.1.10/lib/ext/ecc.c
} }
+ +
+#endif +#endif
diff -up gnutls-3.1.10/lib/gnutls_extensions.c.noecc gnutls-3.1.10/lib/gnutls_extensions.c diff -up gnutls-3.1.11/lib/gnutls_extensions.c.noecc gnutls-3.1.11/lib/gnutls_extensions.c
--- gnutls-3.1.10/lib/gnutls_extensions.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/lib/gnutls_extensions.c.noecc 2013-05-05 12:39:09.000000000 +0200
+++ gnutls-3.1.10/lib/gnutls_extensions.c 2013-03-25 13:42:20.747422053 +0100 +++ gnutls-3.1.11/lib/gnutls_extensions.c 2013-05-13 11:08:41.413446905 +0200
@@ -350,6 +350,7 @@ _gnutls_ext_init (void) @@ -350,6 +350,7 @@ _gnutls_ext_init (void)
if (ret != GNUTLS_E_SUCCESS) if (ret != GNUTLS_E_SUCCESS)
return ret; return ret;
@ -194,9 +194,9 @@ diff -up gnutls-3.1.10/lib/gnutls_extensions.c.noecc gnutls-3.1.10/lib/gnutls_ex
ret = _gnutls_ext_register (&ext_mod_sig); ret = _gnutls_ext_register (&ext_mod_sig);
if (ret != GNUTLS_E_SUCCESS) if (ret != GNUTLS_E_SUCCESS)
diff -up gnutls-3.1.10/lib/gnutls_priority.c.noecc gnutls-3.1.10/lib/gnutls_priority.c diff -up gnutls-3.1.11/lib/gnutls_priority.c.noecc gnutls-3.1.11/lib/gnutls_priority.c
--- gnutls-3.1.10/lib/gnutls_priority.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/lib/gnutls_priority.c.noecc 2013-04-27 10:04:48.000000000 +0200
+++ gnutls-3.1.10/lib/gnutls_priority.c 2013-03-25 13:42:20.747422053 +0100 +++ gnutls-3.1.11/lib/gnutls_priority.c 2013-05-13 11:08:41.414446927 +0200
@@ -245,35 +245,45 @@ gnutls_certificate_type_set_priority (gn @@ -245,35 +245,45 @@ gnutls_certificate_type_set_priority (gn
} }
@ -243,7 +243,7 @@ diff -up gnutls-3.1.10/lib/gnutls_priority.c.noecc gnutls-3.1.10/lib/gnutls_prio
0 0
}; };
@@ -455,51 +465,75 @@ static const int comp_priority[] = { @@ -460,51 +470,75 @@ static const int comp_priority[] = {
static const int sign_priority_default[] = { static const int sign_priority_default[] = {
GNUTLS_SIGN_RSA_SHA256, GNUTLS_SIGN_RSA_SHA256,
GNUTLS_SIGN_DSA_SHA256, GNUTLS_SIGN_DSA_SHA256,
@ -319,9 +319,9 @@ diff -up gnutls-3.1.10/lib/gnutls_priority.c.noecc gnutls-3.1.10/lib/gnutls_prio
0 0
}; };
diff -up gnutls-3.1.10/lib/nettle/init.c.noecc gnutls-3.1.10/lib/nettle/init.c diff -up gnutls-3.1.11/lib/nettle/init.c.noecc gnutls-3.1.11/lib/nettle/init.c
--- gnutls-3.1.10/lib/nettle/init.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/lib/nettle/init.c.noecc 2013-04-27 10:04:48.000000000 +0200
+++ gnutls-3.1.10/lib/nettle/init.c 2013-03-25 13:42:20.748422080 +0100 +++ gnutls-3.1.11/lib/nettle/init.c 2013-05-13 11:08:41.414446927 +0200
@@ -32,7 +32,11 @@ @@ -32,7 +32,11 @@
int int
gnutls_crypto_init (void) gnutls_crypto_init (void)
@ -342,9 +342,9 @@ diff -up gnutls-3.1.10/lib/nettle/init.c.noecc gnutls-3.1.10/lib/nettle/init.c
ecc_wmnaf_cache_free(); ecc_wmnaf_cache_free();
+#endif +#endif
} }
diff -up gnutls-3.1.10/lib/nettle/Makefile.am.noecc gnutls-3.1.10/lib/nettle/Makefile.am diff -up gnutls-3.1.11/lib/nettle/Makefile.am.noecc gnutls-3.1.11/lib/nettle/Makefile.am
--- gnutls-3.1.10/lib/nettle/Makefile.am.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/lib/nettle/Makefile.am.noecc 2013-04-27 10:04:48.000000000 +0200
+++ gnutls-3.1.10/lib/nettle/Makefile.am 2013-03-25 13:42:20.748422080 +0100 +++ gnutls-3.1.11/lib/nettle/Makefile.am 2013-05-13 11:08:41.415446949 +0200
@@ -33,9 +33,13 @@ endif @@ -33,9 +33,13 @@ endif
noinst_LTLIBRARIES = libcrypto.la noinst_LTLIBRARIES = libcrypto.la
@ -364,9 +364,9 @@ diff -up gnutls-3.1.10/lib/nettle/Makefile.am.noecc gnutls-3.1.10/lib/nettle/Mak
- ecc_projective_check_point.c ecc_projective_negate_point.c \ - ecc_projective_check_point.c ecc_projective_negate_point.c \
- ecc_projective_add_point_ng.c ecc_sign_hash.c ecc_verify_hash.c gnettle.h - ecc_projective_add_point_ng.c ecc_sign_hash.c ecc_verify_hash.c gnettle.h
+ multi.c wmnaf.c $(ECC_SOURCES) gnettle.h + multi.c wmnaf.c $(ECC_SOURCES) gnettle.h
diff -up gnutls-3.1.10/lib/nettle/pk.c.noecc gnutls-3.1.10/lib/nettle/pk.c diff -up gnutls-3.1.11/lib/nettle/pk.c.noecc gnutls-3.1.11/lib/nettle/pk.c
--- gnutls-3.1.10/lib/nettle/pk.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/lib/nettle/pk.c.noecc 2013-04-27 10:04:48.000000000 +0200
+++ gnutls-3.1.10/lib/nettle/pk.c 2013-03-25 13:42:20.749422119 +0100 +++ gnutls-3.1.11/lib/nettle/pk.c 2013-05-13 11:08:41.415446949 +0200
@@ -137,6 +137,7 @@ static int _wrap_nettle_pk_derive(gnutls @@ -137,6 +137,7 @@ static int _wrap_nettle_pk_derive(gnutls
switch (algo) switch (algo)
@ -447,9 +447,9 @@ diff -up gnutls-3.1.10/lib/nettle/pk.c.noecc gnutls-3.1.10/lib/nettle/pk.c
default: default:
ret = gnutls_assert_val(GNUTLS_E_INVALID_REQUEST); ret = gnutls_assert_val(GNUTLS_E_INVALID_REQUEST);
} }
diff -up gnutls-3.1.10/tests/cert-tests/dane.noecc gnutls-3.1.10/tests/cert-tests/dane diff -up gnutls-3.1.11/tests/cert-tests/dane.noecc gnutls-3.1.11/tests/cert-tests/dane
--- gnutls-3.1.10/tests/cert-tests/dane.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/tests/cert-tests/dane.noecc 2013-04-24 10:34:02.000000000 +0200
+++ gnutls-3.1.10/tests/cert-tests/dane 2013-03-25 13:42:20.749422119 +0100 +++ gnutls-3.1.11/tests/cert-tests/dane 2013-05-13 11:08:41.416446971 +0200
@@ -22,6 +22,8 @@ @@ -22,6 +22,8 @@
set -e set -e
@ -459,9 +459,9 @@ diff -up gnutls-3.1.10/tests/cert-tests/dane.noecc gnutls-3.1.10/tests/cert-test
srcdir=${srcdir:-.} srcdir=${srcdir:-.}
DANETOOL=${DANETOOL:-../../src/danetool$EXEEXT} DANETOOL=${DANETOOL:-../../src/danetool$EXEEXT}
diff -up gnutls-3.1.10/tests/dtls/dtls-nb.noecc gnutls-3.1.10/tests/dtls/dtls-nb diff -up gnutls-3.1.11/tests/dtls/dtls-nb.noecc gnutls-3.1.11/tests/dtls/dtls-nb
--- gnutls-3.1.10/tests/dtls/dtls-nb.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/tests/dtls/dtls-nb.noecc 2013-04-24 10:34:02.000000000 +0200
+++ gnutls-3.1.10/tests/dtls/dtls-nb 2013-03-25 13:42:20.749422119 +0100 +++ gnutls-3.1.11/tests/dtls/dtls-nb 2013-05-13 11:08:41.416446971 +0200
@@ -22,9 +22,7 @@ @@ -22,9 +22,7 @@
set -e set -e
@ -473,9 +473,9 @@ diff -up gnutls-3.1.10/tests/dtls/dtls-nb.noecc gnutls-3.1.10/tests/dtls/dtls-nb
./dtls-stress -nb -shello 021 -sfinished 01 -cfinished 012 SKeyExchange CKeyExchange CFinished ./dtls-stress -nb -shello 021 -sfinished 01 -cfinished 012 SKeyExchange CKeyExchange CFinished
./dtls-stress -nb -shello 012 -sfinished 10 -cfinished 210 SHello SKeyExchange SHelloDone ./dtls-stress -nb -shello 012 -sfinished 10 -cfinished 210 SHello SKeyExchange SHelloDone
diff -up gnutls-3.1.10/tests/dtls/dtls.noecc gnutls-3.1.10/tests/dtls/dtls diff -up gnutls-3.1.11/tests/dtls/dtls.noecc gnutls-3.1.11/tests/dtls/dtls
--- gnutls-3.1.10/tests/dtls/dtls.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/tests/dtls/dtls.noecc 2013-04-24 10:34:02.000000000 +0200
+++ gnutls-3.1.10/tests/dtls/dtls 2013-03-25 13:42:20.749422119 +0100 +++ gnutls-3.1.11/tests/dtls/dtls 2013-05-13 11:08:41.416446971 +0200
@@ -22,9 +22,7 @@ @@ -22,9 +22,7 @@
set -e set -e
@ -487,9 +487,9 @@ diff -up gnutls-3.1.10/tests/dtls/dtls.noecc gnutls-3.1.10/tests/dtls/dtls
./dtls-stress -shello 021 -sfinished 01 -cfinished 012 SKeyExchange CKeyExchange CFinished ./dtls-stress -shello 021 -sfinished 01 -cfinished 012 SKeyExchange CKeyExchange CFinished
./dtls-stress -shello 012 -sfinished 10 -cfinished 210 SHello SKeyExchange SHelloDone ./dtls-stress -shello 012 -sfinished 10 -cfinished 210 SHello SKeyExchange SHelloDone
diff -up gnutls-3.1.10/tests/ecdsa/ecdsa.noecc gnutls-3.1.10/tests/ecdsa/ecdsa diff -up gnutls-3.1.11/tests/ecdsa/ecdsa.noecc gnutls-3.1.11/tests/ecdsa/ecdsa
--- gnutls-3.1.10/tests/ecdsa/ecdsa.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/tests/ecdsa/ecdsa.noecc 2013-04-24 10:34:02.000000000 +0200
+++ gnutls-3.1.10/tests/ecdsa/ecdsa 2013-03-25 13:42:20.750422152 +0100 +++ gnutls-3.1.11/tests/ecdsa/ecdsa 2013-05-13 11:08:41.416446971 +0200
@@ -22,6 +22,8 @@ @@ -22,6 +22,8 @@
#set -e #set -e
@ -499,9 +499,21 @@ diff -up gnutls-3.1.10/tests/ecdsa/ecdsa.noecc gnutls-3.1.10/tests/ecdsa/ecdsa
srcdir=${srcdir:-.} srcdir=${srcdir:-.}
CERTTOOL=${CERTTOOL:-../../src/certtool$EXEEXT} CERTTOOL=${CERTTOOL:-../../src/certtool$EXEEXT}
diff -up gnutls-3.1.10/tests/mini-dtls-record.c.noecc gnutls-3.1.10/tests/mini-dtls-record.c diff -up gnutls-3.1.11/tests/mini-dtls-heartbeat.c.noecc gnutls-3.1.11/tests/mini-dtls-heartbeat.c
--- gnutls-3.1.10/tests/mini-dtls-record.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/tests/mini-dtls-heartbeat.c.noecc 2013-05-10 10:10:27.000000000 +0200
+++ gnutls-3.1.10/tests/mini-dtls-record.c 2013-03-25 13:42:20.750422152 +0100 +++ gnutls-3.1.11/tests/mini-dtls-heartbeat.c 2013-05-13 11:16:23.185518179 +0200
@@ -27,7 +27,7 @@
#include <stdio.h>
#include <stdlib.h>
-#if defined(_WIN32) || !defined(ENABLE_HEARTBEAT)
+#if defined(_WIN32) || !defined(ENABLE_HEARTBEAT) || !defined(ENABLE_ECC)
int
main ()
diff -up gnutls-3.1.11/tests/mini-dtls-record.c.noecc gnutls-3.1.11/tests/mini-dtls-record.c
--- gnutls-3.1.11/tests/mini-dtls-record.c.noecc 2013-05-10 10:10:27.000000000 +0200
+++ gnutls-3.1.11/tests/mini-dtls-record.c 2013-05-13 11:08:41.416446971 +0200
@@ -27,7 +27,7 @@ @@ -27,7 +27,7 @@
#include <stdio.h> #include <stdio.h>
#include <stdlib.h> #include <stdlib.h>
@ -511,9 +523,9 @@ diff -up gnutls-3.1.10/tests/mini-dtls-record.c.noecc gnutls-3.1.10/tests/mini-d
int int
main () main ()
diff -up gnutls-3.1.10/tests/mini-dtls-rehandshake.c.noecc gnutls-3.1.10/tests/mini-dtls-rehandshake.c diff -up gnutls-3.1.11/tests/mini-dtls-rehandshake.c.noecc gnutls-3.1.11/tests/mini-dtls-rehandshake.c
--- gnutls-3.1.10/tests/mini-dtls-rehandshake.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/tests/mini-dtls-rehandshake.c.noecc 2013-05-10 10:10:27.000000000 +0200
+++ gnutls-3.1.10/tests/mini-dtls-rehandshake.c 2013-03-25 13:42:20.750422152 +0100 +++ gnutls-3.1.11/tests/mini-dtls-rehandshake.c 2013-05-13 11:08:41.416446971 +0200
@@ -27,7 +27,7 @@ @@ -27,7 +27,7 @@
#include <stdio.h> #include <stdio.h>
#include <stdlib.h> #include <stdlib.h>
@ -523,9 +535,9 @@ diff -up gnutls-3.1.10/tests/mini-dtls-rehandshake.c.noecc gnutls-3.1.10/tests/m
int main() int main()
{ {
diff -up gnutls-3.1.10/tests/mini-dtls-srtp.c.noecc gnutls-3.1.10/tests/mini-dtls-srtp.c diff -up gnutls-3.1.11/tests/mini-dtls-srtp.c.noecc gnutls-3.1.11/tests/mini-dtls-srtp.c
--- gnutls-3.1.10/tests/mini-dtls-srtp.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/tests/mini-dtls-srtp.c.noecc 2013-05-10 10:10:27.000000000 +0200
+++ gnutls-3.1.10/tests/mini-dtls-srtp.c 2013-03-25 13:42:20.751422175 +0100 +++ gnutls-3.1.11/tests/mini-dtls-srtp.c 2013-05-13 11:08:41.417446993 +0200
@@ -27,7 +27,7 @@ @@ -27,7 +27,7 @@
#include <stdio.h> #include <stdio.h>
#include <stdlib.h> #include <stdlib.h>
@ -535,9 +547,9 @@ diff -up gnutls-3.1.10/tests/mini-dtls-srtp.c.noecc gnutls-3.1.10/tests/mini-dtl
int int
main (int argc, char** argv) main (int argc, char** argv)
diff -up gnutls-3.1.10/tests/mini-handshake-timeout.c.noecc gnutls-3.1.10/tests/mini-handshake-timeout.c diff -up gnutls-3.1.11/tests/mini-handshake-timeout.c.noecc gnutls-3.1.11/tests/mini-handshake-timeout.c
--- gnutls-3.1.10/tests/mini-handshake-timeout.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/tests/mini-handshake-timeout.c.noecc 2013-05-10 10:10:27.000000000 +0200
+++ gnutls-3.1.10/tests/mini-handshake-timeout.c 2013-03-25 13:42:20.751422175 +0100 +++ gnutls-3.1.11/tests/mini-handshake-timeout.c 2013-05-13 11:08:41.417446993 +0200
@@ -28,7 +28,7 @@ @@ -28,7 +28,7 @@
#include <stdlib.h> #include <stdlib.h>
#include <string.h> #include <string.h>
@ -560,9 +572,9 @@ diff -up gnutls-3.1.10/tests/mini-handshake-timeout.c.noecc gnutls-3.1.10/tests/
} }
static void static void
diff -up gnutls-3.1.10/tests/mini-loss-time.c.noecc gnutls-3.1.10/tests/mini-loss-time.c diff -up gnutls-3.1.11/tests/mini-loss-time.c.noecc gnutls-3.1.11/tests/mini-loss-time.c
--- gnutls-3.1.10/tests/mini-loss-time.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/tests/mini-loss-time.c.noecc 2013-05-10 10:10:27.000000000 +0200
+++ gnutls-3.1.10/tests/mini-loss-time.c 2013-03-25 13:42:20.751422175 +0100 +++ gnutls-3.1.11/tests/mini-loss-time.c 2013-05-13 11:08:41.417446993 +0200
@@ -28,7 +28,7 @@ @@ -28,7 +28,7 @@
#include <stdlib.h> #include <stdlib.h>
#include <string.h> #include <string.h>
@ -572,9 +584,9 @@ diff -up gnutls-3.1.10/tests/mini-loss-time.c.noecc gnutls-3.1.10/tests/mini-los
int main() int main()
{ {
diff -up gnutls-3.1.10/tests/mini-record.c.noecc gnutls-3.1.10/tests/mini-record.c diff -up gnutls-3.1.11/tests/mini-record.c.noecc gnutls-3.1.11/tests/mini-record.c
--- gnutls-3.1.10/tests/mini-record.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/tests/mini-record.c.noecc 2013-05-10 10:10:27.000000000 +0200
+++ gnutls-3.1.10/tests/mini-record.c 2013-03-25 13:42:20.751422175 +0100 +++ gnutls-3.1.11/tests/mini-record.c 2013-05-13 11:08:41.417446993 +0200
@@ -27,7 +27,7 @@ @@ -27,7 +27,7 @@
#include <stdio.h> #include <stdio.h>
#include <stdlib.h> #include <stdlib.h>
@ -584,9 +596,9 @@ diff -up gnutls-3.1.10/tests/mini-record.c.noecc gnutls-3.1.10/tests/mini-record
int main() int main()
{ {
diff -up gnutls-3.1.10/tests/mini-xssl.c.noecc gnutls-3.1.10/tests/mini-xssl.c diff -up gnutls-3.1.11/tests/mini-record-range.c.noecc gnutls-3.1.11/tests/mini-record-range.c
--- gnutls-3.1.10/tests/mini-xssl.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/tests/mini-record-range.c.noecc 2013-05-10 10:10:27.000000000 +0200
+++ gnutls-3.1.10/tests/mini-xssl.c 2013-03-25 13:42:20.752422192 +0100 +++ gnutls-3.1.11/tests/mini-record-range.c 2013-05-13 11:17:05.526439771 +0200
@@ -27,7 +27,7 @@ @@ -27,7 +27,7 @@
#include <stdio.h> #include <stdio.h>
#include <stdlib.h> #include <stdlib.h>
@ -596,9 +608,21 @@ diff -up gnutls-3.1.10/tests/mini-xssl.c.noecc gnutls-3.1.10/tests/mini-xssl.c
int main() int main()
{ {
diff -up gnutls-3.1.10/tests/pkcs12_simple.c.noecc gnutls-3.1.10/tests/pkcs12_simple.c diff -up gnutls-3.1.11/tests/mini-xssl.c.noecc gnutls-3.1.11/tests/mini-xssl.c
--- gnutls-3.1.10/tests/pkcs12_simple.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/tests/mini-xssl.c.noecc 2013-05-10 10:10:27.000000000 +0200
+++ gnutls-3.1.10/tests/pkcs12_simple.c 2013-03-25 13:42:20.752422192 +0100 +++ gnutls-3.1.11/tests/mini-xssl.c 2013-05-13 11:08:41.417446993 +0200
@@ -27,7 +27,7 @@
#include <stdio.h>
#include <stdlib.h>
-#if defined(_WIN32)
+#if defined(_WIN32) || !defined(ENABLE_ECC)
int main()
{
diff -up gnutls-3.1.11/tests/pkcs12_simple.c.noecc gnutls-3.1.11/tests/pkcs12_simple.c
--- gnutls-3.1.11/tests/pkcs12_simple.c.noecc 2013-05-10 10:10:27.000000000 +0200
+++ gnutls-3.1.11/tests/pkcs12_simple.c 2013-05-13 11:08:41.417446993 +0200
@@ -50,6 +50,10 @@ doit (void) @@ -50,6 +50,10 @@ doit (void)
gnutls_x509_privkey_t pkey; gnutls_x509_privkey_t pkey;
int ret; int ret;
@ -607,12 +631,12 @@ diff -up gnutls-3.1.10/tests/pkcs12_simple.c.noecc gnutls-3.1.10/tests/pkcs12_si
+ exit(77); + exit(77);
+#endif +#endif
+ +
ret = gnutls_global_init (); ret = global_init ();
if (ret < 0) if (ret < 0)
fail ("gnutls_global_init failed %d\n", ret); fail ("global_init failed %d\n", ret);
diff -up gnutls-3.1.10/tests/slow/keygen.c.noecc gnutls-3.1.10/tests/slow/keygen.c diff -up gnutls-3.1.11/tests/slow/keygen.c.noecc gnutls-3.1.11/tests/slow/keygen.c
--- gnutls-3.1.10/tests/slow/keygen.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/tests/slow/keygen.c.noecc 2013-05-10 10:10:27.000000000 +0200
+++ gnutls-3.1.10/tests/slow/keygen.c 2013-03-25 13:42:20.752422192 +0100 +++ gnutls-3.1.11/tests/slow/keygen.c 2013-05-13 11:08:41.417446993 +0200
@@ -65,6 +65,11 @@ doit (void) @@ -65,6 +65,11 @@ doit (void)
if (algorithm == GNUTLS_PK_DH) if (algorithm == GNUTLS_PK_DH)
continue; continue;
@ -625,9 +649,9 @@ diff -up gnutls-3.1.10/tests/slow/keygen.c.noecc gnutls-3.1.10/tests/slow/keygen
ret = gnutls_x509_privkey_init (&pkey); ret = gnutls_x509_privkey_init (&pkey);
if (ret < 0) if (ret < 0)
{ {
diff -up gnutls-3.1.10/tests/srp/mini-srp.c.noecc gnutls-3.1.10/tests/srp/mini-srp.c diff -up gnutls-3.1.11/tests/srp/mini-srp.c.noecc gnutls-3.1.11/tests/srp/mini-srp.c
--- gnutls-3.1.10/tests/srp/mini-srp.c.noecc 2013-03-21 21:42:28.000000000 +0100 --- gnutls-3.1.11/tests/srp/mini-srp.c.noecc 2013-05-10 10:10:27.000000000 +0200
+++ gnutls-3.1.10/tests/srp/mini-srp.c 2013-03-25 13:42:20.753422209 +0100 +++ gnutls-3.1.11/tests/srp/mini-srp.c 2013-05-13 11:08:41.418447015 +0200
@@ -27,7 +27,7 @@ @@ -27,7 +27,7 @@
#include <stdio.h> #include <stdio.h>
#include <stdlib.h> #include <stdlib.h>

View File

@ -2,10 +2,11 @@
%bcond_with guile %bcond_with guile
Summary: A TLS protocol implementation Summary: A TLS protocol implementation
Name: gnutls Name: gnutls
Version: 3.1.10 Version: 3.1.11
Release: 1%{?dist} Release: 1%{?dist}
# The libraries are LGPLv2.1+, utilities are GPLv3+ # The libraries are LGPLv2.1+, utilities are GPLv3+, however
License: GPLv3+ and LGPLv2+ # the bundled gnulib is LGPLv3+
License: GPLv3+ and LGPLv2+ and LGPLv3+
Group: System Environment/Libraries Group: System Environment/Libraries
BuildRequires: p11-kit-devel >= 0.11, gettext BuildRequires: p11-kit-devel >= 0.11, gettext
BuildRequires: zlib-devel, readline-devel, libtasn1-devel >= 3.1 BuildRequires: zlib-devel, readline-devel, libtasn1-devel >= 3.1
@ -28,13 +29,13 @@ Patch1: gnutls-3.1.7-rpath.patch
# Use only FIPS approved ciphers in the FIPS mode # Use only FIPS approved ciphers in the FIPS mode
Patch7: gnutls-2.12.21-fips-algorithms.patch Patch7: gnutls-2.12.21-fips-algorithms.patch
# Make ECC optional as it is now hobbled # Make ECC optional as it is now hobbled
Patch8: gnutls-3.1.10-noecc.patch Patch8: gnutls-3.1.11-noecc.patch
# Use random port in some tests to avoid conflicts during simultaneous builds on the same machine # Use random port in some tests to avoid conflicts during simultaneous builds on the same machine
Patch9: gnutls-3.1.10-tests-rndport.patch Patch9: gnutls-3.1.10-tests-rndport.patch
Requires: libgcrypt >= 1.2.2 Requires: libgcrypt >= 1.2.2
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174 # Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
Provides: bundled(gnulib) = 20120301 Provides: bundled(gnulib) = 20130424
%package c++ %package c++
Summary: The C++ interface to GnuTLS Summary: The C++ interface to GnuTLS
@ -139,10 +140,12 @@ export LDFLAGS="-Wl,--no-add-needed"
--disable-static \ --disable-static \
--disable-openssl-compatibility \ --disable-openssl-compatibility \
--disable-srp-authentication \ --disable-srp-authentication \
--disable-heartbeat-support \
--disable-ecdhe \ --disable-ecdhe \
%if %{with guile} %if %{with guile}
--enable-guile \ --enable-guile \
%ifarch %{arm}
--disable-largefile \
%endif
%else %else
--disable-guile \ --disable-guile \
%endif %endif
@ -150,9 +153,6 @@ export LDFLAGS="-Wl,--no-add-needed"
--enable-dane \ --enable-dane \
%else %else
--disable-dane \ --disable-dane \
%endif
%ifarch %{arm}
--disable-largefile \
%endif %endif
--disable-rpath --disable-rpath
# Note that the arm hack above is not quite right and the proper thing would # Note that the arm hack above is not quite right and the proper thing would
@ -256,6 +256,9 @@ fi
%endif %endif
%changelog %changelog
* Mon May 13 2013 Tomáš Mráz <tmraz@redhat.com> 3.1.11-1
- new upstream release
* Mon Mar 25 2013 Tomas Mraz <tmraz@redhat.com> 3.1.10-1 * Mon Mar 25 2013 Tomas Mraz <tmraz@redhat.com> 3.1.10-1
- new upstream release - new upstream release
- license of the library is back to LGPLv2.1+ - license of the library is back to LGPLv2.1+

View File

@ -1 +1 @@
60b4ac7e86de67029a55400ce97d21b3 gnutls-3.1.10-hobbled.tar.xz 6637d1265917a222a1b404d31d5943ac gnutls-3.1.11-hobbled.tar.xz