new upstream version
This commit is contained in:
parent
f2f3720380
commit
3647f5500d
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@ gnutls-2.10.1-nosrp.tar.bz2
|
||||
/gnutls-2.10.3-nosrp.tar.bz2
|
||||
/gnutls-2.10.4-nosrp.tar.bz2
|
||||
/gnutls-2.10.5-nosrp.tar.bz2
|
||||
/gnutls-2.12.2-nosrp.tar.bz2
|
||||
|
@ -1,57 +0,0 @@
|
||||
diff -up gnutls-2.10.1/lib/gnutls_handshake.c.errors gnutls-2.10.1/lib/gnutls_handshake.c
|
||||
--- gnutls-2.10.1/lib/gnutls_handshake.c.errors 2010-07-25 10:35:31.000000000 +0200
|
||||
+++ gnutls-2.10.1/lib/gnutls_handshake.c 2010-09-13 17:16:05.000000000 +0200
|
||||
@@ -2769,7 +2769,7 @@ _gnutls_handshake_client (gnutls_session
|
||||
case STATE1:
|
||||
ret = _gnutls_send_hello (session, AGAIN (STATE1));
|
||||
STATE = STATE1;
|
||||
- IMED_RET ("send hello", ret, 0);
|
||||
+ IMED_RET ("send hello", ret, 1);
|
||||
|
||||
case STATE2:
|
||||
/* receive the server hello */
|
||||
@@ -2849,7 +2849,7 @@ _gnutls_handshake_client (gnutls_session
|
||||
ret =
|
||||
_gnutls_send_client_certificate_verify (session, AGAIN (STATE9));
|
||||
STATE = STATE9;
|
||||
- IMED_RET ("send client certificate verify", ret, 0);
|
||||
+ IMED_RET ("send client certificate verify", ret, 1);
|
||||
|
||||
STATE = STATE0;
|
||||
default:
|
||||
@@ -3002,7 +3002,7 @@ _gnutls_handshake_server (gnutls_session
|
||||
case STATE2:
|
||||
ret = _gnutls_send_hello (session, AGAIN (STATE2));
|
||||
STATE = STATE2;
|
||||
- IMED_RET ("send hello", ret, 0);
|
||||
+ IMED_RET ("send hello", ret, 1);
|
||||
|
||||
case STATE70:
|
||||
if (session->security_parameters.extensions.do_send_supplemental)
|
||||
@@ -3044,7 +3044,7 @@ _gnutls_handshake_server (gnutls_session
|
||||
GNUTLS_HANDSHAKE_SERVER_HELLO_DONE,
|
||||
AGAIN (STATE6));
|
||||
STATE = STATE6;
|
||||
- IMED_RET ("send server hello done", ret, 0);
|
||||
+ IMED_RET ("send server hello done", ret, 1);
|
||||
|
||||
case STATE71:
|
||||
if (session->security_parameters.extensions.do_recv_supplemental)
|
||||
@@ -3119,7 +3119,7 @@ _gnutls_handshake_common (gnutls_session
|
||||
#endif
|
||||
|
||||
ret = _gnutls_send_handshake_final (session, FALSE);
|
||||
- IMED_RET ("send handshake final", ret, 0);
|
||||
+ IMED_RET ("send handshake final", ret, 1);
|
||||
|
||||
/* only store if we are not resuming */
|
||||
if (session->security_parameters.entity == GNUTLS_SERVER)
|
||||
@@ -3132,7 +3132,7 @@ _gnutls_handshake_common (gnutls_session
|
||||
{ /* if we are a client not resuming - or we are a server resuming */
|
||||
|
||||
ret = _gnutls_send_handshake_final (session, TRUE);
|
||||
- IMED_RET ("send handshake final 2", ret, 0);
|
||||
+ IMED_RET ("send handshake final 2", ret, 1);
|
||||
|
||||
#ifdef ENABLE_SESSION_TICKET
|
||||
switch (STATE)
|
@ -1,16 +1,7 @@
|
||||
diff -up gnutls-2.10.1/doc/gnutls.texi.nosrp gnutls-2.10.1/doc/gnutls.texi
|
||||
--- gnutls-2.10.1/doc/gnutls.texi.nosrp 2010-06-21 09:50:55.000000000 +0200
|
||||
+++ gnutls-2.10.1/doc/gnutls.texi 2010-08-04 11:58:22.000000000 +0200
|
||||
@@ -524,7 +524,7 @@ data to the transport layer.
|
||||
@end itemize
|
||||
|
||||
Other callback functions such as the one set by
|
||||
-@ref{gnutls_srp_set_server_credentials_function}, may require more
|
||||
+gnutls_srp_set_server_credentials_function, may require more
|
||||
complicated input, including data to be allocated. These callbacks
|
||||
should allocate and free memory using the functions shown below.
|
||||
|
||||
@@ -1576,9 +1576,9 @@ authenticated using a certificate with R
|
||||
diff -up gnutls-2.12.2/doc/cha-auth.texi.nosrp gnutls-2.12.2/doc/cha-auth.texi
|
||||
--- gnutls-2.12.2/doc/cha-auth.texi.nosrp 2011-04-08 02:30:44.000000000 +0200
|
||||
+++ gnutls-2.12.2/doc/cha-auth.texi 2011-04-19 09:46:25.000000000 +0200
|
||||
@@ -255,9 +255,9 @@ authenticated using a certificate with R
|
||||
|
||||
If clients supporting @acronym{SRP} know the username and password
|
||||
before the connection, should initialize the client credentials and
|
||||
@ -22,7 +13,7 @@ diff -up gnutls-2.10.1/doc/gnutls.texi.nosrp gnutls-2.10.1/doc/gnutls.texi
|
||||
the advantage that allows probing the server for @acronym{SRP}
|
||||
support. In that case the callback function will be called twice per
|
||||
handshake. The first time is before the ciphersuite is negotiated,
|
||||
@@ -1593,20 +1593,20 @@ In server side the default behaviour of
|
||||
@@ -272,20 +272,20 @@ In server side the default behaviour of
|
||||
the usernames and @acronym{SRP} verifiers from password files. These
|
||||
password files are the ones used by the @emph{Stanford srp libraries}
|
||||
and can be specified using the
|
||||
@ -48,3 +39,15 @@ diff -up gnutls-2.10.1/doc/gnutls.texi.nosrp gnutls-2.10.1/doc/gnutls.texi
|
||||
|
||||
@end itemize
|
||||
|
||||
diff -up gnutls-2.12.2/doc/cha-library.texi.nosrp gnutls-2.12.2/doc/cha-library.texi
|
||||
--- gnutls-2.12.2/doc/cha-library.texi.nosrp 2011-04-08 02:30:44.000000000 +0200
|
||||
+++ gnutls-2.12.2/doc/cha-library.texi 2011-04-19 09:44:58.000000000 +0200
|
||||
@@ -174,7 +174,7 @@ data to the transport layer.
|
||||
@end itemize
|
||||
|
||||
Other callback functions such as the one set by
|
||||
-@ref{gnutls_srp_set_server_credentials_function}, may require more
|
||||
+gnutls_srp_set_server_credentials_function, may require more
|
||||
complicated input, including data to be allocated. These callbacks
|
||||
should allocate and free memory using the functions shown below.
|
||||
|
@ -1,8 +1,8 @@
|
||||
diff -up gnutls-2.10.4/build-aux/config.rpath gnutls-2.10.4/build-aux/config
|
||||
diff -up gnutls-2.10.4/configure.rpath gnutls-2.10.4/configure
|
||||
--- gnutls-2.10.4/configure.rpath 2010-12-06 14:53:28.000000000 +0100
|
||||
+++ gnutls-2.10.4/configure 2010-12-08 21:29:22.000000000 +0100
|
||||
@@ -15112,7 +15112,7 @@ shlibpath_var=
|
||||
diff -up gnutls-2.12.2/build-aux/config.rpath gnutls-2.12.2/build-aux/config
|
||||
diff -up gnutls-2.12.2/configure.rpath gnutls-2.12.2/configure
|
||||
--- gnutls-2.12.2/configure.rpath 2011-04-08 18:18:09.000000000 +0200
|
||||
+++ gnutls-2.12.2/configure 2011-04-19 10:55:42.000000000 +0200
|
||||
@@ -16740,7 +16740,7 @@ shlibpath_var=
|
||||
shlibpath_overrides_runpath=unknown
|
||||
version_type=none
|
||||
dynamic_linker="$host_os ld.so"
|
||||
@ -11,16 +11,16 @@ diff -up gnutls-2.10.4/configure.rpath gnutls-2.10.4/configure
|
||||
need_lib_prefix=unknown
|
||||
hardcode_into_libs=no
|
||||
|
||||
@@ -15510,7 +15510,7 @@ fi
|
||||
@@ -17125,7 +17125,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
# Append ld.so.conf contents to the search path
|
||||
if test -f /etc/ld.so.conf; then
|
||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
||||
fi
|
||||
|
||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||
@@ -18777,7 +18777,7 @@ shlibpath_var=
|
||||
@@ -20209,7 +20209,7 @@ shlibpath_var=
|
||||
shlibpath_overrides_runpath=unknown
|
||||
version_type=none
|
||||
dynamic_linker="$host_os ld.so"
|
||||
@ -29,20 +29,20 @@ diff -up gnutls-2.10.4/configure.rpath gnutls-2.10.4/configure
|
||||
need_lib_prefix=unknown
|
||||
hardcode_into_libs=no
|
||||
|
||||
@@ -19173,7 +19173,7 @@ fi
|
||||
@@ -20593,7 +20593,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
# Append ld.so.conf contents to the search path
|
||||
if test -f /etc/ld.so.conf; then
|
||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
||||
fi
|
||||
|
||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||
diff -up gnutls-2.10.4/lib/build-aux/config.rpath gnutls-2.10.4/lib/build-aux/config
|
||||
diff -up gnutls-2.10.4/lib/configure.rpath gnutls-2.10.4/lib/configure
|
||||
--- gnutls-2.10.4/lib/configure.rpath 2010-12-06 14:53:11.000000000 +0100
|
||||
+++ gnutls-2.10.4/lib/configure 2010-12-08 21:30:09.000000000 +0100
|
||||
@@ -10839,7 +10839,7 @@ shlibpath_var=
|
||||
diff -up gnutls-2.12.2/lib/build-aux/config.rpath gnutls-2.12.2/lib/build-aux/config
|
||||
diff -up gnutls-2.12.2/lib/configure.rpath gnutls-2.12.2/lib/configure
|
||||
--- gnutls-2.12.2/lib/configure.rpath 2011-04-08 18:17:13.000000000 +0200
|
||||
+++ gnutls-2.12.2/lib/configure 2011-04-19 10:57:03.000000000 +0200
|
||||
@@ -10842,7 +10842,7 @@ shlibpath_var=
|
||||
shlibpath_overrides_runpath=unknown
|
||||
version_type=none
|
||||
dynamic_linker="$host_os ld.so"
|
||||
@ -51,16 +51,16 @@ diff -up gnutls-2.10.4/lib/configure.rpath gnutls-2.10.4/lib/configure
|
||||
need_lib_prefix=unknown
|
||||
hardcode_into_libs=no
|
||||
|
||||
@@ -11237,7 +11237,7 @@ fi
|
||||
@@ -11227,7 +11227,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
# Append ld.so.conf contents to the search path
|
||||
if test -f /etc/ld.so.conf; then
|
||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
||||
fi
|
||||
|
||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||
@@ -25790,7 +25790,7 @@ shlibpath_var=
|
||||
@@ -28572,7 +28572,7 @@ shlibpath_var=
|
||||
shlibpath_overrides_runpath=unknown
|
||||
version_type=none
|
||||
dynamic_linker="$host_os ld.so"
|
||||
@ -69,20 +69,20 @@ diff -up gnutls-2.10.4/lib/configure.rpath gnutls-2.10.4/lib/configure
|
||||
need_lib_prefix=unknown
|
||||
hardcode_into_libs=no
|
||||
|
||||
@@ -26186,7 +26186,7 @@ fi
|
||||
@@ -28956,7 +28956,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
# Append ld.so.conf contents to the search path
|
||||
if test -f /etc/ld.so.conf; then
|
||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
||||
fi
|
||||
|
||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||
diff -up gnutls-2.10.4/libextra/build-aux/config.rpath gnutls-2.10.4/libextra/build-aux/config
|
||||
diff -up gnutls-2.10.4/libextra/configure.rpath gnutls-2.10.4/libextra/configure
|
||||
--- gnutls-2.10.4/libextra/configure.rpath 2010-12-06 14:53:20.000000000 +0100
|
||||
+++ gnutls-2.10.4/libextra/configure 2010-12-08 21:30:27.000000000 +0100
|
||||
@@ -10013,7 +10013,7 @@ shlibpath_var=
|
||||
diff -up gnutls-2.12.2/libextra/build-aux/config.rpath gnutls-2.12.2/libextra/build-aux/config
|
||||
diff -up gnutls-2.12.2/libextra/configure.rpath gnutls-2.12.2/libextra/configure
|
||||
--- gnutls-2.12.2/libextra/configure.rpath 2011-04-08 18:17:42.000000000 +0200
|
||||
+++ gnutls-2.12.2/libextra/configure 2011-04-19 10:57:59.000000000 +0200
|
||||
@@ -9971,7 +9971,7 @@ shlibpath_var=
|
||||
shlibpath_overrides_runpath=unknown
|
||||
version_type=none
|
||||
dynamic_linker="$host_os ld.so"
|
||||
@ -91,10 +91,10 @@ diff -up gnutls-2.10.4/libextra/configure.rpath gnutls-2.10.4/libextra/configure
|
||||
need_lib_prefix=unknown
|
||||
hardcode_into_libs=no
|
||||
|
||||
@@ -10411,7 +10411,7 @@ fi
|
||||
@@ -10356,7 +10356,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
# Append ld.so.conf contents to the search path
|
||||
if test -f /etc/ld.so.conf; then
|
||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64 $lt_ld_extra"
|
||||
fi
|
File diff suppressed because it is too large
Load Diff
20
gnutls.spec
20
gnutls.spec
@ -1,6 +1,6 @@
|
||||
Summary: A TLS protocol implementation
|
||||
Name: gnutls
|
||||
Version: 2.10.5
|
||||
Version: 2.12.2
|
||||
Release: 1%{?dist}
|
||||
# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
|
||||
License: GPLv3+ and LGPLv2+
|
||||
@ -15,12 +15,10 @@ URL: http://www.gnutls.org/
|
||||
# XXX patent tainted SRP code removed.
|
||||
Source0: %{name}-%{version}-nosrp.tar.bz2
|
||||
Source1: libgnutls-config
|
||||
Patch1: gnutls-2.10.4-rpath.patch
|
||||
Patch1: gnutls-2.12.2-rpath.patch
|
||||
Patch2: gnutls-2.8.6-link-libgcrypt.patch
|
||||
# Remove nonexisting references from texinfo file
|
||||
Patch3: gnutls-2.10.1-nosrp.patch
|
||||
# Backport from upstream git
|
||||
Patch4: gnutls-2.10.1-handshake-errors.patch
|
||||
Patch3: gnutls-2.12.2-nosrp.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: libgcrypt >= 1.2.2
|
||||
@ -76,7 +74,6 @@ This package contains Guile bindings for the library.
|
||||
%patch1 -p1 -b .rpath
|
||||
%patch2 -p1 -b .link
|
||||
%patch3 -p1 -b .nosrp
|
||||
%patch4 -p1 -b .errors
|
||||
|
||||
for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
|
||||
touch lib/$i
|
||||
@ -89,13 +86,15 @@ export LDFLAGS="-Wl,--no-add-needed"
|
||||
%configure --with-libtasn1-prefix=%{_prefix} \
|
||||
--with-included-libcfg \
|
||||
--disable-static \
|
||||
--disable-srp-authentication
|
||||
--disable-srp-authentication \
|
||||
--disable-rpath \
|
||||
--with-libgcrypt
|
||||
make
|
||||
cp lib/COPYING COPYING.LIB
|
||||
|
||||
%install
|
||||
rm -fr $RPM_BUILD_ROOT
|
||||
%makeinstall
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
|
||||
rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
|
||||
cp -f %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/libgnutls-config
|
||||
@ -144,11 +143,13 @@ fi
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%{_mandir}/man3/*
|
||||
%{_infodir}/gnutls*
|
||||
%{_infodir}/pkcs11-vision*
|
||||
|
||||
%files utils
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/certtool
|
||||
%{_bindir}/psktool
|
||||
%{_bindir}/p11tool
|
||||
%{_bindir}/gnutls*
|
||||
%{_mandir}/man1/*
|
||||
%doc doc/certtool.cfg
|
||||
@ -160,6 +161,9 @@ fi
|
||||
%{_datadir}/guile/site/gnutls.scm
|
||||
|
||||
%changelog
|
||||
* Mon Apr 18 2011 Tomas Mraz <tmraz@redhat.com> 2.12.2-1
|
||||
- new upstream version
|
||||
|
||||
* Thu Mar 3 2011 Tomas Mraz <tmraz@redhat.com> 2.10.5-1
|
||||
- new upstream version
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user