- upgrade to new upstream version (#192070), rebuild of dependent packages
required
This commit is contained in:
parent
c0160c6226
commit
109ee1c769
@ -1 +1 @@
|
|||||||
gnutls-1.2.10-nosrp.tar.bz2
|
gnutls-1.4.0-nosrp.tar.bz2
|
||||||
|
59
gnutls-1.4.0-nosrp.patch
Normal file
59
gnutls-1.4.0-nosrp.patch
Normal file
@ -0,0 +1,59 @@
|
|||||||
|
--- gnutls-1.2.9/doc/examples/ex-client-srp.c.nosrp 2005-08-10 11:13:30.000000000 +0200
|
||||||
|
+++ gnutls-1.2.9/doc/examples/ex-client-srp.c 2005-11-23 11:58:46.000000000 +0100
|
||||||
|
@@ -17,13 +17,16 @@
|
||||||
|
#define SA struct sockaddr
|
||||||
|
#define MSG "GET / HTTP/1.0\r\n\r\n"
|
||||||
|
|
||||||
|
+#if 0
|
||||||
|
const int kx_priority[] = { GNUTLS_KX_SRP, GNUTLS_KX_SRP_DSS,
|
||||||
|
GNUTLS_KX_SRP_RSA, 0
|
||||||
|
};
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
int
|
||||||
|
main (void)
|
||||||
|
{
|
||||||
|
+#if 0
|
||||||
|
int ret;
|
||||||
|
int sd, ii;
|
||||||
|
gnutls_session_t session;
|
||||||
|
@@ -122,6 +125,6 @@
|
||||||
|
gnutls_certificate_free_credentials (cert_cred);
|
||||||
|
|
||||||
|
gnutls_global_deinit ();
|
||||||
|
-
|
||||||
|
+#endif
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
--- gnutls-1.2.9/doc/examples/ex-serv-srp.c.nosrp 2005-09-23 00:40:19.000000000 +0200
|
||||||
|
+++ gnutls-1.2.9/doc/examples/ex-serv-srp.c 2005-11-23 12:02:44.000000000 +0100
|
||||||
|
@@ -26,6 +26,7 @@
|
||||||
|
#define MAX_BUF 1024
|
||||||
|
#define PORT 5556 /* listen to 5556 port */
|
||||||
|
|
||||||
|
+#if 0
|
||||||
|
/* These are global */
|
||||||
|
gnutls_srp_server_credentials_t srp_cred;
|
||||||
|
gnutls_certificate_credentials_t cert_cred;
|
||||||
|
@@ -54,10 +55,12 @@
|
||||||
|
|
||||||
|
return session;
|
||||||
|
}
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
int
|
||||||
|
main (void)
|
||||||
|
{
|
||||||
|
+#if 0
|
||||||
|
int err, listen_sd, i;
|
||||||
|
int sd, ret;
|
||||||
|
struct sockaddr_in sa_serv;
|
||||||
|
@@ -170,7 +173,7 @@
|
||||||
|
gnutls_certificate_free_credentials (cert_cred);
|
||||||
|
|
||||||
|
gnutls_global_deinit ();
|
||||||
|
-
|
||||||
|
+#endif
|
||||||
|
return 0;
|
||||||
|
|
||||||
|
}
|
18
gnutls.spec
18
gnutls.spec
@ -1,10 +1,10 @@
|
|||||||
Summary: A TLS protocol implementation.
|
Summary: A TLS protocol implementation.
|
||||||
Name: gnutls
|
Name: gnutls
|
||||||
Version: 1.2.10
|
Version: 1.4.0
|
||||||
Release: 2
|
Release: 1
|
||||||
License: LGPL
|
License: LGPL
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
BuildRequires: libgcrypt-devel >= 1.2.2
|
BuildRequires: libgcrypt-devel >= 1.2.2, gettext
|
||||||
BuildRequires: zlib-devel, readline-devel, libtermcap-devel
|
BuildRequires: zlib-devel, readline-devel, libtermcap-devel
|
||||||
#BuildPrereq: libtasn1-devel
|
#BuildPrereq: libtasn1-devel
|
||||||
#BuildPrereq: opencdk-devel
|
#BuildPrereq: opencdk-devel
|
||||||
@ -14,7 +14,8 @@ URL: http://www.gnutls.org/
|
|||||||
# XXX patent tainted SRP code removed.
|
# XXX patent tainted SRP code removed.
|
||||||
Source0: %{name}-%{version}-nosrp.tar.bz2
|
Source0: %{name}-%{version}-nosrp.tar.bz2
|
||||||
Source1: libgnutls-config
|
Source1: libgnutls-config
|
||||||
Patch0: gnutls-1.2.9-nosrp.patch
|
Patch0: gnutls-1.4.0-nosrp.patch
|
||||||
|
Patch1: gnutls-1.4.0-enable-psk.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-root
|
BuildRoot: %{_tmppath}/%{name}-root
|
||||||
Requires: libgcrypt >= 1.2.2
|
Requires: libgcrypt >= 1.2.2
|
||||||
|
|
||||||
@ -52,6 +53,7 @@ manipulation tools.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .nosrp
|
%patch0 -p1 -b .nosrp
|
||||||
|
%patch1 -p1 -b .enable-psk
|
||||||
|
|
||||||
for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
|
for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
|
||||||
touch lib/$i
|
touch lib/$i
|
||||||
@ -72,6 +74,7 @@ rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
|
|||||||
rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
|
rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
|
||||||
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||||
|
%find_lang %{name}
|
||||||
|
|
||||||
%check
|
%check
|
||||||
make check
|
make check
|
||||||
@ -93,7 +96,7 @@ if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
|
|||||||
/sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir
|
/sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir
|
||||||
fi
|
fi
|
||||||
|
|
||||||
%files
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/*.so.*
|
%{_libdir}/*.so.*
|
||||||
|
|
||||||
@ -111,10 +114,15 @@ fi
|
|||||||
%files utils
|
%files utils
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/certtool
|
%{_bindir}/certtool
|
||||||
|
%{_bindir}/psktool
|
||||||
%{_bindir}/gnutls*
|
%{_bindir}/gnutls*
|
||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 14 2006 Tomas Mraz <tmraz@redhat.com> - 1.4.0-1
|
||||||
|
- upgrade to new upstream version (#192070), rebuild
|
||||||
|
of dependent packages required
|
||||||
|
|
||||||
* Tue May 16 2006 Tomas Mraz <tmraz@redhat.com> - 1.2.10-2
|
* Tue May 16 2006 Tomas Mraz <tmraz@redhat.com> - 1.2.10-2
|
||||||
- added missing buildrequires
|
- added missing buildrequires
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user