remove lena images and adjust demos, bz1295324
This commit is contained in:
parent
3203b64bcf
commit
f3be28f7ba
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@
|
||||
/gnuplot-5.0.3.tar.gz
|
||||
/gnuplot-5.0.5.tar.gz
|
||||
/gnuplot-5.0.6.tar.gz
|
||||
/gnuplot-5.0.6-clean.tar.gz
|
||||
|
92
gnuplot-5.0.6-no-lena.patch
Normal file
92
gnuplot-5.0.6-no-lena.patch
Normal file
@ -0,0 +1,92 @@
|
||||
diff -up gnuplot-5.0.6/demo/circles.dem.nolena gnuplot-5.0.6/demo/circles.dem
|
||||
--- gnuplot-5.0.6/demo/circles.dem.nolena 2017-06-26 12:44:54.497798902 -0400
|
||||
+++ gnuplot-5.0.6/demo/circles.dem 2017-06-26 12:45:05.006547459 -0400
|
||||
@@ -98,21 +98,6 @@ pause -1 "Hit return to continue"
|
||||
|
||||
reset
|
||||
set size ratio -1
|
||||
-set title "Lena's key points"
|
||||
-unset xtics
|
||||
-unset ytics
|
||||
-unset key
|
||||
-unset border
|
||||
-set yrange [] reverse
|
||||
-
|
||||
-plot 'lena.rgb' binary array=(128,128) dx=4 dy=4 format='%uchar' with rgbimage, \
|
||||
- 'lena-keypoints.bin' binary format='%double' with circles lc rgb "yellow"
|
||||
-
|
||||
-pause -1 "Hit return to continue"
|
||||
-
|
||||
-
|
||||
-reset
|
||||
-set size ratio -1
|
||||
set title "Delaunay triangulation of Hemisphere points, some empty circles in red"
|
||||
unset key
|
||||
|
||||
diff -up gnuplot-5.0.6/demo/Makefile.am.nolena gnuplot-5.0.6/demo/Makefile.am
|
||||
--- gnuplot-5.0.6/demo/Makefile.am.nolena 2017-06-26 12:44:33.146309782 -0400
|
||||
+++ gnuplot-5.0.6/demo/Makefile.am 2017-06-26 12:44:43.322066306 -0400
|
||||
@@ -64,7 +64,7 @@ epslatex:
|
||||
dvips epslatex
|
||||
|
||||
##m4-files-begin
|
||||
-EXTRA_DIST = Makefile.am.in lena-keypoints.bin scatter2.bin sine.bin \
|
||||
+EXTRA_DIST = Makefile.am.in scatter2.bin sine.bin \
|
||||
using.bin gnuplot.cfg world.cor 1.dat 2.dat 3.dat arrowstyle.dat \
|
||||
asciimat.dat battery.dat big_peak.dat candlesticks.dat cities.dat \
|
||||
clip14in.dat ctg-y2.dat delaunay-edges.dat ellipses.dat empty-circles.dat \
|
||||
@@ -97,7 +97,7 @@ stringvar.dem surface1.dem surface2.dem
|
||||
tics.dem timedat.dem transparent.dem transparent_solids.dem using.dem \
|
||||
utf8.dem varcolor.dem vector.dem world2.dem world.dem demo.edf density.fnc \
|
||||
hexa.fnc line.fnc reflect.fnc gen-random.inc stat.inc GM1_sugar.pdb \
|
||||
-bldg.png GM1_bonds.r3d blutux.rgb lena.rgb sound.par sound2.par start.par \
|
||||
+bldg.png GM1_bonds.r3d blutux.rgb sound.par sound2.par start.par \
|
||||
gnuplot.rot gnu-valley random-points gpdemos.tcl html
|
||||
##m4-files-end
|
||||
|
||||
diff -up gnuplot-5.0.6/demo/Makefile.in.nolena gnuplot-5.0.6/demo/Makefile.in
|
||||
--- gnuplot-5.0.6/demo/Makefile.in.nolena 2017-06-26 12:43:56.569184965 -0400
|
||||
+++ gnuplot-5.0.6/demo/Makefile.in 2017-06-26 12:44:17.562682652 -0400
|
||||
@@ -331,7 +331,7 @@ SUBDIRS = $(PLUGIN_DIR)
|
||||
DIST_SUBDIRS = plugin
|
||||
DEMO = all.dem
|
||||
GNUPLOT = gnuplot
|
||||
-EXTRA_DIST = Makefile.am.in lena-keypoints.bin scatter2.bin sine.bin \
|
||||
+EXTRA_DIST = Makefile.am.in scatter2.bin sine.bin \
|
||||
using.bin gnuplot.cfg world.cor 1.dat 2.dat 3.dat arrowstyle.dat \
|
||||
asciimat.dat battery.dat big_peak.dat candlesticks.dat cities.dat \
|
||||
clip14in.dat ctg-y2.dat delaunay-edges.dat ellipses.dat empty-circles.dat \
|
||||
@@ -364,7 +364,7 @@ stringvar.dem surface1.dem surface2.dem
|
||||
tics.dem timedat.dem transparent.dem transparent_solids.dem using.dem \
|
||||
utf8.dem varcolor.dem vector.dem world2.dem world.dem demo.edf density.fnc \
|
||||
hexa.fnc line.fnc reflect.fnc gen-random.inc stat.inc GM1_sugar.pdb \
|
||||
-bldg.png GM1_bonds.r3d blutux.rgb lena.rgb sound.par sound2.par start.par \
|
||||
+bldg.png GM1_bonds.r3d blutux.rgb sound.par sound2.par start.par \
|
||||
gnuplot.rot gnu-valley random-points gpdemos.tcl html
|
||||
|
||||
@BUILD_PLUGIN_TRUE@PLUGIN_DIR = plugin
|
||||
diff -up gnuplot-5.0.6/demo/rgbalpha.dem.nolena gnuplot-5.0.6/demo/rgbalpha.dem
|
||||
--- gnuplot-5.0.6/demo/rgbalpha.dem.nolena 2017-06-26 12:46:06.232082511 -0400
|
||||
+++ gnuplot-5.0.6/demo/rgbalpha.dem 2017-06-26 12:46:37.431336005 -0400
|
||||
@@ -18,8 +18,8 @@ set yrange [ 0. : 128. ]
|
||||
# Alpha = linear gradient on x
|
||||
|
||||
plot 100.*(.4+sin(x/5.)/(x/5.)) lw 5 title 'solid line', \
|
||||
- 'lena.rgb' binary array=(128,128) format="%uchar" flipy using 1:2:3:(2.*column(0)) \
|
||||
- with rgbalpha title "Lena with linear\nalpha gradient"
|
||||
+ 'blutux.rgb' binary array=(128,128) format="%uchar" flipy using 1:2:3:(2.*column(0)) \
|
||||
+ with rgbalpha title "Tux with linear\nalpha gradient"
|
||||
|
||||
pause -1 "Hit return to continue"
|
||||
|
||||
@@ -28,8 +28,8 @@ pause -1 "Hit return to continue"
|
||||
focus(x,y) = ((column(0)-x)**2 + (column(-1)-(127-y))**2) > 400 ? 0 : 255
|
||||
|
||||
plot 100.*(.4+sin(x/5.)/(x/5.)) lw 5 title 'solid line', \
|
||||
- 'lena.rgb' binary array=(128,128) format="%uchar" flipy using 1:2:3:(focus(70,50)) \
|
||||
- with rgbalpha title "Lena with circular mask"
|
||||
+ 'blutux.rgb' binary array=(128,128) format="%uchar" flipy using 1:2:3:(focus(70,50)) \
|
||||
+ with rgbalpha title "Tux with circular mask"
|
||||
|
||||
pause -1 "Hit return to continue"
|
||||
reset
|
12
gnuplot.spec
12
gnuplot.spec
@ -7,12 +7,15 @@
|
||||
Summary: A program for plotting mathematical expressions and data
|
||||
Name: gnuplot
|
||||
Version: %{major}.%{minor}.%{patchlevel}
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
# MIT .. term/PostScript/aglfn.txt
|
||||
License: gnuplot and MIT
|
||||
Group: Applications/Engineering
|
||||
URL: http://www.gnuplot.info/
|
||||
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
# Need to remove non-free lena files
|
||||
# rm -rf demo/lena*
|
||||
# Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
Source0: %{name}-%{version}-clean.tar.gz
|
||||
Source1: gnuplot-init.el
|
||||
|
||||
Patch0: gnuplot-4.2.0-refers_to.patch
|
||||
@ -22,6 +25,7 @@ Patch1: gnuplot-4.2.0-fonts.patch
|
||||
Patch3: gnuplot-4.6.1-plot-sigsegv.patch
|
||||
Patch4: gnuplot-4.6.4-singlethread.patch
|
||||
Patch5: gnuplot-5.0.0-lua_checkint.patch
|
||||
Patch6: gnuplot-5.0.6-no-lena.patch
|
||||
|
||||
Requires: %{name}-common = %{version}-%{release}
|
||||
Requires: dejavu-sans-fonts
|
||||
@ -154,6 +158,7 @@ plotting tool.
|
||||
%patch3 -p1 -b .plot-sigsegv
|
||||
%patch4 -p1 -b .isinglethread
|
||||
%patch5 -p1 -b .checkint
|
||||
%patch6 -p1 -b .nolena
|
||||
sed -i -e 's:"/usr/lib/X11/app-defaults":"%{x11_app_defaults_dir}":' src/gplt_x11.c
|
||||
iconv -f windows-1252 -t utf-8 ChangeLog > ChangeLog.aux
|
||||
mv ChangeLog.aux ChangeLog
|
||||
@ -341,6 +346,9 @@ fi
|
||||
%{_datadir}/texmf/tex/latex/gnuplot/
|
||||
|
||||
%changelog
|
||||
* Mon Jun 26 2017 Tom Callaway <spot@fedoraproject.org> - 5.0.6-3
|
||||
- remove non-free lena images (and adjust demos) (bz1295324)
|
||||
|
||||
* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gnuplot-5.0.6.tar.gz) = 7f9b05725a8594dcfbf1f1fc8f1db9bf45e1b6841fa1089b2c2528a3e36f71baab16d5fbeb027e4dd3618461a4895d037cb9f43781bfee2cb078cb9583567d8d
|
||||
SHA512 (gnuplot-5.0.6-clean.tar.gz) = b2f974c02e4120c27e4107ed87720d0f317cb3b888dbc51781afcab18469b19d178ed181fd5fe5ccd55bff025c1747147f804942baafe6f93edc9d8ed32feaa5
|
||||
|
Loading…
Reference in New Issue
Block a user