Update to 5.4.2
This commit is contained in:
parent
31a8cb2f1b
commit
92274d61c9
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@
|
||||
/gnuplot-5.0.6-clean.tar.gz
|
||||
/gnuplot-5.2.4-clean.tar.gz
|
||||
/gnuplot-5.2.8-clean.tar.gz
|
||||
/gnuplot-5.4.2-clean.tar.gz
|
||||
|
@ -1,11 +1,12 @@
|
||||
diff -up gnuplot-5.2.4/demo/circles.dem.nolena gnuplot-5.2.4/demo/circles.dem
|
||||
--- gnuplot-5.2.4/demo/circles.dem.nolena 2017-12-22 18:32:30.000000000 +0100
|
||||
+++ gnuplot-5.2.4/demo/circles.dem 2018-08-08 10:14:21.308379527 +0200
|
||||
@@ -98,21 +98,6 @@ pause -1 "Hit return to continue"
|
||||
diff -up gnuplot-5.4.2/demo/circles.dem.nolena gnuplot-5.4.2/demo/circles.dem
|
||||
--- gnuplot-5.4.2/demo/circles.dem.nolena 2021-08-03 21:18:34.337717507 -0600
|
||||
+++ gnuplot-5.4.2/demo/circles.dem 2021-08-03 21:20:36.298806964 -0600
|
||||
@@ -66,22 +66,6 @@ pause -1 "Hit return to continue"
|
||||
|
||||
reset
|
||||
set size ratio -1
|
||||
-set title "Lena's key points"
|
||||
-unset xlabel
|
||||
-unset xtics
|
||||
-unset ytics
|
||||
-unset key
|
||||
@ -23,9 +24,9 @@ diff -up gnuplot-5.2.4/demo/circles.dem.nolena gnuplot-5.2.4/demo/circles.dem
|
||||
set title "Delaunay triangulation of Hemisphere points, some empty circles in red"
|
||||
unset key
|
||||
|
||||
diff -up gnuplot-5.2.4/demo/Makefile.am.nolena gnuplot-5.2.4/demo/Makefile.am
|
||||
--- gnuplot-5.2.4/demo/Makefile.am.nolena 2017-12-23 07:29:12.000000000 +0100
|
||||
+++ gnuplot-5.2.4/demo/Makefile.am 2018-08-08 10:18:08.787797877 +0200
|
||||
diff -up gnuplot-5.4.2/demo/Makefile.am.nolena gnuplot-5.4.2/demo/Makefile.am
|
||||
--- gnuplot-5.4.2/demo/Makefile.am.nolena 2021-08-03 21:18:34.338717516 -0600
|
||||
+++ gnuplot-5.4.2/demo/Makefile.am 2021-08-03 21:19:37.044277654 -0600
|
||||
@@ -68,7 +68,7 @@ epslatex:
|
||||
dvips epslatex
|
||||
|
||||
@ -34,20 +35,20 @@ diff -up gnuplot-5.2.4/demo/Makefile.am.nolena gnuplot-5.2.4/demo/Makefile.am
|
||||
+EXTRA_DIST = Makefile.am.in scatter2.bin sine.bin \
|
||||
using.bin gnuplot.cfg world.cor 1.dat 2.dat 3.dat arrowstyle.dat \
|
||||
asciimat.dat battery.dat big_peak.dat candlesticks.dat cities.dat \
|
||||
clip14in.dat ctg-y2.dat delaunay-edges.dat ellipses.dat empty-circles.dat \
|
||||
@@ -107,7 +107,7 @@ textrotate.dem tics.dem timedat.dem tran
|
||||
ttics.dem using.dem utf8.dem varcolor.dem vector.dem violinplot.dem \
|
||||
volatile.dem world2.dem world.dem zerror.dem demo.edf density.fnc \
|
||||
hexa.fnc line.fnc reflect.fnc gen-random.inc stat.inc GM1_sugar.pdb \
|
||||
-bldg.png GM1_bonds.r3d blutux.rgb lena.rgb sound.par sound2.par start.par \
|
||||
+bldg.png GM1_bonds.r3d blutux.rgb sound.par sound2.par start.par \
|
||||
gnuplot.rot gnu-valley random-points gpdemos.tcl html
|
||||
clip14in.dat ctg-y2.dat delaunay-edges.dat dodecahedron.dat ellipses.dat \
|
||||
@@ -115,7 +115,7 @@ ttics.dem unicode.dem using.dem utf8.dem
|
||||
violinplot.dem volatile.dem voxel.dem vplot.dem walls.dem week_date.dem \
|
||||
world2.dem world.dem zerror.dem demo.edf density.fnc hexa.fnc line.fnc \
|
||||
reflect.fnc gen-random.inc stat.inc GM1_sugar.pdb aries.png bldg.png \
|
||||
-gradient.png icon64x64.png GM1_bonds.r3d blutux.rgb lena.rgb sound.par \
|
||||
+gradient.png icon64x64.png GM1_bonds.r3d blutux.rgb sound.par \
|
||||
sound2.par start.par gnuplot.rot gnu-valley random-points gpdemos.tcl html
|
||||
##m4-files-end
|
||||
|
||||
diff -up gnuplot-5.2.4/demo/Makefile.in.nolena gnuplot-5.2.4/demo/Makefile.in
|
||||
--- gnuplot-5.2.4/demo/Makefile.in.nolena 2018-06-01 03:51:13.000000000 +0200
|
||||
+++ gnuplot-5.2.4/demo/Makefile.in 2018-08-08 10:18:14.455683660 +0200
|
||||
@@ -330,7 +330,7 @@ SUBDIRS = $(PLUGIN_DIR)
|
||||
diff -up gnuplot-5.4.2/demo/Makefile.in.nolena gnuplot-5.4.2/demo/Makefile.in
|
||||
--- gnuplot-5.4.2/demo/Makefile.in.nolena 2021-08-03 21:18:34.340717534 -0600
|
||||
+++ gnuplot-5.4.2/demo/Makefile.in 2021-08-03 21:20:03.262511857 -0600
|
||||
@@ -340,7 +340,7 @@ SUBDIRS = $(PLUGIN_DIR)
|
||||
DIST_SUBDIRS = plugin
|
||||
DEMO = all.dem
|
||||
GNUPLOT = gnuplot
|
||||
@ -55,19 +56,19 @@ diff -up gnuplot-5.2.4/demo/Makefile.in.nolena gnuplot-5.2.4/demo/Makefile.in
|
||||
+EXTRA_DIST = Makefile.am.in scatter2.bin sine.bin \
|
||||
using.bin gnuplot.cfg world.cor 1.dat 2.dat 3.dat arrowstyle.dat \
|
||||
asciimat.dat battery.dat big_peak.dat candlesticks.dat cities.dat \
|
||||
clip14in.dat ctg-y2.dat delaunay-edges.dat ellipses.dat empty-circles.dat \
|
||||
@@ -369,7 +369,7 @@ textrotate.dem tics.dem timedat.dem tran
|
||||
ttics.dem using.dem utf8.dem varcolor.dem vector.dem violinplot.dem \
|
||||
volatile.dem world2.dem world.dem zerror.dem demo.edf density.fnc \
|
||||
hexa.fnc line.fnc reflect.fnc gen-random.inc stat.inc GM1_sugar.pdb \
|
||||
-bldg.png GM1_bonds.r3d blutux.rgb lena.rgb sound.par sound2.par start.par \
|
||||
+bldg.png GM1_bonds.r3d blutux.rgb sound.par sound2.par start.par \
|
||||
gnuplot.rot gnu-valley random-points gpdemos.tcl html
|
||||
clip14in.dat ctg-y2.dat delaunay-edges.dat dodecahedron.dat ellipses.dat \
|
||||
@@ -387,7 +387,7 @@ ttics.dem unicode.dem using.dem utf8.dem
|
||||
violinplot.dem volatile.dem voxel.dem vplot.dem walls.dem week_date.dem \
|
||||
world2.dem world.dem zerror.dem demo.edf density.fnc hexa.fnc line.fnc \
|
||||
reflect.fnc gen-random.inc stat.inc GM1_sugar.pdb aries.png bldg.png \
|
||||
-gradient.png icon64x64.png GM1_bonds.r3d blutux.rgb lena.rgb sound.par \
|
||||
+gradient.png icon64x64.png GM1_bonds.r3d blutux.rgb sound.par \
|
||||
sound2.par start.par gnuplot.rot gnu-valley random-points gpdemos.tcl html
|
||||
|
||||
@BUILD_PLUGIN_TRUE@PLUGIN_DIR = plugin
|
||||
diff -up gnuplot-5.2.4/demo/rgbalpha.dem.nolena gnuplot-5.2.4/demo/rgbalpha.dem
|
||||
--- gnuplot-5.2.4/demo/rgbalpha.dem.nolena 2017-12-22 18:32:30.000000000 +0100
|
||||
+++ gnuplot-5.2.4/demo/rgbalpha.dem 2018-08-08 10:14:21.309379507 +0200
|
||||
diff -up gnuplot-5.4.2/demo/rgbalpha.dem.nolena gnuplot-5.4.2/demo/rgbalpha.dem
|
||||
--- gnuplot-5.4.2/demo/rgbalpha.dem.nolena 2017-12-22 10:32:30.000000000 -0700
|
||||
+++ gnuplot-5.4.2/demo/rgbalpha.dem 2021-08-03 21:18:34.341717543 -0600
|
||||
@@ -18,8 +18,8 @@ set yrange [ 0. : 128. ]
|
||||
# Alpha = linear gradient on x
|
||||
|
43
gnuplot.spec
43
gnuplot.spec
@ -1,6 +1,6 @@
|
||||
%global major 5
|
||||
%global minor 2
|
||||
%global patchlevel 8
|
||||
%global minor 4
|
||||
%global patchlevel 2
|
||||
|
||||
%global x11_app_defaults_dir %{_datadir}/X11/app-defaults
|
||||
|
||||
@ -19,7 +19,7 @@
|
||||
Summary: A program for plotting mathematical expressions and data
|
||||
Name: gnuplot
|
||||
Version: %{major}.%{minor}.%{patchlevel}
|
||||
Release: 11%{?dist}
|
||||
Release: 1%{?dist}
|
||||
# MIT .. term/PostScript/aglfn.txt
|
||||
License: gnuplot and MIT
|
||||
URL: http://www.gnuplot.info/
|
||||
@ -29,14 +29,13 @@ URL: http://www.gnuplot.info/
|
||||
Source0: %{name}-%{version}-clean.tar.gz
|
||||
Source1: gnuplot-init.el
|
||||
|
||||
Patch0: gnuplot-4.2.0-refers_to.patch
|
||||
Patch1: gnuplot-4.2.0-fonts.patch
|
||||
# resolves: #812225
|
||||
# submitted upstream: http://sourceforge.net/tracker/?func=detail&aid=3558973&group_id=2055&atid=302055
|
||||
Patch3: gnuplot-4.6.1-plot-sigsegv.patch
|
||||
Patch4: gnuplot-4.6.4-singlethread.patch
|
||||
Patch5: gnuplot-5.0.0-lua_checkint.patch
|
||||
Patch6: gnuplot-5.2.4-no-lena.patch
|
||||
Patch6: gnuplot-5.4.2-no-lena.patch
|
||||
Patch7: gnuplot-5.2.2-doc.patch
|
||||
Patch8: gnuplot-5.2.8-cmd-opts.patch
|
||||
Patch9: gnuplot-config.patch
|
||||
@ -171,7 +170,6 @@ plotting tool.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .refto
|
||||
%patch1 -p1 -b .font
|
||||
%patch3 -p1 -b .plot-sigsegv
|
||||
%patch4 -p1 -b .isinglethread
|
||||
@ -182,8 +180,6 @@ plotting tool.
|
||||
%patch9 -p1 -b .config
|
||||
%patch20 -p1 -b .qlist-index
|
||||
sed -i -e 's:"/usr/lib/X11/app-defaults":"%{x11_app_defaults_dir}":' src/gplt_x11.c
|
||||
iconv -f windows-1252 -t utf-8 ChangeLog > ChangeLog.aux
|
||||
mv ChangeLog.aux ChangeLog
|
||||
chmod 644 src/getcolor.h
|
||||
chmod 644 demo/html/webify.pl
|
||||
chmod 644 demo/html/webify_svg.pl
|
||||
@ -193,7 +189,7 @@ chmod 644 demo/html/webify_canvas.pl
|
||||
#remove binaries from source tarball
|
||||
rm -rf demo/plugin/*.so demo/plugin/*.o
|
||||
|
||||
%global configure_opts --with-readline=builtin --without-linux-vga \\\
|
||||
%global configure_opts --with-readline=builtin \\\
|
||||
--enable-history-file --with-texdir=/usr/share/texlive/texmf-dist/tex/latex/gnuplot
|
||||
|
||||
# at first create minimal version of gnuplot for server SIG purposes
|
||||
@ -225,13 +221,12 @@ cd -
|
||||
|
||||
|
||||
# Docs don't build properly out of tree
|
||||
%configure %{configure_opts} --with-tutorial
|
||||
%configure %{configure_opts}
|
||||
ln -s ../minimal/src/gnuplot src/
|
||||
make -C docs html info
|
||||
export GNUPLOT_PS_DIR=../../term/PostScript
|
||||
make -C docs/psdoc ps_symbols.ps ps_fontfile_doc.pdf
|
||||
rm -rf docs/htmldocs/images.idx
|
||||
make -C tutorial
|
||||
|
||||
%install
|
||||
%if %{with wx}
|
||||
@ -267,8 +262,6 @@ mkdir -p $RPM_BUILD_ROOT%{x11_app_defaults_dir}
|
||||
mv $RPM_BUILD_ROOT%{_datadir}/gnuplot/%{major}.%{minor}/app-defaults/Gnuplot $RPM_BUILD_ROOT%{x11_app_defaults_dir}/Gnuplot
|
||||
rm -rf $RPM_BUILD_ROOT%{_libdir}/
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT/%{_mandir}/ja/man1
|
||||
mv $RPM_BUILD_ROOT%{_mandir}/man1/gnuplot-ja.1 $RPM_BUILD_ROOT/%{_mandir}/ja/man1/
|
||||
ln -s gnuplot.1 $RPM_BUILD_ROOT/%{_mandir}/man1/gnuplot-qt.1
|
||||
%if %{with wx}
|
||||
ln -s gnuplot.1 $RPM_BUILD_ROOT/%{_mandir}/man1/gnuplot-wx.1
|
||||
@ -310,18 +303,18 @@ fi
|
||||
|
||||
%files
|
||||
%ghost %attr(0755,-,-) %{_bindir}/gnuplot
|
||||
%doc ChangeLog Copyright
|
||||
%doc Copyright
|
||||
%{_bindir}/gnuplot-qt
|
||||
%{_libexecdir}/gnuplot/%{major}.%{minor}/gnuplot_qt
|
||||
%{_datadir}/gnuplot/%{major}.%{minor}/qt/
|
||||
|
||||
%files doc
|
||||
%doc ChangeLog Copyright
|
||||
%doc docs/psdoc/ps_guide.ps docs/psdoc/ps_symbols.ps tutorial/tutorial.dvi docs/psdoc/ps_file.doc demo
|
||||
%doc docs/psdoc/ps_fontfile_doc.pdf docs/htmldocs tutorial/eg7.eps
|
||||
%doc Copyright
|
||||
%doc docs/psdoc/ps_guide.ps docs/psdoc/ps_symbols.ps docs/psdoc/ps_file.doc demo
|
||||
%doc docs/psdoc/ps_fontfile_doc.pdf docs/htmldocs
|
||||
|
||||
%files common
|
||||
%doc BUGS ChangeLog Copyright NEWS README
|
||||
%doc BUGS Copyright FAQ.pdf NEWS README RELEASE_NOTES
|
||||
%{_mandir}/man1/gnuplot.1.gz
|
||||
%{_mandir}/man1/gnuplot-qt.1.gz
|
||||
%dir %{_datadir}/gnuplot
|
||||
@ -341,38 +334,40 @@ fi
|
||||
%{_libexecdir}/gnuplot/%{major}.%{minor}/gnuplot_x11
|
||||
%{x11_app_defaults_dir}/Gnuplot
|
||||
%{_infodir}/gnuplot.info.*
|
||||
%{_mandir}/ja/man1/gnuplot-ja.1.gz
|
||||
|
||||
%files minimal
|
||||
%ghost %attr(0755,-,-) %{_bindir}/gnuplot
|
||||
%doc ChangeLog Copyright
|
||||
%doc Copyright
|
||||
%{_bindir}/gnuplot-minimal
|
||||
|
||||
%if %{with wx}
|
||||
%files wx
|
||||
%ghost %attr(0755,-,-) %{_bindir}/gnuplot
|
||||
%{_mandir}/man1/gnuplot-wx.1.gz
|
||||
%doc ChangeLog Copyright
|
||||
%doc Copyright
|
||||
%{_bindir}/gnuplot-wx
|
||||
%endif
|
||||
|
||||
#%files -n emacs-%{name}
|
||||
#%doc ChangeLog Copyright
|
||||
#%doc Copyright
|
||||
#%dir %{_emacs_sitelispdir}/%{name}
|
||||
#%{_emacs_sitelispdir}/*.elc
|
||||
#%{_emacs_sitelispdir}/%{name}/*.elc
|
||||
#%{_emacs_sitestartdir}/*.el
|
||||
|
||||
#%files -n emacs-%{name}-el
|
||||
#%doc ChangeLog Copyright
|
||||
#%doc Copyright
|
||||
#%{_emacs_sitelispdir}/%{name}/*.el
|
||||
#%{_emacs_sitelispdir}/*.el
|
||||
|
||||
%files latex
|
||||
%doc ChangeLog Copyright
|
||||
%doc Copyright
|
||||
%{_datadir}/texlive/texmf-dist/tex/latex/gnuplot/
|
||||
|
||||
%changelog
|
||||
* Tue Aug 03 2021 Orion Poplawski <orion@nwra.com> - 5.4.2-1
|
||||
- Update to 5.4.2
|
||||
|
||||
* Thu Aug 05 2021 Vasiliy N. Glazov <vascom2@gmail.com> - 5.2.8-11
|
||||
- Fix Qlist error message #1970658
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gnuplot-5.2.8-clean.tar.gz) = 5a66d730b31995a5530b0cc57c63337fb14ff573a6b88423e01174a77c398914686a080ed2843754d643edc44781132edc3dafaa5cbdc63466814ccfade469d8
|
||||
SHA512 (gnuplot-5.4.2-clean.tar.gz) = c0c095c761787e57e22e97b14287604cc2cb13e0c820d9c05450f4cfc4e7126eab818f6dc4eca48ff15dd53cb5586f52df911c18dcd8cc7083255c5196d035a9
|
||||
|
Loading…
Reference in New Issue
Block a user