- Resolves: #231205 update to 4.2.0 spec changes from Tim Orling
This commit is contained in:
parent
08e219374b
commit
8a0986461c
@ -1 +1 @@
|
|||||||
gnuplot-4.0.0.tar.gz
|
gnuplot-4.2.0.tar.gz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -uNr gnuplot-4.0.0.orig/src/gplt_x11.c gnuplot-4.0.0/src/gplt_x11.c
|
|
||||||
--- gnuplot-4.0.0.orig/src/gplt_x11.c 2004-04-13 19:23:53.000000000 +0200
|
|
||||||
+++ gnuplot-4.0.0/src/gplt_x11.c 2005-10-15 19:23:38.000000000 +0200
|
|
||||||
@@ -1104,7 +1104,7 @@
|
|
||||||
read_input()
|
|
||||||
{
|
|
||||||
static int rdbuf_size = 10 * Nbuf;
|
|
||||||
- static char rdbuf[10 * Nbuf - 1];
|
|
||||||
+ static char rdbuf[10 * Nbuf];
|
|
||||||
static int total_chars;
|
|
||||||
static int rdbuf_offset;
|
|
||||||
static int buf_offset;
|
|
11
gnuplot-4.2.0-ver.patch
Normal file
11
gnuplot-4.2.0-ver.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- gnuplot-4.2.0/docs/psdoc/Makefile.pom 2002-12-16 15:17:52.000000000 +0100
|
||||||
|
+++ gnuplot-4.2.0/docs/psdoc/Makefile 2007-05-21 12:39:03.000000000 +0200
|
||||||
|
@@ -2,7 +2,7 @@
|
||||||
|
# Create ps_symbols.ps
|
||||||
|
#
|
||||||
|
|
||||||
|
-top_srcdir = ../..
|
||||||
|
+top_srcdir =
|
||||||
|
|
||||||
|
all: ps_symbols.ps ps_fontfile_doc.ps
|
||||||
|
|
38
gnuplot.spec
38
gnuplot.spec
@ -1,16 +1,21 @@
|
|||||||
|
%define major 4
|
||||||
|
%define minor 2
|
||||||
|
%define patchlevel 0
|
||||||
|
|
||||||
Summary: A program for plotting mathematical expressions and data
|
Summary: A program for plotting mathematical expressions and data
|
||||||
Name: gnuplot
|
Name: gnuplot
|
||||||
Version: 4.0.0
|
Version: %{major}.%{minor}.%{patchlevel}
|
||||||
Release: 18%{?dist}
|
Release: 1%{?dist}
|
||||||
License: distributable
|
License: distributable
|
||||||
# Modifications are to be distributed as patches to the released version.
|
# Modifications are to be distributed as patches to the released version.
|
||||||
Group: Applications/Engineering
|
Group: Applications/Engineering
|
||||||
Source: http://prdownloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
Source2: gnuplot-init.el
|
Source2: gnuplot-init.el
|
||||||
Patch0: gnuplot-4.0.0-x11segv.patch
|
|
||||||
Patch1: gnuplot-4.0.0-refers_to.patch
|
Patch1: gnuplot-4.0.0-refers_to.patch
|
||||||
|
Patch2: gnuplot-4.2.0-ver.patch
|
||||||
BuildRequires: libpng-devel, tetex-latex, zlib-devel, libX11-devel, emacs
|
BuildRequires: libpng-devel, tetex-latex, zlib-devel, libX11-devel, emacs
|
||||||
BuildRequires: texinfo, readline-devel, libXt-devel, gd-devel
|
BuildRequires: texinfo, readline-devel, libXt-devel, gd-devel
|
||||||
|
Requires: latex2html
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
URL: http://www.gnuplot.info/
|
URL: http://www.gnuplot.info/
|
||||||
|
|
||||||
@ -34,16 +39,15 @@ nicely interacts and integrates into emacs.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p 1 -b .x11segv
|
|
||||||
%patch1 -p1 -b .refto
|
%patch1 -p1 -b .refto
|
||||||
|
%patch2 -p1 -b .ver
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --with-readline=gnu --with-png --without-linux-vga \
|
%configure --with-readline=gnu --with-png --without-linux-vga \
|
||||||
--enable-history-file
|
--enable-history-file
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
|
||||||
|
|
||||||
rm demo/webify.pl
|
|
||||||
cd docs
|
cd docs
|
||||||
make html
|
make html
|
||||||
cd psdoc
|
cd psdoc
|
||||||
@ -69,16 +73,21 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc BUGS ChangeLog Copyright FAQ NEWS README TODO docs/gnuplot.html
|
%doc BUGS ChangeLog Copyright FAQ NEWS README TODO
|
||||||
|
#docs/gnuplot.html
|
||||||
%doc docs/psdoc/ps_guide.ps docs/psdoc/ps_symbols.gpi tutorial/tutorial.dvi demo
|
%doc docs/psdoc/ps_guide.ps docs/psdoc/ps_symbols.gpi tutorial/tutorial.dvi demo
|
||||||
%dir %{_libexecdir}/gnuplot
|
%dir %{_libexecdir}/gnuplot
|
||||||
%dir %{_libexecdir}/gnuplot/4.0
|
%dir %{_libexecdir}/gnuplot/%{major}.%{minor}
|
||||||
%{_libexecdir}/gnuplot/4.0/gnuplot_x11
|
%{_libexecdir}/gnuplot/%{major}.%{minor}/gnuplot_x11
|
||||||
%{_bindir}/gnuplot
|
%{_bindir}/gnuplot
|
||||||
%{_mandir}/man1/gnuplot.1.gz
|
%{_mandir}/man1/gnuplot.1.gz
|
||||||
%dir %{_datadir}/gnuplot
|
%dir %{_datadir}/gnuplot
|
||||||
%dir %{_datadir}/gnuplot/4.0
|
%dir %{_datadir}/gnuplot/%{major}.%{minor}
|
||||||
%{_datadir}/gnuplot/4.0/gnuplot.gih
|
%dir %{_datadir}/gnuplot/%{major}.%{minor}/PostScript
|
||||||
|
%{_datadir}/gnuplot/%{major}.%{minor}/PostScript/*.ps
|
||||||
|
%{_datadir}/gnuplot/%{major}.%{minor}/gnuplot.gih
|
||||||
|
%{_datadir}/texmf/tex/latex/gnuplot/gnuplot.cfg
|
||||||
|
%{_libdir}/X11/app-defaults/Gnuplot.app-defaults
|
||||||
%{_infodir}/gnuplot.info.gz
|
%{_infodir}/gnuplot.info.gz
|
||||||
|
|
||||||
%files emacs
|
%files emacs
|
||||||
@ -93,6 +102,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 21 2007 Ivana Varekova <varekova@redhat.com> - 4.2.0-1
|
||||||
|
- Resolves: #231205
|
||||||
|
update to 4.2.0
|
||||||
|
spec changes from Tim Orling
|
||||||
|
|
||||||
* Mon Mar 26 2007 Ivana Varekova <varekova@redhat.com> - 4.0.0-18
|
* Mon Mar 26 2007 Ivana Varekova <varekova@redhat.com> - 4.0.0-18
|
||||||
- add missing directories (#233838)
|
- add missing directories (#233838)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user