parent
d3e8e148ec
commit
2c78bb5940
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/gnuplot-4.4.4.tar.gz
|
||||
/gnuplot-4.6.0.tar.gz
|
||||
|
@ -1,15 +0,0 @@
|
||||
diff -up gnuplot-4.4.1/man/gnuplot.1.pom gnuplot-4.4.1/man/gnuplot.1
|
||||
--- gnuplot-4.4.1/man/gnuplot.1.pom 2009-02-18 05:03:52.000000000 +0100
|
||||
+++ gnuplot-4.4.1/man/gnuplot.1 2010-09-24 14:58:00.000000000 +0200
|
||||
@@ -236,8 +236,8 @@ gnuplot. None of these are required.
|
||||
.TP
|
||||
.B GNUTERM
|
||||
The name of the terminal type to be used. This overrides any terminal
|
||||
-type sensed by gnuplot on start-up, but is itself overridden by the
|
||||
-.gnuplot (or equivalent) start-up file (see \fBFILES\fP and "help
|
||||
+type sensed by gnuplot on start-up, but is itself overridden by the .gnuplot
|
||||
+(or equivalent) start-up file (see \fBFILES\fP and "help
|
||||
start-up") and, of course, by later explicit changes.
|
||||
.TP
|
||||
.B GNUHELP
|
||||
diff -up gnuplot-4.4.1/man/.pom gnuplot-4.4.1/man/
|
@ -1,11 +0,0 @@
|
||||
diff -up gnuplot-4.4.4/term/lua/gnuplot-tikz.lua.tikz gnuplot-4.4.4/term/lua/gnuplot-tikz.lua
|
||||
--- gnuplot-4.4.4/term/lua/gnuplot-tikz.lua.tikz 2011-11-13 00:57:15.000000000 +0100
|
||||
+++ gnuplot-4.4.4/term/lua/gnuplot-tikz.lua 2012-01-06 10:55:45.157816216 +0100
|
||||
@@ -251,6 +251,7 @@ pgf.write_graph_begin = function (font,
|
||||
gp.write(string.format("\\begin{tikzpicture}[gnuplot%s]\n",global_opt))
|
||||
gp.write(string.format("%%%% generated with GNUPLOT %sp%s (%s; terminal rev. %s, script rev. %s)\n%%%% %s\n",
|
||||
term.gp_version, term.gp_patchlevel,
|
||||
+ _VERSION,
|
||||
string.sub(term.lua_term_revision,7,-3),
|
||||
pgf.REVISION,os.date()))
|
||||
if font ~= "" then
|
29
gnuplot.spec
29
gnuplot.spec
@ -1,13 +1,13 @@
|
||||
%define major 4
|
||||
%define minor 4
|
||||
%define patchlevel 4
|
||||
%define minor 6
|
||||
%define patchlevel 0
|
||||
|
||||
%define x11_app_defaults_dir %{_datadir}/X11/app-defaults
|
||||
|
||||
Summary: A program for plotting mathematical expressions and data
|
||||
Name: gnuplot
|
||||
Version: %{major}.%{minor}.%{patchlevel}
|
||||
Release: 3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
# Modifications are to be distributed as patches to the released version.
|
||||
# aglfn.txt has license: MIT
|
||||
License: gnuplot and MIT
|
||||
@ -17,12 +17,10 @@ Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
Source2: gnuplot-init.el
|
||||
Patch1: gnuplot-4.2.0-refers_to.patch
|
||||
Patch2: gnuplot-4.2.0-fonts.patch
|
||||
Patch3: gnuplot-4.4.1-mp.patch
|
||||
Patch4: gnuplot-4.4.4-tikz.patch
|
||||
BuildRequires: libpng-devel, tex(latex), zlib-devel, libX11-devel, emacs
|
||||
BuildRequires: texinfo, readline-devel, libXt-devel, gd-devel, latex2html
|
||||
BuildRequires: librsvg2, giflib-devel, libotf, m17n-lib-flt, lua-devel
|
||||
BuildRequires: pango-devel, cairo-devel, texlive-texmf-latex
|
||||
BuildRequires: pango-devel, cairo-devel, texlive-texmf-latex, tex4ht
|
||||
%if !0%{?rhel:1}
|
||||
BuildRequires: wxGTK-devel
|
||||
%endif
|
||||
@ -123,8 +121,6 @@ plotting tool.
|
||||
%setup -q
|
||||
%patch1 -p1 -b .refto
|
||||
%patch2 -p1 -b .font
|
||||
%patch3 -p1 -b .mp
|
||||
%patch4 -p1 -b .tikz
|
||||
sed -i -e 's:"/usr/lib/X11/app-defaults":"%{x11_app_defaults_dir}":' src/gplt_x11.c
|
||||
iconv -f windows-1252 -t utf-8 ChangeLog > ChangeLog.aux
|
||||
mv ChangeLog.aux ChangeLog
|
||||
@ -147,11 +143,11 @@ make clean
|
||||
%if !0%{?rhel:1}
|
||||
# Fedora
|
||||
%configure --with-readline=gnu --with-png --without-linux-vga \
|
||||
--enable-history-file
|
||||
--enable-history-file --with-tutorial
|
||||
%else
|
||||
# RHEL - without wxWidgets support
|
||||
%configure --with-readline=gnu --with-png --without-linux-vga \
|
||||
--enable-history-file --disable-wxwidgets
|
||||
--enable-history-file --with-tutorial --disable-wxwidgets
|
||||
%endif
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -238,9 +234,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/gnuplot/%{major}.%{minor}/PostScript/aglfn.txt
|
||||
%dir %{_datadir}/gnuplot/%{major}.%{minor}/js
|
||||
%{_datadir}/gnuplot/%{major}.%{minor}/js/*
|
||||
%dir %{_datadir}/gnuplot/4.4/lua/
|
||||
/usr/share/gnuplot/4.4/lua/gnuplot-tikz.lua
|
||||
%dir %{_datadir}/gnuplot/%{major}.%{minor}/lua/
|
||||
%{_datadir}/gnuplot/%{major}.%{minor}/lua/gnuplot-tikz.lua
|
||||
%{_datadir}/gnuplot/%{major}.%{minor}/colors_*
|
||||
%{_datadir}/gnuplot/%{major}.%{minor}/gnuplot.gih
|
||||
%{_datadir}/gnuplot/%{major}.%{minor}/gnuplotrc
|
||||
%dir %{_libexecdir}/gnuplot
|
||||
%dir %{_libexecdir}/gnuplot/%{major}.%{minor}
|
||||
%{_libexecdir}/gnuplot/%{major}.%{minor}/gnuplot_x11
|
||||
@ -268,10 +266,13 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%defattr(-,root,root,-)
|
||||
%doc ChangeLog Copyright
|
||||
%dir %{_datadir}/texmf/tex/latex/gnuplot
|
||||
%{_datadir}/texmf/tex/latex/gnuplot/gnuplot.cfg
|
||||
%{_datadir}/texmf/tex/latex/gnuplot/gnuplot-lua-tikz.sty
|
||||
%{_datadir}/texmf/tex/latex/gnuplot/*
|
||||
|
||||
%changelog
|
||||
* Thu Jul 12 2012 Peter Schiffer <pschiffe@redhat.com> 4.6.0-1
|
||||
- resolves: #783421
|
||||
update to 4.6.0
|
||||
|
||||
* Wed Jan 18 2012 Peter Schiffer <pschiffe@redhat.com> 4.4.4-3
|
||||
- resolves: #761260
|
||||
disabled wxWidgets support for RHEL
|
||||
|
Loading…
Reference in New Issue
Block a user