update to 2.4.1
Remove systemd user unit files which have been dropped upstream (rhbz#2158627).
This commit is contained in:
parent
7a08af2ffa
commit
e5239dd1e4
@ -1,7 +1,19 @@
|
||||
diff -up gnupg-2.2.20/g10/gpg.c.file-is-digest gnupg-2.2.20/g10/gpg.c
|
||||
--- gnupg-2.2.20/g10/gpg.c.file-is-digest 2020-04-14 16:33:42.630269318 +0200
|
||||
+++ gnupg-2.2.20/g10/gpg.c 2020-04-14 16:34:46.455100086 +0200
|
||||
@@ -380,6 +380,7 @@ enum cmd_and_opt_values
|
||||
From cdd5082a9e3bdfc8de4aee4835dbdd607b4510be Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Tom=C3=A1=C5=A1=20Mr=C3=A1z?= <tmraz@fedoraproject.org>
|
||||
Date: Tue, 5 Aug 2014 17:04:08 +0200
|
||||
Subject: [PATCH gnupg] add --file-is-digest option needed for copr
|
||||
|
||||
---
|
||||
g10/gpg.c | 4 +++
|
||||
g10/options.h | 1 +
|
||||
g10/sign.c | 93 ++++++++++++++++++++++++++++++++++++++++++++-------
|
||||
3 files changed, 85 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/g10/gpg.c b/g10/gpg.c
|
||||
index f9bc8395f..dcab0a11a 100644
|
||||
--- a/g10/gpg.c
|
||||
+++ b/g10/gpg.c
|
||||
@@ -395,6 +395,7 @@ enum cmd_and_opt_values
|
||||
oTTYtype,
|
||||
oLCctype,
|
||||
oLCmessages,
|
||||
@ -9,7 +21,7 @@ diff -up gnupg-2.2.20/g10/gpg.c.file-is-digest gnupg-2.2.20/g10/gpg.c
|
||||
oXauthority,
|
||||
oGroup,
|
||||
oUnGroup,
|
||||
@@ -831,6 +832,7 @@ static ARGPARSE_OPTS opts[] = {
|
||||
@@ -656,6 +657,7 @@ static gpgrt_opt_t opts[] = {
|
||||
ARGPARSE_s_s (oTempDir, "temp-directory", "@"),
|
||||
ARGPARSE_s_s (oExecPath, "exec-path", "@"),
|
||||
ARGPARSE_s_n (oExpert, "expert", "@"),
|
||||
@ -17,7 +29,7 @@ diff -up gnupg-2.2.20/g10/gpg.c.file-is-digest gnupg-2.2.20/g10/gpg.c
|
||||
ARGPARSE_s_n (oNoExpert, "no-expert", "@"),
|
||||
ARGPARSE_s_n (oNoSecmemWarn, "no-secmem-warning", "@"),
|
||||
ARGPARSE_s_n (oRequireSecmem, "require-secmem", "@"),
|
||||
@@ -2419,6 +2421,7 @@ main (int argc, char **argv)
|
||||
@@ -2484,6 +2486,7 @@ main (int argc, char **argv)
|
||||
opt.keyid_format = KF_NONE;
|
||||
opt.def_sig_expire = "0";
|
||||
opt.def_cert_expire = "0";
|
||||
@ -25,7 +37,7 @@ diff -up gnupg-2.2.20/g10/gpg.c.file-is-digest gnupg-2.2.20/g10/gpg.c
|
||||
opt.passphrase_repeat = 1;
|
||||
opt.emit_version = 0;
|
||||
opt.weak_digests = NULL;
|
||||
@@ -2997,6 +3000,7 @@ main (int argc, char **argv)
|
||||
@@ -3111,6 +3114,7 @@ main (int argc, char **argv)
|
||||
case oPhotoViewer: opt.photo_viewer = pargs.r.ret_str; break;
|
||||
|
||||
case oForceAEAD: opt.force_aead = 1; break;
|
||||
@ -33,10 +45,11 @@ diff -up gnupg-2.2.20/g10/gpg.c.file-is-digest gnupg-2.2.20/g10/gpg.c
|
||||
|
||||
case oDisableSignerUID: opt.flags.disable_signer_uid = 1; break;
|
||||
case oIncludeKeyBlock: opt.flags.include_key_block = 1; break;
|
||||
diff -up gnupg-2.2.20/g10/options.h.file-is-digest gnupg-2.2.20/g10/options.h
|
||||
--- gnupg-2.2.20/g10/options.h.file-is-digest 2020-03-14 19:54:05.000000000 +0100
|
||||
+++ gnupg-2.2.20/g10/options.h 2020-04-14 16:33:42.634269245 +0200
|
||||
@@ -202,6 +202,7 @@ struct
|
||||
diff --git a/g10/options.h b/g10/options.h
|
||||
index 9015e321f..10852046c 100644
|
||||
--- a/g10/options.h
|
||||
+++ b/g10/options.h
|
||||
@@ -219,6 +219,7 @@ struct
|
||||
int no_auto_check_trustdb;
|
||||
int preserve_permissions;
|
||||
int no_homedir_creation;
|
||||
@ -44,9 +57,10 @@ diff -up gnupg-2.2.20/g10/options.h.file-is-digest gnupg-2.2.20/g10/options.h
|
||||
struct groupitem *grouplist;
|
||||
int mangle_dos_filenames;
|
||||
int enable_progress_filter;
|
||||
diff -up gnupg-2.2.20/g10/sign.c.file-is-digest gnupg-2.2.20/g10/sign.c
|
||||
--- gnupg-2.2.20/g10/sign.c.file-is-digest 2020-03-14 19:35:46.000000000 +0100
|
||||
+++ gnupg-2.2.20/g10/sign.c 2020-04-14 16:36:54.661751422 +0200
|
||||
diff --git a/g10/sign.c b/g10/sign.c
|
||||
index b5e9d422d..7ad143649 100644
|
||||
--- a/g10/sign.c
|
||||
+++ b/g10/sign.c
|
||||
@@ -40,6 +40,7 @@
|
||||
#include "pkglue.h"
|
||||
#include "../common/sysutils.h"
|
||||
@ -55,7 +69,7 @@ diff -up gnupg-2.2.20/g10/sign.c.file-is-digest gnupg-2.2.20/g10/sign.c
|
||||
#include "../common/mbox-util.h"
|
||||
#include "../common/compliance.h"
|
||||
|
||||
@@ -834,6 +835,8 @@ write_signature_packets (ctrl_t ctrl,
|
||||
@@ -945,6 +946,8 @@ write_signature_packets (ctrl_t ctrl,
|
||||
|
||||
if (pk->version >= 5)
|
||||
sig->version = 5; /* Required for v5 keys. */
|
||||
@ -64,11 +78,11 @@ diff -up gnupg-2.2.20/g10/sign.c.file-is-digest gnupg-2.2.20/g10/sign.c
|
||||
else
|
||||
sig->version = 4; /* Required. */
|
||||
|
||||
@@ -860,14 +863,22 @@ write_signature_packets (ctrl_t ctrl,
|
||||
@@ -962,14 +965,22 @@ write_signature_packets (ctrl_t ctrl,
|
||||
if (gcry_md_copy (&md, hash))
|
||||
BUG ();
|
||||
|
||||
- build_sig_subpkt_from_sig (sig, pk);
|
||||
- build_sig_subpkt_from_sig (sig, pk, 0);
|
||||
- mk_notation_policy_etc (ctrl, sig, NULL, pk);
|
||||
- if (opt.flags.include_key_block && IS_SIG (sig))
|
||||
- err = mk_sig_subpkt_key_block (ctrl, sig, pk);
|
||||
@ -78,7 +92,7 @@ diff -up gnupg-2.2.20/g10/sign.c.file-is-digest gnupg-2.2.20/g10/sign.c
|
||||
- gcry_md_final (md);
|
||||
+ if (!opt.file_is_digest)
|
||||
+ {
|
||||
+ build_sig_subpkt_from_sig (sig, pk);
|
||||
+ build_sig_subpkt_from_sig (sig, pk, 0);
|
||||
+ mk_notation_policy_etc (ctrl, sig, NULL, pk);
|
||||
+ if (opt.flags.include_key_block && IS_SIG (sig))
|
||||
+ err = mk_sig_subpkt_key_block (ctrl, sig, pk);
|
||||
@ -95,16 +109,16 @@ diff -up gnupg-2.2.20/g10/sign.c.file-is-digest gnupg-2.2.20/g10/sign.c
|
||||
|
||||
if (!err)
|
||||
err = do_sign (ctrl, pk, sig, md, hash_for (pk), cache_nonce, 0);
|
||||
@@ -924,6 +930,8 @@ sign_file (ctrl_t ctrl, strlist_t filena
|
||||
@@ -1034,6 +1045,8 @@ sign_file (ctrl_t ctrl, strlist_t filenames, int detached, strlist_t locusr,
|
||||
SK_LIST sk_rover = NULL;
|
||||
int multifile = 0;
|
||||
u32 duration=0;
|
||||
+ int sigclass = 0x00;
|
||||
+ u32 timestamp = 0;
|
||||
pt_extra_hash_data_t extrahash = NULL;
|
||||
|
||||
pfx = new_progress_context ();
|
||||
@@ -941,7 +949,16 @@ sign_file (ctrl_t ctrl, strlist_t filena
|
||||
char peekbuf[32];
|
||||
int peekbuflen = 0;
|
||||
@@ -1056,7 +1069,16 @@ sign_file (ctrl_t ctrl, strlist_t filenames, int detached, strlist_t locusr,
|
||||
fname = NULL;
|
||||
|
||||
if (fname && filenames->next && (!detached || encryptflag))
|
||||
@ -122,7 +136,7 @@ diff -up gnupg-2.2.20/g10/sign.c.file-is-digest gnupg-2.2.20/g10/sign.c
|
||||
|
||||
if (encryptflag == 2
|
||||
&& (rc = setup_symkey (&efx.symkey_s2k, &efx.symkey_dek)))
|
||||
@@ -962,7 +979,7 @@ sign_file (ctrl_t ctrl, strlist_t filena
|
||||
@@ -1077,7 +1099,7 @@ sign_file (ctrl_t ctrl, strlist_t filenames, int detached, strlist_t locusr,
|
||||
goto leave;
|
||||
|
||||
/* Prepare iobufs. */
|
||||
@ -131,7 +145,7 @@ diff -up gnupg-2.2.20/g10/sign.c.file-is-digest gnupg-2.2.20/g10/sign.c
|
||||
inp = NULL; /* we do it later */
|
||||
else
|
||||
{
|
||||
@@ -1100,7 +1117,7 @@ sign_file (ctrl_t ctrl, strlist_t filena
|
||||
@@ -1240,7 +1262,7 @@ sign_file (ctrl_t ctrl, strlist_t filenames, int detached, strlist_t locusr,
|
||||
for (sk_rover = sk_list; sk_rover; sk_rover = sk_rover->next)
|
||||
gcry_md_enable (mfx.md, hash_for (sk_rover->pk));
|
||||
|
||||
@ -140,7 +154,7 @@ diff -up gnupg-2.2.20/g10/sign.c.file-is-digest gnupg-2.2.20/g10/sign.c
|
||||
iobuf_push_filter (inp, md_filter, &mfx);
|
||||
|
||||
if (detached && !encryptflag)
|
||||
@@ -1155,6 +1172,8 @@ sign_file (ctrl_t ctrl, strlist_t filena
|
||||
@@ -1306,6 +1328,8 @@ sign_file (ctrl_t ctrl, strlist_t filenames, int detached, strlist_t locusr,
|
||||
|
||||
write_status_begin_signing (mfx.md);
|
||||
|
||||
@ -149,7 +163,7 @@ diff -up gnupg-2.2.20/g10/sign.c.file-is-digest gnupg-2.2.20/g10/sign.c
|
||||
/* Setup the inner packet. */
|
||||
if (detached)
|
||||
{
|
||||
@@ -1195,6 +1214,49 @@ sign_file (ctrl_t ctrl, strlist_t filena
|
||||
@@ -1353,6 +1377,49 @@ sign_file (ctrl_t ctrl, strlist_t filenames, int detached, strlist_t locusr,
|
||||
if (opt.verbose)
|
||||
log_printf ("\n");
|
||||
}
|
||||
@ -159,7 +173,7 @@ diff -up gnupg-2.2.20/g10/sign.c.file-is-digest gnupg-2.2.20/g10/sign.c
|
||||
+ size_t mdlen;
|
||||
+ const char *fp;
|
||||
+ int c, d;
|
||||
+
|
||||
+
|
||||
+ gcry_md_final(mfx.md);
|
||||
+ /* this assumes gcry_md_read returns the same buffer */
|
||||
+ mdb = gcry_md_read(mfx.md, opt.def_digest_algo);
|
||||
@ -169,27 +183,27 @@ diff -up gnupg-2.2.20/g10/sign.c.file-is-digest gnupg-2.2.20/g10/sign.c
|
||||
+ d = -1;
|
||||
+ for (fp = fname ; *fp; )
|
||||
+ {
|
||||
+ c = *fp++;
|
||||
+ if (c >= '0' && c <= '9')
|
||||
+ c -= '0';
|
||||
+ else if (c >= 'a' && c <= 'f')
|
||||
+ c -= 'a' - 10;
|
||||
+ else if (c >= 'A' && c <= 'F')
|
||||
+ c -= 'A' - 10;
|
||||
+ else
|
||||
+ log_bug("filename is not hex\n");
|
||||
+ if (d >= 0)
|
||||
+ c = *fp++;
|
||||
+ if (c >= '0' && c <= '9')
|
||||
+ c -= '0';
|
||||
+ else if (c >= 'a' && c <= 'f')
|
||||
+ c -= 'a' - 10;
|
||||
+ else if (c >= 'A' && c <= 'F')
|
||||
+ c -= 'A' - 10;
|
||||
+ else
|
||||
+ log_bug("filename is not hex\n");
|
||||
+ if (d >= 0)
|
||||
+ {
|
||||
+ *mdb++ = d << 4 | c;
|
||||
+ c = -1;
|
||||
+ if (--mdlen == 0)
|
||||
+ *mdb++ = d << 4 | c;
|
||||
+ c = -1;
|
||||
+ if (--mdlen == 0)
|
||||
+ {
|
||||
+ mdb = ts;
|
||||
+ if (*fp++ != '@')
|
||||
+ log_bug("missing time separator\n");
|
||||
+ }
|
||||
+ }
|
||||
+ d = c;
|
||||
+ mdb = ts;
|
||||
+ if (*fp++ != '@')
|
||||
+ log_bug("missing time separator\n");
|
||||
+ }
|
||||
+ }
|
||||
+ d = c;
|
||||
+ }
|
||||
+ sigclass = ts[0];
|
||||
+ if (sigclass != 0x00 && sigclass != 0x01)
|
||||
@ -199,7 +213,7 @@ diff -up gnupg-2.2.20/g10/sign.c.file-is-digest gnupg-2.2.20/g10/sign.c
|
||||
else
|
||||
{
|
||||
/* Read, so that the filter can calculate the digest. */
|
||||
@@ -1213,8 +1271,8 @@ sign_file (ctrl_t ctrl, strlist_t filena
|
||||
@@ -1374,8 +1441,8 @@ sign_file (ctrl_t ctrl, strlist_t filenames, int detached, strlist_t locusr,
|
||||
|
||||
/* Write the signatures. */
|
||||
rc = write_signature_packets (ctrl, sk_list, out, mfx.md, extrahash,
|
@ -1,27 +1,21 @@
|
||||
From 4583f4fe2e11b3dd070066628c3f16776cc74f72 Mon Sep 17 00:00:00 2001
|
||||
From: Werner Koch <wk@gnupg.org>
|
||||
Date: Mon, 31 Oct 2022 16:14:18 +0100
|
||||
Subject: [PATCH GnuPG] gpg: Merge --rfc4880bis features into --gnupg
|
||||
From 1e4f1550996334d2a631a5d769e937d29ace47bb Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Jelen <jjelen@redhat.com>
|
||||
Date: Thu, 9 Feb 2023 16:38:58 +0100
|
||||
Subject: [PATCH gnupg] Revert the introduction of the RFC4880bis draft into
|
||||
defaults
|
||||
|
||||
* g10/gpg.c (oRFC4880bis): Remove.
|
||||
(opts): Make --rfc4880bis a Noop.
|
||||
(compliance_options): Make rfc4880bis to gnupg.
|
||||
(set_compliance_option): Remove rfc4880bis stuff.
|
||||
(main): Ditto. Note that this now activates the --mimemode option.
|
||||
* g10/keygen.c (keygen_set_std_prefs): Remove rfc4880bis protection.
|
||||
(keygen_upd_std_prefs): Always announce support for v5 keys.
|
||||
(read_parameter_file): Activate the v4 and v5 keywords.
|
||||
--
|
||||
This reverts commit 4583f4fe2 (gpg: Merge --rfc4880bis features into
|
||||
--gnupg, 2022-10-31).
|
||||
---
|
||||
g10/gpg.c | 35 ++++++++++++++++++++++++++++++++---
|
||||
g10/keygen.c | 30 ++++++++++++++++++------------
|
||||
2 files changed, 50 insertions(+), 15 deletions(-)
|
||||
|
||||
diff --git b/g10/gpg.c a/g10/gpg.c
|
||||
index 932a4e0f0..f6d4d2b4c 100644
|
||||
--- b/g10/gpg.c
|
||||
+++ a/g10/gpg.c
|
||||
@@ -245,6 +245,7 @@ enum cmd_and_opt_values
|
||||
diff --git a/g10/gpg.c b/g10/gpg.c
|
||||
index dcab0a11a..796888013 100644
|
||||
--- a/g10/gpg.c
|
||||
+++ b/g10/gpg.c
|
||||
@@ -247,6 +247,7 @@ enum cmd_and_opt_values
|
||||
oGnuPG,
|
||||
oRFC2440,
|
||||
oRFC4880,
|
||||
@ -29,7 +23,7 @@ index 932a4e0f0..f6d4d2b4c 100644
|
||||
oOpenPGP,
|
||||
oPGP7,
|
||||
oPGP8,
|
||||
@@ -627,6 +628,7 @@ static gpgrt_opt_t opts[] = {
|
||||
@@ -636,6 +637,7 @@ static gpgrt_opt_t opts[] = {
|
||||
ARGPARSE_s_n (oGnuPG, "no-pgp8", "@"),
|
||||
ARGPARSE_s_n (oRFC2440, "rfc2440", "@"),
|
||||
ARGPARSE_s_n (oRFC4880, "rfc4880", "@"),
|
||||
@ -37,15 +31,15 @@ index 932a4e0f0..f6d4d2b4c 100644
|
||||
ARGPARSE_s_n (oOpenPGP, "openpgp", N_("use strict OpenPGP behavior")),
|
||||
ARGPARSE_s_n (oPGP7, "pgp6", "@"),
|
||||
ARGPARSE_s_n (oPGP7, "pgp7", "@"),
|
||||
@@ -967,7 +969,6 @@ static gpgrt_opt_t opts[] = {
|
||||
@@ -978,7 +980,6 @@ static gpgrt_opt_t opts[] = {
|
||||
ARGPARSE_s_n (oNoop, "no-allow-multiple-messages", "@"),
|
||||
ARGPARSE_s_s (oNoop, "aead-algo", "@"),
|
||||
ARGPARSE_s_s (oNoop, "personal-aead-preferences","@"),
|
||||
- ARGPARSE_s_n (oNoop, "rfc4880bis", "@"),
|
||||
ARGPARSE_s_n (oNoop, "override-compliance-check", "@"),
|
||||
|
||||
|
||||
ARGPARSE_group (302, N_(
|
||||
@@ -2197,7 +2198,7 @@ static struct gnupg_compliance_option compliance_options[] =
|
||||
@@ -2227,7 +2228,7 @@ static struct gnupg_compliance_option compliance_options[] =
|
||||
{
|
||||
{ "gnupg", oGnuPG },
|
||||
{ "openpgp", oOpenPGP },
|
||||
@ -54,7 +48,7 @@ index 932a4e0f0..f6d4d2b4c 100644
|
||||
{ "rfc4880", oRFC4880 },
|
||||
{ "rfc2440", oRFC2440 },
|
||||
{ "pgp6", oPGP7 },
|
||||
@@ -2213,8 +2214,28 @@ static struct gnupg_compliance_option compliance_options[] =
|
||||
@@ -2243,8 +2244,28 @@ static struct gnupg_compliance_option compliance_options[] =
|
||||
static void
|
||||
set_compliance_option (enum cmd_and_opt_values option)
|
||||
{
|
||||
@ -83,7 +77,7 @@ index 932a4e0f0..f6d4d2b4c 100644
|
||||
case oOpenPGP:
|
||||
case oRFC4880:
|
||||
/* This is effectively the same as RFC2440, but with
|
||||
@@ -2258,6 +2279,7 @@ set_compliance_option (enum cmd_and_opt_values option)
|
||||
@@ -2288,6 +2309,7 @@ set_compliance_option (enum cmd_and_opt_values option)
|
||||
case oPGP8: opt.compliance = CO_PGP8; break;
|
||||
case oGnuPG:
|
||||
opt.compliance = CO_GNUPG;
|
||||
@ -91,7 +85,7 @@ index 932a4e0f0..f6d4d2b4c 100644
|
||||
break;
|
||||
|
||||
case oDE_VS:
|
||||
@@ -2460,6 +2482,7 @@ main (int argc, char **argv)
|
||||
@@ -2491,6 +2513,7 @@ main (int argc, char **argv)
|
||||
opt.emit_version = 0;
|
||||
opt.weak_digests = NULL;
|
||||
opt.compliance = CO_GNUPG;
|
||||
@ -99,7 +93,7 @@ index 932a4e0f0..f6d4d2b4c 100644
|
||||
|
||||
/* Check special options given on the command line. */
|
||||
orig_argc = argc;
|
||||
@@ -2997,6 +3020,7 @@ main (int argc, char **argv)
|
||||
@@ -3033,6 +3056,7 @@ main (int argc, char **argv)
|
||||
case oOpenPGP:
|
||||
case oRFC2440:
|
||||
case oRFC4880:
|
||||
@ -107,7 +101,7 @@ index 932a4e0f0..f6d4d2b4c 100644
|
||||
case oPGP7:
|
||||
case oPGP8:
|
||||
case oGnuPG:
|
||||
@@ -3808,6 +3832,11 @@ main (int argc, char **argv)
|
||||
@@ -3862,6 +3886,11 @@ main (int argc, char **argv)
|
||||
if( may_coredump && !opt.quiet )
|
||||
log_info(_("WARNING: program may create a core file!\n"));
|
||||
|
||||
@ -119,7 +113,7 @@ index 932a4e0f0..f6d4d2b4c 100644
|
||||
if (eyes_only) {
|
||||
if (opt.set_filename)
|
||||
log_info(_("WARNING: %s overrides %s\n"),
|
||||
@@ -4033,7 +4062,7 @@ main (int argc, char **argv)
|
||||
@@ -4078,7 +4107,7 @@ main (int argc, char **argv)
|
||||
/* Check our chosen algorithms against the list of legal
|
||||
algorithms. */
|
||||
|
||||
@ -128,11 +122,11 @@ index 932a4e0f0..f6d4d2b4c 100644
|
||||
{
|
||||
const char *badalg=NULL;
|
||||
preftype_t badtype=PREFTYPE_NONE;
|
||||
diff --git b/g10/keygen.c a/g10/keygen.c
|
||||
index c2f2dcc9d..484352583 100644
|
||||
--- b/g10/keygen.c
|
||||
+++ a/g10/keygen.c
|
||||
@@ -407,7 +407,7 @@ keygen_set_std_prefs (const char *string,int personal)
|
||||
diff --git a/g10/keygen.c b/g10/keygen.c
|
||||
index a2cfe3ccf..2a1dd1f81 100644
|
||||
--- a/g10/keygen.c
|
||||
+++ b/g10/keygen.c
|
||||
@@ -404,7 +404,7 @@ keygen_set_std_prefs (const char *string,int personal)
|
||||
strcat(dummy_string,"S7 ");
|
||||
strcat(dummy_string,"S2 "); /* 3DES */
|
||||
|
||||
@ -141,7 +135,7 @@ index c2f2dcc9d..484352583 100644
|
||||
strcat(dummy_string,"A2 ");
|
||||
|
||||
if (personal)
|
||||
@@ -892,7 +892,7 @@ keygen_upd_std_prefs (PKT_signature *sig, void *opaque)
|
||||
@@ -889,7 +889,7 @@ keygen_upd_std_prefs (PKT_signature *sig, void *opaque)
|
||||
/* Make sure that the MDC feature flag is set if needed. */
|
||||
add_feature_mdc (sig,mdc_available);
|
||||
add_feature_aead (sig, aead_available);
|
||||
@ -150,7 +144,7 @@ index c2f2dcc9d..484352583 100644
|
||||
add_keyserver_modify (sig,ks_modify);
|
||||
keygen_add_keyserver_url(sig,NULL);
|
||||
|
||||
@@ -3387,7 +3387,10 @@ parse_key_parameter_part (ctrl_t ctrl,
|
||||
@@ -3382,7 +3382,10 @@ parse_key_parameter_part (ctrl_t ctrl,
|
||||
}
|
||||
}
|
||||
else if (!ascii_strcasecmp (s, "v5"))
|
||||
@ -162,7 +156,7 @@ index c2f2dcc9d..484352583 100644
|
||||
else if (!ascii_strcasecmp (s, "v4"))
|
||||
keyversion = 4;
|
||||
else
|
||||
@@ -3646,7 +3649,7 @@ parse_key_parameter_part (ctrl_t ctrl,
|
||||
@@ -3641,7 +3644,7 @@ parse_key_parameter_part (ctrl_t ctrl,
|
||||
* ecdsa := Use algorithm ECDSA.
|
||||
* eddsa := Use algorithm EdDSA.
|
||||
* ecdh := Use algorithm ECDH.
|
||||
@ -171,7 +165,7 @@ index c2f2dcc9d..484352583 100644
|
||||
*
|
||||
* There are several defaults and fallbacks depending on the
|
||||
* algorithm. PART can be used to select which part of STRING is
|
||||
@@ -4428,9 +4431,9 @@ read_parameter_file (ctrl_t ctrl, const char *fname )
|
||||
@@ -4513,9 +4516,9 @@ read_parameter_file (ctrl_t ctrl, const char *fname )
|
||||
}
|
||||
}
|
||||
|
||||
@ -184,7 +178,7 @@ index c2f2dcc9d..484352583 100644
|
||||
else
|
||||
{
|
||||
r = xmalloc_clear( sizeof *r + strlen( value ) );
|
||||
@@ -4525,11 +4528,14 @@ quickgen_set_para (struct para_data_s *para, int for_subkey,
|
||||
@@ -4610,11 +4613,14 @@ quickgen_set_para (struct para_data_s *para, int for_subkey,
|
||||
para = r;
|
||||
}
|
||||
|
||||
@ -204,6 +198,3 @@ index c2f2dcc9d..484352583 100644
|
||||
|
||||
if (keytime)
|
||||
{
|
||||
--
|
||||
2.39.1
|
||||
|
||||
|
24
gnupg2.spec
24
gnupg2.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Utility for secure communication and data storage
|
||||
Name: gnupg2
|
||||
Version: 2.4.0
|
||||
Release: 4%{?dist}
|
||||
Version: 2.4.1
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: GPLv3+
|
||||
Source0: https://gnupg.org/ftp/gcrypt/%{?pre:alpha/}gnupg/gnupg-%{version}%{?pre}.tar.bz2
|
||||
@ -13,7 +13,7 @@ Source2: https://gnupg.org/signature_key.asc
|
||||
Patch3: gnupg-2.1.10-secmem.patch
|
||||
# non-upstreamable patch adding file-is-digest option needed for Copr
|
||||
# https://dev.gnupg.org/T1646
|
||||
Patch4: gnupg-2.2.20-file-is-digest.patch
|
||||
Patch4: gnupg-2.4.1-file-is-digest.patch
|
||||
Patch6: gnupg-2.1.1-fips-algo.patch
|
||||
# allow 8192 bit RSA keys in keygen UI with large RSA
|
||||
Patch9: gnupg-2.2.23-large-rsa.patch
|
||||
@ -24,11 +24,8 @@ Patch21: gnupg-2.4.0-gpg-allow-import-of-previously-known-keys-even-without-UI.p
|
||||
Patch22: gnupg-2.2.18-gpg-accept-subkeys-with-a-good-revocation-but-no-self-sig.patch
|
||||
# Fixes for issues found in Coverity scan - reported upstream
|
||||
Patch30: gnupg-2.2.21-coverity.patch
|
||||
# fix gpgme tests fail for in-source-tree builds (https://dev.gnupg.org/T6313)
|
||||
# (edited to patch Makefile.in instead of Makefile.am to avoid autoreconf)
|
||||
Patch31: gnupg-2.4.0-tests-Fix-tests-gpgme-for-in-source-tree-builds.patch
|
||||
# Revert the introduction of the RFC4880bis draft into defaults
|
||||
Patch32: gnupg2-revert-rfc4880bis.patch
|
||||
Patch31: gnupg2-revert-rfc4880bis.patch
|
||||
|
||||
|
||||
URL: https://www.gnupg.org/
|
||||
@ -57,7 +54,6 @@ BuildRequires: gnutls-devel
|
||||
BuildRequires: sqlite-devel
|
||||
BuildRequires: fuse
|
||||
BuildRequires: make
|
||||
BuildRequires: systemd-rpm-macros
|
||||
# for tests
|
||||
BuildRequires: openssh-clients
|
||||
|
||||
@ -120,8 +116,7 @@ to the base GnuPG package
|
||||
%patch22 -p1 -b .good_revoc
|
||||
|
||||
%patch30 -p1 -b .coverity
|
||||
%patch31 -p1 -b .tests_gpgme
|
||||
%patch32 -p1 -b .revert-rfc4880bis
|
||||
%patch31 -p1 -b .revert-rfc4880bis
|
||||
|
||||
# pcsc-lite library major: 0 in 1.2.0, 1 in 1.2.9+ (dlopen()'d in pcsc-wrapper)
|
||||
# Note: this is just the name of the default shared lib to load in scdaemon,
|
||||
@ -173,11 +168,6 @@ rm -f %{buildroot}%{_infodir}/dir
|
||||
# drop the gpg scheme interpreter
|
||||
rm -f %{buildroot}%{_bindir}/gpgscm
|
||||
|
||||
# Move the systemd user units to appropriate directory
|
||||
install -d -m755 %{buildroot}%{_userunitdir}
|
||||
mv %{buildroot}%{_pkgdocdir}/examples/systemd-user/*.socket %{buildroot}%{_userunitdir}
|
||||
mv %{buildroot}%{_pkgdocdir}/examples/systemd-user/*.service %{buildroot}%{_userunitdir}
|
||||
|
||||
%check
|
||||
# need scratch gpg database for tests
|
||||
mkdir -p $HOME/.gnupg
|
||||
@ -213,7 +203,6 @@ make -k check
|
||||
%{_libexecdir}/*
|
||||
%{_infodir}/*.info*
|
||||
%{_mandir}/man?/*
|
||||
%{_userunitdir}/*
|
||||
%exclude %{_mandir}/man?/gpgsm*
|
||||
|
||||
%files smime
|
||||
@ -223,6 +212,9 @@ make -k check
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Apr 28 2023 Todd Zullinger <tmz@pobox.com> - 2.4.1-1
|
||||
- update to 2.4.1
|
||||
|
||||
* Fri Apr 28 2023 Todd Zullinger <tmz@pobox.com> - 2.4.0-4
|
||||
- remove %%skip_verify, brainpool signatures are supported now
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (gnupg-2.4.0.tar.bz2) = 094d631130d4dfe4421cc5e715eaec1888d0b4b764f1be9287be86cbc34430313211739d5481b34e9b59021d05cdbae8a87a1007031cc4dc6213045984a8559a
|
||||
SHA512 (gnupg-2.4.0.tar.bz2.sig) = 3ed098ad036907fde2c80fdd09a5f3fd1a151ecfa47b5a34a949e129fcd1a748ab0ed7219433e5104d98a670bd91d353157ef2e8cc4e0c5817da2d7da58c4b20
|
||||
SHA512 (gnupg-2.4.1.tar.bz2) = 4d6b30ec4b8d786508ec1ac5f3c5b0ddebdc4f60aa72eb5d6ecc185ff0e9f1f4798f80ae16a3d136052b91ec54978ec0b7969a11a6c2727f30b3b6efabbaf388
|
||||
SHA512 (gnupg-2.4.1.tar.bz2.sig) = 0923b34da162c26f56d586eae748f8a9a58088006f2db384251bf81dac7bbb23a9923ca8b275bffb4c504c3a342e300abeaa83e9f29105af90ee7915ad92901e
|
||||
|
Loading…
Reference in New Issue
Block a user