- gnupg-2.0.16
This commit is contained in:
parent
e6d50bbbe6
commit
a3e59f8458
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
gnupg-2.0.14.tar.bz2
|
gnupg-2.0.16.tar.bz2
|
||||||
gnupg-2.0.14.tar.bz2.sig
|
gnupg-2.0.16.tar.bz2.sig
|
||||||
|
@ -1,9 +1,6 @@
|
|||||||
We have to use fixed s2k-count number otherwise the gpg2 would
|
diff -up gnupg-2.0.16/tests/openpgp/conventional-mdc.test.s2k gnupg-2.0.16/tests/openpgp/conventional-mdc.test
|
||||||
want to consult gpg-agent which is not yet installed in the mock
|
--- gnupg-2.0.16/tests/openpgp/conventional-mdc.test.s2k 2009-09-21 11:53:46.000000000 -0500
|
||||||
chroot.
|
+++ gnupg-2.0.16/tests/openpgp/conventional-mdc.test 2010-07-23 12:22:33.892728352 -0500
|
||||||
diff -up gnupg-2.0.14/tests/openpgp/conventional-mdc.test.s2k gnupg-2.0.14/tests/openpgp/conventional-mdc.test
|
|
||||||
--- gnupg-2.0.14/tests/openpgp/conventional-mdc.test.s2k 2009-09-21 18:53:46.000000000 +0200
|
|
||||||
+++ gnupg-2.0.14/tests/openpgp/conventional-mdc.test 2010-01-11 10:42:36.000000000 +0100
|
|
||||||
@@ -21,9 +21,9 @@ for ciph in `all_cipher_algos`; do
|
@@ -21,9 +21,9 @@ for ciph in `all_cipher_algos`; do
|
||||||
dd if=data-80000 of=z bs=1 count=$i 2>/dev/null
|
dd if=data-80000 of=z bs=1 count=$i 2>/dev/null
|
||||||
fi
|
fi
|
||||||
@ -16,9 +13,9 @@ diff -up gnupg-2.0.14/tests/openpgp/conventional-mdc.test.s2k gnupg-2.0.14/tests
|
|||||||
cmp z y || error "$ciph/$i: mismatch"
|
cmp z y || error "$ciph/$i: mismatch"
|
||||||
done
|
done
|
||||||
done
|
done
|
||||||
diff -up gnupg-2.0.14/tests/openpgp/conventional.test.s2k gnupg-2.0.14/tests/openpgp/conventional.test
|
diff -up gnupg-2.0.16/tests/openpgp/conventional.test.s2k gnupg-2.0.16/tests/openpgp/conventional.test
|
||||||
--- gnupg-2.0.14/tests/openpgp/conventional.test.s2k 2009-09-21 18:53:46.000000000 +0200
|
--- gnupg-2.0.16/tests/openpgp/conventional.test.s2k 2009-09-21 11:53:46.000000000 -0500
|
||||||
+++ gnupg-2.0.14/tests/openpgp/conventional.test 2010-01-11 10:43:00.000000000 +0100
|
+++ gnupg-2.0.16/tests/openpgp/conventional.test 2010-07-23 12:22:33.892728352 -0500
|
||||||
@@ -12,8 +12,8 @@
|
@@ -12,8 +12,8 @@
|
||||||
|
|
||||||
#info Checking conventional encryption
|
#info Checking conventional encryption
|
||||||
@ -41,15 +38,15 @@ diff -up gnupg-2.0.14/tests/openpgp/conventional.test.s2k gnupg-2.0.14/tests/ope
|
|||||||
cmp $i y || error "$i: ($a) mismatch"
|
cmp $i y || error "$i: ($a) mismatch"
|
||||||
done
|
done
|
||||||
done
|
done
|
||||||
diff -up gnupg-2.0.14/tests/openpgp/genkey1024.test.s2k gnupg-2.0.14/tests/openpgp/genkey1024.test
|
diff -up gnupg-2.0.16/tests/openpgp/genkey1024.test.s2k gnupg-2.0.16/tests/openpgp/genkey1024.test
|
||||||
--- gnupg-2.0.14/tests/openpgp/genkey1024.test.s2k 2009-09-21 18:53:46.000000000 +0200
|
--- gnupg-2.0.16/tests/openpgp/genkey1024.test.s2k 2010-05-11 09:28:03.000000000 -0500
|
||||||
+++ gnupg-2.0.14/tests/openpgp/genkey1024.test 2010-01-11 10:43:14.000000000 +0100
|
+++ gnupg-2.0.16/tests/openpgp/genkey1024.test 2010-07-23 12:27:27.217718995 -0500
|
||||||
@@ -10,7 +10,7 @@
|
@@ -10,7 +10,7 @@
|
||||||
|
|
||||||
. $srcdir/defs.inc || exit 3
|
. $srcdir/defs.inc || exit 3
|
||||||
|
|
||||||
-../../g10/gpg2 --quiet --batch --debug-quick-random --homedir . --gen-key <<EOF
|
-$GPG --quiet --batch --debug-quick-random --gen-key <<EOF
|
||||||
+../../g10/gpg2 --quiet --batch --debug-quick-random --homedir . --s2k-count 65536 --gen-key <<EOF
|
+$GPG --quiet --batch --debug-quick-random --s2k-count 65536 --gen-key <<EOF
|
||||||
Key-Type: DSA
|
Key-Type: DSA
|
||||||
Key-Length: 1024
|
Key-Length: 1024
|
||||||
Subkey-Type: ELG
|
Subkey-Type: ELG
|
||||||
@ -57,8 +54,8 @@ diff -up gnupg-2.0.14/tests/openpgp/genkey1024.test.s2k gnupg-2.0.14/tests/openp
|
|||||||
EOF
|
EOF
|
||||||
|
|
||||||
if have_pubkey_algo "RSA"; then
|
if have_pubkey_algo "RSA"; then
|
||||||
-../../g10/gpg2 --quiet --batch --debug-quick-random --homedir . --gen-key <<EOF
|
-$GPG --quiet --batch --debug-quick-random --gen-key <<EOF
|
||||||
+../../g10/gpg2 --quiet --batch --debug-quick-random --homedir . --s2k-count 65536 --gen-key <<EOF
|
+$GPG --quiet --batch --debug-quick-random --s2k-count 65536 --gen-key <<EOF
|
||||||
Key-Type: RSA
|
Key-Type: RSA
|
||||||
Key-Length: 1024
|
Key-Length: 1024
|
||||||
Key-Usage: sign,encrypt
|
Key-Usage: sign,encrypt
|
14
gnupg2.spec
14
gnupg2.spec
@ -1,8 +1,8 @@
|
|||||||
|
|
||||||
Summary: Utility for secure communication and data storage
|
Summary: Utility for secure communication and data storage
|
||||||
Name: gnupg2
|
Name: gnupg2
|
||||||
Version: 2.0.14
|
Version: 2.0.16
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -11,7 +11,7 @@ Source1: ftp://ftp.gnupg.org/gcrypt/%{?pre:alpha/}gnupg/gnupg-%{version}%{?pre}.
|
|||||||
# svn export svn://cvs.gnupg.org/gnupg/trunk gnupg2; tar cjf gnupg-<date>svn.tar.bz2 gnupg2
|
# svn export svn://cvs.gnupg.org/gnupg/trunk gnupg2; tar cjf gnupg-<date>svn.tar.bz2 gnupg2
|
||||||
#Source0: gnupg2-20090809svn.tar.bz2
|
#Source0: gnupg2-20090809svn.tar.bz2
|
||||||
Patch1: gnupg-2.0.13-insttools.patch
|
Patch1: gnupg-2.0.13-insttools.patch
|
||||||
Patch2: gnupg-2.0.14-tests-s2kcount.patch
|
Patch2: gnupg-2.0.16-tests-s2kcount.patch
|
||||||
Patch3: gnupg-2.0.14-secmem.patch
|
Patch3: gnupg-2.0.14-secmem.patch
|
||||||
|
|
||||||
URL: http://www.gnupg.org/
|
URL: http://www.gnupg.org/
|
||||||
@ -27,7 +27,7 @@ BuildRequires: bzip2-devel
|
|||||||
BuildRequires: curl-devel
|
BuildRequires: curl-devel
|
||||||
BuildRequires: docbook-utils
|
BuildRequires: docbook-utils
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
BuildRequires: libassuan-static, libassuan-devel >= 1.0.4
|
BuildRequires: libassuan-devel >= 2.0.0
|
||||||
BuildRequires: libgcrypt-devel >= 1.4
|
BuildRequires: libgcrypt-devel >= 1.4
|
||||||
BuildRequires: libgpg-error-devel => 1.4
|
BuildRequires: libgpg-error-devel => 1.4
|
||||||
BuildRequires: libksba-devel >= 1.0.2
|
BuildRequires: libksba-devel >= 1.0.2
|
||||||
@ -117,7 +117,7 @@ touch %{buildroot}%{_sysconfdir}/gnupg/gpgconf.conf
|
|||||||
install -m644 -p AUTHORS COPYING ChangeLog NEWS THANKS TODO \
|
install -m644 -p AUTHORS COPYING ChangeLog NEWS THANKS TODO \
|
||||||
%{buildroot}%{_docdir}/%{name}-%{version}/
|
%{buildroot}%{_docdir}/%{name}-%{version}/
|
||||||
|
|
||||||
# compat symlinks
|
# compat symlinks (these need to go away when/if gnupg1 review passes)
|
||||||
ln -sf gpg2 %{buildroot}%{_bindir}/gpg
|
ln -sf gpg2 %{buildroot}%{_bindir}/gpg
|
||||||
ln -sf gpgv2 %{buildroot}%{_bindir}/gpgv
|
ln -sf gpgv2 %{buildroot}%{_bindir}/gpgv
|
||||||
ln -sf gpg2.1 %{buildroot}%{_mandir}/man1/gpg.1
|
ln -sf gpg2.1 %{buildroot}%{_mandir}/man1/gpg.1
|
||||||
@ -182,11 +182,15 @@ fi
|
|||||||
%{_mandir}/man?/scdaemon*
|
%{_mandir}/man?/scdaemon*
|
||||||
%{_datadir}/gnupg/com-certs.pem
|
%{_datadir}/gnupg/com-certs.pem
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 27 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.0.16-1
|
||||||
|
- gnupg-2.0.16
|
||||||
|
|
||||||
* Fri Jul 23 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.0.14-4
|
* Fri Jul 23 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.0.14-4
|
||||||
- gpgsm realloc patch (#617706)
|
- gpgsm realloc patch (#617706)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user