1.9.17 (#162264).
This commit is contained in:
parent
3805ff83e8
commit
5cea16c68d
@ -1 +1,2 @@
|
||||
gnupg-1.9.16.tar.bz2
|
||||
gnupg-1.9.17.tar.bz2
|
||||
gnupg-1.9.17.tar.bz2.sig
|
||||
|
@ -1,74 +0,0 @@
|
||||
diff -Nur gnupg-1.9.16-orig/common/signal.c gnupg-1.9.16/common/signal.c
|
||||
--- gnupg-1.9.16-orig/common/signal.c 2004-12-21 11:03:00.000000000 +0100
|
||||
+++ gnupg-1.9.16/common/signal.c 2005-05-13 14:56:37.000000000 +0200
|
||||
@@ -1,5 +1,6 @@
|
||||
/* signal.c - signal handling
|
||||
- * Copyright (C) 1998, 1999, 2000, 2001, 2002 Free Software Foundation, Inc.
|
||||
+ * Copyright (C) 1998, 1999, 2000, 2001, 2002,
|
||||
+ * 2005 Free Software Foundation, Inc.
|
||||
*
|
||||
* This file is part of GnuPG.
|
||||
*
|
||||
@@ -73,10 +74,12 @@
|
||||
static const char *
|
||||
get_signal_name( int signum )
|
||||
{
|
||||
-#if defined(SYS_SIGLIST_DECLARED) && defined(NSIG)
|
||||
+ /* Note that we can't use strsignal(), because it is not
|
||||
+ reentrant. */
|
||||
+#if defined(HAVE_DECL_SYS_SIGLIST) && defined(NSIG)
|
||||
return (signum >= 0 && signum < NSIG) ? sys_siglist[signum] : "?";
|
||||
#else
|
||||
- return "some signal";
|
||||
+ return NULL;
|
||||
#endif
|
||||
}
|
||||
#endif /*!HAVE_DOSISH_SYSTEM*/
|
||||
@@ -93,19 +96,42 @@
|
||||
|
||||
if (cleanup_fnc)
|
||||
cleanup_fnc ();
|
||||
- /* better don't translate these messages */
|
||||
+ /* Better don't translate these messages. */
|
||||
write (2, "\n", 1 );
|
||||
s = log_get_prefix (NULL);
|
||||
if (s)
|
||||
write(2, s, strlen (s));
|
||||
- write (2, ": ", 2 );
|
||||
+ write (2, ": signal ", 9 );
|
||||
s = get_signal_name(sig);
|
||||
- write (2, s, strlen(s) );
|
||||
+ if (s)
|
||||
+ write (2, s, strlen(s) );
|
||||
+ else
|
||||
+ {
|
||||
+ /* We are in a signal handler so we can't use any kind of printf
|
||||
+ even not sprintf. USe a straightforward algorithm. */
|
||||
+ if (sig < 0 || sig >= 100000)
|
||||
+ write (2, "?", 1);
|
||||
+ else
|
||||
+ {
|
||||
+ int i, any=0;
|
||||
+
|
||||
+ for (i=10000; i; i /= 10)
|
||||
+ {
|
||||
+ if (sig >= i || ((any || i==1) && !(sig/i)))
|
||||
+ {
|
||||
+ write (2, "0123456789"+(sig/i), 1);
|
||||
+ if ((sig/i))
|
||||
+ any = 1;
|
||||
+ sig %= i;
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
write (2, " caught ... exiting\n", 20);
|
||||
|
||||
- /* reset action to default action and raise signal again */
|
||||
+ /* Reset action to default action and raise signal again */
|
||||
init_one_signal (sig, SIG_DFL, 0);
|
||||
- /* fixme: remove_lockfiles ();*/
|
||||
+ /* Fixme: remove_lockfiles ();*/
|
||||
#ifdef __riscos__
|
||||
close_fds ();
|
||||
#endif /* __riscos__ */
|
Binary file not shown.
15
gnupg-1.9.17-lvalue.patch
Normal file
15
gnupg-1.9.17-lvalue.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- g10/misc.c~ 2005-06-15 18:34:29.000000000 +0300
|
||||
+++ g10/misc.c 2005-07-01 21:02:05.000000000 +0300
|
||||
@@ -986,10 +986,10 @@
|
||||
}
|
||||
else {
|
||||
int rc;
|
||||
- char *buffer;
|
||||
+ unsigned char *buffer;
|
||||
|
||||
rc = gcry_mpi_aprint( GCRYMPI_FMT_HEX,
|
||||
- &(unsigned char*)buffer, NULL, a );
|
||||
+ &buffer, NULL, a );
|
||||
assert( !rc );
|
||||
fputs( buffer, fp );
|
||||
n += strlen(buffer);
|
26
gnupg2.spec
26
gnupg2.spec
@ -1,7 +1,12 @@
|
||||
# pcsc-lite library major: 0 in 1.2.0, 1 in 1.2.9+ (dlopen()'d in pcsc-wrapper)
|
||||
# Note: this is just the name of the default shared lib to load in scdaemon,
|
||||
# it can use other implementations too (including non-pcsc ones).
|
||||
%define pcsc_lib libpcsclite.so.0
|
||||
|
||||
Summary: GNU utility for secure communication and data storage
|
||||
Name: gnupg2
|
||||
Version: 1.9.16
|
||||
Release: 4%{?dist}
|
||||
Version: 1.9.17
|
||||
Release: 1%{?dist}
|
||||
License: GPL
|
||||
Group: Applications/System
|
||||
Source0: ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/gnupg-%{version}.tar.bz2
|
||||
@ -10,7 +15,7 @@ URL: http://www.gnupg.org/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Patch0: gnupg-1.9.16-pth.patch
|
||||
Patch1: gnupg-1.9.16-signal-info.patch
|
||||
Patch1: gnupg-1.9.17-lvalue.patch
|
||||
Patch2: gnupg-1.9.16-testverbose.patch
|
||||
|
||||
Obsoletes: newpg < 0.9.5
|
||||
@ -28,10 +33,9 @@ BuildRequires: gcc
|
||||
BuildRequires: libgcrypt-devel => 1.2.0
|
||||
BuildRequires: libgpg-error-devel => 1.0
|
||||
Requires: libgpg-error >= 1.0
|
||||
BuildRequires: libassuan-devel >= 0.6.9
|
||||
BuildRequires: libassuan-devel >= 0.6.10
|
||||
BuildRequires: libksba-devel >= 0.9.11
|
||||
BuildRequires: opensc-devel >= 0.9
|
||||
BuildRequires: pcsc-lite-devel
|
||||
BuildRequires: gettext
|
||||
BuildRequires: openldap-devel
|
||||
BuildRequires: libusb-devel
|
||||
@ -64,9 +68,11 @@ the stable gpg version 1.4 (as well as the old 1.2 series).
|
||||
%setup -q -n gnupg-%{version}
|
||||
|
||||
%patch0 -p1 -b .pth
|
||||
%patch1 -p1 -b .strsignal
|
||||
%patch1 -p0 -b .lvalue
|
||||
%patch2 -p1 -b .testverbose
|
||||
|
||||
sed -i -e 's/"libpcsclite\.so"/"%{pcsc_lib}"/' scd/{scdaemon,pcsc-wrapper}.c
|
||||
|
||||
|
||||
%build
|
||||
|
||||
@ -114,10 +120,10 @@ fi
|
||||
%{_bindir}/gpg-connect-agent
|
||||
%{_bindir}/gpg-agent
|
||||
%{_bindir}/gpgconf
|
||||
%{_bindir}/gpgkey2ssh
|
||||
%{_bindir}/gpgsm*
|
||||
%{_bindir}/gpgv2
|
||||
%{_bindir}/kbxutil
|
||||
%{_bindir}/sc-copykeys
|
||||
%{_bindir}/scdaemon
|
||||
%{_bindir}/watchgnupg
|
||||
%{_sbindir}/*
|
||||
@ -132,6 +138,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jul 1 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.9.17-1
|
||||
- 1.9.17, signal info patch applied upstream (#162264).
|
||||
- Patch to fix lvalue build error with gcc4 (upstream #485).
|
||||
- Patch scdaemon and pcsc-wrapper to load the versioned (non-devel)
|
||||
pcsc-lite lib by default.
|
||||
|
||||
* Fri May 13 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.9.16-3
|
||||
- Include upstream's patch for signal.c.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user