scdaemon is now needed by gpg
This commit is contained in:
parent
5d915030cb
commit
5bcc193b5c
71
gnupg-2.1.21-scdaemon-path.patch
Normal file
71
gnupg-2.1.21-scdaemon-path.patch
Normal file
@ -0,0 +1,71 @@
|
|||||||
|
From 386a7bbb245dd3ab7c4156a554adbe75d82bdf49 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Justus Winter <justus@g10code.com>
|
||||||
|
Date: Tue, 16 May 2017 16:07:25 +0200
|
||||||
|
Subject: [PATCH] tests: Configure the environments to use scdaemon from build
|
||||||
|
tree.
|
||||||
|
|
||||||
|
* tests/gpgme/gpgme-defs.scm: Use the scdaemon from the build tree
|
||||||
|
when writing a 'gpg-agent.conf'.
|
||||||
|
* tests/gpgsm/gpgsm-defs.scm: Likewise.
|
||||||
|
* tests/openpgp/defs.scm: Likewise.
|
||||||
|
--
|
||||||
|
|
||||||
|
As of 97a2394ecafaa6f58e4a1f70ecfd04408dc15606 gpg may query the
|
||||||
|
scdaemon for a signing key to use. To make sure that the agent calls
|
||||||
|
the right scdaemon, we provide the path explicitly in the
|
||||||
|
'gpg-agent.conf' that is used in the tests, similar to what we do for
|
||||||
|
the agent itself and the pinentry.
|
||||||
|
|
||||||
|
GnuPG-bug-id: 3165
|
||||||
|
Signed-off-by: Justus Winter <justus@g10code.com>
|
||||||
|
---
|
||||||
|
tests/gpgme/gpgme-defs.scm | 4 +++-
|
||||||
|
tests/gpgsm/gpgsm-defs.scm | 4 +++-
|
||||||
|
tests/openpgp/defs.scm | 1 +
|
||||||
|
3 files changed, 7 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/tests/gpgme/gpgme-defs.scm b/tests/gpgme/gpgme-defs.scm
|
||||||
|
index e24db25..0de589f 100644
|
||||||
|
--- a/tests/gpgme/gpgme-defs.scm
|
||||||
|
+++ b/tests/gpgme/gpgme-defs.scm
|
||||||
|
@@ -66,7 +66,9 @@
|
||||||
|
(string-append "agent-program " (tool 'gpg-agent) "|--debug-quick-random\n"))
|
||||||
|
(create-file
|
||||||
|
"gpg-agent.conf"
|
||||||
|
- (string-append "pinentry-program " (tool 'pinentry)))
|
||||||
|
+ (string-append "pinentry-program " (tool 'pinentry))
|
||||||
|
+ (string-append "scdaemon-program " (tool 'scdaemon))
|
||||||
|
+ )
|
||||||
|
|
||||||
|
(start-agent)
|
||||||
|
|
||||||
|
diff --git a/tests/gpgsm/gpgsm-defs.scm b/tests/gpgsm/gpgsm-defs.scm
|
||||||
|
index 711922a..d99d7da 100644
|
||||||
|
--- a/tests/gpgsm/gpgsm-defs.scm
|
||||||
|
+++ b/tests/gpgsm/gpgsm-defs.scm
|
||||||
|
@@ -66,7 +66,9 @@
|
||||||
|
"disable-crl-checks"
|
||||||
|
"faked-system-time 1008241200")
|
||||||
|
(create-file "gpg-agent.conf"
|
||||||
|
- (string-append "pinentry-program " (tool 'pinentry)))
|
||||||
|
+ (string-append "pinentry-program " (tool 'pinentry))
|
||||||
|
+ (string-append "scdaemon-program " (tool 'scdaemon))
|
||||||
|
+ )
|
||||||
|
(start-agent)
|
||||||
|
(create-file
|
||||||
|
"trustlist.txt"
|
||||||
|
diff --git a/tests/openpgp/defs.scm b/tests/openpgp/defs.scm
|
||||||
|
index 1531dc1..0cd45ad 100644
|
||||||
|
--- a/tests/openpgp/defs.scm
|
||||||
|
+++ b/tests/openpgp/defs.scm
|
||||||
|
@@ -349,6 +349,7 @@
|
||||||
|
"no-grab"
|
||||||
|
"enable-ssh-support"
|
||||||
|
(string-append "pinentry-program " (tool 'pinentry))
|
||||||
|
+ (string-append "scdaemon-program " (tool 'scdaemon))
|
||||||
|
))
|
||||||
|
|
||||||
|
;; Initialize the test environment, install appropriate configuration
|
||||||
|
--
|
||||||
|
2.9.3
|
||||||
|
|
14
gnupg2.spec
14
gnupg2.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Utility for secure communication and data storage
|
Summary: Utility for secure communication and data storage
|
||||||
Name: gnupg2
|
Name: gnupg2
|
||||||
Version: 2.1.21
|
Version: 2.1.21
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
|
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -19,6 +19,7 @@ Patch4: gnupg-2.1.20-file-is-digest.patch
|
|||||||
Patch5: gnupg-2.1.1-ocsp-keyusage.patch
|
Patch5: gnupg-2.1.1-ocsp-keyusage.patch
|
||||||
Patch6: gnupg-2.1.1-fips-algo.patch
|
Patch6: gnupg-2.1.1-fips-algo.patch
|
||||||
Patch7: gnupg-2.1.20-build.patch
|
Patch7: gnupg-2.1.20-build.patch
|
||||||
|
Patch8: gnupg-2.1.21-scdaemon-path.patch
|
||||||
|
|
||||||
URL: http://www.gnupg.org/
|
URL: http://www.gnupg.org/
|
||||||
|
|
||||||
@ -97,6 +98,7 @@ to the base GnuPG package
|
|||||||
%patch5 -p1 -b .keyusage
|
%patch5 -p1 -b .keyusage
|
||||||
%patch6 -p1 -b .fips
|
%patch6 -p1 -b .fips
|
||||||
%patch7 -p1 -b .build
|
%patch7 -p1 -b .build
|
||||||
|
%patch8 -p1 -b .scdaemon
|
||||||
|
|
||||||
# pcsc-lite library major: 0 in 1.2.0, 1 in 1.2.9+ (dlopen()'d in pcsc-wrapper)
|
# pcsc-lite library major: 0 in 1.2.0, 1 in 1.2.9+ (dlopen()'d in pcsc-wrapper)
|
||||||
# Note: this is just the name of the default shared lib to load in scdaemon,
|
# Note: this is just the name of the default shared lib to load in scdaemon,
|
||||||
@ -155,8 +157,7 @@ rm -f %{buildroot}%{_infodir}/dir
|
|||||||
%check
|
%check
|
||||||
# need scratch gpg database for tests
|
# need scratch gpg database for tests
|
||||||
mkdir -p $HOME/.gnupg
|
mkdir -p $HOME/.gnupg
|
||||||
# check is currently broken due to hardcoded paths to scdaemon, agent, etc.
|
make -k check
|
||||||
make -k check || :
|
|
||||||
|
|
||||||
|
|
||||||
%post
|
%post
|
||||||
@ -198,19 +199,18 @@ fi
|
|||||||
%{_infodir}/*.info*
|
%{_infodir}/*.info*
|
||||||
%{_mandir}/man?/*
|
%{_mandir}/man?/*
|
||||||
%exclude %{_mandir}/man?/gpgsm*
|
%exclude %{_mandir}/man?/gpgsm*
|
||||||
%exclude %{_mandir}/man?/scdaemon*
|
|
||||||
%exclude %{_libexecdir}/scdaemon
|
|
||||||
%exclude %{_bindir}/gpgscm*
|
%exclude %{_bindir}/gpgscm*
|
||||||
|
|
||||||
%files smime
|
%files smime
|
||||||
%{_bindir}/gpgsm*
|
%{_bindir}/gpgsm*
|
||||||
%{_bindir}/kbxutil
|
%{_bindir}/kbxutil
|
||||||
%{_libexecdir}/scdaemon
|
|
||||||
%{_mandir}/man?/gpgsm*
|
%{_mandir}/man?/gpgsm*
|
||||||
%{_mandir}/man?/scdaemon*
|
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 16 2017 Tomáš Mráz <tmraz@redhat.com> - 2.1.21-2
|
||||||
|
- scdaemon is now needed by gpg
|
||||||
|
|
||||||
* Tue May 16 2017 Tomáš Mráz <tmraz@redhat.com> - 2.1.21-1
|
* Tue May 16 2017 Tomáš Mráz <tmraz@redhat.com> - 2.1.21-1
|
||||||
- upgrade to 2.1.21
|
- upgrade to 2.1.21
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user