- gnupg-2.0.10
This commit is contained in:
parent
e70647deb7
commit
4de5f7ef1e
@ -1,2 +1,2 @@
|
|||||||
gnupg-2.0.9.tar.bz2
|
gnupg-2.0.10.tar.bz2
|
||||||
gnupg-2.0.9.tar.bz2.sig
|
gnupg-2.0.10.tar.bz2.sig
|
||||||
|
@ -1,9 +0,0 @@
|
|||||||
diff -Nur gnupg-1.9.16-orig/tests/runtest gnupg-1.9.16/tests/runtest
|
|
||||||
--- gnupg-1.9.16-orig/tests/runtest 2004-02-20 14:46:35.000000000 +0100
|
|
||||||
+++ gnupg-1.9.16/tests/runtest 2005-05-10 07:49:56.000000000 +0200
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
#!/bin/sh
|
|
||||||
[ -x "$1" ] && exec $1 $2
|
|
||||||
-exec ./asschk --no-echo -DGPGSM=${GPGSM} <"$1"
|
|
||||||
+exec ./asschk --verbose --no-echo -DGPGSM=${GPGSM} <"$1"
|
|
||||||
|
|
@ -1,49 +0,0 @@
|
|||||||
diff -up gnupg-2.0.9/keyserver/gpgkeys_curl.c.BAD gnupg-2.0.9/keyserver/gpgkeys_curl.c
|
|
||||||
--- gnupg-2.0.9/keyserver/gpgkeys_curl.c.BAD 2008-05-24 12:22:13.000000000 -0500
|
|
||||||
+++ gnupg-2.0.9/keyserver/gpgkeys_curl.c 2008-05-24 12:23:06.000000000 -0500
|
|
||||||
@@ -285,7 +285,7 @@ main(int argc,char *argv[])
|
|
||||||
|
|
||||||
if(follow_redirects)
|
|
||||||
{
|
|
||||||
- curl_easy_setopt(curl,CURLOPT_FOLLOWLOCATION,1);
|
|
||||||
+ curl_easy_setopt(curl,CURLOPT_FOLLOWLOCATION,1L);
|
|
||||||
if(follow_redirects>0)
|
|
||||||
curl_easy_setopt(curl,CURLOPT_MAXREDIRS,follow_redirects);
|
|
||||||
}
|
|
||||||
@@ -297,10 +297,10 @@ main(int argc,char *argv[])
|
|
||||||
{
|
|
||||||
fprintf(console,"gpgkeys: curl version = %s\n",curl_version());
|
|
||||||
curl_easy_setopt(curl,CURLOPT_STDERR,console);
|
|
||||||
- curl_easy_setopt(curl,CURLOPT_VERBOSE,1);
|
|
||||||
+ curl_easy_setopt(curl,CURLOPT_VERBOSE,1L);
|
|
||||||
}
|
|
||||||
|
|
||||||
- curl_easy_setopt(curl,CURLOPT_SSL_VERIFYPEER,opt->flags.check_cert);
|
|
||||||
+ curl_easy_setopt(curl,CURLOPT_SSL_VERIFYPEER,(long)opt->flags.check_cert);
|
|
||||||
curl_easy_setopt(curl,CURLOPT_CAINFO,opt->ca_cert_file);
|
|
||||||
|
|
||||||
if(proxy)
|
|
||||||
diff -up gnupg-2.0.9/keyserver/gpgkeys_hkp.c.BAD gnupg-2.0.9/keyserver/gpgkeys_hkp.c
|
|
||||||
--- gnupg-2.0.9/keyserver/gpgkeys_hkp.c.BAD 2008-05-24 12:23:18.000000000 -0500
|
|
||||||
+++ gnupg-2.0.9/keyserver/gpgkeys_hkp.c 2008-05-24 12:23:51.000000000 -0500
|
|
||||||
@@ -197,9 +197,9 @@ send_key(int *r_eof)
|
|
||||||
fprintf(console,"gpgkeys: HTTP URL is `%s'\n",request);
|
|
||||||
|
|
||||||
curl_easy_setopt(curl,CURLOPT_URL,request);
|
|
||||||
- curl_easy_setopt(curl,CURLOPT_POST,1);
|
|
||||||
+ curl_easy_setopt(curl,CURLOPT_POST,1L);
|
|
||||||
curl_easy_setopt(curl,CURLOPT_POSTFIELDS,key);
|
|
||||||
- curl_easy_setopt(curl,CURLOPT_FAILONERROR,1);
|
|
||||||
+ curl_easy_setopt(curl,CURLOPT_FAILONERROR,1L);
|
|
||||||
|
|
||||||
res=curl_easy_perform(curl);
|
|
||||||
if(res!=0)
|
|
||||||
@@ -656,7 +656,7 @@ main(int argc,char *argv[])
|
|
||||||
{
|
|
||||||
fprintf(console,"gpgkeys: curl version = %s\n",curl_version());
|
|
||||||
curl_easy_setopt(curl,CURLOPT_STDERR,console);
|
|
||||||
- curl_easy_setopt(curl,CURLOPT_VERBOSE,1);
|
|
||||||
+ curl_easy_setopt(curl,CURLOPT_VERBOSE,1L);
|
|
||||||
}
|
|
||||||
|
|
||||||
if(proxy)
|
|
36
gnupg2.spec
36
gnupg2.spec
@ -1,8 +1,8 @@
|
|||||||
|
|
||||||
Summary: Utility for secure communication and data storage
|
Summary: Utility for secure communication and data storage
|
||||||
Name: gnupg2
|
Name: gnupg2
|
||||||
Version: 2.0.9
|
Version: 2.0.10
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -11,21 +11,15 @@ Source1: ftp://ftp.gnupg.org/gcrypt/%{?pre:alpha/}gnupg/gnupg-%{version}%{?pre}.
|
|||||||
URL: http://www.gnupg.org/
|
URL: http://www.gnupg.org/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Patch1: gnupg-1.9.16-testverbose.patch
|
|
||||||
|
|
||||||
# Patch from upstream to fix curl 7.18.1+ and gcc4.3+ compile error
|
|
||||||
# http://lists.gnupg.org/pipermail/gnupg-devel/2008-April/024344.html
|
|
||||||
Patch2: gnupg2-2.0.9-gcc43.patch
|
|
||||||
|
|
||||||
BuildRequires: bzip2-devel
|
BuildRequires: bzip2-devel
|
||||||
BuildRequires: curl-devel
|
BuildRequires: curl-devel
|
||||||
BuildRequires: docbook-utils
|
BuildRequires: docbook-utils
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
BuildRequires: libassuan-devel >= 1.0.4
|
BuildRequires: libassuan-devel >= 1.0.4
|
||||||
# libgcrypt-devel >= 1.4.0 is preferred, see http://bugzilla.redhat.com/435320
|
# libgcrypt-devel >= 1.4.0 is preferred, see http://bugzilla.redhat.com/435320
|
||||||
#BuildRequires: libgcrypt-devel >= 1.4.0
|
BuildRequires: libgcrypt-devel >= 1.4
|
||||||
#Requires(hint): libgcrypt >= 1.4.0
|
#Requires(hint): libgcrypt >= 1.4
|
||||||
BuildRequires: libgcrypt-devel => 1.2.2
|
#BuildRequires: libgcrypt-devel => 1.2.2
|
||||||
BuildRequires: libgpg-error-devel => 1.4
|
BuildRequires: libgpg-error-devel => 1.4
|
||||||
BuildRequires: libksba-devel >= 1.0.2
|
BuildRequires: libksba-devel >= 1.0.2
|
||||||
BuildRequires: libusb-devel
|
BuildRequires: libusb-devel
|
||||||
@ -72,9 +66,6 @@ dependency on other modules at run and build time.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n gnupg-%{version}%{?pre}
|
%setup -q -n gnupg-%{version}%{?pre}
|
||||||
|
|
||||||
#patch1 -p1 -b .testverbose
|
|
||||||
%patch2 -p1 -b .gcc43
|
|
||||||
|
|
||||||
# pcsc-lite library major: 0 in 1.2.0, 1 in 1.2.9+ (dlopen()'d in pcsc-wrapper)
|
# pcsc-lite library major: 0 in 1.2.0, 1 in 1.2.9+ (dlopen()'d in pcsc-wrapper)
|
||||||
# Note: this is just the name of the default shared lib to load in scdaemon,
|
# Note: this is just the name of the default shared lib to load in scdaemon,
|
||||||
# it can use other implementations too (including non-pcsc ones).
|
# it can use other implementations too (including non-pcsc ones).
|
||||||
@ -102,7 +93,8 @@ make
|
|||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
make install DESTDIR=%{buildroot} \
|
make install DESTDIR=%{buildroot} \
|
||||||
INSTALL="install -p"
|
INSTALL="install -p" \
|
||||||
|
docdir=%{_docdir}/%{name}-%{version}
|
||||||
|
|
||||||
%find_lang %{name}
|
%find_lang %{name}
|
||||||
|
|
||||||
@ -110,11 +102,15 @@ make install DESTDIR=%{buildroot} \
|
|||||||
mkdir -p %{buildroot}%{_sysconfdir}/gnupg
|
mkdir -p %{buildroot}%{_sysconfdir}/gnupg
|
||||||
touch %{buildroot}%{_sysconfdir}/gnupg/gpgconf.conf
|
touch %{buildroot}%{_sysconfdir}/gnupg/gpgconf.conf
|
||||||
|
|
||||||
|
# more docs
|
||||||
|
install -m644 -p AUTHORS COPYING ChangeLog NEWS THANKS TODO \
|
||||||
|
%{buildroot}%{_docdir}/%{name}-%{version}/
|
||||||
|
|
||||||
## Unpackaged files
|
## Unpackaged files
|
||||||
# file conflicts with gnupg-1.x
|
# file conflicts with gnupg-1.x
|
||||||
# shouldn't gnupg2 be providing these now (maybe only f9+)? -- Rex
|
# shouldn't gnupg2 be providing these now (maybe only f11+)? -- Rex
|
||||||
rm -f %{buildroot}%{_bindir}/{gpgsplit,gpg-zip}
|
rm -f %{buildroot}%{_bindir}/{gpgsplit,gpg-zip}
|
||||||
rm -f %{buildroot}%{_datadir}/gnupg/{FAQ,faq.html}
|
rm -f %{buildroot}%{_mandir}/man1/gpg-zip.1*
|
||||||
|
|
||||||
# info dir
|
# info dir
|
||||||
rm -f %{buildroot}%{_infodir}/dir
|
rm -f %{buildroot}%{_infodir}/dir
|
||||||
@ -138,7 +134,8 @@ fi
|
|||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
|
#doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
|
||||||
|
%{_docdir}/%{name}-%{version}/
|
||||||
%dir %{_sysconfdir}/gnupg
|
%dir %{_sysconfdir}/gnupg
|
||||||
%ghost %config(noreplace) %{_sysconfdir}/gnupg/gpgconf.conf
|
%ghost %config(noreplace) %{_sysconfdir}/gnupg/gpgconf.conf
|
||||||
#docs say to install suid root, but we won't, for now.
|
#docs say to install suid root, but we won't, for now.
|
||||||
@ -168,6 +165,9 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 2.0.10-1
|
||||||
|
- gnupg-2.0.10
|
||||||
|
|
||||||
* Mon Aug 04 2008 Rex Dieter <rdieter@fedoraproject.org> 2.0.9-3
|
* Mon Aug 04 2008 Rex Dieter <rdieter@fedoraproject.org> 2.0.9-3
|
||||||
- workaround rpm quirks
|
- workaround rpm quirks
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user