drop old patch 'make check' now optional, default off, since FE4+ &
buildsystem borks it up (FC3 is fine?)
This commit is contained in:
parent
fb20eb6c92
commit
2ba40d0d11
@ -1,15 +0,0 @@
|
||||
--- g10/misc.c~ 2005-06-15 18:34:29.000000000 +0300
|
||||
+++ g10/misc.c 2005-07-01 21:02:05.000000000 +0300
|
||||
@@ -986,10 +986,10 @@
|
||||
}
|
||||
else {
|
||||
int rc;
|
||||
- char *buffer;
|
||||
+ unsigned char *buffer;
|
||||
|
||||
rc = gcry_mpi_aprint( GCRYMPI_FMT_HEX,
|
||||
- &(unsigned char*)buffer, NULL, a );
|
||||
+ &buffer, NULL, a );
|
||||
assert( !rc );
|
||||
fputs( buffer, fp );
|
||||
n += strlen(buffer);
|
12
gnupg2.spec
12
gnupg2.spec
@ -6,7 +6,7 @@
|
||||
Summary: GNU utility for secure communication and data storage
|
||||
Name: gnupg2
|
||||
Version: 1.9.18
|
||||
Release: 1%{?dist}
|
||||
Release: 5%{?dist}
|
||||
License: GPL
|
||||
Group: Applications/System
|
||||
Source0: ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/gnupg-%{version}.tar.bz2
|
||||
@ -22,12 +22,6 @@ Obsoletes: newpg < 0.9.5
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(postun): /sbin/install-info
|
||||
|
||||
# Build with -pie/-fPIE?
|
||||
BuildRequires: gcc
|
||||
%define gcc_ver %(gcc -dumpversion)
|
||||
%if "%{gcc_ver}" < "3.2.3"
|
||||
%define _without_pie --without pie
|
||||
%endif
|
||||
%{!?_without_pie:%define _with_pie --with pie}
|
||||
|
||||
BuildRequires: libassuan-devel >= 0.6.10
|
||||
@ -92,7 +86,7 @@ make %{?_smp_mflags}
|
||||
|
||||
|
||||
%check || :
|
||||
make check
|
||||
%{?_with_check:make check}
|
||||
|
||||
|
||||
%install
|
||||
@ -142,7 +136,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 8 2005 Rex Dieter <rexdieter[AT]users.sf.net> - 1.9.18-1
|
||||
* Mon Aug 8 2005 Rex Dieter <rexdieter[AT]users.sf.net> - 1.9.18-5
|
||||
- 1.9.18
|
||||
- drop pth patch (--enable-gpg build fixed)
|
||||
- update description (from README)
|
||||
|
Loading…
Reference in New Issue
Block a user