Patch from upstream to fix curl 7.18.1+ and gcc4.3+ compile error
This commit is contained in:
parent
cf126ad736
commit
28ec59bc37
49
gnupg2-2.0.9-gcc43.patch
Normal file
49
gnupg2-2.0.9-gcc43.patch
Normal file
@ -0,0 +1,49 @@
|
||||
diff -up gnupg-2.0.9/keyserver/gpgkeys_curl.c.BAD gnupg-2.0.9/keyserver/gpgkeys_curl.c
|
||||
--- gnupg-2.0.9/keyserver/gpgkeys_curl.c.BAD 2008-05-24 12:22:13.000000000 -0500
|
||||
+++ gnupg-2.0.9/keyserver/gpgkeys_curl.c 2008-05-24 12:23:06.000000000 -0500
|
||||
@@ -285,7 +285,7 @@ main(int argc,char *argv[])
|
||||
|
||||
if(follow_redirects)
|
||||
{
|
||||
- curl_easy_setopt(curl,CURLOPT_FOLLOWLOCATION,1);
|
||||
+ curl_easy_setopt(curl,CURLOPT_FOLLOWLOCATION,1L);
|
||||
if(follow_redirects>0)
|
||||
curl_easy_setopt(curl,CURLOPT_MAXREDIRS,follow_redirects);
|
||||
}
|
||||
@@ -297,10 +297,10 @@ main(int argc,char *argv[])
|
||||
{
|
||||
fprintf(console,"gpgkeys: curl version = %s\n",curl_version());
|
||||
curl_easy_setopt(curl,CURLOPT_STDERR,console);
|
||||
- curl_easy_setopt(curl,CURLOPT_VERBOSE,1);
|
||||
+ curl_easy_setopt(curl,CURLOPT_VERBOSE,1L);
|
||||
}
|
||||
|
||||
- curl_easy_setopt(curl,CURLOPT_SSL_VERIFYPEER,opt->flags.check_cert);
|
||||
+ curl_easy_setopt(curl,CURLOPT_SSL_VERIFYPEER,(long)opt->flags.check_cert);
|
||||
curl_easy_setopt(curl,CURLOPT_CAINFO,opt->ca_cert_file);
|
||||
|
||||
if(proxy)
|
||||
diff -up gnupg-2.0.9/keyserver/gpgkeys_hkp.c.BAD gnupg-2.0.9/keyserver/gpgkeys_hkp.c
|
||||
--- gnupg-2.0.9/keyserver/gpgkeys_hkp.c.BAD 2008-05-24 12:23:18.000000000 -0500
|
||||
+++ gnupg-2.0.9/keyserver/gpgkeys_hkp.c 2008-05-24 12:23:51.000000000 -0500
|
||||
@@ -197,9 +197,9 @@ send_key(int *r_eof)
|
||||
fprintf(console,"gpgkeys: HTTP URL is `%s'\n",request);
|
||||
|
||||
curl_easy_setopt(curl,CURLOPT_URL,request);
|
||||
- curl_easy_setopt(curl,CURLOPT_POST,1);
|
||||
+ curl_easy_setopt(curl,CURLOPT_POST,1L);
|
||||
curl_easy_setopt(curl,CURLOPT_POSTFIELDS,key);
|
||||
- curl_easy_setopt(curl,CURLOPT_FAILONERROR,1);
|
||||
+ curl_easy_setopt(curl,CURLOPT_FAILONERROR,1L);
|
||||
|
||||
res=curl_easy_perform(curl);
|
||||
if(res!=0)
|
||||
@@ -656,7 +656,7 @@ main(int argc,char *argv[])
|
||||
{
|
||||
fprintf(console,"gpgkeys: curl version = %s\n",curl_version());
|
||||
curl_easy_setopt(curl,CURLOPT_STDERR,console);
|
||||
- curl_easy_setopt(curl,CURLOPT_VERBOSE,1);
|
||||
+ curl_easy_setopt(curl,CURLOPT_VERBOSE,1L);
|
||||
}
|
||||
|
||||
if(proxy)
|
13
gnupg2.spec
13
gnupg2.spec
@ -2,7 +2,7 @@
|
||||
Summary: Utility for secure communication and data storage
|
||||
Name: gnupg2
|
||||
Version: 2.0.9
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
|
||||
License: GPLv3+
|
||||
Group: Applications/System
|
||||
@ -13,6 +13,10 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Patch1: gnupg-1.9.16-testverbose.patch
|
||||
|
||||
# Patch from upstream to fix curl 7.18.1+ and gcc4.3+ compile error
|
||||
# http://lists.gnupg.org/pipermail/gnupg-devel/2008-April/024344.html
|
||||
Patch2: gnupg2-2.0.9-gcc43.patch
|
||||
|
||||
BuildRequires: bzip2-devel
|
||||
BuildRequires: curl-devel
|
||||
BuildRequires: docbook-utils
|
||||
@ -69,6 +73,7 @@ dependency on other modules at run and build time.
|
||||
%setup -q -n gnupg-%{version}%{?pre}
|
||||
|
||||
#patch1 -p1 -b .testverbose
|
||||
%patch2 -p1 -b .gcc43
|
||||
|
||||
# pcsc-lite library major: 0 in 1.2.0, 1 in 1.2.9+ (dlopen()'d in pcsc-wrapper)
|
||||
# Note: this is just the name of the default shared lib to load in scdaemon,
|
||||
@ -163,6 +168,12 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat May 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.9-2
|
||||
- Patch from upstream to fix curl 7.18.1+ and gcc4.3+ compile error
|
||||
|
||||
* Mon May 19 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.9-1.1
|
||||
- minor release bump for sparc rebuild
|
||||
|
||||
* Wed Mar 26 2008 Rex Dieter <rdieter@fedoraproject.org> 2.0.9-1
|
||||
- gnupg2-2.0.9
|
||||
- drop Provides: openpgp
|
||||
|
Loading…
Reference in New Issue
Block a user