Attempt at enabling gpgtar build failed, disable it again.
This commit is contained in:
parent
5150ef0add
commit
24709b5070
@ -1,6 +1,6 @@
|
||||
diff -up gnupg-2.1.11/configure.ac.build gnupg-2.1.11/configure.ac
|
||||
--- gnupg-2.1.11/configure.ac.build 2016-01-26 10:36:37.000000000 +0100
|
||||
+++ gnupg-2.1.11/configure.ac 2016-02-01 17:51:47.173400243 +0100
|
||||
+++ gnupg-2.1.11/configure.ac 2016-02-16 13:20:24.655953923 +0100
|
||||
@@ -89,8 +89,8 @@ AC_GNU_SOURCE
|
||||
# CFLAGS (they are restored at the end of the configure script). This
|
||||
# is because some configure checks don't work with -Werror, but we'd
|
||||
@ -23,7 +23,7 @@ diff -up gnupg-2.1.11/configure.ac.build gnupg-2.1.11/configure.ac
|
||||
# Decide what to build
|
||||
diff -up gnupg-2.1.11/configure.build gnupg-2.1.11/configure
|
||||
--- gnupg-2.1.11/configure.build 2016-01-26 13:54:50.000000000 +0100
|
||||
+++ gnupg-2.1.11/configure 2016-02-01 17:52:58.736827069 +0100
|
||||
+++ gnupg-2.1.11/configure 2016-02-16 13:20:24.657953969 +0100
|
||||
@@ -5039,8 +5039,8 @@ $as_echo "$ac_cv_safe_to_define___extens
|
||||
# CFLAGS (they are restored at the end of the configure script). This
|
||||
# is because some configure checks don't work with -Werror, but we'd
|
||||
@ -46,7 +46,7 @@ diff -up gnupg-2.1.11/configure.build gnupg-2.1.11/configure
|
||||
# Decide what to build
|
||||
diff -up gnupg-2.1.11/dirmngr/Makefile.am.build gnupg-2.1.11/dirmngr/Makefile.am
|
||||
--- gnupg-2.1.11/dirmngr/Makefile.am.build 2016-01-26 10:36:37.000000000 +0100
|
||||
+++ gnupg-2.1.11/dirmngr/Makefile.am 2016-02-01 17:46:13.840412143 +0100
|
||||
+++ gnupg-2.1.11/dirmngr/Makefile.am 2016-02-16 13:20:24.657953969 +0100
|
||||
@@ -132,7 +132,7 @@ endif
|
||||
t_http_SOURCES = t-http.c http.c dns-stuff.c
|
||||
t_http_CFLAGS = -DWITHOUT_NPTH=1 \
|
||||
@ -67,7 +67,7 @@ diff -up gnupg-2.1.11/dirmngr/Makefile.am.build gnupg-2.1.11/dirmngr/Makefile.am
|
||||
t_dns_stuff_CFLAGS = -DWITHOUT_NPTH=1
|
||||
diff -up gnupg-2.1.11/dirmngr/Makefile.in.build gnupg-2.1.11/dirmngr/Makefile.in
|
||||
--- gnupg-2.1.11/dirmngr/Makefile.in.build 2016-01-26 13:54:48.000000000 +0100
|
||||
+++ gnupg-2.1.11/dirmngr/Makefile.in 2016-02-01 17:46:13.840412143 +0100
|
||||
+++ gnupg-2.1.11/dirmngr/Makefile.in 2016-02-16 13:20:24.658953991 +0100
|
||||
@@ -640,7 +640,7 @@ module_tests = t-dns-stuff $(am__append_
|
||||
t_http_SOURCES = t-http.c http.c dns-stuff.c
|
||||
t_http_CFLAGS = -DWITHOUT_NPTH=1 \
|
||||
@ -86,3 +86,17 @@ diff -up gnupg-2.1.11/dirmngr/Makefile.in.build gnupg-2.1.11/dirmngr/Makefile.in
|
||||
t_ldap_parse_uri_LDADD = $(ldaplibs) $(t_common_ldadd) $(DNSLIBS)
|
||||
t_dns_stuff_CFLAGS = -DWITHOUT_NPTH=1
|
||||
t_dns_stuff_SOURCES = t-dns-stuff.c dns-stuff.c
|
||||
diff -up gnupg-2.1.11/tests/openpgp/gpgtar.test.build gnupg-2.1.11/tests/openpgp/gpgtar.test
|
||||
--- gnupg-2.1.11/tests/openpgp/gpgtar.test.build 2016-01-26 10:36:37.000000000 +0100
|
||||
+++ gnupg-2.1.11/tests/openpgp/gpgtar.test 2016-02-16 15:33:13.215537860 +0100
|
||||
@@ -33,6 +33,10 @@ GPGARGS="$opt_always --no-permission-war
|
||||
GPGTAR="../../tools/gpgtar"
|
||||
GPGZIP="sh ../../tools/gpg-zip"
|
||||
|
||||
+if [ ! -f "$GPGTAR" ] ; then
|
||||
+ exit 77
|
||||
+fi
|
||||
+
|
||||
# Create, inspect, and extract an archive with the given options.
|
||||
#
|
||||
# $1 the tool to test
|
||||
|
@ -104,6 +104,7 @@ sed -i -e 's/"libpcsclite\.so"/"%{pcsclib}"/' scd/scdaemon.c
|
||||
%build
|
||||
|
||||
%configure \
|
||||
--disable-gpgtar \
|
||||
--disable-rpath \
|
||||
--enable-g13
|
||||
|
||||
@ -176,7 +177,6 @@ fi
|
||||
%{_bindir}/gpg-agent
|
||||
%{_bindir}/gpgconf
|
||||
%{_bindir}/gpgparsemail
|
||||
%{_bindir}/gpgtar
|
||||
%{_bindir}/g13
|
||||
%{_bindir}/dirmngr
|
||||
%{_bindir}/dirmngr-client
|
||||
|
Loading…
Reference in New Issue
Block a user