Revert the introduction of the RFC4880bis draft into defaults
This commit is contained in:
parent
5c6730daef
commit
146a5fe7ef
209
gnupg2-revert-rfc4880bis.patch
Normal file
209
gnupg2-revert-rfc4880bis.patch
Normal file
@ -0,0 +1,209 @@
|
|||||||
|
From 4583f4fe2e11b3dd070066628c3f16776cc74f72 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Werner Koch <wk@gnupg.org>
|
||||||
|
Date: Mon, 31 Oct 2022 16:14:18 +0100
|
||||||
|
Subject: [PATCH GnuPG] gpg: Merge --rfc4880bis features into --gnupg
|
||||||
|
|
||||||
|
* g10/gpg.c (oRFC4880bis): Remove.
|
||||||
|
(opts): Make --rfc4880bis a Noop.
|
||||||
|
(compliance_options): Make rfc4880bis to gnupg.
|
||||||
|
(set_compliance_option): Remove rfc4880bis stuff.
|
||||||
|
(main): Ditto. Note that this now activates the --mimemode option.
|
||||||
|
* g10/keygen.c (keygen_set_std_prefs): Remove rfc4880bis protection.
|
||||||
|
(keygen_upd_std_prefs): Always announce support for v5 keys.
|
||||||
|
(read_parameter_file): Activate the v4 and v5 keywords.
|
||||||
|
--
|
||||||
|
---
|
||||||
|
g10/gpg.c | 35 ++++++++++++++++++++++++++++++++---
|
||||||
|
g10/keygen.c | 30 ++++++++++++++++++------------
|
||||||
|
2 files changed, 50 insertions(+), 15 deletions(-)
|
||||||
|
|
||||||
|
diff --git b/g10/gpg.c a/g10/gpg.c
|
||||||
|
index 932a4e0f0..f6d4d2b4c 100644
|
||||||
|
--- b/g10/gpg.c
|
||||||
|
+++ a/g10/gpg.c
|
||||||
|
@@ -245,6 +245,7 @@ enum cmd_and_opt_values
|
||||||
|
oGnuPG,
|
||||||
|
oRFC2440,
|
||||||
|
oRFC4880,
|
||||||
|
+ oRFC4880bis,
|
||||||
|
oOpenPGP,
|
||||||
|
oPGP7,
|
||||||
|
oPGP8,
|
||||||
|
@@ -627,6 +628,7 @@ static gpgrt_opt_t opts[] = {
|
||||||
|
ARGPARSE_s_n (oGnuPG, "no-pgp8", "@"),
|
||||||
|
ARGPARSE_s_n (oRFC2440, "rfc2440", "@"),
|
||||||
|
ARGPARSE_s_n (oRFC4880, "rfc4880", "@"),
|
||||||
|
+ ARGPARSE_s_n (oRFC4880bis, "rfc4880bis", "@"),
|
||||||
|
ARGPARSE_s_n (oOpenPGP, "openpgp", N_("use strict OpenPGP behavior")),
|
||||||
|
ARGPARSE_s_n (oPGP7, "pgp6", "@"),
|
||||||
|
ARGPARSE_s_n (oPGP7, "pgp7", "@"),
|
||||||
|
@@ -967,7 +969,6 @@ static gpgrt_opt_t opts[] = {
|
||||||
|
ARGPARSE_s_n (oNoop, "no-allow-multiple-messages", "@"),
|
||||||
|
ARGPARSE_s_s (oNoop, "aead-algo", "@"),
|
||||||
|
ARGPARSE_s_s (oNoop, "personal-aead-preferences","@"),
|
||||||
|
- ARGPARSE_s_n (oNoop, "rfc4880bis", "@"),
|
||||||
|
|
||||||
|
|
||||||
|
ARGPARSE_group (302, N_(
|
||||||
|
@@ -2197,7 +2198,7 @@ static struct gnupg_compliance_option compliance_options[] =
|
||||||
|
{
|
||||||
|
{ "gnupg", oGnuPG },
|
||||||
|
{ "openpgp", oOpenPGP },
|
||||||
|
- { "rfc4880bis", oGnuPG },
|
||||||
|
+ { "rfc4880bis", oRFC4880bis },
|
||||||
|
{ "rfc4880", oRFC4880 },
|
||||||
|
{ "rfc2440", oRFC2440 },
|
||||||
|
{ "pgp6", oPGP7 },
|
||||||
|
@@ -2213,8 +2214,28 @@ static struct gnupg_compliance_option compliance_options[] =
|
||||||
|
static void
|
||||||
|
set_compliance_option (enum cmd_and_opt_values option)
|
||||||
|
{
|
||||||
|
+ opt.flags.rfc4880bis = 0; /* Clear because it is initially set. */
|
||||||
|
+
|
||||||
|
switch (option)
|
||||||
|
{
|
||||||
|
+ case oRFC4880bis:
|
||||||
|
+ opt.flags.rfc4880bis = 1;
|
||||||
|
+ opt.compliance = CO_RFC4880;
|
||||||
|
+ opt.flags.dsa2 = 1;
|
||||||
|
+ opt.flags.require_cross_cert = 1;
|
||||||
|
+ opt.rfc2440_text = 0;
|
||||||
|
+ opt.allow_non_selfsigned_uid = 1;
|
||||||
|
+ opt.allow_freeform_uid = 1;
|
||||||
|
+ opt.escape_from = 1;
|
||||||
|
+ opt.not_dash_escaped = 0;
|
||||||
|
+ opt.def_cipher_algo = 0;
|
||||||
|
+ opt.def_digest_algo = 0;
|
||||||
|
+ opt.cert_digest_algo = 0;
|
||||||
|
+ opt.compress_algo = -1;
|
||||||
|
+ opt.s2k_mode = 3; /* iterated+salted */
|
||||||
|
+ opt.s2k_digest_algo = DIGEST_ALGO_SHA256;
|
||||||
|
+ opt.s2k_cipher_algo = CIPHER_ALGO_AES256;
|
||||||
|
+ break;
|
||||||
|
case oOpenPGP:
|
||||||
|
case oRFC4880:
|
||||||
|
/* This is effectively the same as RFC2440, but with
|
||||||
|
@@ -2258,6 +2279,7 @@ set_compliance_option (enum cmd_and_opt_values option)
|
||||||
|
case oPGP8: opt.compliance = CO_PGP8; break;
|
||||||
|
case oGnuPG:
|
||||||
|
opt.compliance = CO_GNUPG;
|
||||||
|
+ opt.flags.rfc4880bis = 1;
|
||||||
|
break;
|
||||||
|
|
||||||
|
case oDE_VS:
|
||||||
|
@@ -2460,6 +2482,7 @@ main (int argc, char **argv)
|
||||||
|
opt.emit_version = 0;
|
||||||
|
opt.weak_digests = NULL;
|
||||||
|
opt.compliance = CO_GNUPG;
|
||||||
|
+ opt.flags.rfc4880bis = 1;
|
||||||
|
|
||||||
|
/* Check special options given on the command line. */
|
||||||
|
orig_argc = argc;
|
||||||
|
@@ -2997,6 +3020,7 @@ main (int argc, char **argv)
|
||||||
|
case oOpenPGP:
|
||||||
|
case oRFC2440:
|
||||||
|
case oRFC4880:
|
||||||
|
+ case oRFC4880bis:
|
||||||
|
case oPGP7:
|
||||||
|
case oPGP8:
|
||||||
|
case oGnuPG:
|
||||||
|
@@ -3808,6 +3832,11 @@ main (int argc, char **argv)
|
||||||
|
if( may_coredump && !opt.quiet )
|
||||||
|
log_info(_("WARNING: program may create a core file!\n"));
|
||||||
|
|
||||||
|
+ if (!opt.flags.rfc4880bis)
|
||||||
|
+ {
|
||||||
|
+ opt.mimemode = 0; /* This will use text mode instead. */
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
if (eyes_only) {
|
||||||
|
if (opt.set_filename)
|
||||||
|
log_info(_("WARNING: %s overrides %s\n"),
|
||||||
|
@@ -4033,7 +4062,7 @@ main (int argc, char **argv)
|
||||||
|
/* Check our chosen algorithms against the list of legal
|
||||||
|
algorithms. */
|
||||||
|
|
||||||
|
- if(!GNUPG)
|
||||||
|
+ if(!GNUPG && !opt.flags.rfc4880bis)
|
||||||
|
{
|
||||||
|
const char *badalg=NULL;
|
||||||
|
preftype_t badtype=PREFTYPE_NONE;
|
||||||
|
diff --git b/g10/keygen.c a/g10/keygen.c
|
||||||
|
index c2f2dcc9d..484352583 100644
|
||||||
|
--- b/g10/keygen.c
|
||||||
|
+++ a/g10/keygen.c
|
||||||
|
@@ -407,7 +407,7 @@ keygen_set_std_prefs (const char *string,int personal)
|
||||||
|
strcat(dummy_string,"S7 ");
|
||||||
|
strcat(dummy_string,"S2 "); /* 3DES */
|
||||||
|
|
||||||
|
- if (!openpgp_aead_test_algo (AEAD_ALGO_OCB))
|
||||||
|
+ if (opt.flags.rfc4880bis && !openpgp_aead_test_algo (AEAD_ALGO_OCB))
|
||||||
|
strcat(dummy_string,"A2 ");
|
||||||
|
|
||||||
|
if (personal)
|
||||||
|
@@ -892,7 +892,7 @@ keygen_upd_std_prefs (PKT_signature *sig, void *opaque)
|
||||||
|
/* Make sure that the MDC feature flag is set if needed. */
|
||||||
|
add_feature_mdc (sig,mdc_available);
|
||||||
|
add_feature_aead (sig, aead_available);
|
||||||
|
- add_feature_v5 (sig, 1);
|
||||||
|
+ add_feature_v5 (sig, opt.flags.rfc4880bis);
|
||||||
|
add_keyserver_modify (sig,ks_modify);
|
||||||
|
keygen_add_keyserver_url(sig,NULL);
|
||||||
|
|
||||||
|
@@ -3387,7 +3387,10 @@ parse_key_parameter_part (ctrl_t ctrl,
|
||||||
|
}
|
||||||
|
}
|
||||||
|
else if (!ascii_strcasecmp (s, "v5"))
|
||||||
|
- keyversion = 5;
|
||||||
|
+ {
|
||||||
|
+ if (opt.flags.rfc4880bis)
|
||||||
|
+ keyversion = 5;
|
||||||
|
+ }
|
||||||
|
else if (!ascii_strcasecmp (s, "v4"))
|
||||||
|
keyversion = 4;
|
||||||
|
else
|
||||||
|
@@ -3646,7 +3649,7 @@ parse_key_parameter_part (ctrl_t ctrl,
|
||||||
|
* ecdsa := Use algorithm ECDSA.
|
||||||
|
* eddsa := Use algorithm EdDSA.
|
||||||
|
* ecdh := Use algorithm ECDH.
|
||||||
|
- * v5 := Create version 5 key
|
||||||
|
+ * v5 := Create version 5 key (requires option --rfc4880bis)
|
||||||
|
*
|
||||||
|
* There are several defaults and fallbacks depending on the
|
||||||
|
* algorithm. PART can be used to select which part of STRING is
|
||||||
|
@@ -4428,9 +4431,9 @@ read_parameter_file (ctrl_t ctrl, const char *fname )
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- if ((keywords[i].key == pVERSION
|
||||||
|
- || keywords[i].key == pSUBVERSION))
|
||||||
|
- ; /* Ignore version. */
|
||||||
|
+ if (!opt.flags.rfc4880bis && (keywords[i].key == pVERSION
|
||||||
|
+ || keywords[i].key == pSUBVERSION))
|
||||||
|
+ ; /* Ignore version unless --rfc4880bis is active. */
|
||||||
|
else
|
||||||
|
{
|
||||||
|
r = xmalloc_clear( sizeof *r + strlen( value ) );
|
||||||
|
@@ -4525,11 +4528,14 @@ quickgen_set_para (struct para_data_s *para, int for_subkey,
|
||||||
|
para = r;
|
||||||
|
}
|
||||||
|
|
||||||
|
- r = xmalloc_clear (sizeof *r + 20);
|
||||||
|
- r->key = for_subkey? pSUBVERSION : pVERSION;
|
||||||
|
- snprintf (r->u.value, 20, "%d", version);
|
||||||
|
- r->next = para;
|
||||||
|
- para = r;
|
||||||
|
+ if (opt.flags.rfc4880bis)
|
||||||
|
+ {
|
||||||
|
+ r = xmalloc_clear (sizeof *r + 20);
|
||||||
|
+ r->key = for_subkey? pSUBVERSION : pVERSION;
|
||||||
|
+ snprintf (r->u.value, 20, "%d", version);
|
||||||
|
+ r->next = para;
|
||||||
|
+ para = r;
|
||||||
|
+ }
|
||||||
|
|
||||||
|
if (keytime)
|
||||||
|
{
|
||||||
|
--
|
||||||
|
2.39.1
|
||||||
|
|
@ -32,6 +32,8 @@ Patch30: gnupg-2.2.21-coverity.patch
|
|||||||
# fix gpgme tests fail for in-source-tree builds (https://dev.gnupg.org/T6313)
|
# fix gpgme tests fail for in-source-tree builds (https://dev.gnupg.org/T6313)
|
||||||
# (edited to patch Makefile.in instead of Makefile.am to avoid autoreconf)
|
# (edited to patch Makefile.in instead of Makefile.am to avoid autoreconf)
|
||||||
Patch31: gnupg-2.4.0-tests-Fix-tests-gpgme-for-in-source-tree-builds.patch
|
Patch31: gnupg-2.4.0-tests-Fix-tests-gpgme-for-in-source-tree-builds.patch
|
||||||
|
# Revert the introduction of the RFC4880bis draft into defaults
|
||||||
|
Patch32: gnupg2-revert-rfc4880bis.patch
|
||||||
|
|
||||||
|
|
||||||
URL: https://www.gnupg.org/
|
URL: https://www.gnupg.org/
|
||||||
@ -124,6 +126,7 @@ to the base GnuPG package
|
|||||||
|
|
||||||
%patch30 -p1 -b .coverity
|
%patch30 -p1 -b .coverity
|
||||||
%patch31 -p1 -b .tests_gpgme
|
%patch31 -p1 -b .tests_gpgme
|
||||||
|
%patch32 -p1 -b .revert-rfc4880bis
|
||||||
|
|
||||||
# pcsc-lite library major: 0 in 1.2.0, 1 in 1.2.9+ (dlopen()'d in pcsc-wrapper)
|
# pcsc-lite library major: 0 in 1.2.0, 1 in 1.2.9+ (dlopen()'d in pcsc-wrapper)
|
||||||
# Note: this is just the name of the default shared lib to load in scdaemon,
|
# Note: this is just the name of the default shared lib to load in scdaemon,
|
||||||
|
Loading…
Reference in New Issue
Block a user