gnupg2-2.3.7-1
This commit is contained in:
parent
821042c48b
commit
088abd1806
@ -1,50 +0,0 @@
|
|||||||
From 34c649b3601383cd11dbc76221747ec16fd68e1b Mon Sep 17 00:00:00 2001
|
|
||||||
From: Werner Koch <wk@gnupg.org>
|
|
||||||
Date: Tue, 14 Jun 2022 11:33:27 +0200
|
|
||||||
Subject: [PATCH GnuPG] g10: Fix garbled status messages in NOTATION_DATA
|
|
||||||
|
|
||||||
* g10/cpr.c (write_status_text_and_buffer): Fix off-by-one
|
|
||||||
--
|
|
||||||
|
|
||||||
Depending on the escaping and line wrapping the computed remaining
|
|
||||||
buffer length could be wrong. Fixed by always using a break to
|
|
||||||
terminate the escape detection loop. Might have happened for all
|
|
||||||
status lines which may wrap.
|
|
||||||
|
|
||||||
GnuPG-bug-id: T6027
|
|
||||||
---
|
|
||||||
g10/cpr.c | 13 ++++---------
|
|
||||||
1 file changed, 4 insertions(+), 9 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/g10/cpr.c b/g10/cpr.c
|
|
||||||
index 9bfdd3c34..fa8005d6f 100644
|
|
||||||
--- a/g10/cpr.c
|
|
||||||
+++ b/g10/cpr.c
|
|
||||||
@@ -372,20 +372,15 @@ write_status_text_and_buffer (int no, const char *string,
|
|
||||||
}
|
|
||||||
first = 0;
|
|
||||||
}
|
|
||||||
- for (esc=0, s=buffer, n=len; n && !esc; s++, n--)
|
|
||||||
+ for (esc=0, s=buffer, n=len; n; s++, n--)
|
|
||||||
{
|
|
||||||
if (*s == '%' || *(const byte*)s <= lower_limit
|
|
||||||
|| *(const byte*)s == 127 )
|
|
||||||
esc = 1;
|
|
||||||
if (wrap && ++count > wrap)
|
|
||||||
- {
|
|
||||||
- dowrap=1;
|
|
||||||
- break;
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
- if (esc)
|
|
||||||
- {
|
|
||||||
- s--; n++;
|
|
||||||
+ dowrap=1;
|
|
||||||
+ if (esc || dowrap)
|
|
||||||
+ break;
|
|
||||||
}
|
|
||||||
if (s != buffer)
|
|
||||||
es_fwrite (buffer, s-buffer, 1, statusfp);
|
|
||||||
--
|
|
||||||
2.35.3
|
|
||||||
|
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/g10/keygen.c b/g10/keygen.c
|
|
||||||
index 6106d98ba..945494a8b 100644
|
|
||||||
--- a/g10/keygen.c
|
|
||||||
+++ b/g10/keygen.c
|
|
||||||
@@ -568,7 +568,7 @@ keygen_set_std_prefs (const char *string,int personal)
|
|
||||||
for (i=0; i<naead; i++)
|
|
||||||
{
|
|
||||||
opt.personal_aead_prefs[i].type = PREFTYPE_AEAD;
|
|
||||||
- opt.personal_aead_prefs[i].value = sym[i];
|
|
||||||
+ opt.personal_aead_prefs[i].value = aead[i];
|
|
||||||
}
|
|
||||||
|
|
||||||
opt.personal_aead_prefs[i].type = PREFTYPE_NONE;
|
|
12
gnupg2.spec
12
gnupg2.spec
@ -6,8 +6,8 @@
|
|||||||
|
|
||||||
Summary: Utility for secure communication and data storage
|
Summary: Utility for secure communication and data storage
|
||||||
Name: gnupg2
|
Name: gnupg2
|
||||||
Version: 2.3.6
|
Version: 2.3.7
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Source0: https://gnupg.org/ftp/gcrypt/%{?pre:alpha/}gnupg/gnupg-%{version}%{?pre}.tar.bz2
|
Source0: https://gnupg.org/ftp/gcrypt/%{?pre:alpha/}gnupg/gnupg-%{version}%{?pre}.tar.bz2
|
||||||
@ -27,9 +27,6 @@ Patch21: gnupg-2.2.18-gpg-allow-import-of-previously-known-keys-even-without-UI.
|
|||||||
Patch22: gnupg-2.2.18-gpg-accept-subkeys-with-a-good-revocation-but-no-self-sig.patch
|
Patch22: gnupg-2.2.18-gpg-accept-subkeys-with-a-good-revocation-but-no-self-sig.patch
|
||||||
# Fixes for issues found in Coverity scan - reported upstream
|
# Fixes for issues found in Coverity scan - reported upstream
|
||||||
Patch30: gnupg-2.2.21-coverity.patch
|
Patch30: gnupg-2.2.21-coverity.patch
|
||||||
# https://dev.gnupg.org/T6019
|
|
||||||
Patch31: gnupg2-aead.patch
|
|
||||||
Patch32: gnupg-2.3.6-status-line-injection.patch
|
|
||||||
|
|
||||||
|
|
||||||
URL: https://www.gnupg.org/
|
URL: https://www.gnupg.org/
|
||||||
@ -114,8 +111,6 @@ to the base GnuPG package
|
|||||||
%patch22 -p1 -b .good_revoc
|
%patch22 -p1 -b .good_revoc
|
||||||
|
|
||||||
%patch30 -p1 -b .coverity
|
%patch30 -p1 -b .coverity
|
||||||
%patch31 -p1 -b .aead
|
|
||||||
%patch32 -p1 -b .inject
|
|
||||||
|
|
||||||
# pcsc-lite library major: 0 in 1.2.0, 1 in 1.2.9+ (dlopen()'d in pcsc-wrapper)
|
# pcsc-lite library major: 0 in 1.2.0, 1 in 1.2.9+ (dlopen()'d in pcsc-wrapper)
|
||||||
# Note: this is just the name of the default shared lib to load in scdaemon,
|
# Note: this is just the name of the default shared lib to load in scdaemon,
|
||||||
@ -229,6 +224,9 @@ make -k check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 12 2022 Jakub Jelen <jjelen@redhat.com> - 2.3.7-1
|
||||||
|
- New upstream release (#2106045)
|
||||||
|
|
||||||
* Mon Jul 04 2022 Jakub Jelen <jjelen@redhat.com> - 2.3.6-2
|
* Mon Jul 04 2022 Jakub Jelen <jjelen@redhat.com> - 2.3.6-2
|
||||||
- Fix for CVE-2022-34903 (#2103242)
|
- Fix for CVE-2022-34903 (#2103242)
|
||||||
- Fix focing AEAD through configuration files (#2093760)
|
- Fix focing AEAD through configuration files (#2093760)
|
||||||
|
Loading…
Reference in New Issue
Block a user