import gnome-tweaks-3.28.1-4.el8

This commit is contained in:
CentOS Sources 2019-07-31 21:03:04 -04:00 committed by Stepan Oksanichenko
commit 4cadebd529
5 changed files with 189 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/gnome-tweaks-3.28.1.tar.xz

1
.gnome-tweaks.metadata Normal file
View File

@ -0,0 +1 @@
4b73d3e4a9a8f67f8b65bcb7a2d169183e5e0640 SOURCES/gnome-tweaks-3.28.1.tar.xz

View File

@ -0,0 +1,30 @@
From ca3581fe34030438c323b7da6b6d08abcd4d391d Mon Sep 17 00:00:00 2001
From: Kalev Lember <klember@redhat.com>
Date: Mon, 19 Nov 2018 11:06:30 +0100
Subject: [PATCH] extensions: Fix opening system installed extensions in
gnome-software
When generating the app id that's passed to gnome-software, avoid
hardcoding the 'user' scope and use 'system' scope for system-wide
installed shell extensions.
---
gtweak/tweaks/tweak_group_shell_extensions.py | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/gtweak/tweaks/tweak_group_shell_extensions.py b/gtweak/tweaks/tweak_group_shell_extensions.py
index 47854a7..284e6e0 100644
--- a/gtweak/tweaks/tweak_group_shell_extensions.py
+++ b/gtweak/tweaks/tweak_group_shell_extensions.py
@@ -88,7 +88,8 @@ class _ShellExtensionTweak(Gtk.ListBoxRow, Tweak):
self._shell = shell
state = ext.get("state")
uuid = ext["uuid"]
- self._app_id = "user/*/extensions-web/shell-extension/" + uuid.replace('@', '_') + "/*"
+ scope = "user" if ext.get("type") == GnomeShell.EXTENSION_TYPE["PER_USER"] else "system"
+ self._app_id = scope + "/*/*/shell-extension/" + uuid.replace('@', '_') + "/*"
shell._settings.bind("disable-user-extensions", self,
"sensitive", Gio.SettingsBindFlags.INVERT_BOOLEAN)
--
2.19.1

View File

@ -0,0 +1,51 @@
From 3efa6fff00f812a034180d3d980a50cfa9a3250b Mon Sep 17 00:00:00 2001
From: Carlos Soriano <csoriano@redhat.com>
Date: Tue, 23 Apr 2019 15:16:17 +0200
Subject: [PATCH] Reflect extension status in the UI
---
gtweak/gshellwrapper.py | 3 ++-
gtweak/tweaks/tweak_group_shell_extensions.py | 6 ++++--
2 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/gtweak/gshellwrapper.py b/gtweak/gshellwrapper.py
index d654f88..ef1873a 100644
--- a/gtweak/gshellwrapper.py
+++ b/gtweak/gshellwrapper.py
@@ -81,7 +81,8 @@ class GnomeShell:
EXTENSION_TYPE = {
"SYSTEM" : 1,
- "PER_USER" : 2
+ "PER_USER" : 2,
+ "SESSION_MODE" : 3
}
DATA_DIR = os.path.join(GLib.get_user_data_dir(), "gnome-shell")
diff --git a/gtweak/tweaks/tweak_group_shell_extensions.py b/gtweak/tweaks/tweak_group_shell_extensions.py
index e295d0b..5769774 100644
--- a/gtweak/tweaks/tweak_group_shell_extensions.py
+++ b/gtweak/tweaks/tweak_group_shell_extensions.py
@@ -114,7 +114,8 @@ class _ShellExtensionTweak(Gtk.ListBoxRow, Tweak):
if state == GnomeShell.EXTENSION_STATE["ENABLED"] or \
state == GnomeShell.EXTENSION_STATE["DISABLED"] or \
state == GnomeShell.EXTENSION_STATE["INITIALIZED"]:
- sensitive = True
+ if ext.get("type") != GnomeShell.EXTENSION_TYPE["SESSION_MODE"]:
+ sensitive = True
elif state == GnomeShell.EXTENSION_STATE["DOWNLOADING"]:
info = _("Extension downloading")
elif state == GnomeShell.EXTENSION_STATE["ERROR"]:
@@ -145,7 +146,8 @@ class _ShellExtensionTweak(Gtk.ListBoxRow, Tweak):
sw = Gtk.Switch(sensitive=sensitive)
sw.props.vexpand = False
sw.props.valign = Gtk.Align.CENTER
- sw.set_active(self._shell.extension_is_active(state, uuid))
+ sw.set_active(self._shell.extension_is_active(state, uuid) or
+ ext.get("type") == GnomeShell.EXTENSION_TYPE["SESSION_MODE"])
sw.connect('notify::active', self._on_extension_toggled, uuid)
self.hbox.pack_start(sw, False, False, 0)
--
libgit2 0.26.0

106
SPECS/gnome-tweaks.spec Normal file
View File

@ -0,0 +1,106 @@
%global majorversion %(cut -d "." -f 1-2 <<<%{version})
Name: gnome-tweaks
Version: 3.28.1
Release: 4%{?dist}
Summary: Customize advanced GNOME 3 options
# Software is GPLv3, Appdata file is CC0-1.0
License: GPLv3 and CC0
URL: https://wiki.gnome.org/action/show/Apps/Tweaks
Source0: https://download.gnome.org/sources/%{name}/%{majorversion}/%{name}-%{version}.tar.xz
Patch0: reflect-extensions-status.patch
Patch1: 0001-extensions-Fix-opening-system-installed-extensions-i.patch
BuildRequires: desktop-file-utils
BuildRequires: gettext
BuildRequires: libappstream-glib
BuildRequires: meson
BuildRequires: python3-devel
Requires: gnome-desktop3
Requires: gnome-settings-daemon
Requires: gnome-shell >= 3.24
Requires: gnome-shell-extension-user-theme
Requires: gobject-introspection
Requires: gsettings-desktop-schemas >= 3.27.90
Requires: gtk3 >= 3.12
Requires: libnotify
Requires: libsoup
Requires: mutter
Requires: pango
Requires: python3dist(pygobject)
Provides: gnome-tweak-tool = %{version}.%{release}
Obsoletes: gnome-tweak-tool < 3.27.3-4
BuildArch: noarch
%description
GNOME Tweaks allows adjusting advanced configuration settings in GNOME 3. This
includes things like the fonts used in user interface elements, alternative user
interface themes, changes in window management behavior, GNOME Shell appearance
and extension, etc.
%prep
%autosetup -p1
%build
%meson
%meson_build
%install
%meson_install
# Update the screenshot shown in the software center
#
# NOTE: It would be *awesome* if this file was pushed upstream.
#
# See http://people.freedesktop.org/~hughsient/appdata/#screenshots for more details.
#
appstream-util replace-screenshots $RPM_BUILD_ROOT%{_datadir}/metainfo/org.gnome.tweaks.appdata.xml \
https://raw.githubusercontent.com/hughsie/fedora-appstream/master/screenshots-extra/gnome-tweak-tool/a.png \
https://raw.githubusercontent.com/hughsie/fedora-appstream/master/screenshots-extra/gnome-tweak-tool/b.png
%find_lang %{name}
%check
desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
appstream-util validate-relax --nonet $RPM_BUILD_ROOT/%{_datadir}/metainfo/*.appdata.xml
%files -f %{name}.lang
%doc AUTHORS NEWS README.md
%license LICENSES/
%{_bindir}/%{name}
%{_libexecdir}/gnome-tweak-tool-lid-inhibitor
%{python3_sitelib}/gtweak/
%{_datadir}/metainfo/*.appdata.xml
%{_datadir}/applications/*.desktop
%{_datadir}/%{name}/
%{_datadir}/icons/hicolor/*/apps/*.png
%{_datadir}/icons/hicolor/scalable/apps/*.svg
%changelog
* Tue Jun 18 2019 Milan Crha <mcrha@redhat.com> - 3.28.1-4
- extensions: Fix opening system installed extensions in gnome-software
- Resolves: #1721575
* Fri Apr 26 2019 Carlos Soriano <csoriano@redhat.com> - 3.28.1-3
- Fix reflect extension status in the UI
- Resolves: #1679127
* Tue Apr 23 2019 Carlos Soriano <csoriano@redhat.com> - 3.28.1-2
- Reflect extension status in the UI
- Resolves: #1679127
* Sun Apr 08 2018 Kalev Lember <klember@redhat.com> - 3.28.1-1
- Update to 3.28.1
* Mon Mar 12 2018 Mohamed El Morabity <melmorabity@fedoraproject.org> - 3.28.0-1
- Update to 3.28.0
* Fri Mar 09 2018 Mohamed El Morabity <melmorabity@fedoraproject.org> - 3.27.92-1
- Initial RPM release, based on gnome-tweak-tool.spec